NEWS

Test Adapter tr-064-community v1.0.x


  • Developer

    @skokarl sagte in [Aufruf] Test Community-Version vom tr-064 Adapter:

    das würde ja heissen der neue TR läuft nicht wenn man ihn alleine installiert

    probier es erst mal ist ja noch in der test testphase


  • Developer

    @apollon77 hab jetzt mal auf meinem test system beide adapter installiert und bei beiden kommen die errors
    ein npm install soef hat bei beiden geholfen

    host.Test	2019-05-30 04:40:00.436	error	instance system.adapter.tr-064.0 terminated with code 1 ()
    Caught	2019-05-30 04:40:00.436	error	by controller[0]: at Function.Module._load (module.js:498:3)
    Caught	2019-05-30 04:40:00.436	error	by controller[0]: at tryModuleLoad (module.js:506:12)
    Caught	2019-05-30 04:40:00.436	error	by controller[0]: at Module.load (module.js:566:32)
    Caught	2019-05-30 04:40:00.436	error	by controller[0]: at Object.Module._extensions..js (module.js:664:10)
    Caught	2019-05-30 04:40:00.436	error	by controller[0]: at Module._compile (module.js:653:30)
    Caught	2019-05-30 04:40:00.436	error	by controller[0]: at Object.<anonymous> (/opt/iobroker/node_modules/iobroker.tr-064/lib/calllist.js:3:12)
    Caught	2019-05-30 04:40:00.436	error	by controller[0]: at require (internal/module.js:11:18)
    Caught	2019-05-30 04:40:00.436	error	by controller[0]: at Module.require (module.js:597:17)
    Caught	2019-05-30 04:40:00.436	error	by controller[0]: at Function.Module._load (module.js:475:25)
    Caught	2019-05-30 04:40:00.436	error	by controller[0]: at Function.Module._resolveFilename (module.js:548:15)
    Caught	2019-05-30 04:40:00.435	error	by controller[0]: Error: Cannot find module 'soef'
    Caught	2019-05-30 04:40:00.435	error	by controller[0]: ^
    Caught	2019-05-30 04:40:00.435	error	by controller[0]: throw err;
    Caught	2019-05-30 04:40:00.435	error	by controller[0]: module.js:550
    
    host.Test	2019-05-30 06:43:11.236	error	instance system.adapter.tr-064-community.0 terminated with code 1 ()
    host.Test	2019-05-30 06:43:11.236	error	Caught by controller[0]: at Function.Module._load (module.js:498:3)
    host.Test	2019-05-30 06:43:11.236	error	Caught by controller[0]: at tryModuleLoad (module.js:506:12)
    host.Test	2019-05-30 06:43:11.236	error	Caught by controller[0]: at Module.load (module.js:566:32)
    host.Test	2019-05-30 06:43:11.236	error	Caught by controller[0]: at Object.Module._extensions..js (module.js:664:10)
    host.Test	2019-05-30 06:43:11.236	error	Caught by controller[0]: at Module._compile (module.js:653:30)
    host.Test	2019-05-30 06:43:11.236	error	Caught by controller[0]: at Object.<anonymous> (/opt/iobroker/node_modules/iobroker.tr-064-community/lib/calllist.js:3:12)
    host.Test	2019-05-30 06:43:11.236	error	Caught by controller[0]: at require (internal/module.js:11:18)
    host.Test	2019-05-30 06:43:11.236	error	Caught by controller[0]: at Module.require (module.js:597:17)
    host.Test	2019-05-30 06:43:11.236	error	Caught by controller[0]: at Function.Module._load (module.js:475:25)
    host.Test	2019-05-30 06:43:11.236	error	Caught by controller[0]: at Function.Module._resolveFilename (module.js:548:15)
    host.Test	2019-05-30 06:43:11.236	error	Caught by controller[0]: Error: Cannot find module 'soef'
    host.Test	2019-05-30 06:43:11.236	error	Caught by controller[0]: ^
    host.Test	2019-05-30 06:43:11.236	error	Caught by controller[0]: throw err;
    host.Test	2019-05-30 06:43:11.235	error	Caught by controller[0]: module.js:550
    

    und noch was interessantes wenn man beide adapter installiert hat und dann den alten deinstallieren will wird der neue auch deinstalliert

    hir mal das log

    2019-05-30 04:49:53.012  - info: iobroker del tr-064
    2019-05-30 04:49:53.491  - info: iobroker Delete adapter "tr-064"
    2019-05-30 04:49:53.517  - info: iobroker host.Test Counted 2 instances of tr-064
    2019-05-30 04:49:53.539  - info: iobroker host.Test Counted 2 adapters for tr-064
    2019-05-30 04:49:53.545  - info: iobroker host.Test Counted 12 devices of tr-064
    2019-05-30 04:49:53.551  - info: iobroker host.Test Counted 4 channels of tr-064
    2019-05-30 04:49:53.578  - info: iobroker host.Test Counted 78 states of tr-064
    2019-05-30 04:49:53.613  - info: iobroker host.Test Counted 29 states (io.tr-064.*) from states
    2019-05-30 04:49:53.620  - info: iobroker host.Test Counted 10 states (system.adapter.tr-064.*) from states
    2019-05-30 04:49:53.636  - info: iobroker host.Test Deleting 98 object(s).
    2019-05-30 04:49:53.868  - info: host.Test object change system.adapter.tr-064-community.0
    2019-05-30 04:49:53.868  - info: host.Test object deleted system.adapter.tr-064-community.0
    2019-05-30 04:49:53.869  - info: host.Test stopInstance system.adapter.tr-064-community.0
    2019-05-30 04:49:53.870  - info: host.Test stopInstance system.adapter.tr-064-community.0 killing pid 3498
    2019-05-30 04:49:53.875  - info: host.Test object change system.adapter.tr-064.0
    2019-05-30 04:49:53.875  - info: host.Test object deleted system.adapter.tr-064.0
    2019-05-30 04:49:53.875  - info: host.Test stopInstance system.adapter.tr-064.0
    2019-05-30 04:49:53.875  - info: host.Test stopInstance system.adapter.tr-064.0 killing pid 1403
    2019-05-30 04:49:53.878  - info: iobroker host.Test Deleting 39 state(s).
    2019-05-30 04:49:53.904  - error: host.Test instance system.adapter.tr-064.0 terminated with code 0 (OK)
    2019-05-30 04:49:53.905  - info: host.Test Do not restart adapter system.adapter.tr-064.0 because disabled or deleted
    2019-05-30 04:49:53.907  - error: host.Test instance system.adapter.tr-064-community.0 terminated with code 0 (OK)
    2019-05-30 04:49:53.907  - info: host.Test Do not restart adapter system.adapter.tr-064-community.0 because disabled or deleted
    2019-05-30 04:49:54.354  - info: iobroker npm uninstall iobroker.tr-064 --silent --save --prefix "/opt/iobroker" (System call)
    2019-05-30 04:49:54.629  - error: host.Test Cannot write files: /opt/iobroker/node_modules/iobroker.js-controller/lib/objects/../../../../iobroker-data/files/tr-064.admin/_data.json: ENOENT: no such file or directory, open '/opt/iobroker/node_modules/iobroker.js-controller/lib/objects/../../../../iobroker-data/files/tr-064.admin/_data.json'
    2019-05-30 04:50:08.667  - error: iobroker Error deleting adapter tr-064 from disk: Error: host.Test: Cannot uninstall iobroker.tr-064: 216You might have to delete it yourself!
    
    2019-05-30 04:50:08.674  - info: iobroker exit 0
    


  • @Issi
    ich hatte beide installiert, den alten deinstalliert und der neu blieb wie gehabt am Laufen. Scheint als wäre bei Dir ne Vermischung gewesen.

    Mal ne andre Frage, sollte das soef Modul nicht mit der Community Version ersetzt werden?


  • Developer

    @Jan1 ja kann sein ich teste es noch paar mal ☺

    Mal ne andre Frage, sollte das soef Modul nicht mit der Community Version ersetzt werden?

    noch ist es auf jeden fall drin sagte

    @apollon77 sagte in [Aufruf] Test Community-Version vom tr-064 Adapter:

    Jain ... Es ist immer noch drin, aber nicht mehr als externe Abhängigkeit, sondern integriert.



  • @Jan1 sagte in [Aufruf] Test Community-Version vom tr-064 Adapter:

    @Issi
    ich hatte beide installiert, den alten deinstalliert und der neu blieb wie gehabt am Laufen. Scheint als wäre bei Dir ne Vermischung gewesen.

    Hast recht, hatte auch beide drauf, dann den alten weg, der neue blieb.

    Mal ne andre Frage, sollte das soef Modul nicht mit der Community Version ersetzt werden?

    Genauso hatte ich es auch verstanden



  • Gut, das erklärt zumindest mal dass es auch mit der Community Version zu Problemen mit dem Modul kommen kann.

    Eins noch, wäre es nicht möglich den Adapter Namen nicht zu verändern, da so sämtliche Scripte an den "neuen" Pfad angepasst werden müssen und da die restlichen Adapter von soef ja auch irgendwann mal eingepflegt werden, ist das bei einigen recht viel Aufwand. Oder hab ich hier eine Funktion übersehen mit der man das mit einem Klick erledigen kann?


  • Developer

    ok dass mit dem doppelt löschen war anscheint wirklich irgend eine Vermischung der Adapter hat jetzt alles so wie es soll funktioniert


  • Starter

    Adapter gestern installiert ohne Probleme, bisher nichts negativ auffällig gewesen.
    Eine Verbesserung fiel mir sofort auf, „getPauseState“ wechselt bei aktiver Telefonverbindung auf „connect“, beim alten Adapter änderte sich dort nichts bei mir.


  • Forum Testing Most Active

    Und bitte nicht umbenennen, ich passe gerade alle meine Skripte an...............


  • Forum Testing Most Active

    Sorry @sigi234 ...

    @Jan1 sagte in [Aufruf] Test Community-Version vom tr-064 Adapter:

    Eins noch, wäre es nicht möglich den Adapter Namen nicht zu verändern, da so sämtliche Scripte an den "neuen" Pfad angepasst werden müssen und da die restlichen Adapter von soef ja auch irgendwann mal eingepflegt werden, ist das bei einigen recht viel Aufwand. Oder hab ich hier eine Funktion übersehen mit der man das mit einem Klick erledigen kann?

    Wäre ich auch dafür. Solange er noch im Test ist, völlig OK zur klaren Abgrenzung. Warum aber einen neuen Namen für im Grunde den gleichen Adapter? Der "alte" fliegt doch dann eh raus, da genügt doch eine neue Versionsnummer. Mag gar nicht daran denken wo der überall bei mir drin steckt...
    ...und die One-Klick-Lösung suche ich auch noch^^
    ...oder alles im LinkedDevice-Adapter...


  • Forum Testing Most Active

    @SBorg sagte in [Aufruf] Test Community-Version vom tr-064 Adapter:

    Sorry @sigi234 .

    Wenn man nicht alles durchlest kommt sowas raus...........
    Leider kann man es ja nicht löschen.



  • Nachdem der alte Adapter nicht mehr möchte nach dem Admin update habe ich diesen hier gefunden. Leider lässt er sich nicht installieren. Muss ich mal schauen was da falsch läuft.


  • Developer

    @markus397 sagte in [Aufruf] Test Community-Version vom tr-064 Adapter:

    Nachdem der alte Adapter nicht mehr möchte nach dem Admin update habe ich diesen hier gefunden. Leider lässt er sich nicht installieren. Muss ich mal schauen was da falsch läuft.

    ein Log wäre schön dann könnte man vllt helfen



  • $ ./iobroker url "https://github.com/iobroker-community-adapters/ioBroker.tr-064-community"
    install https://github.com/iobroker-community-adapters/ioBroker.tr-064-community/tarball/master
    npm install https://github.com/iobroker-community-adapters/ioBroker.tr-064-community/tarball/master --production --save --prefix "/opt/iobroker" (System call)
    npm WARN deprecated dgram@1.0.1: npm is holding this package for security reasons. As it's a core Node module, we will not transfer it over to other users. You may safely remove the package from your dependencies.
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/npmlog/node_modules/are-we-there-yet/node_modules/readable-stream/node_modules/buffer-shims/package.json'npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/npmlog/node_modules/are-we-there-yet/node_modules/readable-stream/node_modules/core-util-is/package.json'
    
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/npmlog/node_modules/are-we-there-yet/node_modules/readable-stream/node_modules/inherits/package.json'npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/npmlog/node_modules/are-we-there-yet/node_modules/readable-stream/node_modules/isarray/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/npmlog/node_modules/are-we-there-yet/node_modules/readable-stream/node_modules/process-nextick-args/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/npmlog/node_modules/are-we-there-yet/node_modules/readable-stream/node_modules/string_decoder/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/npmlog/node_modules/are-we-there-yet/node_modules/readable-stream/node_modules/util-deprecate/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/npmlog/node_modules/gauge/node_modules/string-width/node_modules/code-point-at/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/npmlog/node_modules/gauge/node_modules/string-width/node_modules/is-fullwidth-code-point/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/npmlog/node_modules/gauge/node_modules/strip-ansi/node_modules/ansi-regex/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/har-validator/node_modules/chalk/node_modules/ansi-styles/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/har-validator/node_modules/chalk/node_modules/escape-string-regexp/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/har-validator/node_modules/chalk/node_modules/has-ansi/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/har-validator/node_modules/chalk/node_modules/strip-ansi/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/har-validator/node_modules/chalk/node_modules/supports-color/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/har-validator/node_modules/is-my-json-valid/node_modules/generate-function/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/har-validator/node_modules/is-my-json-valid/node_modules/generate-object-property/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/har-validator/node_modules/is-my-json-valid/node_modules/jsonpointer/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/har-validator/node_modules/is-my-json-valid/node_modules/xtend/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/har-validator/node_modules/pinkie-promise/node_modules/pinkie/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/http-signature/node_modules/jsprim/node_modules/extsprintf/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/http-signature/node_modules/jsprim/node_modules/json-schema/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/http-signature/node_modules/jsprim/node_modules/verror/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/assert-plus/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/bcrypt-pbkdf/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/dashdash/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/ecc-jsbn/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/getpass/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/jodid25519/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/request/node_modules/http-signature/node_modules/sshpk/node_modules/tweetnacl/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/rimraf/node_modules/glob/node_modules/minimatch/node_modules/brace-expansion/package.json'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/serialport/node_modules/node-pre-gyp/node_modules/tar-pack/node_modules/fstream-ignore/node_modules/minimatch/node_modules/brace-expansion/package.json'
    npm WARN bl@0.7.0 requires a peer of stream-browserify@* but none is installed. You must install peer dependencies yourself.
    
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: osx-temperature-sensor@1.0.3 (node_modules/osx-temperature-sensor):npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for osx-temperature-sensor@1.0.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"arm64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: xpc-connection@0.1.4 (node_modules/xpc-connection):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for xpc-connection@0.1.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"arm64"})
    
    
    process exited with code 0
    


  • @Issi sagte in [Aufruf] Test Community-Version vom tr-064 Adapter:

    sudo npm install soef

    eben gemacht,...danach geht es sofort.
    Muss also definitiv mit rein.



  • Das dies funktioniert ist klar, allerdings hatte @apollon77 ja geschrieben daß er zwar benötigt wird aber im Adapter integriert ist. Scheint so wohl noch nicht zu funktionieren.



  • @steimi sagte in [Aufruf] Test Community-Version vom tr-064 Adapter:

    Das dies funktioniert ist klar, allerdings hatte @apollon77 ja geschrieben daß er zwar benötigt wird aber im Adapter integriert ist. Scheint so wohl noch nicht zu funktionieren.

    ja, hatte ich ja auch schon geschrieben, bin allerdings noch nicht so fit um alles richtig zu beurteilen.



  • Also, da ist ein riesen Bock drin.
    Hab mal was getestet.

    nagelneue IOBroker Installation, kommt mit JS 1.5.11

    alte TR064 geht nicht mehr ( müsste der jetzt nicht aus den wählbaren Adaptern raus ? )
    deinstalliert
    neue TR064 geht nicht, wird nicht grün, soef fehlt
    sudo npm install soef
    neue geht immer noch nicht !!
    alte TR064 wieder installiert
    jetzt geht der neue, der alte aber natürlich immer noch nicht, wird er vermutlich unter JS 1.5.11 auch nicht mehr
    also, alte wieder runter.... der neue wieder rot 😨
    also, der alte wieder drauf..... --> der neue wieder grün.
    Instanz vom alten deaktiviert.
    Was ein Durcheinander.

    Kurzum, es gibt da ziemlich üble Abhängigkeiten, der alte geht gar nicht mehr, der neue nur wenn der alte installiert ist.

    Und für die die anderer Meinung sind....
    Ich habe hier ein nagelneues installiertes Sytem !, wenn das bei Euch irgendwie anders oder besser funktioniert
    könnte es vielleicht sein weil ihr noch alte für den TR064 benötigte Programmteile installiert habt.


  • Developer

    @skokarl sagte in [Aufruf] Test Community-Version vom tr-064 Adapter:

    Also, da ist ein riesen Bock drin.
    Hab mal was getestet.

    nagelneue IOBroker Installation, kommt mit JS 1.5.11

    alte TR064 geht nicht mehr ( müsste der jetzt nicht aus den wählbaren Adaptern raus ? )
    deinstalliert
    neue TR064 geht nicht, wird nicht grün, soef fehlt
    sudo npm install soef
    neue geht immer noch nicht !!
    alte TR064 wieder installiert
    jetzt geht der neue, der alte aber natürlich immer noch nicht, wird er vermutlich unter JS 1.5.11 auch nicht mehr
    also, alte wieder runter.... der neue wieder rot 😨
    also, der alte wieder drauf..... --> der neue wieder grün.
    Instanz vom alten deaktiviert.
    Was ein Durcheinander.

    Kurzum, es gibt da ziemlich üble Abhängigkeiten, der alte geht gar nicht mehr, der neue nur wenn der alte installiert ist.

    Und für die die anderer Meinung sind....
    Ich habe hier ein nagelneues installiertes Sytem !, wenn das bei Euch irgendwie anders oder besser funktioniert
    könnte es vielleicht sein weil ihr noch alte für den TR064 benötigte Programmteile installiert habt.

    hast du das sudo npm install soef im /opt/iobroker/node_modules/iobroker.tr-064-community gemacht ?



  • @Issi nein, muss das ?

    Hatte ich aber bei meinem ersten Versuch heute mittag auch nicht, und da hat es sofort den Adapter grün gemacht.


Log in to reply
 

Suggested Topics

1.3k
Online

32.0k
Users

38.7k
Topics

525.2k
Posts