NEWS

[Diskussion] js-controller 1.5.8 im Latest Repository



  • Hi,

    wie in https://forum.iobroker.net/post/259008 informiert ist auch der js-controller in 1.5.8 jetzt für weitere Tests freigegeben und soll als nächstes ins Stable Repository kommen. Changelog im Announcement-Thread.

    Fragen oder Diskussionen? Hier ist der richtige Platz.

    Bitte beachtet vor allem:
    Breaking changes von 1.5.7:

    On Master/Slave systems please start updating master and the slaves afterwards
    Required versions of adapters (only if used) for normal functionality: javascript >= 3.6.5, dasWetter >= 2.7.1, upnp >= 1.0.4
    (bluefox) Breaking changes: "][*,;'"`<>?" are no more allowed in IDs
    

    Falls Euer System Rechteprobleme hat überlegt bitte ggf den Installation Fixer zu nutzen (https://forum.iobroker.net/topic/20211/iobroker-installation-fixer-beta-verfügbar)! Es lohnt sich 🙂

    Dieser thread führt den 1.5.7er Diskussions-Thread fort (https://forum.iobroker.net/topic/20317/diskussion-js-controller-1-5-7-im-latest-repository).


  • Forum Testing Most Active

    Hallo Ingo,

    installiert, werde es beobachten. Alle Adapter Grün.

    Nachtrag:
    TR-064 bei mir Ok!

    Screenshot (3108).png

    Platform: Windows
    Architecture: x64
    CPUs: 4
    Speed: 3912 MHz
    Model: Intel(R) Core(TM) i3-7100 CPU @ 3.90GHz
    RAM: 7.9 GB 
    System uptime: 14:27:47
    Node.js: v8.16.0
    NPM: 6.4.1
    Admin: 3.6.2
    Disk size: 232.3 GiB
    Disk free: 135.4 GiB
    adapters count: 268
    Uptime: 00:03:39
    Active instances: 42
    

  • TeamSpeak Developer Most Active

    grün läuft



  • Nach Update wurde der TR-064 Adapter nicht mehr grün und das stand im LOG:

    host.Beelink	2019-05-07 07:44:04.107	error	instance system.adapter.tr-064.0 terminated with code 1 ()
    Caught	2019-05-07 07:44:04.106	error	by controller[0]: at bootstrapNodeJSCore (internal/bootstrap/node.js:622:3)
    Caught	2019-05-07 07:44:04.106	error	by controller[0]: at startup (internal/bootstrap/node.js:283:19)
    Caught	2019-05-07 07:44:04.106	error	by controller[0]: at Function.Module.runMain (internal/modules/cjs/loader.js:754:12)
    Caught	2019-05-07 07:44:04.106	error	by controller[0]: at Function.Module._load (internal/modules/cjs/loader.js:531:3)
    Caught	2019-05-07 07:44:04.106	error	by controller[0]: at tryModuleLoad (internal/modules/cjs/loader.js:539:12)
    Caught	2019-05-07 07:44:04.106	error	by controller[0]: at Module.load (internal/modules/cjs/loader.js:600:32)
    Caught	2019-05-07 07:44:04.106	error	by controller[0]: at Object.Module._extensions..js (internal/modules/cjs/loader.js:712:10)
    Caught	2019-05-07 07:44:04.106	error	by controller[0]: at Module._compile (internal/modules/cjs/loader.js:701:30)
    Caught	2019-05-07 07:44:04.106	error	by controller[0]: at Object.<anonymous> (/opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:16:20)
    Caught	2019-05-07 07:44:04.106	error	by controller[0]: at Object.exports.Adapter (/opt/iobroker/node_modules/soef/soef.js:1383:23)
    Caught	2019-05-07 07:44:04.106	error	by controller[0]: TypeError: fns.adapter is not a function
    Caught	2019-05-07 07:44:04.106	error	by controller[0]: ^
    Caught	2019-05-07 07:44:04.105	error	by controller[0]: fns.adapter = fns.adapter(options);
    Caught	2019-05-07 07:44:04.105	error	by controller[0]: /opt/iobroker/node_modules/soef/soef.js:1383
    

    Hab dann wieder auf 1.5.7 downgegradet und nun läuft das ganze System nicht mehr:

    Error:	2019-05-07 07:53:08.820	error	at Timer.processTimers (timers.js:223:10)
    Error:	2019-05-07 07:53:08.820	error	at listOnTimeout (timers.js:263:5)
    Error:	2019-05-07 07:53:08.820	error	at tryOnTimeout (timers.js:300:5)
    Error:	2019-05-07 07:53:08.820	error	at ontimeout (timers.js:436:11)
    Error:	2019-05-07 07:53:08.820	error	at Timeout._onTimeout (/opt/iobroker/node_modules/iobroker.js-controller/controller.js:2024:16)
    Error:	2019-05-07 07:53:08.820	error	at Object.writeFileSync (fs.js:1189:35)
    Error:	2019-05-07 07:53:08.820	error	at Object.openSync (fs.js:438:3)
    Error:	2019-05-07 07:53:08.820	error	EACCES: permission denied, open '/opt/iobroker/node_modules/iobroker.js-controller/pids.txt'
    uncaught	2019-05-07 07:53:08.818	error	exception: EACCES: permission denied, open '/opt/iobroker/node_modules/iobroker.js-controller/pids.txt'
    


  • @Jan1 Also diesbezüglich gab es keine Änderung in der 1.5.8. Welche version war vorher drauf? Bitte tr-064 aktualisieren

    Bezüglich der Rechte da ist was komisch. Bitte den Installation Fixer laufen lassen oder das PID file von den rechten her fixen oder löschen



  • @apollon77
    Es lief vorher die 1.5.7 und bis auf den TR-064 lief alles sofort.
    Ich konnte das System nun wieder manuell starten (node node_modules/iobroker.js-controller/controller.js --logs). Der js-controller ist nun auch wieder auf 1.5.7, allerdings läuft der TR-064 Adapter hier nun auch nicht mehr.

    Ich deinstalliere den mal, lass den Fixer laufen (unter root oder normaler User?). Wenn es danach immer noch Probleme gibt, melde ich mich noch mal.


  • TeamSpeak Developer Most Active

    @Jan1 sagte in [Diskussion] js-controller 1.5.8 im Latest Repository:

    TR-064 Adapter

    hab ich auch am laufen.. ohne Probleme.. welche Version ??



  • Via Terminal ins Verzeichnis "/opt/iobroker/node_modules/iobroker.tr-064" gehen und:
    sudo npm install soef



  • @Yetiberg Da wäre ich vorsichtig!! Die soef Library wurde gern zwischen Releases gern mal inompatibel zu vorversionen. Also am besten von Girgub neu installieren den ganzen Adapter oder so



  • @apollon77
    ich bin dabei ein Backup zurück zu spielen, mal sehen obs läuft. Adapter dürfte der aktuellste gewesen sein, da ich auch latest bin und bis auf den Host alles aktuell war 😉



  • dann vllt besser latest npm anstelle GitHub versuchen



  • @apollon77
    wie stelle ich dass denn an?



  • im Zweifel an der Kommandozeile im ioBroker verzeichnis:

    npm install iobroker.tr-064 --production
    dann
    iobroker upload tr-064
    und instanz neu starten



  • Bei mir verlief das Upgrade geräuschlos und alle Adapter sind auch gleich wieder auf grün gewechselt

    [Nachtrag]
    den tr-064 habe ich nicht im Einsatz



  • Also der TR-064 hat definitiv ein Problem mit der neuen js-controiller Version!
    Hab eben mal IOBroker nackt neu installiert und nur den TR-064 Adapter installiert, lief sofort grün. Dann den js-controller aktualisiert und der TR-064 Adapter läuft nicht mehr.
    824ddf1f-4bb3-4ac5-9521-c561eef0a161-grafik.png
    2c96cb86-5e7e-4e09-8f9c-05b67f5233b6-grafik.png

    host.Beelink	2019-05-07 09:11:35.628	info	Restart adapter system.adapter.tr-064.0 because enabled
    host.Beelink	2019-05-07 09:11:35.628	error	instance system.adapter.tr-064.0 terminated with code 1 ()
    Caught	2019-05-07 09:11:35.628	error	by controller[0]: at bootstrapNodeJSCore (internal/bootstrap/node.js:622:3)
    Caught	2019-05-07 09:11:35.627	error	by controller[0]: at startup (internal/bootstrap/node.js:283:19)
    Caught	2019-05-07 09:11:35.627	error	by controller[0]: at Function.Module.runMain (internal/modules/cjs/loader.js:754:12)
    Caught	2019-05-07 09:11:35.627	error	by controller[0]: at Function.Module._load (internal/modules/cjs/loader.js:531:3)
    Caught	2019-05-07 09:11:35.627	error	by controller[0]: at tryModuleLoad (internal/modules/cjs/loader.js:539:12)
    Caught	2019-05-07 09:11:35.627	error	by controller[0]: at Module.load (internal/modules/cjs/loader.js:600:32)
    Caught	2019-05-07 09:11:35.627	error	by controller[0]: at Object.Module._extensions..js (internal/modules/cjs/loader.js:712:10)
    Caught	2019-05-07 09:11:35.627	error	by controller[0]: at Module._compile (internal/modules/cjs/loader.js:701:30)
    Caught	2019-05-07 09:11:35.627	error	by controller[0]: at Object.<anonymous> (/opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:16:20)
    Caught	2019-05-07 09:11:35.627	error	by controller[0]: at Object.exports.Adapter (/opt/iobroker/node_modules/soef/soef.js:1383:23)
    Caught	2019-05-07 09:11:35.627	error	by controller[0]: TypeError: fns.adapter is not a function
    Caught	2019-05-07 09:11:35.626	error	by controller[0]: ^
    Caught	2019-05-07 09:11:35.626	error	by controller[0]: fns.adapter = fns.adapter(options);
    Caught	2019-05-07 09:11:35.626	error	by controller[0]: /opt/iobroker/node_modules/soef/soef.js:1383
    host.Beelink	2019-05-07 09:11:34.828	info	instance system.adapter.tr-064.0 started with pid 22165
    host.Beelink	2019-05-07 09:11:04.813	info	Restart adapter system.adapter.tr-064.0 because enabled
    

    wobei bei der IOBroker Installation auch das als Fehler in der Konsole aufgetaucht ist (lief aber durch):

    make: *** [Release/obj.target/unix_dgram/src/unix_dgram.o] Fehler 1
    gyp ERR! build error
    gyp ERR! stack Error: `make` failed with exit code: 2
    gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:262:23)
    gyp ERR! stack     at ChildProcess.emit (events.js:189:13)
    gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)
    gyp ERR! System Linux 4.9.0-9-amd64
    gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
    gyp ERR! cwd /opt/iobroker/node_modules/unix-dgram
    gyp ERR! node -v v10.15.3
    gyp ERR! node-gyp -v v3.8.0
    gyp ERR! not ok
    

    Hier mal die gesamte Ausgabe der Konsole von der IOBroker Installation:



  • @apollon77 sagte in [Diskussion] js-controller 1.5.8 im Latest Repository:

    im Zweifel an der Kommandozeile im ioBroker verzeichnis:

    npm install iobroker.tr-064 --production
    dann
    iobroker upload tr-064
    und instanz neu starten

    Habe ich getestet und funktioniert nicht.
    Sobald ich auf 1.5.8 hoch gehe, geht der TR-064 Adapter mit dem oben geposteten Fehler nicht mehr. Auch wenn ich danach wieder zurück auf 1.5.7 gehe.

    Was allerdings da Problem löst und zwar dauerhaft, ist der Vorschalg von @Yetiberg "sudo npm install soef"

    im Verzeichnis "/opt/iobroker/node_modules/iobroker.tr-064".
    Das funktioniert selbst wenn ich von 1.5.8 nach 1.5.7 zurück gehe, Adapter wird sofort grün und bleibt auch grün bei einem erneuten Update auf 1.5.8.

    Das ganze hab ich wieder auf einer jungfräulichen IOBroker Installation mit Node 10.15.3 und NPM 6.9.0 unter Debian 9.8 mit 64 Struktur getestet.
    Also irgendwas passt da nicht zusammen.

    Braucht Ihr noch mehr Infos zum System? Ich bin heute noch bis 13Uhr am Basteln 😉



  • Eine frische Installation bringt js-controller 1.4.2 denke ich ... ist also die Frage ob das an 1.4.2->1.5.x liegt ... an 1.5.8 an sich kann ich mir nicht vorstellen.

    Wenn ein install der soef lib ersthal hilft ist ja super. Der Adapter wird eh bald durch eine community Version ersetzt


  • TeamSpeak Developer Most Active

    @Jan1
    nochmal bei mir läuft es

    e54c53cc-fb16-48c4-a4a7-ca487d29ec66-grafik.png

    ef8ac089-8a5b-4168-824a-d5aeb9c03921-grafik.png



  • @apollon77
    Welcher Adapter wird ersetzt, der TR-064?

    Also ich teste gerne wo es hier klemmt, hab gerade alles wieder mit einem Backup und der aktuellen Version 1.5.8 am Laufen, wobei er mir jetzt das Problem beim wifilight Adapter an meckert.
    Ich schau mal ob man das auch mit "sudo npm install soef" auf die Reihe bekommt, an sonst lösche ich noch mal alles und bleibe bei der 1.5.7.



  • @arteck
    Ja das ist schön für Dich, hatte ja auch einige Fehler bei der IOBroker Installation gepostet, die eventuell an der Node 10 oder an meinem 64er Debian liegen könnten.
    Ich bin hier nicht wirklich fit und deshalb postet ich auch alles was auffällig ist. Bei mit läuft der TR-064 ja nun auch, nach dem ich "sudo npm install soef" im Adapter Verzeichnis durchgeführt hatte, nur dass jetzt eben der wifilight Adapter das an meckert.

    Ich bin hier auf Euch angewiesen, was noch zu tun ist, oder doch was am gesamt System nicht passt. Deshalb bitte fragen wenn ich mich unklar ausdrücke, oder mehr Infos benötigt werden.


Log in to reply
 

Suggested Topics

1.7k
Online

29.9k
Users

37.0k
Topics

495.3k
Posts