NEWS

Proxmox USB an LXC durchreichen



  • Moin zusammen,

    ich habe ioBroker seit ein paar Wochen am laufen. Bin also noch ein Anfänger.

    ioBroker läuft als LXC unter Proxmox.

    Nun habe ich mir mir die Tage einen fertigen CC2531 Zigbee Stick gekauft.

    Erst als beim anstecken nix passierte, habe ich im Netz gelesen, dass man den USB Port durchreichen muss.

    Muss ich die Hardware ID oder was auch immer ich jetzt brauche aus dem ioBroker LXC auslesen?

    Oder direkt unter Proxmox?

    Kann man das alles über die WebGui von Proxmox machen? Oder muss ich das per Putty erledigen?

    Zuletzt habe ich gelesen, dass man bei einem LXC Container noch eine Config anpassen muss.

    Ich weiss nicht wirklich, wie ich jetzt anfange. Möchte meine Proxmox Installation nicht zerstören.

    Vielleicht kann mir ja jemand verständlich erklären, was zu machen ist.

    Da wäre ich sehr dankbar.

    LG Kai



  • Hi Kai,

    mit dieser Anleitung solltest du genau das Ergebnis erhalten, das du benötigst: http://coldcorner.de/2018/07/12/proxmox … wave-uzb1/

    Grüße

    Bastian



  • Hi Bastian,

    vielen Dank für den Link.

    Ich habe jetzt alles so gemacht wie dort beschrieben wird.

    Was mich wundert, ist das in der Anleitung von einem Gerät ttyACM0 gesprochen wird. So habe ich es dann auch gemacht.

    root@pve:~# pct stop 101
    root@pve:~# lsusb
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 002: ID 8087:0a2b Intel Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    root@pve:~# lsusb
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 002: ID 8087:0a2b Intel Corp.
    Bus 001 Device 003: ID 0451:16a8 Texas Instruments, Inc.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    root@pve:~# ls -l /dev/bus/usb/001/003
    crw-rw-r-- 1 root root 189, 2 Feb  7 19:40 /dev/bus/usb/001/003
    root@pve:~# cd /etc/pve/nodes/pve/lxc
    root@pve:/etc/pve/nodes/pve/lxc# ls
    101.conf
    root@pve:/etc/pve/nodes/pve/lxc# nano 101.conf
    root@pve:/etc/pve/nodes/pve/lxc# nano 101.conf
    root@pve:/etc/pve/nodes/pve/lxc# ls -l /dev/ttyACM0
    crw-rw---- 1 root dialout 166, 0 Feb  7 19:40 /dev/ttyACM0
    root@pve:/etc/pve/nodes/pve/lxc# nano 101.conf
    root@pve:/etc/pve/nodes/pve/lxc# chmod o+rw /dev/ttyACM0
    root@pve:/etc/pve/nodes/pve/lxc# pct start 101
    root@pve:/etc/pve/nodes/pve/lxc# pct stop 101
    root@pve:/etc/pve/nodes/pve/lxc# lsusb
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 002: ID 8087:0a2b Intel Corp.
    Bus 001 Device 003: ID 0451:16a8 Texas Instruments, Inc.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    root@pve:/etc/pve/nodes/pve/lxc#  101.conf
    -bash: 101.conf: command not found
    root@pve:/etc/pve/nodes/pve/lxc# ls -l /dev/bus/usb/001/003
    crw-rw-r-- 1 root root 189, 2 Feb  7 19:40 /dev/bus/usb/001/003
    root@pve:/etc/pve/nodes/pve/lxc# 1
    -bash: 1: command not found
    root@pve:/etc/pve/nodes/pve/lxc#
    root@pve:/etc/pve/nodes/pve/lxc# cd /etc/pve/nodes/pve/lxc
    root@pve:/etc/pve/nodes/pve/lxc# nano 101.conf
    root@pve:/etc/pve/nodes/pve/lxc#  101.conf
    -bash: 101.conf: command not found
    root@pve:/etc/pve/nodes/pve/lxc# ls -l /dev/ttyACM0
    crw-rw-rw- 1 root dialout 166, 0 Feb  7 19:40 /dev/ttyACM0
    root@pve:/etc/pve/nodes/pve/lxc#
    root@pve:/etc/pve/nodes/pve/lxc# nano 101.conf
    root@pve:/etc/pve/nodes/pve/lxc# chmod o+rw /dev/ttyACM0
    root@pve:/etc/pve/nodes/pve/lxc# pct start 101
    
    

    Die Konfig habe ich so angepasst. Ich denke das ist richtig:

    arch: amd64
    cores: 2
    hostname: iobroker-1804
    memory: 4096
    net0: name=eth0,bridge=vmbr0,hwaddr=BA:98:73:F5:03:F9,ip=dhcp,type=veth
    onboot: 1
    ostype: ubuntu
    rootfs: local-lvm:vm-101-disk-0,size=8G
    swap: 4096
    lxc.cgroup.devices.allow: c 189:* rwm
    lxc.mount.entry: /dev/bus/usb/001/003 dev/bus/usb/001/003 none bind,optional,cr$
    lxc.cgroup.devices.allow: c 166:* rwm
    lxc.mount.entry: /dev/ttyACM0 dev/ttyACM0 none bind,optional,create=file
    
    

    Wie man den Adapter einrichtet, habe ich hier https://www.youtube.com/watch?v=balBJclg7Gc gefunden.

    Da wird aber nicht von ttyACM0 sondern von ttyAMA0 gesprochen.

    Ist das das gleiche? Das verstehe ich nicht wirklich.

    Ich habe auch den Pfad ls -la /dev/serial nicht.
    9054_ssh.png
    Vielleicht kannst Du Licht ins dunkle bringen.

    LG Kai



  • @Kaiman55 said in Proxmox USB an LXC durchreichen:

    ttyAMA0

    Hallo zusammen,
    kann mi vielleicht jemand weiterhelfen?

    Nachdem ich die oben empfohlene Anleitung durchgeführt habe, wird mein Zigbee Stick durchgereicht.
    Allerdings brauche ich für den Zigbee Adapter noch ein Gerät ttyAMA0.
    Wie erzeuge ich das?

    ich bin ja nach der Anleitung gegangen und habe nur ein ttyACM0
    Ich denke mal, dass das nicht richtig ist.

    Vielen Dank für die Hilfe.


  • Starter

    @Kaiman55
    Hi, bin auch neu bei ioBroker und arbeite mich durch. Wenn du das nach der Anleitung von Coldcorner machst bekommst du logischerweise ein /dev/ttyACM0. ttyAMA0 wäre korrekt, wenn du einen HAT auf einem Pi benutzen wolltest. Bei mir klappt es nach der Anleitung von Coldcorner einwandfrei mit einer Ubuntu LXC.
    Den Pfad /dev/serial habe ich auch nicht, das mag am Betriebssystem liegen. Was für ein Template hast du denn für deine VM bzw. den Container benutzt?
    Was mich viel mehr nervt, ist, dass ich keine ZWEI USB-Sticks durchgereicht bekomme. Die haben beide (zigbee2mqtt und ein nanoCUL) die gleiche ID (189). Da muss ich wohl noch ein wenig gucken, wie ich das hin bekomme.

    LG



  • woher weiß man denn welches Gerät hier angelegt werden muss?



  • @Arne-Schuch bei mir klappt das nicht. Möchte usb zigbee durchreichen. Denke es liegt am Gerät was man anlegen muss. Woher weiß man welches tty man da anlegt?


  • Starter

    @Gerni Du musst die Geräte nicht selbst anlegen.
    Mit

    ls -l /dev/ttyA*
    

    solltest du auf der pve-Konsole die vorhandenen Geräte angezeigt bekommen.

    root@pve:~# ls -l /dev/ttyACM*
    crw-rw-rw- 1 root dialout 166, 0 Jul 30 07:03 /dev/ttyACM0
    crw-rw-rw- 1 root dialout 166, 1 Jul 30 11:35 /dev/ttyACM1
    

    Die musst du dann in der jeweiligen .conf-Datei ebenfalls eintragen. Bei mir sieht das dann so aus.

    arch: amd64
    cores: 2
    hostname: ioBroker
    memory: 2048
    net0: name=eth0,bridge=vmbr0,firewall=1,hwaddr=5A:BB:D9:5A:66:12,ip=dhcp,ip6=dhcp,type=veth
    ostype: ubuntu
    rootfs: local-lvm:vm-4000-disk-0,size=16G
    swap: 512
    unprivileged: 1
    lxc.cgroup.devices.allow: c 189:138 rwm
    lxc.mount.entry: /dev/bus/usb/002/011 dev/bus/usb/002/011 none bind,optional,create=file
    lxc.cgroup.devices.allow: c 166:0 rwm
    lxc.mount.entry: /dev/ttyACM0 dev/ttyACM0 none bind,optional,create=file
    lxc.cgroup.devices.allow: c 189:139 rwm
    lxc.mount.entry: /dev/bus/usb/002/012 dev/bus/usb/002/012 none bind,optional,create=file
    lxc.cgroup.devices.allow: c 166:1 rwm
    lxc.mount.entry: /dev/ttyACM1 dev/ttyACM1 none bind,optional,create=file
    

    Wenn du danach den Container neu startest solltest du die dort dann auch sehen.

    LG A



  • @Arne-Schuch sagte in Proxmox USB an LXC durchreichen:

    usst die Geräte nicht selbst anlegen.

    Na dann gehe ich da nochmal ran. Wenn das läuft wäre ja echt cool dann kann wieder ein Pi weg.



  • @Arne-Schuch kannst du mich vielleicht nochmal abholen bzgl der Datei also wie aufrufen usw damit ich sicher das richtige mache?



  • @Gerni also ich nutze auch Proxmox, allersings richtige VMs, keine Container. In meiner ioBrokerVM musste ich nix an der config ändern. Ging alles ganz easy einfach über die Proxmox-Oberfläche (siehe Fotos).

    ProxmoxUSB1.png

    ProxmoxUSB2.png


  • Forum Testing

    @Kueppert sagte in Proxmox USB an LXC durchreichen:

    @Gerni also ich nutze auch Proxmox, allersings richtige VMs, keine Container. In meiner ioBrokerVM musste ich nix an der config ändern. Ging alles ganz easy einfach über die Proxmox-Oberfläche (siehe Fotos).

    Ja habe ich auch schon festgestellt. An einer VM lässt sich USB viel einfacher durchreichen als bei einem LXC


  • Developer

    @Kueppert sagte in Proxmox USB an LXC durchreichen:

    @Gerni also ich nutze auch Proxmox, allersings richtige VMs, keine Container. In meiner ioBrokerVM musste ich nix an der config ändern. Ging alles ganz easy einfach über die Proxmox-Oberfläche (siehe Fotos).

    Stimme Dir absolut zu, dass das in VMs deutlich einfacher geht, aber ich nehme immer Container, wann nur möglich. Weniger Ressourcen, Backups kleiner, bootet schneller, schnellere Installation usw. Nur eben das Durchreichen von USB aufwändiger und deutlich zeitintensiver.

    @Gerni sagte in Proxmox USB an LXC durchreichen:

    @Arne-Schuch kannst du mich vielleicht nochmal abholen bzgl der Datei also wie aufrufen usw damit ich sicher das richtige mache?

    In der Konsole eingeben: sudo nano /etc/pve/nodes/pve/lxc/105.conf
    Wobei statt "105" Du die ID Deines Containers nimmst.

    ACHTUNG:
    In vielen Anleitungen steht, dann am Ende der Datei die Zeilen "lxc.cgroup.devices.allow......... usw." einfügen. Das klappt aber nicht, wenn Du Snapshots angelegt hast. Dann musst Du das vor den Snapshots einfügen, also hier im Beispiel beim roten Pfeil.
    snapshot.png



  • ok dann versuche ich das doch nochmal per VM, wahrscheinlich einfacher.

    Klappt das so auch irgendwie eine USB Festplatte an den pve anzubinden die dann für Backups, Images und Templates genutzt wird?


  • Developer

    @Gerni sagte in Proxmox USB an LXC durchreichen:

    Klappt das so auch irgendwie eine USB Festplatte an den pve anzubinden die dann für Backups, Images und Templates genutzt wird?

    Ja, sehr gut sogar. Mach am besten einen neuen Thread mit aussagekräftigem Titel auf, dann wird dir geholfen.



  • deconz ist nun in einer VM installiert, USB Gateway ebenfalls gefunden und verbunden. Nur über welche Adresse rufe ich die GUI nun auf? Die IP der VM ist es nicht

    EDIT: Falscher Thread kann ich hier jedoch nicht löschen.


  • Starter

    @Gerni Dann hat sich das erledigt? Hätte sonst gern geholfen.



  • @Arne-Schuch jep, :8080 vergessen.

    Ggf heute Abend versuchen eine USB Platte an pve zu übergeben für Backups usw. Wenn Du möchtest, Hilfe gern gesehen.



  • @Mic USB Platte an Proxmox pve habe ich erstellt. Weiß nur nicht wie ich das hier per Smartphone verlinken kann aber Vielleicht findest du es ja.


  • Starter

    @Gerni sagte in Proxmox USB an LXC durchreichen:

    @Mic USB Platte an Proxmox pve habe ich erstellt. Weiß nur nicht wie ich das hier per Smartphone verlinken kann aber Vielleicht findest du es ja.

    Bin gerade maximalverwirrt. 😀
    Du hast jetzt umgestellt auf VM? Sehe ich richtig, ja? Da brauchst du also keine Unterstützung mehr, wie das bei CTs funktioniert?
    Und die USB-Platte hast du auch dran und Backups bzw. Snapshots aktiviert?
    Also alles fluffig?


Log in to reply
 

Suggested Topics

  • 2
  • 4
  • 6
  • 3
  • 9
  • 5
  • 37
  • 8

2.0k
Online

32.6k
Users

39.1k
Topics

530.3k
Posts