NEWS

Installationsprobleme Raspberry pi



  • @gutgut30 sagte in Installationsprobleme Raspberry pi:

    @Jan1
    Du hast mein Posting aber schon vollständig gelesen und gesehen wo die Fragestellung und Problematik liegt?
    Es sind ja sogar konkrete Infos enthalten was missverständlich ist (beides ausführen, Reihenfolge, nur anpassen) UND dass die Lösung die ich dann gewählt habe (von der ich aus der Anleitung nicht entnehmen kann obs nun die richtige ist) gar nicht zum Ziel führt?

    Welche Art von Beteiligung wird denn von "Neuen Usern" erwünscht wenn man hier schon so "angefressen" auf konstruktive Hinweise reagiert?

    Du beschreibst es genau so wie ich es auch sehe. Ich bin nun doch schon 40 Jahre alt und beschäftige mich mit IObroker nun schon 7 Jahre. Dennoch hatte ich hier erhebliche Schwierigkeiten ein laufendes System zu erstellen.
    Das sollte in keiner Weise eine Kritik sein aber manchmal ist es eben so, dass es die Profis als "ganz klar sehen" sehen. Immerhin stecken sie viel tiefer in der Materie drin und das ist auch gut so. Dafür meinen Dank und Anerkennung!

    Da ich aber meistens nur die Updates über das WebUI mache komme ich normalerweise kaum mit der Konsole in Berührung. Da ich aber hier ein neues System aufsetzen wollt bin ich immer wieder an den 8.x hängen geblieben und ein Fertiges Image gibt's mit 10.x im Moment nicht. Ich bin daher auf eine genaue Anleitung angewiesen, an diesem Punkt war die Anleitung mir auch nicht präzise genug. Und das war nur als Hinweis zu sehen könnte auch andere treffen. Ich denke schon das man das sagen darf.

    Um es fest zu halten, nur diesen Befehl nicht den Befehl mit 8.x:
    curl -sL https://deb.nodesource.com/setup_10.x | sudo -E bash -

    Nochmals Herzlichen Dank das System läuft und läuft ...


  • Forum Testing Most Active Global Moderator Administrators

    @gutgut30

    Da ich von @deimos noch kein Feedback habe, bitte nur als Workaround sehen, da ich nicht weiß ob hinter dem Problem und seiner "Lösung" noch anderes steckt, was mit der Lösung evtl. nicht mehr klappt.

    Wir denken zwar nicht, aber wenn doch werde ich es hier sofort melden.

    Vorgehen für ioBroker mit piVCCU auf Raspberry Pi mit Buster

    • Das entsprechende Image bei Github herunterladen
    • Image aktualisieren mit sudo apt update && sudo apt upgrade
    • Gemäß der Doku Schritt 2 und 3 vornehmen
      • Überprüfung sollte aber nichts ergeben
    • jetzt den Befehl sudo update-ca-certificates --fresh ausführen
    • ab jetzt mit Schritt 4 der Doku fortfahren

    Viel Glück


  • Forum Testing Most Active

    @chemieka sagte in Installationsprobleme Raspberry pi:

    und ein Fertiges Image gibt's mit 10.x im Moment nicht

    Ja Leider, ich hoffe es wird eines gemacht.................



  • @chemieka
    Ich bin wesentlich frischer mit IOBroker unterwegs, so gutes Jahr und älter bin ich auch. Hab nix mit Informatik am Hut und bin von Raspi auf den Beelink mit der alten Anleitung direkt auf Node 10 und Debian Buster umgezogen. Da war noch nicht mal klar, dass Buster nur mit Node 10 läuft und hatte mit der Anleitung kein Problem (mit der alten und da stand weniger drin). Nein ich bin keine Leuchte und verstehe vieles auch nicht sofort, aber lebe eben nach dem Motto, wenn's die anderen geschafft haben, schaff ich das auch, auch wenn's mal länger dauert. Hab auch schon oft eine Anleitung 3 mal gelesen und dachte das ist Quark und beim vierten Mal hats klick gemacht. Ist eben so.
    Ist genau das was ich meine, man kann rein schreiben was man will , ein paar User kommen trotzdem nicht zurecht. Das Problem, wenn man noch mehr reinschreibt, kann noch mehr fehlinterpretiert werden und die Anleitung wird unübersichtlich. Was anderes, wenn klare Fehler drin stehen, oder sich was komplett geändert hat.

    Fakt ist eben, alles was relevant ist steht drin. Ab und an hilft wirklich mal kurz Ruhe und nachdenken, oder einfach ausprobieren.


  • Forum Testing Most Active Global Moderator Administrators

    @gutgut30 sagte in Installationsprobleme Raspberry pi:

    Es sind ja sogar konkrete Infos enthalten was missverständlich ist

    Und genau das habe ich nicht verstanden wo da was unverständlich war.

    Natürlich ist Feedback gewünscht, aber wenn ich es nicht verstehe nutzt es nix.

    PS.
    Es ist noch ein Fehler drin gewesen (?)
    In der Befehlszeile sollte natürlich eine 10 statt der 8 stehen.
    Das ist bereits korrigiert, es kann nur etwas dauern bis es in der Doku erscheint


  • Starter

    Ich probiere es gerne noch mal - kann mir eigentlich nicht vorstellen etwas so dermaßen falsch verstanden zu haben. Denke aber ich werde beim gleichen Ergebnis landen:

    Auf der einen SD-Karte (dieser Thread) kommt kein npm mit, auf der anderen (anderer Thread) startet die Installation nicht. Vielleicht liegt es aber auch am Image welches ich verwende (ein "fertiges" mit pivccu3). Ich werde es noch mal mit einem offiziellen, absolut nacktem Buster-Image versuchen.

    Aller guten Dinge sind drei.


  • Forum Testing Most Active Global Moderator Administrators

    @gutgut30
    Ich versuche es gerade zu reproduzieren.

    Seit meiner Testinstallationmit Buster auf dem Pi4 ist eine neue Version RaspBian herausgekommen.

    Ich weiß noch nicht, ob da ggf. ein Bug drin sist


  • Forum Testing Most Active Global Moderator Administrators

    @gutgut30

    Bei mir klappt es:

    All packages are up to date.
    pi@raspberrypi:~ $ node -v
    -bash: node: command not found
    pi@raspberrypi:~ $ nodejs -v
    -bash: nodejs: command not found
    pi@raspberrypi:~ $ npm -v
    -bash: npm: command not found

    pi@raspberrypi:~ $ curl -sL https://deb.nodesource.com/setup_10.x | sudo -E bash -

    :
    :
    :

    pi@raspberrypi:~ $ sudo apt install -y nodejs

    :
    :
    :

    pi@raspberrypi:~ $ node -v
    v10.16.0
    pi@raspberrypi:~ $ nodejs -v
    v10.16.0
    pi@raspberrypi:~ $ npm -v
    6.9.0

    pi4_Buster.png


  • Starter

    @Homoran
    Nur damit wir nicht völlig aneinander vorbei reden...

    Nach der Eingabe von:

    curl -sL https://iobroker.net/install.sh | bash -
    

    Muss etwas in der Konsole passieren, oder? Also ich muss nicht via Webbrowser irgendwas machen. Richtig?


  • Forum Testing Most Active Global Moderator Administrators

    @gutgut30 sagte in Installationsprobleme Raspberry pi:

    Nach der Eingabe von:
    curl -sL https://iobroker.net/install.sh | bash -
    Muss etwas in der Konsole passieren, oder?

    Korrekt:

    pi@raspberrypi:~ $ curl -sL https://iobroker.net/install.sh | bash -
    
    ==========================================================================
    
        Welcome to the ioBroker installer!
        Installer version: 2019-07-03
    
        You might need to enter your password a couple of times.
    
    ==========================================================================
    
    
    ==========================================================================
        Installing prerequisites (1/4)
    ==========================================================================
    
    Installed acl
    Installed libavahi-compat-libdnssd-dev
    


  • Meine Zusammenfassung zur Neuinstallation von ioBroker unter Raspbian Buster Lite auf einem Raspberry Pi 3B:

    • Das heruntergeladene Buster-Image auf die SD-Karte schreiben. Dazu z.B. das Programm „etcher“ verwenden.
    • Eine leere Textdatei mit dem Namen „ssh“ auf das neue logische Volume mit dem Namen „boot“ schreiben. Dann braucht man keinen Monitor und Tastatur an den Raspberry anschließen und kann alles von Remote aus machen.
    • SD-Karte in den Raspberry einlegen, den über Ethernet mit dem Netzwerk verbinden und anschalten. Das Booten dauert einen Moment. Grüne LED blinkt.
    • An einem anderen Rechner im Netzerk (z.B. mit Windows) ein Terminal-Programm wie „putty“ o.ä. herunterladen und verwenden, um die über die z.B. Fritzbox (Heimnetzwerk) herausgefundene IP-Adresse des Raspberrys anzusprechen und ein Terminalfenster zu öffnen. Der Raspberry wird „raspberrypi“ heißen.
    • Als User „pi“ mit Kennwort „raspberry“ anmelden. Nichts weiter eingeben. Die folgenden Befehle kann man hier kopieren und mit der rechten Maustaste in putty direkt in die Kommandozeile einfügen und ausführen.
    • curl -sL https://deb.nodesource.com/setup_10.x | sudo -E bash - eingeben und ausführen. Damit ist Node.js 10 als Installationsquelle ausgewählt.
    • Dann sudo apt-get install -y nodejs eingeben und bestätigen. Jetzt ist Node.js 10 installiert.
    • Nichts weiter eingeben oder Verzeichnisse oder sonst was anlegen. Immer noch User „pi“.
    • Jetzt curl -sL https://raw.githubusercontent.com/ioBroker/ioBroker/buster/installer.sh | bash - ausführen und damit ioBroker installieren. Sämtliche „warnings“ ignorieren. Rote „errors“ hier im Thread benennen.
    • logout eingeben und ausführen. „putty“ schließt sich.
    • Wer mag, kann sich wieder mit „putty“ wie oben beschrieben mit User „pi“ und Kennwort „raspberry“ anmelden.
    • In das Installationsverzeichnis mit cd /opt/iobroker wechseln und dort z.B. den Befehl iobroker --help ausprobieren, um zu sehen, was ioBoker auf der Kommandozeile kann.
    • Die Admin-Oberfläche mit einen aktuellen Webbrowser (Firefox, Chrome, Edge, aber kein Internet Explorer) öffnen. Die Adresse ist die IP-Adresse von oben, ergänzt mit dem Port 8081. Also z.B. http://192.168.178.39:8081
    • Adapter nach den eigenen Anforderungen installieren und konfigurieren.
    • Spaß haben.

    Siehe auch zentrale Installationsanleitung für ioBroker unter Linux:
    https://www.iobroker.net/#de/documentation/install/linux.md


  • Forum Testing Most Active Global Moderator Administrators

    @Stabilostick sagte in Installationsprobleme Raspberry pi:

    unter Raspberian Buster Lite auf einem Raspberry Pi 3B:

    Auch wenn es Raspbian heisst ;-), funktioniert es genau so auch auf dem RPi4


  • Forum Testing Most Active Global Moderator Administrators

    @gutgut30 sagte in Installationsprobleme Raspberry pi:

    Nur damit wir nicht völlig aneinander vorbei reden...

    Und?
    Wie sieht es aus?



  • @Homoran sagte in Installationsprobleme Raspberry pi:

    Auch wenn es Raspbian heisst 😉

    Touché. Korrigiert.


  • Starter

    @Homoran
    So, bin durch. Wenn ich mit dem Image direkt von raspberrypi.org arbeite, klappt es. Dafür schon mal besten Dank. So kann ich zumindest endlich mal in den iobroker schauen.

    Auf meiner SD-Karte die auf dem Image mit der pivccu3 basiert, geht es nicht. Das finde ich schon spannend weil es ja auf dem gleichen Grundimage basieren sollte, mir fehlt aber Detailwissen um das jetzt zu bewerten.

    Was ich dabei gesehen habe ist folgendes:
    Auf dem Image von raspberrypi.org erhalte ich auf die curl-Befehle immer eine Rückmeldung in Form von einer Installationsübersicht usw..

    Auf dem pivccu3 Image bekomme ich keine Rückmeldung sondern direkt die Eingabeaufforderung.

    Kann es sein, dass dort curl "deaktiviert" ist oder so etwas?


  • Forum Testing Most Active Global Moderator Administrators

    @gutgut30 sagte in Installationsprobleme Raspberry pi:

    Auf meiner SD-Karte die auf dem Image mit der pivccu3 basiert, geht es nicht. Das finde ich schon spannend weil es ja auf dem gleichen Grundimage basieren sollte, mir fehlt aber Detailwissen um das jetzt zu bewerten.

    Von piVCCU war nie die Rede!
    wo ist diese SD-Karte her?

    Muss ich mir mal ansehen, was @deimos da gemacht hat.

    eventuell ist da schon das falsche node drauf.


  • Forum Testing Most Active Global Moderator Administrators

    @gutgut30 sagte in Installationsprobleme Raspberry pi:

    Auf dem pivccu3 Image bekomme ich keine Rückmeldung sondern direkt die Eingabeaufforderung.

    @stabilostick und ich haben gestern Stunden damit verbracht dieses Verhalten und die Ursache dazu herauszubekommen.

    Es ist uns schlussendlich gelungen eine ioBroker-Installation aufbauend auf das Buster-Image von Alex hinzubekommen.

    Solltest du daran noch interessiert sein, können wir dir einen Workaround anbieten.
    Ich habe Alex bisher noch nicht erreichen können.


  • Starter

    @Homoran Super gerne, ich möchte mich wirklich mit dem Gespann beschäftigen. Wenn du also Infos für mich hast, immer her damit. Ansonsten würde ich versuchen alles manuell, ohne Grundimage aufzubauen. Sollte ja eigentlich auch mit den ganzen Anleitungen gehen.


  • Forum Testing Most Active Global Moderator Administrators

    @gutgut30

    Da ich von @deimos noch kein Feedback habe, bitte nur als Workaround sehen, da ich nicht weiß ob hinter dem Problem und seiner "Lösung" noch anderes steckt, was mit der Lösung evtl. nicht mehr klappt.

    Wir denken zwar nicht, aber wenn doch werde ich es hier sofort melden.

    Vorgehen für ioBroker mit piVCCU auf Raspberry Pi mit Buster

    • Das entsprechende Image bei Github herunterladen
    • Image aktualisieren mit sudo apt update && sudo apt upgrade
    • Gemäß der Doku Schritt 2 und 3 vornehmen
      • Überprüfung sollte aber nichts ergeben
    • jetzt den Befehl sudo update-ca-certificates --fresh ausführen
    • ab jetzt mit Schritt 4 der Doku fortfahren

    Viel Glück



  • Hi Homoran,
    vielen Dank für die einfache und verständliche Zusammenfassung.
    Funktioniert einwandfrei!

    Gruß JR


  • Starter

    @Homoran said in Installationsprobleme Raspberry pi:

    Da ich von @deimos noch kein Feedback habe, bitte nur als Workaround sehen, da ich nicht weiß ob hinter dem Problem und seiner "Lösung" noch anderes steckt, was mit der Lösung evtl. nicht mehr klappt.

    Danke! Wird am Wochenende direkt gemacht.



Suggested Topics

1.8k
Online

32.1k
Users

38.8k
Topics

525.9k
Posts