NEWS

  • Developer

    Hi Leute,

    ich habe einen Adapter zum steuern einer Xbox entwickelt. Der Adapter kann derzeit eine Konsole handhaben und ist noch in einem sehr frühen Stadium. D. h. ich habe ihn unter Windows gar nicht getestet (da ich kein entsprechendes System habe) + teilweise werden noch JSONs geloggt, die Erkennung der Xbox läuft derzeit nur über den Ping und manchmal scheint sie kurz Ping Pong zu spielen obwohl sie aus ist.

    Voraussetzung ist eine Python Version >= 3.5

    Den Adapter kann man testen indem man unter Windows/Mac versucht
    https://github.com/foxriver76/ioBroker.xbox
    von https://youtu.be/nFuiHQD-5wI. Sollte dies nicht möglich sein oder solltet ihr Linux laufen haben, bitte über das Terminal probieren: (wenn ihr bei Linux ohne sudo versucht zu installieren, können die benötigten Debian Packages im Normalfall nicht mit installiert werden).

    sudo -H npm i iobroker.xbox --unsafe-perm
    
    

    Windows Installation & allgemeines Troubleshooting:

    viewtopic.php?f=36&t=17044&p=193027#p192987

    beste Grüße

    fox

  • Developer Most Active Administrators

    Ist ja cool den probieren wir nachher Directory Mal aus !

    Irgendwelche speziellen Feedback wünsche ?

    Sent from my iPhone using Tapatalk

  • Developer

    @Dutchman:

    Ist ja cool den probieren wir nachher Directory Mal aus !

    Irgendwelche speziellen Feedback wünsche ? `

    Grundsätzlich wäre eine erfolgreiche Installation schon mal ein gutes Feedback. Ansonsten natürlich Fehler und was so auffällt.

    Weiterführend, weiß ich nicht unter welchen Umständen manche Funktionen nutzbar sind, z. B. media.record

    Falls das jemand wer herausfindet, gerne posten, damit wir die Doku ergänzen können.

  • Developer Most Active Administrators

    na dan mal los

    Ubuntu 16.4 LTS

    Nodejs 6.14.1

    NPM 3.10.10

    Installation ging direct aus dem admin raus per git ohne probleme, hier mal der log dazu:

    $ ./iobroker url "https://github.com/foxriver76/ioBroker.xbox" --debug
    install https://github.com/foxriver76/ioBroker.xbox/tarball/master
    npm install https://github.com/foxriver76/ioBroker.xbox/tarball/master --production --save --prefix "/opt/iobroker" (System call)
    npm WARN lifecycle iobroker.xbox@0.0.5~preinstall: cannot run in wd %s %s (wd=%s) iobroker.xbox@0.0.5 apt install -y build-essential libssl-dev libffi-dev python3-dev || echo -e '[INFO] Cant install build-essential libssl-dev libffi-dev python3-dev Debian packages. If you are on a Linux system, try installing the package via: sudo npm i iobroker.xbox --unsafe-perm, otherwise you have to manage to install the packages by yourself. If you are not running on Linux, you can ignore this INFO.' /opt/iobroker/node_modules/.staging/iobroker.xbox-4a3b83e7
    > authenticate-pam@1.0.2 install /opt/iobroker/node_modules/authenticate-pam
    > node-gyp rebuild
    
    make: Entering directory '/opt/iobroker/node_modules/authenticate-pam/build'
      CXX(target) Release/obj.target/authenticate_pam/authenticate_pam.o
    ../authenticate_pam.cc:30:31: fatal error: security/pam_appl.h: No such file or directory
    compilation terminated.
    authenticate_pam.target.mk:94: recipe for target 'Release/obj.target/authenticate_pam/authenticate_pam.o' failedmake: Leaving directory '/opt/iobroker/node_modules/authenticate-pam/build'
    make: *** [Release/obj.target/authenticate_pam/authenticate_pam.o] Error 1
    
    gyp ERR! build error 
    gyp ERR! stack Error: `make` failed with exit code: 2gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:276:23)
    gyp ERR! stack     at emitTwo (events.js:106:13)
    gyp ERR! stack     at ChildProcess.emit (events.js:191:7)
    gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:219:12)
    
    gyp ERR! System Linux 4.4.0-62-genericgyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
    gyp ERR! cwd /opt/iobroker/node_modules/authenticate-pam
    gyp ERR! node -v v6.14.1
    gyp ERR! node-gyp -v v3.4.0
    gyp ERR! not ok 
    
    > iobroker.xbox@0.0.5 install /opt/iobroker/node_modules/iobroker.xbox
    > npip install
    
    No python_modules directory; installing pip locally if needed.
    Successfully completed pip check.
    Collecting xbox-smartglass-rest
      Downloading https://files.pythonhosted.org/packages/d4/f6/73521851d42496d7d703036bc5cb79a49144602bf4fffd85ba3bfb4afa8f/xbox_smartglass_rest-0.9.5-py2.py3-none-any.whl
    Collecting xbox-smartglass-core
      Downloading https://files.pythonhosted.org/packages/3f/9f/2e9c16dce7523dabf37dd8f1cdff44de42851d5970534baf0fe2a4f9badb/xbox_smartglass_core-1.0.10-py2.py3-none-any.whl (56kB)
    Collecting xbox-smartglass-stump>=0.9.4 (from xbox-smartglass-rest)
      Downloading https://files.pythonhosted.org/packages/7e/ea/fae9ae03e3ef0afc3c27638e8872254bf96bd14f06dc1ba5bce08b7916c7/xbox_smartglass_stump-0.9.4-py2.py3-none-any.whl
    Collecting Flask (from xbox-smartglass-rest)
      Downloading https://files.pythonhosted.org/packages/7f/e7/08578774ed4536d3242b14dacb4696386634607af824ea997202cd0edb4b/Flask-1.0.2-py2.py3-none-any.whl (91kB)
    Collecting construct==2.9.41 (from xbox-smartglass-core)
      Downloading https://files.pythonhosted.org/packages/e6/f5/064be5013506d54212b396e8fc3e9890e60ed6a27df6d52529f0b8361cd5/construct-2.9.41.tar.gz (54kB)
    Collecting aenum==2.1.2; python_version <= "3.5" (from xbox-smartglass-core)
      Downloading https://files.pythonhosted.org/packages/0d/46/5b6a6c13fee40f9dfaba84de1394bfe082c0c7d95952ba0ffbd56ce3a3f7/aenum-2.1.2-py3-none-any.whl
    Collecting urwid==2.0.1 (from xbox-smartglass-core)
      Downloading https://files.pythonhosted.org/packages/c7/90/415728875c230fafd13d118512bde3184d810d7bf798a631abc05fac09d0/urwid-2.0.1.tar.gz (604kB)
    Collecting cryptography==2.2.2 (from xbox-smartglass-core)
      Downloading https://files.pythonhosted.org/packages/fa/f4/3cde3604972dfa2b0fea85b9711948bb4fb70ab64095322aef35071bd254/cryptography-2.2.2-cp34-abi3-manylinux1_x86_64.whl (2.2MB)
    Collecting dpkt==1.9.1 (from xbox-smartglass-core)
      Downloading https://files.pythonhosted.org/packages/bf/a4/8e4622fac4841b5e4a347fa9da4c057a7974258df247031280008d6ac0d0/dpkt-1.9.1.tar.gz (115kB)
    Collecting gevent==1.2.2 (from xbox-smartglass-core)
      Downloading https://files.pythonhosted.org/packages/13/a9/81166b3ad2d344882ab42eb222e7723f93838fdf641b17b319b3a84821a7/gevent-1.2.2-cp35-cp35m-manylinux1_x86_64.whl (1.7MB)
    Collecting xbox-webapi>=1.1.2 (from xbox-smartglass-core)
      Downloading https://files.pythonhosted.org/packages/04/9c/bd60a0093db35f32263306987cb6776ac12e0d9a8911a4be1c5856ff6d0b/xbox_webapi-1.1.5-py2.py3-none-any.whl (44kB)
    Collecting appdirs==1.4.3 (from xbox-smartglass-core)
      Downloading https://files.pythonhosted.org/packages/56/eb/810e700ed1349edde4cbdc1b2a21e28cdf115f9faf263f6bbf8447c1abf3/appdirs-1.4.3-py2.py3-none-any.whl
    Collecting marshmallow-objects (from xbox-smartglass-stump>=0.9.4->xbox-smartglass-rest)
      Downloading https://files.pythonhosted.org/packages/2a/46/710e3383d1216f1f066ee16da24d144c04c2d3180bdd962f08194f123849/marshmallow_objects-1.0.14-py2.py3-none-any.whl
    Collecting itsdangerous>=0.24 (from Flask->xbox-smartglass-rest)
      Downloading https://files.pythonhosted.org/packages/dc/b4/a60bcdba945c00f6d608d8975131ab3f25b22f2bcfe1dab221165194b2d4/itsdangerous-0.24.tar.gz (46kB)
    Collecting Werkzeug>=0.14 (from Flask->xbox-smartglass-rest)
      Downloading https://files.pythonhosted.org/packages/20/c4/12e3e56473e52375aa29c4764e70d1b8f3efa6682bef8d0aae04fe335243/Werkzeug-0.14.1-py2.py3-none-any.whl (322kB)
    Collecting Jinja2>=2.10 (from Flask->xbox-smartglass-rest)
      Downloading https://files.pythonhosted.org/packages/7f/ff/ae64bacdfc95f27a016a7bed8e8686763ba4d277a78ca76f32659220a731/Jinja2-2.10-py2.py3-none-any.whl (126kB)
    Collecting click>=5.1 (from Flask->xbox-smartglass-rest)
      Downloading https://files.pythonhosted.org/packages/34/c1/8806f99713ddb993c5366c362b2f908f18269f8d792aff1abfd700775a77/click-6.7-py2.py3-none-any.whl (71kB)
    Collecting cffi>=1.7; platform_python_implementation != "PyPy" (from cryptography==2.2.2->xbox-smartglass-core)
      Downloading https://files.pythonhosted.org/packages/59/cc/0e1635b4951021ef35f5c92b32c865ae605fac2a19d724fb6ff99d745c81/cffi-1.11.5-cp35-cp35m-manylinux1_x86_64.whl (420kB)
    Requirement already satisfied: six>=1.4.1 in /usr/lib/python3/dist-packages (from cryptography==2.2.2->xbox-smartglass-core) (1.10.0)
    Collecting asn1crypto>=0.21.0 (from cryptography==2.2.2->xbox-smartglass-core)
      Downloading https://files.pythonhosted.org/packages/ea/cd/35485615f45f30a510576f1a56d1e0a7ad7bd8ab5ed7cdc600ef7cd06222/asn1crypto-0.24.0-py2.py3-none-any.whl (101kB)
    Collecting idna>=2.1 (from cryptography==2.2.2->xbox-smartglass-core)
      Downloading https://files.pythonhosted.org/packages/4b/2a/0276479a4b3caeb8a8c1af2f8e4355746a97fab05a372e4a2c6a6b876165/idna-2.7-py2.py3-none-any.whl (58kB)
    Collecting greenlet>=0.4.10 (from gevent==1.2.2->xbox-smartglass-core)
      Downloading https://files.pythonhosted.org/packages/2e/65/27f35497cc0102a792390d056e793e064da95fc9eae45d75ae0ba49c0a0d/greenlet-0.4.15-cp35-cp35m-manylinux1_x86_64.whl (41kB)
    Requirement already satisfied: requests in /usr/lib/python3/dist-packages (from xbox-webapi>=1.1.2->xbox-smartglass-core) (2.9.1)
    Collecting demjson (from xbox-webapi>=1.1.2->xbox-smartglass-core)
      Downloading https://files.pythonhosted.org/packages/96/67/6db789e2533158963d4af689f961b644ddd9200615b8ce92d6cad695c65a/demjson-2.2.4.tar.gz (131kB)
    Collecting marshmallow (from marshmallow-objects->xbox-smartglass-stump>=0.9.4->xbox-smartglass-rest)
      Downloading https://files.pythonhosted.org/packages/d5/32/57d464c250d7a15705d8eb3be9b8b002c611e414940d452b8756e3879bcd/marshmallow-2.15.5-py2.py3-none-any.whl (44kB)
    Collecting MarkupSafe>=0.23 (from Jinja2>=2.10->Flask->xbox-smartglass-rest)
      Downloading https://files.pythonhosted.org/packages/4d/de/32d741db316d8fdb7680822dd37001ef7a448255de9699ab4bfcbdf4172b/MarkupSafe-1.0.tar.gz
    Collecting pycparser (from cffi>=1.7; platform_python_implementation != "PyPy"->cryptography==2.2.2->xbox-smartglass-core)
      Downloading https://files.pythonhosted.org/packages/68/9e/49196946aee219aead1290e00d1e7fdeab8567783e83e1b9ab5585e6206a/pycparser-2.19.tar.gz (158kB)
    Building wheels for collected packages: construct, urwid, dpkt, itsdangerous, demjson, MarkupSafe, pycparser
      Running setup.py bdist_wheel for construct: started
      Running setup.py bdist_wheel for construct: finished with status 'done'  Stored in directory: /root/.cache/pip/wheels/13/cd/02/acabe4bfa9899d53c3e3b13675610d2e2dcb9ae110359d4f61
    
      Running setup.py bdist_wheel for urwid: started
      Running setup.py bdist_wheel for urwid: finished with status 'done'
      Stored in directory: /root/.cache/pip/wheels/34/06/50/24011714e101b5ad8518c69175d117a257413e3c15a92983f0
      Running setup.py bdist_wheel for dpkt: started
      Running setup.py bdist_wheel for dpkt: finished with status 'done'  Stored in directory: /root/.cache/pip/wheels/0a/5f/3c/e0ffceb6554711f12a7101384f29ec13b85136dfcf1f692b8f
    
      Running setup.py bdist_wheel for itsdangerous: started
      Running setup.py bdist_wheel for itsdangerous: finished with status 'done'
      Stored in directory: /root/.cache/pip/wheels/2c/4a/61/5599631c1554768c6290b08c02c72d7317910374ca602ff1e5
      Running setup.py bdist_wheel for demjson: started
      Running setup.py bdist_wheel for demjson: finished with status 'done'  Stored in directory: /root/.cache/pip/wheels/c5/d2/ab/a54fb5ea53ac3badba098160e8452fa126a51febda80440ded
    
      Running setup.py bdist_wheel for MarkupSafe: started
      Running setup.py bdist_wheel for MarkupSafe: finished with status 'done'
      Stored in directory: /root/.cache/pip/wheels/33/56/20/ebe49a5c612fffe1c5a632146b16596f9e64676768661e4e46
      Running setup.py bdist_wheel for pycparser: started
      Running setup.py bdist_wheel for pycparser: finished with status 'done'
      Stored in directory: /root/.cache/pip/wheels/f2/9a/90/de94f8556265ddc9d9c8b271b0f63e57b26fb1d67a45564511
    Successfully built construct urwid dpkt itsdangerous demjson MarkupSafe pycparser
    Installing collected packages: construct, aenum, urwid, pycparser, cffi, asn1crypto, idna, cryptography, dpkt, greenlet, gevent, demjson, appdirs, xbox-webapi, xbox-smartglass-core, marshmallow, marshmallow-objects, xbox-smartglass-stump, itsdangerous, Werkzeug, MarkupSafe, Jinja2, click, Flask, xbox-smartglass-rest
    Successfully installed Flask-1.0.2 Jinja2-2.10 MarkupSafe-1.0 Werkzeug-0.14.1 aenum-2.1.2 appdirs-1.4.3 asn1crypto-0.24.0 cffi-1.11.5 click-6.7 construct-2.9.41 cryptography-2.2.2 demjson-2.2.4 dpkt-1.9.1 gevent-1.2.2 greenlet-0.4.15 idna-2.7 itsdangerous-0.24 marshmallow-2.15.5 marshmallow-objects-1.0.14 pycparser-2.19 urwid-2.0.1 xbox-smartglass-core-1.0.10 xbox-smartglass-rest-0.9.5 xbox-smartglass-stump-0.9.4 xbox-webapi-1.1.5
    iobroker.core@1.0.0 /opt/iobroker└─┬ iobroker.xbox@0.0.5 
      ├── nopy@0.2.6 
      └─┬ request@2.88.0 
        ├── aws4@1.8.0 
        ├── combined-stream@1.0.7 
        ├── extend@3.0.2 
        ├─┬ form-data@2.3.2 
        │ └── combined-stream@1.0.6 
        ├─┬ har-validator@5.1.0 
        │ └─┬ ajv@5.5.2 
        │   └── fast-json-stable-stringify@2.0.0 
        ├─┬ mime-types@2.1.20 
        │ └── mime-db@1.36.0 
        ├── oauth-sign@0.9.0 
        ├── qs@6.5.2 
        ├── safe-buffer@5.1.2 
        ├─┬ tough-cookie@2.4.3 
        │ └── psl@1.1.29 
        └── uuid@3.3.2 
    
    npm
    
    WARN
     optional SKIPPING OPTIONAL DEPENDENCY: xpc-connection@~0.1.4 (node_modules/iobroker.radar/node_modules/noble/node_modules/xpc-connection):npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for xpc-connection@0.1.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: xpc-connection@~0.1.4 (node_modules/noble/node_modules/xpc-connection):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for xpc-connection@0.1.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: authenticate-pam@1.0.2 (node_modules/authenticate-pam):
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: authenticate-pam@1.0.2 install: `node-gyp rebuild`
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1
    
    process exited with code 0
    
    

    Auf meinem PROD system mit docker ging es nicht per admin, mit dem befehl aus deinem post lies sich aber auch hier alles installieren.

    Hier der log der fehlgeschlagenen installation, erfogreiche hab ich keinen log (docker copy/past grr)

    $ ./iobroker url "https://github.com/foxriver76/ioBroker.xbox"
    install https://github.com/foxriver76/ioBroker.xbox/tarball/master
    npm install https://github.com/foxriver76/ioBroker.xbox/tarball/master --production --save --prefix "/opt/iobroker" (System call)
    npm
     WARN lifecycle iobroker.xbox@0.0.5~preinstall: cannot run in wd %s %s (wd=%s) iobroker.xbox@0.0.5 apt install -y build-essential libssl-dev libffi-dev python3-dev || echo -e '[INFO] Cant install build-essential libssl-dev libffi-dev python3-dev Debian packages. If you are on a Linux system, try installing the package via: sudo npm i iobroker.xbox --unsafe-perm, otherwise you have to manage to install the packages by yourself. If you are not running on Linux, you can ignore this INFO.' /opt/iobroker/node_modules/.staging/iobroker.xbox-4a3b83e7
    ../authenticate_pam.cc:30:31: fatal error: security/pam_appl.h: Datei oder Verzeichnis nicht gefunden #include <security pam_appl.h="">^
    
    compilation terminated.
    make: *** [Release/obj.target/authenticate_pam/authenticate_pam.o] Fehler 1
    gyp
     ERR! build error 
    gyp ERR! stack Error: `make` failed with exit code: 2gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:276:23)
    gyp ERR! stack     at emitTwo (events.js:106:13)
    gyp ERR! stack     at ChildProcess.emit (events.js:191:7)
    gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:219:12)
    
    gyp ERR! System Linux 4.4.59+gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
    gyp ERR! cwd /opt/iobroker/node_modules/authenticate-pam
    gyp ERR! node -v v6.14.2
    gyp ERR! node-gyp -v v3.4.0
    gyp ERR! not ok 
    
    npm
     WARN optional SKIPPING OPTIONAL DEPENDENCY: authenticate-pam@1.0.2 (node_modules/authenticate-pam):npm WARN optional SKIPPING OPTIONAL DEPENDENCY: authenticate-pam@1.0.2 install: `node-gyp rebuild`
    npm WARN
     optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1
    process exited with code 0</security> 
    

    Dockere buanet auf synology

    Nodejs 6.14.2

    NPM 3.10.10

    Auf meinem prod-system mit docker laeuft der adapter.

    Musik habe ich noch nicht probiert aber daas gamepad steuern geht, ich habe damit gerade GTA aufgerufen :mrgreen: :mrgreen: :mrgreen:

    Die installation des ubuntu systems leider nicht, spuckt diese fehlelrmeldung aus:

    xbox.0	2018-09-20 20:37:33.063	error	[START] Restarting adapter in 30 seconds
    xbox.0	2018-09-20 20:37:33.062	error	[START] Failed starting REST server: /bin/sh: 1: /opt/iobroker/node_modules/iobroker.xbox/node_modules/nopy/src/nopy.js: not found
    

    also so far so good 🙂

  • Developer

    @Dutchman:

    na dan mal los

    Ubuntu 16.4 LTS

    Nodejs 6.14.1

    NPM 3.10.10

    Installation ging direct aus dem admin raus per git ohne probleme, hier mal der log dazu:

    ! ````
    $ ./iobroker url "https://github.com/foxriver76/ioBroker.xbox" --debug
    install https://github.com/foxriver76/ioBroker.xbox/tarball/master
    npm install https://github.com/foxriver76/ioBroker.xbox/tarball/master --production --save --prefix "/opt/iobroker" (System call)
    npm WARN lifecycle iobroker.xbox@0.0.5~preinstall: cannot run in wd %s %s (wd=%s) iobroker.xbox@0.0.5 apt install -y build-essential libssl-dev libffi-dev python3-dev || echo -e '[INFO] Cant install build-essential libssl-dev libffi-dev python3-dev Debian packages. If you are on a Linux system, try installing the package via: sudo npm i iobroker.xbox --unsafe-perm, otherwise you have to manage to install the packages by yourself. If you are not running on Linux, you can ignore this INFO.' /opt/iobroker/node_modules/.staging/iobroker.xbox-4a3b83e7
    authenticate-pam@1.0.2 install /opt/iobroker/node_modules/authenticate-pam
    node-gyp rebuild
    ! make: Entering directory '/opt/iobroker/node_modules/authenticate-pam/build'
    CXX(target) Release/obj.target/authenticate_pam/authenticate_pam.o
    ../authenticate_pam.cc:30:31: fatal error: security/pam_appl.h: No such file or directory
    compilation terminated.
    authenticate_pam.target.mk:94: recipe for target 'Release/obj.target/authenticate_pam/authenticate_pam.o' failedmake: Leaving directory '/opt/iobroker/node_modules/authenticate-pam/build'
    make: *** [Release/obj.target/authenticate_pam/authenticate_pam.o] Error 1
    ! gyp ERR! build error
    gyp ERR! stack Error: make failed with exit code: 2gyp ERR! stack at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:276:23)
    gyp ERR! stack at emitTwo (events.js:106:13)
    gyp ERR! stack at ChildProcess.emit (events.js:191:7)
    gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:219:12)
    ! gyp ERR! System Linux 4.4.0-62-genericgyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
    gyp ERR! cwd /opt/iobroker/node_modules/authenticate-pam
    gyp ERR! node -v v6.14.1
    gyp ERR! node-gyp -v v3.4.0
    gyp ERR! not ok
    ! > iobroker.xbox@0.0.5 install /opt/iobroker/node_modules/iobroker.xbox
    npip install
    ! No python_modules directory; installing pip locally if needed.
    Successfully completed pip check.
    Collecting xbox-smartglass-rest
    Downloading https://files.pythonhosted.org/packages/d4/f6/73521851d42496d7d703036bc5cb79a49144602bf4fffd85ba3bfb4afa8f/xbox_smartglass_rest-0.9.5-py2.py3-none-any.whl
    Collecting xbox-smartglass-core
    Downloading https://files.pythonhosted.org/packages/3f/9f/2e9c16dce7523dabf37dd8f1cdff44de42851d5970534baf0fe2a4f9badb/xbox_smartglass_core-1.0.10-py2.py3-none-any.whl (56kB)
    Collecting xbox-smartglass-stump>=0.9.4 (from xbox-smartglass-rest)
    Downloading https://files.pythonhosted.org/packages/7e/ea/fae9ae03e3ef0afc3c27638e8872254bf96bd14f06dc1ba5bce08b7916c7/xbox_smartglass_stump-0.9.4-py2.py3-none-any.whl
    Collecting Flask (from xbox-smartglass-rest)
    Downloading https://files.pythonhosted.org/packages/7f/e7/08578774ed4536d3242b14dacb4696386634607af824ea997202cd0edb4b/Flask-1.0.2-py2.py3-none-any.whl (91kB)
    Collecting construct==2.9.41 (from xbox-smartglass-core)
    Downloading https://files.pythonhosted.org/packages/e6/f5/064be5013506d54212b396e8fc3e9890e60ed6a27df6d52529f0b8361cd5/construct-2.9.41.tar.gz (54kB)
    Collecting aenum==2.1.2; python_version <= "3.5" (from xbox-smartglass-core)
    Downloading https://files.pythonhosted.org/packages/0d/46/5b6a6c13fee40f9dfaba84de1394bfe082c0c7d95952ba0ffbd56ce3a3f7/aenum-2.1.2-py3-none-any.whl
    Collecting urwid==2.0.1 (from xbox-smartglass-core)
    Downloading https://files.pythonhosted.org/packages/c7/90/415728875c230fafd13d118512bde3184d810d7bf798a631abc05fac09d0/urwid-2.0.1.tar.gz (604kB)
    Collecting cryptography==2.2.2 (from xbox-smartglass-core)
    Downloading https://files.pythonhosted.org/packages/fa/f4/3cde3604972dfa2b0fea85b9711948bb4fb70ab64095322aef35071bd254/cryptography-2.2.2-cp34-abi3-manylinux1_x86_64.whl (2.2MB)
    Collecting dpkt==1.9.1 (from xbox-smartglass-core)
    Downloading https://files.pythonhosted.org/packages/bf/a4/8e4622fac4841b5e4a347fa9da4c057a7974258df247031280008d6ac0d0/dpkt-1.9.1.tar.gz (115kB)
    Collecting gevent==1.2.2 (from xbox-smartglass-core)
    Downloading https://files.pythonhosted.org/packages/13/a9/81166b3ad2d344882ab42eb222e7723f93838fdf641b17b319b3a84821a7/gevent-1.2.2-cp35-cp35m-manylinux1_x86_64.whl (1.7MB)
    Collecting xbox-webapi>=1.1.2 (from xbox-smartglass-core)
    Downloading https://files.pythonhosted.org/packages/04/9c/bd60a0093db35f32263306987cb6776ac12e0d9a8911a4be1c5856ff6d0b/xbox_webapi-1.1.5-py2.py3-none-any.whl (44kB)
    Collecting appdirs==1.4.3 (from xbox-smartglass-core)
    Downloading https://files.pythonhosted.org/packages/56/eb/810e700ed1349edde4cbdc1b2a21e28cdf115f9faf263f6bbf8447c1abf3/appdirs-1.4.3-py2.py3-none-any.whl
    Collecting marshmallow-objects (from xbox-smartglass-stump>=0.9.4->xbox-smartglass-rest)
    Downloading https://files.pythonhosted.org/packages/2a/46/710e3383d1216f1f066ee16da24d144c04c2d3180bdd962f08194f123849/marshmallow_objects-1.0.14-py2.py3-none-any.whl
    Collecting itsdangerous>=0.24 (from Flask->xbox-smartglass-rest)
    Downloading https://files.pythonhosted.org/packages/dc/b4/a60bcdba945c00f6d608d8975131ab3f25b22f2bcfe1dab221165194b2d4/itsdangerous-0.24.tar.gz (46kB)
    Collecting Werkzeug>=0.14 (from Flask->xbox-smartglass-rest)
    Downloading https://files.pythonhosted.org/packages/20/c4/12e3e56473e52375aa29c4764e70d1b8f3efa6682bef8d0aae04fe335243/Werkzeug-0.14.1-py2.py3-none-any.whl (322kB)
    Collecting Jinja2>=2.10 (from Flask->xbox-smartglass-rest)
    Downloading https://files.pythonhosted.org/packages/7f/ff/ae64bacdfc95f27a016a7bed8e8686763ba4d277a78ca76f32659220a731/Jinja2-2.10-py2.py3-none-any.whl (126kB)
    Collecting click>=5.1 (from Flask->xbox-smartglass-rest)
    Downloading https://files.pythonhosted.org/packages/34/c1/8806f99713ddb993c5366c362b2f908f18269f8d792aff1abfd700775a77/click-6.7-py2.py3-none-any.whl (71kB)
    Collecting cffi>=1.7; platform_python_implementation != "PyPy" (from cryptography==2.2.2->xbox-smartglass-core)
    Downloading https://files.pythonhosted.org/packages/59/cc/0e1635b4951021ef35f5c92b32c865ae605fac2a19d724fb6ff99d745c81/cffi-1.11.5-cp35-cp35m-manylinux1_x86_64.whl (420kB)
    Requirement already satisfied: six>=1.4.1 in /usr/lib/python3/dist-packages (from cryptography==2.2.2->xbox-smartglass-core) (1.10.0)
    Collecting asn1crypto>=0.21.0 (from cryptography==2.2.2->xbox-smartglass-core)
    Downloading https://files.pythonhosted.org/packages/ea/cd/35485615f45f30a510576f1a56d1e0a7ad7bd8ab5ed7cdc600ef7cd06222/asn1crypto-0.24.0-py2.py3-none-any.whl (101kB)
    Collecting idna>=2.1 (from cryptography==2.2.2->xbox-smartglass-core)
    Downloading https://files.pythonhosted.org/packages/4b/2a/0276479a4b3caeb8a8c1af2f8e4355746a97fab05a372e4a2c6a6b876165/idna-2.7-py2.py3-none-any.whl (58kB)
    Collecting greenlet>=0.4.10 (from gevent==1.2.2->xbox-smartglass-core)
    Downloading https://files.pythonhosted.org/packages/2e/65/27f35497cc0102a792390d056e793e064da95fc9eae45d75ae0ba49c0a0d/greenlet-0.4.15-cp35-cp35m-manylinux1_x86_64.whl (41kB)
    Requirement already satisfied: requests in /usr/lib/python3/dist-packages (from xbox-webapi>=1.1.2->xbox-smartglass-core) (2.9.1)
    Collecting demjson (from xbox-webapi>=1.1.2->xbox-smartglass-core)
    Downloading https://files.pythonhosted.org/packages/96/67/6db789e2533158963d4af689f961b644ddd9200615b8ce92d6cad695c65a/demjson-2.2.4.tar.gz (131kB)
    Collecting marshmallow (from marshmallow-objects->xbox-smartglass-stump>=0.9.4->xbox-smartglass-rest)
    Downloading https://files.pythonhosted.org/packages/d5/32/57d464c250d7a15705d8eb3be9b8b002c611e414940d452b8756e3879bcd/marshmallow-2.15.5-py2.py3-none-any.whl (44kB)
    Collecting MarkupSafe>=0.23 (from Jinja2>=2.10->Flask->xbox-smartglass-rest)
    Downloading https://files.pythonhosted.org/packages/4d/de/32d741db316d8fdb7680822dd37001ef7a448255de9699ab4bfcbdf4172b/MarkupSafe-1.0.tar.gz
    Collecting pycparser (from cffi>=1.7; platform_python_implementation != "PyPy"->cryptography==2.2.2->xbox-smartglass-core)
    Downloading https://files.pythonhosted.org/packages/68/9e/49196946aee219aead1290e00d1e7fdeab8567783e83e1b9ab5585e6206a/pycparser-2.19.tar.gz (158kB)
    Building wheels for collected packages: construct, urwid, dpkt, itsdangerous, demjson, MarkupSafe, pycparser
    Running setup.py bdist_wheel for construct: started
    Running setup.py bdist_wheel for construct: finished with status 'done' Stored in directory: /root/.cache/pip/wheels/13/cd/02/acabe4bfa9899d53c3e3b13675610d2e2dcb9ae110359d4f61
    ! Running setup.py bdist_wheel for urwid: started
    Running setup.py bdist_wheel for urwid: finished with status 'done'
    Stored in directory: /root/.cache/pip/wheels/34/06/50/24011714e101b5ad8518c69175d117a257413e3c15a92983f0
    Running setup.py bdist_wheel for dpkt: started
    Running setup.py bdist_wheel for dpkt: finished with status 'done' Stored in directory: /root/.cache/pip/wheels/0a/5f/3c/e0ffceb6554711f12a7101384f29ec13b85136dfcf1f692b8f
    ! Running setup.py bdist_wheel for itsdangerous: started
    Running setup.py bdist_wheel for itsdangerous: finished with status 'done'
    Stored in directory: /root/.cache/pip/wheels/2c/4a/61/5599631c1554768c6290b08c02c72d7317910374ca602ff1e5
    Running setup.py bdist_wheel for demjson: started
    Running setup.py bdist_wheel for demjson: finished with status 'done' Stored in directory: /root/.cache/pip/wheels/c5/d2/ab/a54fb5ea53ac3badba098160e8452fa126a51febda80440ded
    ! Running setup.py bdist_wheel for MarkupSafe: started
    Running setup.py bdist_wheel for MarkupSafe: finished with status 'done'
    Stored in directory: /root/.cache/pip/wheels/33/56/20/ebe49a5c612fffe1c5a632146b16596f9e64676768661e4e46
    Running setup.py bdist_wheel for pycparser: started
    Running setup.py bdist_wheel for pycparser: finished with status 'done'
    Stored in directory: /root/.cache/pip/wheels/f2/9a/90/de94f8556265ddc9d9c8b271b0f63e57b26fb1d67a45564511
    Successfully built construct urwid dpkt itsdangerous demjson MarkupSafe pycparser
    Installing collected packages: construct, aenum, urwid, pycparser, cffi, asn1crypto, idna, cryptography, dpkt, greenlet, gevent, demjson, appdirs, xbox-webapi, xbox-smartglass-core, marshmallow, marshmallow-objects, xbox-smartglass-stump, itsdangerous, Werkzeug, MarkupSafe, Jinja2, click, Flask, xbox-smartglass-rest
    Successfully installed Flask-1.0.2 Jinja2-2.10 MarkupSafe-1.0 Werkzeug-0.14.1 aenum-2.1.2 appdirs-1.4.3 asn1crypto-0.24.0 cffi-1.11.5 click-6.7 construct-2.9.41 cryptography-2.2.2 demjson-2.2.4 dpkt-1.9.1 gevent-1.2.2 greenlet-0.4.15 idna-2.7 itsdangerous-0.24 marshmallow-2.15.5 marshmallow-objects-1.0.14 pycparser-2.19 urwid-2.0.1 xbox-smartglass-core-1.0.10 xbox-smartglass-rest-0.9.5 xbox-smartglass-stump-0.9.4 xbox-webapi-1.1.5
    iobroker.core@1.0.0 /opt/iobroker└─┬ iobroker.xbox@0.0.5
    ├── nopy@0.2.6
    └─┬ request@2.88.0
    ├── aws4@1.8.0
    ├── combined-stream@1.0.7
    ├── extend@3.0.2
    ├─┬ form-data@2.3.2
    │ └── combined-stream@1.0.6
    ├─┬ har-validator@5.1.0
    │ └─┬ ajv@5.5.2
    │ └── fast-json-stable-stringify@2.0.0
    ├─┬ mime-types@2.1.20
    │ └── mime-db@1.36.0
    ├── oauth-sign@0.9.0
    ├── qs@6.5.2
    ├── safe-buffer@5.1.2
    ├─┬ tough-cookie@2.4.3
    │ └── psl@1.1.29
    └── uuid@3.3.2
    ! npm

    WARN
    optional SKIPPING OPTIONAL DEPENDENCY: xpc-connection@~0.1.4 (node_modules/iobroker.radar/node_modules/noble/node_modules/xpc-connection):npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for xpc-connection@0.1.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: xpc-connection@~0.1.4 (node_modules/noble/node_modules/xpc-connection):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for xpc-connection@0.1.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: authenticate-pam@1.0.2 (node_modules/authenticate-pam):
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: authenticate-pam@1.0.2 install: node-gyp rebuild
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1

    ! process exited with code 0
    ! ````

    Die installation des ubuntu systems leider nicht, spuckt diese fehlelrmeldung aus:

    xbox.0	2018-09-20 20:37:33.063	error	[START] Restarting adapter in 30 seconds
    xbox.0	2018-09-20 20:37:33.062	error	[START] Failed starting REST server: /bin/sh: 1: /opt/iobroker/node_modules/iobroker.xbox/node_modules/nopy/src/nopy.js: not found
    ```` `  
    

    Wahrscheinlich gibt es den Ordner "/opt/iobroker/node_modules/iobroker.xbox/node_modules/nopy/" dann bei dir auf dem Ubuntu System gar nicht oder? Ich hätte eher erwartet, dass der Server nicht läuft, weil er am Anfang apt install nicht ausführen konnte.

    Genau, also das ganze basiert auf dem Smartglass Protokoll von Xbox. Kann in Spielen selbst also 'leider' nicht genutzt werden, wäre wohl zu einfach sich daraus was zum mogeln zu programmieren 😄

  • Developer Most Active Administrators

    @foxriver76:

    Wahrscheinlich gibt es den Ordner "/opt/iobroker/node_modules/iobroker.xbox/node_modules/nopy/" dann bei dir auf dem Ubuntu System gar nicht oder? Ich hätte eher erwartet, dass der Server nicht läuft, weil er am Anfang apt install nicht ausführen konnte. `

    doch der ordner ist da :

    979_capture.jpg

    @foxriver76:

    Genau, also das ganze basiert auf dem Smartglass Protokoll von Xbox. Kann in Spielen selbst also 'leider' nicht genutzt werden, wäre wohl zu einfach sich daraus was zum mogeln zu programmieren 😄 `

    lol, jup dan koennte man automatisieren oder mit 2 leuten einen controller bedienen :lol:

  • Developer

    @Dutchman:

    @foxriver76:

    Wahrscheinlich gibt es den Ordner "/opt/iobroker/node_modules/iobroker.xbox/node_modules/nopy/" dann bei dir auf dem Ubuntu System gar nicht oder? Ich hätte eher erwartet, dass der Server nicht läuft, weil er am Anfang apt install nicht ausführen konnte. `

    doch der ordner ist da :

    Capture.JPG `

    Ahhh… okay...

    ja bei dir ist der Ordner /opt/iobroker/node_modules/nopy/, ich suche /opt/iobroker/node_modules/iobroker.xbox/node_modules/nopy/

    hmm Änderungsdatum 20.17 also ja schon von der Installation.. muss mal schauen woran das liegt.

  • Developer Most Active Administrators

    @foxriver76:

    ja bei dir ist der Ordner /opt/iobroker/node_modules/nopy/, ich suche /opt/iobroker/node_modules/iobroker.xbox/node_modules/nopy/

    hmm Änderungsdatum 20.17 also ja schon von der Installation.. muss mal schauen woran das liegt. `

    jup, im iobroker.xbox ordner fehlt er :

    xxx@xxx:~$ ls -l /opt/iobroker/node_modules/iobroker.xbox/node_modules/
    ajv/             extend/          mime-types/      safe-buffer/
    aws4/            form-data/       oauth-sign/      tough-cookie/
    .bin/            har-validator/   qs/              uuid/
    combined-stream/ mime-db/         request/
    
    
  • Developer

    @Dutchman:

    @foxriver76:

    ja bei dir ist der Ordner /opt/iobroker/node_modules/nopy/, ich suche /opt/iobroker/node_modules/iobroker.xbox/node_modules/nopy/

    hmm Änderungsdatum 20.17 also ja schon von der Installation.. muss mal schauen woran das liegt. `

    jup, im iobroker.xbox ordner fehlt er :

    xxx@xxx:~$ ls -l /opt/iobroker/node_modules/iobroker.xbox/node_modules/
    ajv/             extend/          mime-types/      safe-buffer/
    aws4/            form-data/       oauth-sign/      tough-cookie/
    .bin/            har-validator/   qs/              uuid/
    combined-stream/ mime-db/         request/
    
    ```` `  
    

    Würdest du mir bei Gelegenheit mal die Ausgabe von````
    ls -lah /opt/iobroker/node_modules/iobroker.xbox/node_modules/.bin/

  • Developer Most Active Administrators

    @foxriver76:

    Würdest du mir bei Gelegenheit mal die Ausgabe vonls -lah /opt/iobroker/node_modules/iobroker.xbox/node_modules/.bin/ posten? `

    sure

    xxx@xxx:~$ ls -lah /opt/iobroker/node_modules/iobroker.xbox/node_modules/.bin/
    total 8.0K
    drwxrwxrwx  2 root root 4.0K Sep 20 20:17 .
    drwxrwxrwx 17 root root 4.0K Sep 20 20:17 ..
    lrwxrwxrwx  1 root root   16 Sep 20 20:17 uuid -> ../uuid/bin/uuid
    xxx@xxx:~$ 
    
    
  • Developer

    @Dutchman:

    @foxriver76:

    Würdest du mir bei Gelegenheit mal die Ausgabe vonls -lah /opt/iobroker/node_modules/iobroker.xbox/node_modules/.bin/ posten? `

    sure

    xxx@xxx:~$ ls -lah /opt/iobroker/node_modules/iobroker.xbox/node_modules/.bin/
    total 8.0K
    drwxrwxrwx  2 root root 4.0K Sep 20 20:17 .
    drwxrwxrwx 17 root root 4.0K Sep 20 20:17 ..
    lrwxrwxrwx  1 root root   16 Sep 20 20:17 uuid -> ../uuid/bin/uuid
    xxx@xxx:~$ 
    
    ```` `  
    

    Okay, leider kein Link für nopy vorhanden.. another try:

    Wenn du dich in /opt/iobroker/node_modules/iobroker.xbox/ befindest und den Befehl````
    npm root

  • Developer

    Lasse eben die Tests noch laufen und dann veröffentliche ich eine neue Version, die sollte das Problem hoffentlich beheben.

    Probier trotzdem vorher mal das aus dem Post, würde mich interessieren was er als root angibt. Wirkt auf mich etwas inkonsistent, was die Installation da gemacht hat.

  • Developer

    Wäre cool, wenn sich hier noch der ein oder andere Tester findet. Vorallem die Installation + Betrieb auf Mac und Windows.

    Zocke dafür auch eine Runde Battlefield mit euch :lol:

  • Developer

    Ich kann auf Windows Testen.

    Mal sehen ob mein Kopf es zu lässt und die Xbox nicht wieder Stunden lang Updates macht. Bei mir ist das Ding eigentlich nie an, weiss gar nicht warum ich sie noch hab.

    Gesendet von meinem m8 mit Tapatalk

  • Developer Most Active Administrators

    @Jey Cee:

    Bei mir ist das Ding eigentlich nie an, weiss gar nicht warum ich sie noch hab. `

    Schicke dir gerne meine Adresse zum Recycling meinenkiddoes streiten sich immer über die eine hier 😉

    Desweiteren läuft auch nach einem Tag alles, ein und ausschalten funzt auch super.

    Ich reiche die gefragten Informationen noch später nach

    Sent from my iPhone using Tapatalk

  • Developer

    Mein Installationsversuch unter Windows scheitert:

    ! ```
    2018-09-21 18:10:14.025 - [32minfo[39m: iobroker url "https://github.com/foxriver76/ioBroker.xbox" --debug 2018-09-21 18:10:14.444 - [32minfo[39m: iobroker install https://github.com/foxriver76/ioBroker.xbox/tarball/master 2018-09-21 18:10:15.519 - [32minfo[39m: iobroker npm install https://github.com/foxriver76/ioBroker.xbox/tarball/master --production --save --prefix "C:/iobroker" (System call) 2018-09-21 18:10:29.841 - [32minfo[39m: iobroker > iobroker.xbox@0.0.6 preinstall C:\iobroker\node_modules\iobroker.xbox apt install -y build-essential libssl-dev libffi-dev python3-dev || echo -e '[INFO] Cant install build-essential libssl-dev libffi-dev python3-dev Debian packages. If you are on a Linux system, try installing the package via: sudo npm i iobroker.xbox --unsafe-perm, otherwise you have to manage to install the packages by yourself. If you are not running on Linux, you can ignore this INFO.' ! 2018-09-21 18:10:29.874 - [32minfo[39m: iobroker Der Befehl "apt" ist entweder falsch geschrieben oder konnte nicht gefunden werden. ! 2018-09-21 18:10:29.874 - [32minfo[39m: iobroker -e '[INFO] Cant install build-essential libssl-dev libffi-dev python3-dev Debian packages. If you are on a Linux system, try installing the package via: sudo npm i iobroker.xbox --unsafe-perm, otherwise you have to manage to install the packages by yourself. If you are not running on Linux, you can ignore this INFO.' ! 2018-09-21 18:10:29.935 - [32minfo[39m: iobroker > iobroker.xbox@0.0.6 install C:\iobroker\node_modules\iobroker.xbox npip install ! 2018-09-21 18:10:30.149 - [32minfo[39m: iobroker No python_modules directory; installing pip locally if needed. 2018-09-21 18:10:30.161 - [32minfo[39m: iobroker Error: No python executable. at getPythonInfo (C:\iobroker\node_modules\iobroker.xbox\node_modules\nopy\src\api.js:52:11) at Promise.then.catch.error (C:\iobroker\node_modules\iobroker.xbox\node_modules\nopy\src\api.js:115:14) at <anonymous> at process._tickCallback (internal/process/next_tick.js:188:7) ! 2018-09-21 18:10:30.326 - [32minfo[39m: iobroker npm 2018-09-21 18:10:30.326 - [32minfo[39m: iobroker ERR! code ELIFECYCLEnpm ERR! errno 1 ! 2018-09-21 18:10:30.327 - [32minfo[39m: iobroker npm 2018-09-21 18:10:30.327 - [32minfo[39m: iobroker ERR! iobroker.xbox@0.0.6 install: npip installnpm 2018-09-21 18:10:30.327 - [32minfo[39m: iobroker ERR! Exit status 1npm ERR! npm 2018-09-21 18:10:30.327 - [32minfo[39m: iobroker ERR! Failed at the iobroker.xbox@0.0.6 install script.npm ERR! This is probably not a problem with npm. There is likely additional logging output above. ! 2018-09-21 18:10:30.344 - [32minfo[39m: iobroker 2018-09-21 18:10:30.344 - [32minfo[39m: iobroker npm ERR! A complete log of this run can be found in:npm ERR! C:\Windows\system32\config\systemprofile\AppData\Roaming\npm-cache\_logs\2018-09-21T16_10_30_331Z-debug.log ! 2018-09-21 18:10:30.624 - [32minfo[39m: iobroker exit 0[/code]</anonymous>
    ! [quote]
    Schicke dir gerne meine Adresse zum Recycling meinenkiddoes streiten sich immer über die eine hier
    😉 das behalte ich mal im Hinterkopf, für den Fall das ich so los werden will.

  • Developer Most Active Administrators

    Ich glaube der Fehler bei dir ist, wen ich den Log richtig lese, das dir die Python Sachen fehlen und die Installation kein apt ausführen kann (logisch ist ein Linux Commando).

    Hast du per Admin oder per console installiert?

    Sent from my iPhone using Tapatalk

  • Developer

    Hab per admin installiert.

    Python hab ich 3.6.4 installiert.

  • Developer Most Active Administrators

    @Jey Cee:

    Hab per admin installiert.

    Python hab ich 3.6.4 installiert. `

    Mal in der command Line probiert?

    Sent from my iPhone using Tapatalk

  • Developer

    C:\iobroker>npm install https://github.com/foxriver76/ioBroker.xbox
    npm WARN enoent ENOENT: no such file or directory, open 'C:\iobroker\node_module
    s\admin\package.json'
    npm WARN enoent ENOENT: no such file or directory, open 'C:\iobroker\node_module
    s\lib\package.json'
    npm WARN enoent ENOENT: no such file or directory, open 'C:\iobroker\node_module
    s\tasks\package.json'
    npm WARN enoent ENOENT: no such file or directory, open 'C:\iobroker\node_module
    s\scripts\package.json'
    npm WARN enoent ENOENT: no such file or directory, open 'C:\iobroker\node_module
    s\test\package.json'
    
    npm ERR! path C:\iobroker\node_modules\ioBroker.deconz
    npm ERR! code EISGIT
    npm ERR! git C:\iobroker\node_modules\ioBroker.deconz: Appears to be a git repo
    or submodule.
    npm ERR! git     C:\iobroker\node_modules\ioBroker.deconz
    npm ERR! git Refusing to remove it. Update manually,
    npm ERR! git or move it out of the way first.
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     C:\Users\Jey Cee\AppData\Roaming\npm-cache\_logs\2018-09-21T17_31_3
    8_444Z-debug.log
    

Suggested Topics

2.1k
Online

34.9k
Users

40.9k
Topics

561.2k
Posts