NEWS

Update npm und node.js



  • Hallo,

    so einfach kann man npm und node auf den aktuellen Stand halten

    sudo npm cache clean -f
    sudo npm update npm -g
    sudo npm install -g n
    sudo n stable
    
    
    npm -v
    node -v
    
    
    root@raspberrypi:/opt# npm -v
    3.4.0
    root@raspberrypi:/opt# node -v
    v5.0.0
    

  • Most Active

    Hi Sissi,

    könntest du mir auch sagen, wie ich von einer neuen node-js Version wieder zurück komme? Habe momentan 4.1.2 laufen, die läuft aber nicht sauber auf wheezy, deshalb müsste ich zurück auf eine ältere Version. Leider weiß ich noch nicht, wie ich das sauber löse.



  • sudo n 1.3.5

    Wäre Version 1.3.5


  • Most Active

    Hmm, geht leider nicht.

    Wenn ich z.B. sudo n 0.12.7 eingebe, kommt Fehler: Error: invalid version 0.12.3

    Hoch geht, also sudo n 4.2.0 hat funktioniert von 4.1.2
    6359_logfilemultiroom.txt



  • Hallo,

    kannst du alternativ auch einfach mit

    dpkg -i nodejs_0.10.22-1_armhf.deb

    wieder neu installieren.

    (siehe iobroker Installationshinweise auf der Webseite)



  • Hallo, habe eben das node.js update gemacht und habe nun auf meinem Raspberry Pi3 die Version 9.2.1. Und ioBroker funktioniert nicht mehr, s.h. Bild. 4223_fehler.png Wie komme ich wieder auf eine 6.x.x-Version zurück? Zumindest hoffe ich, dass hier der Hund begraben liegt…


  • Most Active

    Ich weiß nicht, was dich geritten hat, eine 9er Version zu installieren, nirgendwo ist geschrieben, dass diese Version benötigt wird, ganz im Gegenteil, es wird dringend empfohlen, keine ungeraden Versionen zu installieren, vor allem dann nicht, wenn man nicht weiß, was man macht! 😉

    Lies dir mal http://forum.iobroker.net/viewtopic.php?f=23&t=8182&hilit=node+js durch vielleicht klappt es.

    Enrico



  • Na ja, schlimmer wie das Update ist in meinen Augen mein alter Fehler vorher mal wieder kein Backup gemacht zu haben :roll:



  • Hallo,

    sorry wenn ich das so sage…..

    super, wenn so eine Anleitung, ioBroker sowas von lahm legt, dass die hälfte der Adapter offline ist.

    Könnte das evtl. mal jemand updaten oder rausnehmen, damit nicht noch jemand die Probleme bekommt?

    Danke

    Gruß Jens


  • Forum Testing Most Active Global Moderator Administrators

    Hallo Jens,
    @AingTii:

    super, wenn so eine Anleitung, ioBroker sowas von lahm legt, dass die hälfte der Adapter offline ist. `
    welche denn??

    @AingTii:

    Könnte das evtl. mal jemand updaten oder rausnehmen, damit nicht noch jemand die Probleme bekommt? `
    Was für Probleme?

    ich denke nicht dass so eine Aussage pauschal berechtigt ist.

    Gruß

    Rainer



  • Die Anleitung ganz am Anfang dieses Themas mit dem Hinweis

    @sissiwup:

    Hallo,

    so einfach kann man npm und node auf den aktuellen Stand halten

    Code: Alles auswählensudo npm cache clean -f

    sudo npm update npm -g

    sudo npm install -g n

    sudo n stable

    Code: Alles auswählennpm -v

    node -v

    Code: Alles auswählenroot@raspberrypi:/opt# npm -v

    3.4.0

    root@raspberrypi:/opt# node -v

    v5.0.0 `

    anscheinend installiert sich dadurch die 9.x im opt und zerschießt alles…. ????

    Warum auch immer anschließend das meiste Lahm gelegt ist. Ursprung war nur dass ich Amazon-dash nicht

    installieren konnte und dort die Meldung war nodejs auf aktuellem stand zu halten....

    Danke

    Gruß Jens


  • Forum Testing Most Active Global Moderator Administrators

    Jetzt wird es knifflig.

    reine Korinthenkackerei und Prizipienreiterei:

    Das ist ein Posting eines Users, keine offizielle Anleitung!

    Die befindet sich hier:

    http://www.iobroker.net/docu/?page_id=5106&lang=de

    Installation von node im Unterpunkt http://www.iobroker.net/docu/?page_id=5106&lang=de#Installation_Nodejs

    @AingTii:

    Könnte das evtl. mal jemand updaten oder rausnehmen `
    Diesen Teil kann (eigentlich) nur derjenige, der das gepostet hat.

    @AingTii:

    anscheinend installiert sich dadurch die 9.x im opt `
    Wo hast du diese Info her? - ich nehme an selbst erlebt?

    @AingTii:

    Ursprung war nur dass ich Amazon-dash nicht

    installieren konnte und dort die Meldung war nodejs auf aktuellem stand zu halten…. `
    mit jedem normalen Linux-Update über````
    apt-update && apt upgrade

    
    Gruß
    
    Rainer


  • ok, danke,

    dann das nächste Mal finger weg von Experimenten, nur die Beiden

    sudo apt-get update

    sudo apt-get upgrade

    war mir ne Lehre!

    Danke

    Gruß Jens


  • Forum Testing Most Active Global Moderator Administrators

    @AingTii:

    dann das nächste Mal finger weg von Experimenten, nur die Beiden

    sudo apt-get update 
    sudo apt-get upgrade
    

    war mir ne Lehre! `
    Das ist nicht was ich schrieb!

    und auf zwei Threads verteilt bringt das echt nicht viel!

    Wenn du die Hauptversion ändern willst 4 -> 6 -> 8 funktioniert das nicht, außerdem ist der Befehl ab Debian Jessie nicht mehr apt-get

    Gruß

    Rainer



  • Guten Morgen,

    okay, nun wird es spannend….

    :shock: ich benutzte seit ich einen RasPi habe immer den apt-get und ich würde fast behaupten,

    ich bin erst angefangen mit jessie?!?!? müsste ich schauen, aber egal.

    Er tut auf jeden Fall eine Menge.

    Aber nun habe ich dazugelernt dass nur noch apt notwendig ist.

    also sudo apt-update && apt upgrade

    verhält sich dieses ebenfalls so bei dem install, sprich "sudo apt install ...."

    also das -get fällt weg?

    Und der Bindestrich bei update ja und upgrade nein, wie ist es dann bei install?

    Ja ich gebe Dir recht über 2 threads ist es kompliziert.

    Was ist denn der unterschied zwischen node und node js und müssen die Versionen gleich sein?

    Irgendwo habe ich gelesen die ungraden 5,7,9 sind nicht gut bzw in Entwicklung oder bezieht es sich

    nur auf die nodejs?

    Welche Versionen laufen denn bei Dir und funktioniert amazon dash bei Dir?

    Schritt 5 ist doch nur für Raspi1...

    Ist das nicht Sinn der Anleitung die schritte durchzuführen?

    Könnte natürlich zu viel sein, aber ich gehe davon aus, etwas vergessen ist schlimmer?!?!?

    Ich probiere es nach der Arbeit noch mal ohen dem -get

    Ist das mit dem Hinweis der npm 5.x noch aktuell in der Anleitung oder bezieht sich das wiederrum

    nur auf nodejs 8.x?

    Danke

    Gruß Jens


  • Forum Testing Most Active Global Moderator Administrators

    Sorry mein Fehler, apt erst ab stretch!

    Das wird dann überall statt apt-get genommen.

    In älteren Installationen musste nach nodejs abgefragt wrden, seit v4(?) nur noch nach node.

    Über einen Symlink sollten trotzdem ältere Applikationen richtig arbeiten und werden dann zur node Installation verlinkt.

    Daher müssten bei beiden Befehlen die gleichen Versionsnummern erscheinen. Passiert dies nicht wurden zwei Versionen auf unterschiedliche Weise installiert. Oft ist bereits eine in der Distro enthalten.

    Nodejs ist ein Framework und die Grundlage auf der ioBroker programmiert ist, node ist in diesem Fall nur die kurzbezeichnung.

    npm ist der Node Package Manager, der dafür sorgt dass die Pakete und deren Abhängigkeiten richtig installiert werden. Mit jeder nodejs Installation wird auch ein npm mit installiert.

    Die geraden Versionsnummern beziehen sich auf Nodejs.

    Die komplette Anleitung ist eine komplette Neuinstallation von ioBroker und der Vorbedingungen auf einem Linux. Da es bei dir aber nur um die Korrektur der nodejs Installation ging, war für dich nur der Abschnitt Installation von nodejs relevant.

    Mit Schritt 5 hast du recht, muss ich korrigieren, bei Raspi 3 wäre das schritt 4 gewesen.

    Npm5 hätte bei allen node versionen Probleme, bei node v8 wird es aber automatisch installiert. Ab der Version 5.71 ist der Bug bei npm 5 behoben, die Installationsroutine von ioBroker wurde darauf angepasst.

    Ich selber habe (zum Testen) eigentlich alle Versionen laufen.

    Gruß Rainer



  • alles gut, jeder kann sich mal versehen.

    so ich habe erst mal geschaut was auf meinem Pi drauf ist.

    Also bei mir ist (Stretch) Versions_ID 9 installiert.

    Habe jetzt noch mal Updates und Upgrades laufen lassen

    sudo apt update
    sudo apt upgrade
    
    

    hat beides funktioniert.

    nun habe ich noch mal versucht node und nodejs zu deinstallieren

    sudo apt --purge remove node
    sudo apt --purge remove nodejs
    sudo apt autoremove
    sudo reboot
    
    

    Ergebnis der Abfrage

    node -v
    v9.10.1
    nodejs -v
    bash: nodejs: Kommando nicht gefunden
    
    

    heißt für mich, node ist noch drauf und ich dürfte nicht mit Schritt 4 fortfahren, wie bekomme ich das nun runter?

    ist die npm 5.6.0 schlimm oder muss ich die auch deinstallieren und neu aufspielen?

    Oder jetzt noch einfach nodejs wie unter 4. beschreiben installieren?

    4\. Node.js neu installieren für Linux und Raspberry 2/3 
      1.curl -sL https://deb.nodesource.com/setup_6.x | sudo -E bash -
      2.sudo apt-get install -y build-essential libavahi-compat-libdnssd-dev libudev-dev libpam0g-dev nodejs
      3.reboot
    
    

    Danke

    Gruß Jens


  • Forum Testing Most Active Global Moderator Administrators

    nodejs v9 ist "böse".

    Das ist eine Entwicklerversion auf dem Weg zur stabilen v10.

    npm v5.6.0 ist ebenfalls böse, da ist ein massiver Bug drin, mit dem ioBroker komplett geschrottet werden kann.

    entweder v4.x oder >v5.7.1, aktuell v5.8

    Dies bedarf aber ggf. einer Neuinstallation

    Jetzt musst du nur noch herausbekommen, wie die v9 installiert wurde und wie die wieder wegkommt.

    ab jetzt bin ich überfragt.

    Gruß

    Rainer



  • bevor ich jetzt wieder was falsch verstehe…

    nodejs oder node V9 ist "böse"?

    Momentan ist ja node V0.x drauf

    aber nodejs nix....

    npm wäre dann der nächste schritt.

    wenn node V9.x böse, dann versuche ich tante Google mal zu quälen es deinstallieren zu können

    Gruß Jens



  • so, mit folgenden schritten habe ich node 8.9.0 installiert und die node 9.10.1 deinstalliert

    sudo n 8.9.0
    sudo shutdown -r now
    
    nach dem neustart
    sudo n rm 9.10.1
    
    

    nun sieht es wie folgt aus…

    node -v
    v8.9.0
    nodejs -v
    bash: nodejs: Kommando nicht gefunden
    npm -v
    5.5.1   (also noch böse)
    
    

    nächster schritt wäre, wie bekomme ich entweder npm 4.x oder V5.7.1 drauf

    und wie und welche nodejs muss nun drauf oder wird empfohlen?

    Danke

    Gruß Jens


Log in to reply
 

Suggested Topics

1.7k
Online

29.8k
Users

36.9k
Topics

494.1k
Posts