Gelöst:Erstinstallation auf Raspberry 3 und schon Fehler...

Forum zum Mitteilen von Fehlern
Antworten
ptec5000
Beiträge: 3
Registriert: 09.07.2018, 13:31

Gelöst:Erstinstallation auf Raspberry 3 und schon Fehler...

Beitrag von ptec5000 » 09.07.2018, 13:40

Hallo Leute,

ich bin komplett neu mit iOBroker komme aber aus der IT und habe einige Linux Grundkenntnisse.

Habe das All-In-One Image aufgespielt. Auf anhieb hat die Weboberfläche mal nicht gestartet. Nach reboot iobroker stop/start usw gings dann mal (kurz).

Dann nicht mehr - ein :

Code: Alles auswählen

cd /opt/iobroker
sudo iobroker stop
sudo chmod 777 * -R
sudo npm install iobroker.js-controller --production
sudo iobroker start
hat dann geholfen. Dann wollte ich den Milight adapter installieren was mit einer Fehler litanei fehl schlug.

Dann habe ich einen Lösungsvorschlag im Forum HIER gefunden.

Nun steht das Ding und ich bekomms nicht mehr zum laufen.

Folgender Output aus Putty:

Code: Alles auswählen

pi@All-In-One_RasPi:~ $ cd /opt/iobroker/
pi@All-In-One_RasPi:/opt/iobroker $ sudo iobroker status
module.js:549
    throw err;
    ^

Error: Cannot find module '/opt/iobroker/node_modules/iobroker.js-controller/iobroker.js'
    at Function.Module._resolveFilename (module.js:547:15)
    at Function.Module._load (module.js:474:25)
    at Function.Module.runMain (module.js:693:10)
    at startup (bootstrap_node.js:191:16)
    at bootstrap_node.js:612:3
pi@All-In-One_RasPi:/opt/iobroker $ ^C
pi@All-In-One_RasPi:/opt/iobroker $ cd /opt/iobroker
pi@All-In-One_RasPi:/opt/iobroker $ sudo chmod 777 * -R
pi@All-In-One_RasPi:/opt/iobroker $ sudo npm install iobroker.js-controller --production

> iobroker.js-controller@1.4.2 preinstall /opt/iobroker/node_modules/iobroker.js-controller
> node lib/preinstall_check.js


┌───────────────────────────────────────────────────┐
│              npm update check failed              │
│        Try running with sudo or get access        │
│       to the local update config store via        │
│ sudo chown -R $USER:$(id -gn $USER) /root/.config │
└───────────────────────────────────────────────────┘
NPM version: 5.6.0
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
WARNING:
You are using an unsupported npm version!
This can lead to problems when installing further packages

Please use "npm install -g npm@4" to downgrade npm to 4.x or
use "npm install -g npm@latest" to install a supported version of npm 5!
You need to make sure to repeat this step after installing an update to NodeJS and/or npm.
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
npm version >= 5: disabling package-lock
fs.js:646
  return binding.open(pathModule._makeLong(path), stringToFlags(flags), mode);
                 ^

Error: EACCES: permission denied, open '/opt/iobroker/.npmrc'
    at Object.fs.openSync (fs.js:646:18)
    at Object.fs.writeFileSync (fs.js:1299:33)
    at Object.<anonymous> (/opt/iobroker/node_modules/iobroker.js-controller/lib/preinstall_check.js:56:5)
    at Module._compile (module.js:652:30)
    at Object.Module._extensions..js (module.js:663:10)
    at Module.load (module.js:565:32)
    at tryModuleLoad (module.js:505:12)
    at Function.Module._load (module.js:497:3)
    at Function.Module.runMain (module.js:693:10)
    at startup (bootstrap_node.js:191:16)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! iobroker.js-controller@1.4.2 preinstall: `node lib/preinstall_check.js`
npm ERR! Exit status 1
Ich hoffe ihr könnt mir helfen - finde das Konzept mit den Adaptern nämlich sehr übersichtlich und Benutzerfreundlich!

Danke!
Zuletzt geändert von ptec5000 am 10.07.2018, 07:57, insgesamt 1-mal geändert.

Benutzeravatar
Homoran
guru
Beiträge: 13027
Registriert: 08.08.2014, 16:50

Re: Erstinstallation auf Raspberry 3 und schon Fehler...

Beitrag von Homoran » 09.07.2018, 14:05

Hallo,
Ich glaube nicht dass es ein ioBroker Fehler ist und werde den Thread gleich in die Kategorie Installation verschieben, also nicht wundern!
ptec5000 hat geschrieben:
09.07.2018, 13:40
Habe das All-In-One Image aufgespielt.
Welches?
ptec5000 hat geschrieben:
09.07.2018, 13:40
Auf anhieb hat die Weboberfläche mal nicht gestartet.
mal mit

Code: Alles auswählen

cd /opt/iobroker
sudo iobroker start
probiert?
Wundert mich aber, so etwas passiert üblicherweise nur nach einer Selbstinstallation - nicht bei einem Image.
Hast du das Readme befolgt?
ptec5000 hat geschrieben:
09.07.2018, 13:40
was mit einer Fehler litanei fehl schlug.
ich persönlich kenne den Adapter nicht, aber ohne log kann man da nichts zu sagen, oft sind das auch nur WARN und keine Fehler.

Gruß
Rainer
kein Support per PN!
Fragen im Forum stellen - es gibt fast nichts, was nicht auch für andere interessant ist.

Benutzeravatar
Stabilostick
professional
Beiträge: 833
Registriert: 23.05.2018, 14:52

Re: Erstinstallation auf Raspberry 3 und schon Fehler...

Beitrag von Stabilostick » 09.07.2018, 14:09

Dann habe ich einen Lösungsvorschlag im Forum HIER gefunden
Welcher war das?

ptec5000
Beiträge: 3
Registriert: 09.07.2018, 13:31

Gelöst: Erstinstallation auf Raspberry 3 und schon Fehler...

Beitrag von ptec5000 » 09.07.2018, 14:35

Ok konnte das Problem lösen.

Anscheinend wurde durch update/upgrade vom raspberry die npm Version aktualisiert auf 5.6.3 oder so - genau weiß ich es nicht mehr.

Vorgeschlagen wurde dann (leider überlesen) eh direkt der Downgrade.

Gesagt getan auf V4. jetzt läuft das Ding wieder!

Und mit aktueller Version meinte ich die, die AKTUELL auf eurer Website ist - das All in One Image:
Homematic All-In-One mit piVCCU - http://www.iobroker.net/docu/?ddownload=8063

Jetzt kann ich endlich rum spielen :)

Benutzeravatar
Homoran
guru
Beiträge: 13027
Registriert: 08.08.2014, 16:50

Re: Erstinstallation auf Raspberry 3 und schon Fehler...

Beitrag von Homoran » 09.07.2018, 14:52

ptec5000 hat geschrieben:
09.07.2018, 14:35
die AKTUELL auf eurer Website ist
allInOne.jpg
Aber gut wenn es jetzt läuft.

Gruß
Rainer
kein Support per PN!
Fragen im Forum stellen - es gibt fast nichts, was nicht auch für andere interessant ist.

paul53
guru
Beiträge: 3956
Registriert: 09.06.2015, 16:03
Wohnort: Berlin

Re: Erstinstallation auf Raspberry 3 und schon Fehler...

Beitrag von paul53 » 09.07.2018, 15:00

ptec5000 hat geschrieben:
09.07.2018, 14:35
jetzt läuft das Ding wieder!
Gelöst bitte im Betreff des ersten Beitrags ergänzen.
Versionen für RPi 2 mit S.USV, HM-MOD-RPI und SLC-USB-Stick mit root fs:
Jessie lite, Kernel 4.4.50-v7+, hmcon 0.18, node 8.11.3, Host 1.4.2, Admin 2.0.9, Javascript 3.6.4, HM-RPC 1.7.4, Email 1.0.4, History 1.8.5, Flot 1.9.1, Vis 1.0.4, Web 2.4.0

ptec5000
Beiträge: 3
Registriert: 09.07.2018, 13:31

Re: Erstinstallation auf Raspberry 3 und schon Fehler...

Beitrag von ptec5000 » 10.07.2018, 07:57

Homoran hat geschrieben:
09.07.2018, 14:52
die AKTUELL auf eurer Website ist
Im Betreff steht eh Raspberry 3 - da gibts nur eins ;)

mafe68
starter
Beiträge: 58
Registriert: 13.06.2017, 09:48

Re: Gelöst:Erstinstallation auf Raspberry 3 und schon Fehler...

Beitrag von mafe68 » 14.07.2018, 11:39

Hallo!

Habe auch das fertige Img für den Rpi installiert. Nur habe ich hier einen Rpi1 am laufen. Nach der Installation habe ich keinen zugriff auf das WebIf bekommen. Wenn man den ioBriker per Konsole starten möchte bekommt mal folgende Fehlermeldung

Code: Alles auswählen

pi@ioBroker-RPi1:/opt/iobroker $ iobroker start
Starting iobroker controller daemon...
iobroker controller daemon failed to start:  Failed to write pidfile (EACCES)
Error: Failed to write pidfile (EACCES)
Die das sind die Versionen von Node Nodejs und npm installiert sind.

Code: Alles auswählen

pi@ioBroker-RPi1:/opt/iobroker $ npm -v
4.6.1
pi@ioBroker-RPi1:/opt/iobroker $ node -v
v6.12.0
pi@ioBroker-RPi1:/opt/iobroker $ nodejs -v
v6.12.0
pi@ioBroker-RPi1:/opt/iobroker $ 
LG. Mario

ioBroker LXC Container Proxmox
ioBroker BananaPi M1

Benutzeravatar
Dutchman
guru
Beiträge: 4053
Registriert: 07.01.2016, 23:42

Re: Gelöst:Erstinstallation auf Raspberry 3 und schon Fehler...

Beitrag von Dutchman » 14.07.2018, 11:54

Probiere Mal mit sudo davor oder als root


Sent from my iPhone using Tapatalk

Antworten