NEWS

Update von Node-js machen !!



  • Hallo
    Mein ioBroker System zeigt mir beim Start an , das ich das Node- ja updaten muss.Ich habe die Version 4.5 drauf.Ich soll auf die Version Node.js v10.16.3 gehen.
    Wie muss ich das genau machen?
    Könnte mir mal jemand genau den Weg beschreiben wie ich das in der Aufforderung eingeben muss.

    Ich würde mich sehr freuen





  • @Kippe
    Version 4.5? Viel mit IOBroker kannst nicht gemacht haben, da Versinon 6 schon als alt gilt und wohl auch Probleme bei neuen Adaptern macht.



  • Ich habe das jetz so gemacht wie beschrieben, aber ich bekomme immer noch diese Meldung auf dem Bildschirm.
    Wenn ich das so sehe habe ich 2 Node Versionen drauf oder? Brauch HilfeScreenshot (150)_LI.jpg Screenshot (149)_LI.jpgScreenshot (151)_LI.jpg



  • @Kippe
    Na so ganz hast Dich nicht an die Anleitung gehalten, sonst hättest jetzt nicht 2 Node Versionen drauf.



  • Was muss ich denn jetzt machen, um die eine wieder zu Löschen?



  • @Kippe
    Such mal den Thread Node updaten, da steht schon alles drin.



  • Ich habe schon alles versucht, aber ich bekomme es nicht hin



  • @Kippe

    1. ioBroker stoppen
    /opt/iobroker/iobroker stop
    
    1. System aktualisieren
    apt update && apt upgrade -y
    
    1. Die existierenden node & node.js Versionen deinstallieren
    apt --purge remove node
    apt --purge remove nodejs
    apt autoremove
    reboot
    
    1. Node.js neu installieren
    curl -sL https://deb.nodesource.com/setup_10.x | sudo -E bash -
    apt install nodejs -y
    reboot
    
    1. Versionen prüfen
    node -v
    nodejs -v
    npm -v
    

    Stand heute sollten node und nodejs v10.16.3 und npm v6.9.0 sein
    node und nodejs müssen identisch sein

    1. Fixer drüber laufen lassen
    curl -sL https://iobroker.net/fix.sh | bash -
    
    1. iobroker wieder starten
    /opt/iobroker/iobroker start
    


  • @BBTown sagte in Update von Node-js machen !!:

    Die existierenden node & node.js Versionen deinstallieren

    apt --purge remove node
    apt --purge remove nodejs
    apt autoremove
    reboot

    gerne auch nach 3 nochmal prüfen das node -v und nodejs -v kein ergebnis mehr liefern nur dann ist node komplett runter.



  • @BBTown sagte in Update von Node-js machen !!:

    node -v

    Also ich habe jetzt alles noch 3 mal so gemacht wie ihr beschrieben habt.
    Wenn ich die Befehle zum Löschen der Node gebe und dann Reboot mache ist immer noch die 4.5.0 Version drin.
    Ich kann die wohl nicht mal Löschen ?Screenshot (152)_LI.jpg



  • @Kippe
    Lösche doch mal die Nodes und dann schaust ob noch eine da ist. Im Screenshot sind wieder zwei und die sollen beide weg sein. Hast den Thread zum Node Update eigentlich gefunden, denn da steht auch wie man hartnäckige Nodes weg bekommt. Erst wenn da keine mehr zu finden ist, wird die neuste Installiert. Dann hast wohl auch noch ein recht alte Debian, was man auch recht einfach auf 10.1 hoch ziehen sollte. Da ist dann eh Node 10 mit drin.
    Dann noch ein Tipp, ein Screenshot ist ne schöne Sache, allerdings nur wenn auch vile Infos darauf zu sehen sind, bei Dir sind 4 Zeilen interessant und die kopierst schön in einen "code" Tack zum posten. Ist angenehmer zu lesen.

    Hier mal der Link zur Node Update Anleitung.



  • Komme nicht weiter



  • @Kippe
    noch ein Versuch aus einem anderen Thread:

    sudo apt-get purge -y nodejs npm nodejs-legacy
    sudo apt -y autoremove
    sudo rm /etc/sources.list.d/nodesource.list
    sudo apt-get update
    sudo rm -rf /usr/local/bin/npm /usr/local/share/man/man1/node* /usr/local/lib/dtrace/node.d ~/.npm ~/.node-gyp /opt/local/bin/node /opt/local/include/node /opt/local/lib/node_modules
    sudo rm -rf /usr/local/lib/node*
    sudo rm -rf /usr/local/include/node*
    

    und anschließend die Neuinstallation wie 5 Antworten zuvor



  • @BBTown
    Das ist Post 3 aus dem oben verlinkten Thread den ich empfohlen habe zu dem Thema, da der TE nicht mal dort bis zum 3 Post gelesen hat, bin ich hier raus. Bisschen Eigeninitiative sollte schon da sein.



  • @BBTown sagte in Update von Node-js machen !!:

    reboot

    Ich habe auch diesen schritt gemacht, und es ist immer noch die 4.5.0 da
    Deine Klugen Sprüche Jan1 kannste dir sparen



  • @Kippe
    Du willst was und nimmst Hilfe nicht an, oder wo steht dass Du das gelesen hast was ich oben geschrieben habe?
    So funktioniert Hilfe nicht, Feedback ist nötig und "komm nicht weiter" ist kein Feedback, suggeriert mir aber, dass Du es nicht gelesen hast.



  • @Kippe sagte in Update von Node-js machen !!:

    Ich habe auch diesen schritt gemacht, und es ist immer noch die 4.5.0 da

    Dann lautet meine Empfehlung - Backup machen und das ganze System neu Aufsetzen



  • @Kippe
    und/oder Du versuchst auf dem System nach weiteren Dateien oder Verzeichnissen bzgl. node bzw. nodejs zu suchen. Linux find und locate



  • Hallo
    Ich habe es Heute noch mal alles versucht.Nach Eurer Anleitung bekomme ich immer wieder die Version unter node -v 4.5.0 angezeigt.
    Ich kann die Version nicht Löschen. Es muss doch irgendwie gehen?
    Würde mich sehr freuen, wenn mir mal jemand genau die Eingabeaufforderung sagen könnte, wie ich die Version runter bekomme.


Log in to reply
 

Suggested Topics

799
Online

32.1k
Users

38.8k
Topics

525.6k
Posts