NEWS

Installationsprobleme Raspberry pi


  • Forum Testing Most Active Global Moderator Administrators

    @gutgut30 sagte in Installationsprobleme Raspberry pi:

    Auf meiner SD-Karte die auf dem Image mit der pivccu3 basiert, geht es nicht. Das finde ich schon spannend weil es ja auf dem gleichen Grundimage basieren sollte, mir fehlt aber Detailwissen um das jetzt zu bewerten.

    Von piVCCU war nie die Rede!
    wo ist diese SD-Karte her?

    Muss ich mir mal ansehen, was @deimos da gemacht hat.

    eventuell ist da schon das falsche node drauf.


  • Forum Testing Most Active Global Moderator Administrators

    @gutgut30

    Da ich von @deimos noch kein Feedback habe, bitte nur als Workaround sehen, da ich nicht weiß ob hinter dem Problem und seiner "Lösung" noch anderes steckt, was mit der Lösung evtl. nicht mehr klappt.

    Wir denken zwar nicht, aber wenn doch werde ich es hier sofort melden.

    Vorgehen für ioBroker mit piVCCU auf Raspberry Pi mit Buster

    • Das entsprechende Image bei Github herunterladen
    • Image aktualisieren mit sudo apt update && sudo apt upgrade
    • Gemäß der Doku Schritt 2 und 3 vornehmen
      • Überprüfung sollte aber nichts ergeben
    • jetzt den Befehl sudo update-ca-certificates --fresh ausführen
    • ab jetzt mit Schritt 4 der Doku fortfahren

    Viel Glück


  • Forum Testing Most Active Global Moderator Administrators

    @gutgut30 sagte in Installationsprobleme Raspberry pi:

    Auf dem pivccu3 Image bekomme ich keine Rückmeldung sondern direkt die Eingabeaufforderung.

    @stabilostick und ich haben gestern Stunden damit verbracht dieses Verhalten und die Ursache dazu herauszubekommen.

    Es ist uns schlussendlich gelungen eine ioBroker-Installation aufbauend auf das Buster-Image von Alex hinzubekommen.

    Solltest du daran noch interessiert sein, können wir dir einen Workaround anbieten.
    Ich habe Alex bisher noch nicht erreichen können.


  • Starter

    @Homoran Super gerne, ich möchte mich wirklich mit dem Gespann beschäftigen. Wenn du also Infos für mich hast, immer her damit. Ansonsten würde ich versuchen alles manuell, ohne Grundimage aufzubauen. Sollte ja eigentlich auch mit den ganzen Anleitungen gehen.


  • Forum Testing Most Active Global Moderator Administrators

    @gutgut30

    Da ich von @deimos noch kein Feedback habe, bitte nur als Workaround sehen, da ich nicht weiß ob hinter dem Problem und seiner "Lösung" noch anderes steckt, was mit der Lösung evtl. nicht mehr klappt.

    Wir denken zwar nicht, aber wenn doch werde ich es hier sofort melden.

    Vorgehen für ioBroker mit piVCCU auf Raspberry Pi mit Buster

    • Das entsprechende Image bei Github herunterladen
    • Image aktualisieren mit sudo apt update && sudo apt upgrade
    • Gemäß der Doku Schritt 2 und 3 vornehmen
      • Überprüfung sollte aber nichts ergeben
    • jetzt den Befehl sudo update-ca-certificates --fresh ausführen
    • ab jetzt mit Schritt 4 der Doku fortfahren

    Viel Glück



  • Hi Homoran,
    vielen Dank für die einfache und verständliche Zusammenfassung.
    Funktioniert einwandfrei!

    Gruß JR


  • Starter

    @Homoran said in Installationsprobleme Raspberry pi:

    Da ich von @deimos noch kein Feedback habe, bitte nur als Workaround sehen, da ich nicht weiß ob hinter dem Problem und seiner "Lösung" noch anderes steckt, was mit der Lösung evtl. nicht mehr klappt.

    Danke! Wird am Wochenende direkt gemacht.


  • Starter

    Funktioniert einwandfrei, habe nun beides auf dem Pi am Laufen. Danke!


  • Starter

    fehlpost....


  • Starter

    Servus,
    ich stoße bei der recherche zu meinem Problem immer wieder auf diesen Foreneintrag desswegen stell ich meine Frage mal direkt hier:

    pi@raspberrypi:~ $ sudo systemctl status iobroker
    ● iobroker.service - ioBroker Server
       Loaded: loaded (/lib/systemd/system/iobroker.service; enabled; vendor 
       Active: failed (Result: exit-code) since Mon 2020-05-25 14:19:42 CEST;
         Docs: http://iobroker.net
      Process: 5576 ExecStart=/bin/bash -c ${NODE} /opt/iobroker/node_modules
     Main PID: 5576 (code=exited, status=1/FAILURE)
    
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Service Restart
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Scheduled resta
    Mai 25 14:19:42 raspberrypi systemd[1]: Stopped ioBroker Server.
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Start request r
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Failed with res
    Mai 25 14:19:42 raspberrypi systemd[1]: Failed to start ioBroker Server.
    

    Ich bekomm diese Fehler und mutmaße dass es daran lieg dass unter "/opt/iobroker/node_modules" quasi nix drin liegt. Ich weiß aber nicht wirklich ob der Fehler beim Installieren passiert ist oder wie oder was.

    pi@raspberrypi:~ $ sudo -H npm install -g npm@6
    npm WARN npm npm does not support Node.js v10.19.0
    npm WARN npm You should probably upgrade to a newer version of node as we
    npm WARN npm can't make any promises that npm will work with this version.
    npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8, 9.
    npm WARN npm You can find the latest version at https://nodejs.org/
    /usr/local/bin/npm -> /usr/local/lib/node_modules/npm/bin/npm-cli.js
    /usr/local/bin/npx -> /usr/local/lib/node_modules/npm/bin/npx-cli.js
    + npm@6.14.5
    added 435 packages from 873 contributors in 25.283s
    
    

    Dann hab ich noch dieses Problem beim NPM was auch weiter oben schon malbeschrieben, aber nicht weiter behandelt wurde.

    Ich bin für sachdienliche Hinweise dankbar.



  • @dj-cd-schubser
    Da ist ein abgeschnittenes Log, somit schlecht.
    Dann soll das heißen:
    @dj-cd-schubser sagte in Installationsprobleme Raspberry pi:

    Ich bekomm diese Fehler und mutmaße dass es daran lieg dass unter "/opt/iobroker/node_modules" quasi nix drin liegt. Ich weiß aber nicht wirklich ob der Fehler beim Installieren passiert ist oder wie oder was.

    Halte Dich an die Installations- Doku für Linux und Du musst nix mutmaßen, da dort dieser Punkt deutlich beschrieben ist.


  • Forum Testing Most Active Global Moderator Administrators

    @dj-cd-schubser sagte in Installationsprobleme Raspberry pi:

    sudo -H npm install -g npm@6

    wieso machst du das?


  • Starter

    @Jan1

    ~~pi@raspberrypi:~ $ sudo systemctl status iobroker
    ● iobroker.service - ioBroker Server
       Loaded: loaded (/lib/systemd/system/iobroker.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Mon 2020-05-25 14:19:42 CEST; 2h 32min ago
         Docs: http://iobroker.net
      Process: 5576 ExecStart=/bin/bash -c ${NODE} /opt/iobroker/node_modules/iobroker.js-controller/contro
     Main PID: 5576 (code=exited, status=1/FAILURE)
    
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Service RestartSec=100ms expired, scheduling 
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Scheduled restart job, restart counter is at 
    Mai 25 14:19:42 raspberrypi systemd[1]: Stopped ioBroker Server.
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Start request repeated too quickly.
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Failed with result 'exit-code'.
    Mai 25 14:19:42 raspberrypi systemd[1]: Failed to start ioBroker Server.
    ...skipping...
    ● iobroker.service - ioBroker Server
       Loaded: loaded (/lib/systemd/system/iobroker.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Mon 2020-05-25 14:19:42 CEST; 2h 32min ago
         Docs: http://iobroker.net
      Process: 5576 ExecStart=/bin/bash -c ${NODE} /opt/iobroker/node_modules/iobroker.js-controller/contro
     Main PID: 5576 (code=exited, status=1/FAILURE)
    
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Service RestartSec=100ms expired, scheduling 
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Scheduled restart job, restart counter is at 
    Mai 25 14:19:42 raspberrypi systemd[1]: Stopped ioBroker Server.
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Start request repeated too quickly.
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Failed with result 'exit-code'.
    Mai 25 14:19:42 raspberrypi systemd[1]: Failed to start ioBroker Server.
    
    ~~
    

    Mod-Edit: Code in code-tags gesetzt!

    Meinst du das hier mit abgeschnitten??

    Ich habe mich an die Anleitung gehalten. Was meinst du mit der Punkt ist deutlich beschrieben? Was habe ich übersehen?


  • Starter

    @Homoran

    Zitat:
    "Als letzte Überprüfung bitte noch die Version von npm mittels npm -v überprüfen.

    Ergibt dies eine Version < 6, bitte noch mit sudo -H npm install -g npm@6 ein npm-Update durchführen"



  • @dj-cd-schubser
    Dann üben wirr mal Code auch in Code Tacks zu packen und mal die Ausgaben zu posten, wie sie in der Doku zur Node und NPM drin stehen und nicht nur zu behaupten man hats gemacht 😉


  • Starter

    @Jan1
    Ich kann dir grade null folgen.



  • @dj-cd-schubser
    Ausgaben der Konsole in Code Tacks packen, dann kann man das auch lesen und nicht einfach rein kopieren.
    Dann mal bisschen was aus der Doku hier auch posten und dazu gehört eigentlich schon Standard die Ausgaben von:

    node -v
    nodejs -v
    npm -v
    

    Dann weiß man mal was Du überhaupt hast.

    Homoran hat ja gefragt warum Du das

    sudo -H npm install -g npm@6
    

    gemacht hast, denn dazu müsste man erst mal wiessen was Die ne NPM Version ist und da bei der Installation nach Doku die Node10 installiert wird, kann das nicht nötig sein , weil Node 10 NPM 6 mitbringt.


  • Forum Testing Most Active Global Moderator Administrators

    @dj-cd-schubser sagte in Installationsprobleme Raspberry pi:

    @Homoran

    Zitat:
    "Als letzte Überprüfung bitte noch die Version von npm mittels npm -v überprüfen.

    Ergibt dies eine Version < 6, bitte noch mit sudo -H npm install -g npm@6 ein npm-Update durchführen"

    ok!
    ich glaube das stammt noch aus node8 - Zeiten. Muss ich mal recherchieren

    Aber bei node 10.x sollte npm 6.x dabei sein.
    wenn das nicht geklappt hat ist etwas anderes faul



  • @Homoran
    Das schreib ich ja auch schon oben 😉


  • Forum Testing Most Active Global Moderator Administrators

    @Jan1 Dann sag dem Forum auch, dass es mit der Veröffentlichung deines Posts nicht 9 Minuten warten soll 😉



  • @Homoran
    böses Forum 😊



Suggested Topics

1.9k
Online

32.1k
Users

38.8k
Topics

526.1k
Posts