NEWS

[How-to] Node.js für ioBroker richtig updaten



  • @Jan1 da werd ich lieber ein proxmox backup machen und restoren falls etwas schief geht 🙂

    aber wegen der sicherheit allein, mach ich jetzt erstmal nix - da keine probleme vorhanden - habe geraade admin adapter 3.6.3 gemacht - keine warnung - kein error

    ich behalt den fixer mal im auge und les noch ein wenig darüber , falls in zukunft etwas sein sollte

    danke dir



  • @crunchip Welche Adapter nutzt Du denn die Bluetooth Dinge tun? Diese musst Du VORHER idealerweise auf Versionen bringen die deine Ziel-Nodejs Version auch unterstützen! Das ergänze ich oben noch.
    Hier könnte es ble sein, ggf radar (musst glaube auf radar2) o.ä.

    Ein Weg es zu fixen ist den betroffenen Adapter ausfindlig zu machen, per "npm install iobroker.adaptername@version" die kompatible Version installieren, dann nochmal den "npm rebuild"versuchen



  • @Diginix An der Stelle beissen sich dann bestimmt Dinge "von früher" wo noch mit sudo gearbeitet wurde und der neuere Ansatz. Auhc interessant, warum nutzt Du User iobroker? An sich. hat der keine Login-Shell nach dem neuen Installer. Ich habe keine Ahnung ob das nicht zusätzlich Probleme bereitet



  • @crunchip @liv-in-sky Aaaaaaaalso 🙂

    Eine saubere Installation die auf dem neuen Installer (für ältere dem Fixer) basiert ist von uns ausdrücklich empfohlen. Einerseits aus Sicherheitsaspekten (Root und so), anderrrseits auch weil sich npm inzwischen mit sudo gaaaanz komisch verhält. Wenn man alles als Root User tut sollte es weitestgehend funktionieren.
    Das ganze Thema ist aber inzwischen so komplett geworden und unterschiedliche npm Versionen verhalten sich unterschiedlich das wir überlegen müssen was wir Support-Technisch unterstützen können. Weil jedem User mit seiner, irgendwie irgendwann einmal durchgeführten, Installation mit Besonderheiten im Forum helfen zu können hat sich als immer aschwieriger herausgestellt. Und einige User mögen es auch nicht wenn keiner Antwortet oder keine Lösung angeboten wird 😉 Am Ende heisst es "ioBroker ist scheisse".

    Wir haben für uns den Ausweg im Ansatz des Installers/Fixers gefunden, wodurch wir eine sinnvolle Support-basis sicherstellen können und damit konnten bisher viele der Sonderfälle direkt gelöst werden.

    Natürlich kann jeder User es so installieren wie er will und sich gegen den Installer/Fixer entscheiden ... es bedeutet aber im Zweifel das er bei Problemen allein da steht. Wer das akzeptiert und such bewusst dafür entscheidet die Lösung ggf. selbst finden zu müssen, kann tun was er will 🙂



  • @Jan1 sagte in [How-to] Node.js für ioBroker richtig updaten:

    Die Doku ist derzeit nicht online, sonst hätte ich es gleich verlinkt.

    Doch: https://www.iobroker.net/docu/


  • Forum Testing Most Active

    @apollon77 ble v 0.7.3, radar2 v1.0.7
    und der amazon-dash v0.3.1 , der auch noch Probleme bereitete, beim wechsel von Nodejs 8 auf 10



  • @apollon77 sagte in [How-to] Node.js für ioBroker richtig updaten:

    @Jan1 sagte in [How-to] Node.js für ioBroker richtig updaten:

    Die Doku ist derzeit nicht online, sonst hätte ich es gleich verlinkt.

    Doch: https://www.iobroker.net/docu/

    Jou der Link funktioniert, nur der oben im Forum geht nicht

    https://www.iobroker.net/docu/?lang=de


  • Forum Testing Most Active

    @apollon77 sagte in [How-to] Node.js für ioBroker richtig updaten:

    Wenn man alles als Root User tut sollte es weitestgehend funktionieren.

    tut es aber nicht, dachte eigentlich, das man so am wenigsten Probleme hätte


  • Forum Testing Most Active

    @Jan1 sagte in [How-to] Node.js für ioBroker richtig updaten:

    @apollon77 sagte in [How-to] Node.js für ioBroker richtig updaten:

    @Jan1 sagte in [How-to] Node.js für ioBroker richtig updaten:

    Die Doku ist derzeit nicht online, sonst hätte ich es gleich verlinkt.

    Doch: https://www.iobroker.net/docu/

    Jou der Link funktioniert, nur der oben im Forum geht nicht

    https://www.iobroker.net/docu/?lang=de

    Kann ich bestätigen:

    Cannot GET /docu/



  • @apollon77 daaaaanke dir - super ausführlich

    kann ich absolut nachvollziehen

    einekleinefrage dazu - es wird wohl ein neuer user iobroker angelegt - aber mein system macht alles mit root - wird dann nach dem fixer iobroker unter dem neuen user gestartet ?
    wenn ich dann auf der console npm oder iobroker befehle ausführe (unter root) - macht das dann keine probleme ? (ich bin auch auf der console mit root eingeloggt (soll man nicht - ich weiß)



  • @crunchip Alle Probleme gelöst?



  • @Jan1 Fixen wir. Danke



  • @liv-in-sky Ja iobroker läuft dann als der User und es wird auch alles so eingerichtet das danach das alles tut. Bisher ist nichts gegenteiliges bekannt 🙂



  • @apollon77 danke

    wegen @crunchip

    da sind einige fehlermeldungen siehe: https://forum.iobroker.net/post/267300 - vielleicht magst du kurz helfen



  • @Diginix sagte in [How-to] Node.js für ioBroker richtig updaten:

    Außerdem hat dieser user bei mir "sudo ALL ALL" in /etc/sudoers.d/iobroker

    (AUch wenn etwas Offtopic hier)
    Naja etwas komplexer ist das sudoers FIle schon. hat bei mitr einiger mehr an Zeilen 🙂

    Das "iobroker ALL=(ALL) ALL" bedeutet das er alles mit einer Passwortabfrage ausführen darf. Danach kommen eine Liste an Kommandos die er ohne Passwort ausfüren darf. Diese haben wir gesammelt mit Sicherheit und Adapterbedarfen im Hinterkopf


  • Forum Testing Most Active

    @apollon77 nein, eigentlich noch keines 😂
    das eigentliche Problem war ja dieses https://forum.iobroker.net/topic/22832
    dann wollte ich Nodejs auf version 10 bringen, woran ich ja gescheitert bin , an den 3 erwähnten Adaptern.
    nach hin und her probieren in sämtlichen Konstellationen, bin ich letztendlich auf meinem alten Stand, nur das ich vom Js-controller nun zurück bin von 1.5.9 auf 1.4.2
    habe nun nochmal ein

     npm rebuild
    
    > bluetooth-hci-socket@0.5.1 install /opt/iobroker/node_modules/bluetooth-hci-socket
    > node-gyp rebuild
    
    make: Verzeichnis „/opt/iobroker/node_modules/bluetooth-hci-socket/build“ wird betreten
      CXX(target) Release/obj.target/binding/src/BluetoothHciSocket.o
    ../src/BluetoothHciSocket.cpp: In member function ‘void BluetoothHciSocket::poll()’:
    ../src/BluetoothHciSocket.cpp:251:95: warning: ‘v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, v8::Local<v8::String>, int, v8::Local<v8::Value>*)’ is deprecated [-Wdeprecated-declarations]
         Nan::MakeCallback(Nan::New<Object>(this->This), Nan::New("emit").ToLocalChecked(), 2, argv);
                                                                                                   ^
    In file included from ../src/BluetoothHciSocket.cpp:8:0:
    ../../nan/nan.h:950:46: note: declared here
       NAN_DEPRECATED inline v8::Local<v8::Value> MakeCallback(
                                                  ^~~~~~~~~~~~
    ../src/BluetoothHciSocket.cpp: In member function ‘void BluetoothHciSocket::emitErrnoError()’:
    ../src/BluetoothHciSocket.cpp:275:72: warning: ‘v8::Local<v8::Object> v8::Function::NewInstance(int, v8::Local<v8::Value>*) const’ is deprecated: Use maybe version [-Wdeprecated-declarations]
       Local<Value> error = errorConstructor->NewInstance(1, constructorArgs);
                                                                            ^
    In file included from /root/.node-gyp/8.16.0/include/node/v8.h:26:0,
                     from /root/.node-gyp/8.16.0/include/node/node.h:63,
                     from /root/.node-gyp/8.16.0/include/node/node_buffer.h:25,
                     from ../src/BluetoothHciSocket.cpp:7:
    /root/.node-gyp/8.16.0/include/node/v8.h:3897:31: note: declared here
                     Local<Object> NewInstance(int argc, Local<Value> argv[]) const);
                                   ^
    /root/.node-gyp/8.16.0/include/node/v8config.h:318:3: note: in definition of macro ‘V8_DEPRECATED’
       declarator __attribute__((deprecated(message)))
       ^~~~~~~~~~
    ../src/BluetoothHciSocket.cpp:282:93: warning: ‘v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, v8::Local<v8::String>, int, v8::Local<v8::Value>*)’ is deprecated [-Wdeprecated-declarations]
       Nan::MakeCallback(Nan::New<Object>(this->This), Nan::New("emit").ToLocalChecked(), 2, argv);
                                                                                                 ^
    In file included from ../src/BluetoothHciSocket.cpp:8:0:
    ../../nan/nan.h:950:46: note: declared here
       NAN_DEPRECATED inline v8::Local<v8::Value> MakeCallback(
                                                  ^~~~~~~~~~~~
      SOLINK_MODULE(target) Release/obj.target/binding.node
      COPY Release/binding.node
    make: Verzeichnis „/opt/iobroker/node_modules/bluetooth-hci-socket/build“ wird verlassen
    
    > iobroker@1.1.2 install /opt/iobroker/node_modules/iobroker
    > node lib/prepareSetup.js && node lib/setup.js
    
    NPM version: 6.4.1
    npm version >= 5: disabling package-lock
    npm install iobroker.discovery@stable --production --save
    
    > serialport@6.2.2 install /opt/iobroker/node_modules/iobroker.discovery/node_modules/serialport
    > prebuild-install || node-gyp rebuild
    
    npm WARN react-beautiful-dnd@9.0.2 requires a peer of react@^16.3.1 but none is installed. You must install peer dependencies yourself.
    npm WARN react-motion@0.5.2 requires a peer of react@^0.14.9 || ^15.3.0 || ^16.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN react-redux@5.0.7 requires a peer of react@^0.14.0 || ^15.0.0-0 || ^16.0.0-0 but none is installed. You must install peer dependencies yourself.
    npm WARN svg-inline-react@1.0.3 requires a peer of react@^0.14.0 || ^15.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: osx-temperature-sensor@1.0.3 (node_modules/osx-temperature-sensor):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for osx-temperature-sensor@1.0.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: xpc-connection@0.1.4 (node_modules/xpc-connection):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for xpc-connection@0.1.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    
    + iobroker.discovery@1.3.0
    added 2 packages from 4 contributors, removed 82 packages, updated 11 packages and audited 48050 packages in 81.804s
    found 142 vulnerabilities (64 low, 17 moderate, 61 high)
      run `npm audit fix` to fix them, or `npm audit` for details
    packet folder is: /opt/iobroker/node_modules/iobroker.discovery | exists: true
    npm install iobroker.admin@stable --production --save
    npm WARN react-beautiful-dnd@9.0.2 requires a peer of react@^16.3.1 but none is installed. You must install peer dependencies yourself.
    npm WARN react-motion@0.5.2 requires a peer of react@^0.14.9 || ^15.3.0 || ^16.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN react-redux@5.0.7 requires a peer of react@^0.14.0 || ^15.0.0-0 || ^16.0.0-0 but none is installed. You must install peer dependencies yourself.
    npm WARN svg-inline-react@1.0.3 requires a peer of react@^0.14.0 || ^15.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: osx-temperature-sensor@1.0.3 (node_modules/osx-temperature-sensor):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for osx-temperature-sensor@1.0.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: xpc-connection@0.1.4 (node_modules/xpc-connection):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for xpc-connection@0.1.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    
    + iobroker.admin@3.6.2
    updated 1 package and audited 48050 packages in 84.565s
    found 142 vulnerabilities (64 low, 17 moderate, 61 high)
      run `npm audit fix` to fix them, or `npm audit` for details
    packet folder is: /opt/iobroker/node_modules/iobroker.admin | exists: true
    npm install iobroker.js-controller@stable --production --save
    
    > iobroker.js-controller@1.5.11 preinstall /opt/iobroker/node_modules/iobroker.js-controller
    > node lib/preinstallCheck.js
    
    NPM version: 6.4.1
    npm version >= 5: disabling package-lock
    
    > ursa-optional@0.9.10 install /opt/iobroker/node_modules/ursa-optional
    > node rebuild.js
    
    
    > diskusage@0.2.6 install /opt/iobroker/node_modules/diskusage
    > node-gyp rebuild
    
    make: Verzeichnis „/opt/iobroker/node_modules/diskusage/build“ wird betreten
      CXX(target) Release/obj.target/diskusage/src/main.o
      CXX(target) Release/obj.target/diskusage/src/diskusage_posix.o
      SOLINK_MODULE(target) Release/obj.target/diskusage.node
      COPY Release/diskusage.node
    make: Verzeichnis „/opt/iobroker/node_modules/diskusage/build“ wird verlassen
    
    > iobroker.js-controller@1.5.11 install /opt/iobroker/node_modules/iobroker.js-controller
    > node iobroker.js setup first
    
    npm WARN react-beautiful-dnd@9.0.2 requires a peer of react@^16.3.1 but none is installed. You must install peer dependencies yourself.
    npm WARN react-motion@0.5.2 requires a peer of react@^0.14.9 || ^15.3.0 || ^16.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN react-redux@5.0.7 requires a peer of react@^0.14.0 || ^15.0.0-0 || ^16.0.0-0 but none is installed. You must install peer dependencies yourself.
    npm WARN svg-inline-react@1.0.3 requires a peer of react@^0.14.0 || ^15.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: osx-temperature-sensor@1.0.3 (node_modules/osx-temperature-sensor):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for osx-temperature-sensor@1.0.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: xpc-connection@0.1.4 (node_modules/xpc-connection):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for xpc-connection@0.1.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    
    + iobroker.js-controller@1.5.11
    added 17 packages from 30 contributors, removed 2 packages, updated 3 packages and audited 48132 packages in 92.007s
    found 160 vulnerabilities (75 low, 18 moderate, 67 high)
      run `npm audit fix` to fix them, or `npm audit` for details
    packet folder is: /opt/iobroker/node_modules/iobroker.js-controller | exists: true
    Write "./iobroker start" to start the ioBroker
    Auto-start was enabled. Write "update-rc.d -f iobroker.sh remove" to disable auto-start
    iobroker is started. Go to "http://ip-addr:8081" to open the admin UI.
    
    > iobroker.amazon-dash@0.3.1 preinstall /opt/iobroker/node_modules/iobroker.amazon-dash
    > apt install libpcap-dev -y || true
    
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    libpcap-dev ist schon die neueste Version (1.8.1-3).
    Das folgende Paket wurde automatisch installiert und wird nicht mehr benötigt:
      linux-image-4.9.0-7-amd64
    Verwenden Sie »apt autoremove«, um es zu entfernen.
    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 3 nicht aktualisiert.
    
    > socketwatcher@0.3.0 install /opt/iobroker/node_modules/iobroker.amazon-dash/node_modules/socketwatcher
    > node-gyp rebuild
    
    make: Verzeichnis „/opt/iobroker/node_modules/iobroker.amazon-dash/node_modules/socketwatcher/build“ wird betreten
      CXX(target) Release/obj.target/socketwatcher/socket_watcher.o
    ../socket_watcher.cpp: In static member function ‘static void SocketWatcher::Callback(uv_poll_t*, int, int)’:
    ../socket_watcher.cpp:77:60: warning: ‘v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, v8::Local<v8::Function>, int, v8::Local<v8::Value>*)’ is deprecated [-Wdeprecated-declarations]
       Nan::MakeCallback(watcher->handle(), callback, argc, argv);
                                                                ^
    In file included from ../socket_watcher.hpp:8:0,
                     from ../socket_watcher.cpp:5:
    ../../nan/nan.h:959:46: note: declared here
       NAN_DEPRECATED inline v8::Local<v8::Value> MakeCallback(
                                                  ^~~~~~~~~~~~
      SOLINK_MODULE(target) Release/obj.target/socketwatcher.node
      COPY Release/socketwatcher.node
    make: Verzeichnis „/opt/iobroker/node_modules/iobroker.amazon-dash/node_modules/socketwatcher/build“ wird verlassen
    
    > pcap@2.1.0 install /opt/iobroker/node_modules/iobroker.amazon-dash/node_modules/pcap
    > node-gyp rebuild
    
    make: Verzeichnis „/opt/iobroker/node_modules/iobroker.amazon-dash/node_modules/pcap/build“ wird betreten
      CXX(target) Release/obj.target/pcap_binding/pcap_binding.o
      CXX(target) Release/obj.target/pcap_binding/pcap_session.o
    ../pcap_session.cc: In static member function ‘static void PcapSession::PacketReady(u_char*, const pcap_pkthdr*, const u_char*)’:
    ../pcap_session.cc:85:102: warning: ‘v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, v8::Local<v8::Function>, int, v8::Local<v8::Value>*)’ is deprecated [-Wdeprecated-declarations]
         Nan::MakeCallback(Nan::GetCurrentContext()->Global(), Nan::New(session->packet_ready_cb), 0, NULL);
                                                                                                          ^
    In file included from ../pcap_session.h:4:0,
                     from ../pcap_session.cc:7:
    ../../nan/nan.h:959:46: note: declared here
       NAN_DEPRECATED inline v8::Local<v8::Value> MakeCallback(
                                                  ^~~~~~~~~~~~
      SOLINK_MODULE(target) Release/obj.target/pcap_binding.node
      COPY Release/pcap_binding.node
    make: Verzeichnis „/opt/iobroker/node_modules/iobroker.amazon-dash/node_modules/pcap/build“ wird verlassen
    
    > socketwatcher@0.3.0 install /opt/iobroker/node_modules/iobroker.amazon-dash/node_modules/socketwatcher
    > node-gyp rebuild
    
    make: Verzeichnis „/opt/iobroker/node_modules/iobroker.amazon-dash/node_modules/socketwatcher/build“ wird betreten
      CXX(target) Release/obj.target/socketwatcher/socket_watcher.o
    ../socket_watcher.cpp: In static member function ‘static void SocketWatcher::Callback(uv_poll_t*, int, int)’:
    ../socket_watcher.cpp:77:60: warning: ‘v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, v8::Local<v8::Function>, int, v8::Local<v8::Value>*)’ is deprecated [-Wdeprecated-declarations]
       Nan::MakeCallback(watcher->handle(), callback, argc, argv);
                                                                ^
    In file included from ../socket_watcher.hpp:8:0,
                     from ../socket_watcher.cpp:5:
    ../../nan/nan.h:959:46: note: declared here
       NAN_DEPRECATED inline v8::Local<v8::Value> MakeCallback(
                                                  ^~~~~~~~~~~~
      SOLINK_MODULE(target) Release/obj.target/socketwatcher.node
      COPY Release/socketwatcher.node
    make: Verzeichnis „/opt/iobroker/node_modules/iobroker.amazon-dash/node_modules/socketwatcher/build“ wird verlassen
    
    > usb@1.5.0 install /opt/iobroker/node_modules/iobroker.ble/node_modules/usb
    > node-pre-gyp install --fallback-to-build
    
    node-pre-gyp WARN Using request for node-pre-gyp https download
    [usb] Success: "/opt/iobroker/node_modules/iobroker.ble/node_modules/usb/src/binding/usb_bindings.node" already installed
    Pass --update-binary to reinstall or --build-from-source to recompile
    
    > @abandonware/noble@1.9.2-2 install /opt/iobroker/node_modules/iobroker.ble/node_modules/@abandonware/noble
    > node-gyp rebuild
    
    make: Verzeichnis „/opt/iobroker/node_modules/iobroker.ble/node_modules/@abandonware/noble/build“ wird betreten
      SOLINK_MODULE(target) Release/obj.target/noble.node
      COPY Release/noble.node
    make: Verzeichnis „/opt/iobroker/node_modules/iobroker.ble/node_modules/@abandonware/noble/build“ wird verlassen
    
    > usb@1.5.0 install /opt/iobroker/node_modules/iobroker.ble/node_modules/usb
    > node-pre-gyp install --fallback-to-build
    
    node-pre-gyp WARN Using request for node-pre-gyp https download
    [usb] Success: "/opt/iobroker/node_modules/iobroker.ble/node_modules/usb/src/binding/usb_bindings.node" already installed
    Pass --update-binary to reinstall or --build-from-source to recompile
    
    > @abandonware/bluetooth-hci-socket@0.5.3-1 preinstall /opt/iobroker/node_modules/iobroker.ble/node_modules/@abandonware/bluetooth-hci-socket
    > npm install node-pre-gyp
    
    + node-pre-gyp@0.12.0
    updated 6 packages and audited 95 packages in 4.815s
    found 0 vulnerabilities
    
    (node:31989) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 SIGINT listeners added. Use emitter.setMaxListeners() to increase limit
    
    > @abandonware/bluetooth-hci-socket@0.5.3-1 install /opt/iobroker/node_modules/iobroker.ble/node_modules/@abandonware/bluetooth-hci-socket
    > node-pre-gyp install --fallback-to-build
    
    node-pre-gyp WARN Using request for node-pre-gyp https download
    [@abandonware/bluetooth-hci-socket] Success: "/opt/iobroker/node_modules/iobroker.ble/node_modules/@abandonware/bluetooth-hci-socket/lib/binding/binding.node" already installed
    Pass --update-binary to reinstall or --build-from-source to recompile
    npm ERR! path /opt/iobroker/node_modules/iobroker.discovery/node_modules/@types/iobroker/package.json
    npm ERR! code ENOENT
    npm ERR! errno -2
    npm ERR! syscall open
    npm ERR! enoent ENOENT: no such file or directory, open '/opt/iobroker/node_modules/iobroker.discovery/node_modules/@types/iobroker/package.json'
    npm ERR! enoent This is related to npm not being able to find a file.
    npm ERR! enoent
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /root/.npm/_logs/2019-06-03T07_11_55_104Z-debug.log
    root@IoBroker:/opt/iobroker# npm cache clean --force
    npm WARN using --force I sure hope you know what you are doing.
    root@IoBroker:/opt/iobroker# iobroker start
    Starting iobroker controller daemon...
    iobroker controller daemon started. PID: 32678
    
    


  • Dann dupliziere ich mal die Antwort 🙂

    Also das meiste sind warnungen und können ignoriert werden. Ich würde bei so eonem Fehler der scheinbar von "iobroker.discovery" getriggert wird einfach die gleiche discovery Version drüber installieren.

    Also ggf in "node_modules/iobroker.discovery/package.json" rausfinden welche Version es ist und dann per

    npm install iobroker.discovery@version --production

    diese neu installieren. Danach nochmals npm rebuild


  • Forum Testing Most Active

    @apollon77 ja der ist danach auf version 1.3.0 hatte ich auch schon wieder auf 2.0.0
    was ich aber nicht verstehe, ist das ich gestern js controller 1.4.2 downgrade gemacht hatte und nun nur nochmal ein rebuild und habe im iobroker wieder v 1.5.11



  • @crunchip sagte in [How-to] Node.js für ioBroker richtig updaten:

    was ich aber nicht verstehe, ist das ich gestern js controller 1.4.2 downgrade gemacht hatte und nun nur nochmal ein rebuild und habe im iobroker wieder v 1.5.11

    Das wäre jetzt Glaskugel. npm rebuild lädt nichts herunter und aktualisiert keine Pakete, er führt nur alle "nativen build Prozesse" nochmals neu aus. Mehr nicht. Also dann hat irgendwie der downgrade nicht sauber geklappt.

    Aber warum kein 1.5 :-)) (aber das wäre anderer Thread). 1.5 ist die Basis der Zukunft wenn es Probleme gibt müssen wir die Lösen!


  • Forum Testing Most Active

    @apollon77 habe mein putty fenster noch offen

    root@IoBroker:~# cd /opt/iobroker
    root@IoBroker:/opt/iobroker# iobroker stop
    Stopping iobroker controller daemon...
    iobroker controller daemon stopped.
    No "killall.sh" script found. Just stop.
    root@IoBroker:/opt/iobroker# npm i iobroker.js-controller@1.4.2 --production
    
    > iobroker.js-controller@1.4.2 preinstall /opt/iobroker/node_modules/iobroker.js                                        -controller
    > node lib/preinstall_check.js
    
    NPM version: 6.4.1
    npm version >= 5: disabling package-lock
    
    > iobroker.js-controller@1.4.2 install /opt/iobroker/node_modules/iobroker.js-co                                        ntroller
    > node iobroker.js setup first
    
    npm WARN react-beautiful-dnd@9.0.2 requires a peer of react@^16.3.1 but none is                                         installed. You must install peer dependencies yourself.
    npm WARN react-motion@0.5.2 requires a peer of react@^0.14.9 || ^15.3.0 || ^16.0                                        .0 but none is installed. You must install peer dependencies yourself.
    npm WARN react-redux@5.0.7 requires a peer of react@^0.14.0 || ^15.0.0-0 || ^16.                                        0.0-0 but none is installed. You must install peer dependencies yourself.
    npm WARN svg-inline-react@1.0.3 requires a peer of react@^0.14.0 || ^15.0.0 but                                         none is installed. You must install peer dependencies yourself.
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: osx-temperature-sensor@1.0.3 (no                                        de_modules/osx-temperature-sensor):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for osx-tempe                                        rature-sensor@1.0.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux"                                        ,"arch":"x64"})
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: xpc-connection@0.1.4 (node_modul                                        es/xpc-connection):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for xpc-conne                                        ction@0.1.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":                                        "x64"})
    
    + iobroker.js-controller@1.4.2
    added 3 packages from 2 contributors, removed 17 packages, updated 3 packages an                                        d audited 48050 packages in 110.973s
    found 142 vulnerabilities (64 low, 17 moderate, 61 high)
      run `npm audit fix` to fix them, or `npm audit` for details
    
    


Suggested Topics

835
Online

32.3k
Users

38.9k
Topics

527.5k
Posts