NEWS

[How-to] Node.js für ioBroker richtig updaten



  • @crunchip sagte in [How-to] Node.js für ioBroker richtig updaten:

    @Stabilostick klinkt so einfach, wie du das schreibst und doch hat es 3Stunden gedauert.😀
    Soviel telefonier ich sonst nicht mal in einem Jahr.😂 😂 😂 😂

    aber das lag wohl eher an der Anzahl der Adapter, hehe.

    die Falschmeldung des Node.js noch zu erwähnen, falls einer danach fragt
    f3546ec5-3800-466d-864e-5dac7a2d2420-image.png

    welche hast denn nun drauf 10.16.0 oder 10.15.3? Ich habe die 10.16.0 und diese Meldung nicht.


  • Starter

    Ich habe auch 10.16.0 und kein falschen Hinweis für 10.15.3

    0321a23f-bcd2-48b5-b970-95af64d79e6c-grafik.png


  • Forum Testing Most Active

    @Diginix @Jan1

    @Stabilostick sagte in [How-to] Node.js für ioBroker richtig updaten:

    Wird wohl heute im Laufe des Tages gefixed.



  • @crunchip
    Da hatte ich diese Version schon ohne den Fehler ne Woche laufen


  • Forum Testing Most Active

    eines was ich noch beheben muss, nach der Aktion, da fehlt was
    Commands.ssml" not found
    0ca7a935-1e83-4374-9f01-c1a93cce3ece-image.png


  • Starter

    @Jan1 sagte in [How-to] Node.js für ioBroker richtig updaten:

    @crunchip
    Da hatte ich diese Version schon ohne den Fehler ne Woche laufen

    Genau so bei mir. Ich hatte 10.16.0 und nie einen Hinweis auf 10.15.3.
    Der Bugfix, wo auch immer, ist bei mir nicht nötig. Daher hat @Jan1 und mich das auch gewundert dass es bei dir als vermeintlich alte Version erkannt wird.
    @crunchip Hast du zufällig Windows?
    Bei mir läuft alles unter Linux.


  • Forum Testing Most Active

    @Diginix nein läuft unter Debian



  • @crunchip
    Dann ist es noch seltsamer, da ich auch Debian laufen habe. Mit 9 und jetzt 10 keine Warnung zur Version.



  • Update von node 8 auf node 10 hat mit Variante 4c problemlos funktioniert.

    Gruß Marco


  • Forum Testing Most Active

    @Stabilostick @apollon77 und nun kommen die ersten gravierenden Probleme!
    Iobroker ist nun 4 Tage gelaufen, nun musste ich IoBroker mal neu starten, nachdem ich Proxmox ein update verpasst habe.
    Jedoch nur noch Störungen seit dem Start.
    Alexa, iogo, iot, pollenflug, telegram, tankerkönig, dwd, ical, skripte, vis lizenz,
    js-controller 1.5.12
    Node.js 10.16, immer noch mit dieser Meldung21f77938-888b-4de5-a299-8a839d5befd8-image.png
    NPM 6.9.0
    Auszug vom log,
    hab aber nur die Warnungen/Errors zusammengetragen

    2019-06-08 00:31:03.319 - error: vis.0 Cannot check license: Error: getaddrinfo EAI_AGAIN iobroker.net iobroker.net:443
    2019-06-08 00:31:08.129 - warn: host.IoBroker warning: Cannot read "http://download.iobroker.net/sources-dist-latest.json"
    2019-06-08 00:31:08.129 - warn: host.IoBroker warning: empty repo received!
    2019-06-08 00:31:24.998 - warn: javascript.0 script.js.Visualisierung.Wegezeit_Arbeit_Landstraße: (Error: getaddrinfo EAI_AGAIN maps.googleapis.com maps.googleapis.com:443) ERROR bei Abfrage von: https://maps.googleapis.com/maps/api/directions/json?...
    2019-06-08 00:31:24.999 - warn: javascript.0 script.js.Visualisierung.Wegezeit_Arbeit_Landstraße: Fehler beim Auslesen des JSON. Keine Daten erhalten.
    2019-06-08 00:31:36.041 - error: telegram.0 polling_error:EFATAL, EFATAL: Error: getaddrinfo EAI_AGAIN api.telegram.org api.telegram.org:443
    2019-06-08 00:31:39.851 - error: tankerkoenig.0 Spritpreise einlesen (gezielte Stationen via ID) - Fehler: Error: getaddrinfo EAI_AGAIN creativecommons.tankerkoenig.de creativecommons.tankerkoenig.de:443
    2019-06-08 00:31:44.665 - error: alexa2.0 Error:
    2019-06-08 00:31:44.666 - error: alexa2.0 Error: You can try to get the cookie manually by opening http://192.168.178.90:40433/ with your browser.
    2019-06-08 00:32:06.998 - error: telegram.0 polling_error:EFATAL, EFATAL: Error: getaddrinfo EAI_AGAIN api.telegram.org api.telegram.org:443
    2019-06-08 00:32:10.032 - error: javascript.0 script.js.Visualisierung.Wetterwarnung_UWZ: TypeError: Cannot read property 'request' of undefined
    2019-06-08 00:32:10.033 - error: javascript.0 at Request._callback (script.js.Visualisierung.Wetterwarnung_UWZ:223:57)
    2019-06-08 00:32:10.034 - error: javascript.0 at self.callback (/opt/iobroker/node_modules/iobroker.javascript/node_modules/request/request.js:185:22)
    2019-06-08 00:32:10.035 - error: javascript.0 at Request.emit (events.js:198:13)
    2019-06-08 00:32:10.036 - error: javascript.0 at Timeout._onTimeout (/opt/iobroker/node_modules/iobroker.javascript/node_modules/request/request.js:852:16)
    2019-06-08 00:32:10.036 - error: javascript.0 at ontimeout (timers.js:436:11)
    2019-06-08 00:32:10.036 - error: javascript.0 at tryOnTimeout (timers.js:300:5)
    2019-06-08 00:32:10.036 - error: javascript.0 at listOnTimeout (timers.js:263:5)
    2019-06-08 00:32:10.036 - error: javascript.0 at Timer.processTimers (timers.js:223:10)
    2019-06-08 00:32:13.600 - error: telegram.0 Cannot send message [chatId - 572229857]: Error: EFATAL: Error: getaddrinfo EAI_AGAIN api.telegram.org api.telegram.org:443
    2019-06-08 00:32:17.316 - error: telegram.0 polling_error:EFATAL, EFATAL: Error: getaddrinfo EAI_AGAIN api.telegram.org api.telegram.org:443
    2019-06-08 00:32:27.637 - error: telegram.0 polling_error:EFATAL, EFATAL: Error: getaddrinfo EAI_AGAIN api.telegram.org api.telegram.org:443
    2019-06-08 00:32:37.955 - error: telegram.0 polling_error:EFATAL, EFATAL: Error: getaddrinfo EAI_AGAIN api.telegram.org api.telegram.org:443
    2019-06-08 00:32:48.273 - error: telegram.0 polling_error:EFATAL, EFATAL: Error: getaddrinfo EAI_AGAIN api.telegram.org api.telegram.org:443
    2019-06-08 00:32:58.592 - error: telegram.0 polling_error:EFATAL, EFATAL: Error: getaddrinfo EAI_AGAIN api.telegram.org api.telegram.org:443
    2019-06-08 00:33:19.603 - error: info.0 Error: getaddrinfo EAI_AGAIN raw.githubusercontent.com raw.githubusercontent.com:443
    2019-06-08 00:33:39.374 - error: dwd.0 Empty or invalid JSON: Cannot read JSON file: Error: getaddrinfo EAI_AGAIN www.dwd.de www.dwd.de:80
    2019-06-08 00:33:46.927 - warn: ical.0 Error reading from URL "https://calendar.google.com/calendar/ical/de.german%23holiday%40group.v.calendar.google.com/public/basic.ics": Error: getaddrinfo EAI_AGAIN calendar.google.com calendar.google.com:443
    2019-06-08 00:33:46.929 - warn: ical.0 Error reading "https://calendar.google.com/calendar/ical/de.german%23holiday%40group.v.calendar.google.com/public/basic.ics": Error: getaddrinfo EAI_AGAIN calendar.google.com calendar.google.com:443
    2019-06-08 00:33:46.933 - warn: ical.0 Error reading from URL "https://calendar.google.com/calendar/ical/xxxxxxxxxxxxgmail.com/private-xxxxxxxxxxxxxxxxxxxxxxxxxxx/basic.ics": Error: getaddrinfo EAI_AGAIN calendar.google.com calendar.google.com:443
    2019-06-08 00:33:46.933 - warn: ical.0 Error reading "https://calendar.google.com/calendar/ical/xxxxxxxxxxxgmail.com/private-xxxxxxxxxxxxxxxxxxxxxxxxxx/basic.ics": Error: getaddrinfo EAI_AGAIN calendar.google.com calendar.google.com:443
    2019-06-08 00:33:58.721 - error: iot.0 getaddrinfo EAI_AGAIN xxxxxxxxx.iot.eu-west-1.amazonaws.com xxxxxxxxxx.iot.eu-west-1.amazonaws.com:8883
    2019-06-08 00:33:59.611 - error: iot.0 [GHOME] Cannot report device state: Error: getaddrinfo EAI_AGAIN gstatus.iobroker.in gstatus.iobroker.in:443
    2019-06-08 00:34:10.023 - error: javascript.0 script.js.Visualisierung.Wetterwarnung_UWZ: TypeError: Cannot read property 'request' of undefined
    2019-06-08 00:34:10.023 - error: javascript.0 at Request._callback (script.js.Visualisierung.Wetterwarnung_UWZ:223:57)
    2019-06-08 00:34:10.023 - error: javascript.0 at self.callback (/opt/iobroker/node_modules/iobroker.javascript/node_modules/request/request.js:185:22)
    2019-06-08 00:34:10.023 - error: javascript.0 at Request.emit (events.js:198:13)
    2019-06-08 00:34:10.023 - error: javascript.0 at Timeout._onTimeout (/opt/iobroker/node_modules/iobroker.javascript/node_modules/request/request.js:852:16)
    2019-06-08 00:34:10.024 - error: javascript.0 at ontimeout (timers.js:436:11)
    2019-06-08 00:34:10.024 - error: javascript.0 at tryOnTimeout (timers.js:300:5)
    2019-06-08 00:34:10.024 - error: javascript.0 at listOnTimeout (timers.js:263:5)
    2019-06-08 00:34:10.024 - error: javascript.0 at Timer.processTimers (timers.js:223:10)
    2019-06-08 00:34:10.815 - error: telegram.0 polling_error:EFATAL, EFATAL: Error: getaddrinfo EAI_AGAIN api.telegram.org api.telegram.org:443
    2019-06-08 00:34:17.020 - error: statistics.0 : message handler implemented, but messagebox not enabled. Define common.messagebox in io-package.json for adapter or delete message handler.
    2019-06-08 00:34:25.047 - warn: iogo.0 You are not logged in
    2019-06-08 00:34:32.100 - error: iogo.0 Authentication: auth/network-request-failed # A network error (such as timeout, interrupted connection or unreachable host) has occurred.
    2019-06-08 00:34:58.394 - error: pollenflug.0 Error requesting URL https://opendata.dwd.de/climate_environment/health/alerts/s31fg.json
    2019-06-08 00:34:58.395 - error: pollenflug.0 Error reading pollen risk index.
    2019-06-08 00:40:12.314 - error: weatherunderground.0 uncaught exception: Cannot read property 'statusCode' of undefined
    2019-06-08 00:40:12.316 - error: weatherunderground.0 TypeError: Cannot read property 'statusCode' of undefined
    2019-06-08 00:42:33.481 - error: pollenflug.0 Error requesting URL https://opendata.dwd.de/climate_environment/health/alerts/s31fg.json
    2019-06-08 00:44:12.145 - error: telegram.0 Cannot send message [user - undefined]: Error: EFATAL: Error: getaddrinfo EAI_AGAIN api.telegram.org api.telegram.org:443
    2019-06-08 00:44:22.153 - error: telegram.0 polling_error:EFATAL, EFATAL: Error: getaddrinfo EAI_AGAIN api.telegram.org api.telegram.org:443
    2019-06-08 00:44:22.156 - error: telegram.0 Cannot send message [chatId - 123456789]: Error: EFATAL: Error: getaddrinfo EAI_AGAIN api.telegram.org api.telegram.org:443
    

    auch ein manuelles cookie holen zwecks alexa, endet in ein

    Proxy-Error: Error: getaddrinfo EAI_AGAIN www.amazon.com www.amazon.com:443
    

    EDIT: Fehler Gefunden
    nach langem suchen habe ich bemerkt, das resolv.conf überschrieben war.


  • Forum Testing Most Active

    @crunchip sagte in [How-to] Node.js für ioBroker richtig updaten:

    Node.js 10.16, immer noch mit dieser Meldung

    habe ich mal erneut ein

    curl -sL https://deb.nodesource.com/setup_10.x | sudo -E bash -
    sudo apt-get install -y nodejs
    

    ausgeführt, mit einem anschließenden

    npm rebuild
    

    ist auch alles durchgelaufen, bis auf ein paar kleineren Warnungen und der letzte Teil, mit Error

    > epoll@0.1.22 install /opt/iobroker/node_modules/epoll
    > node-gyp rebuild
    
    make: Verzeichnis „/opt/iobroker/node_modules/epoll/build“ wird betreten
      CXX(target) Release/obj.target/epoll/src/epoll.o
    In file included from ../node_modules/nan/nan.h:192:0,
                     from ../src/epoll.cc:15:
    ../node_modules/nan/nan_maybe_43_inl.h: In function ‘Nan::Maybe<bool> Nan::ForceSet(v8::Local<v8::Object>, v8::Local<v8::Value>, v8::Local<v8::Value>, v8::PropertyAttribute)’:
    ../node_modules/nan/nan_maybe_43_inl.h:112:15: error: ‘class v8::Object’ has no member named ‘ForceSet’
       return obj->ForceSet(isolate->GetCurrentContext(), key, value, attribs);
                   ^~~~~~~~
    In file included from ../src/epoll.cc:15:0:
    ../node_modules/nan/nan.h: In function ‘v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, v8::Local<v8::Function>, int, v8::Local<v8::Value>*)’:
    ../node_modules/nan/nan.h:835:60: warning: ‘v8::Local<v8::Value> node::MakeCallback(v8::Isolate*, v8::Local<v8::Object>, v8::Local<v8::Function>, int, v8::Local<v8::Value>*)’ is deprecated: Use MakeCallback(..., async_context) [-Wdeprecated-declarations]
             v8::Isolate::GetCurrent(), target, func, argc, argv);
                                                                ^
    In file included from ../src/epoll.cc:12:0:
    /root/.node-gyp/10.16.0/include/node/node.h:177:50: note: declared here
                     NODE_EXTERN v8::Local<v8::Value> MakeCallback(
                                                      ^
    /root/.node-gyp/10.16.0/include/node/node.h:91:42: note: in definition of macro ‘NODE_DEPRECATED’
         __attribute__((deprecated(message))) declarator
                                              ^~~~~~~~~~
    In file included from ../src/epoll.cc:15:0:
    ../node_modules/nan/nan.h: In function ‘v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, v8::Local<v8::String>, int, v8::Local<v8::Value>*)’:
    ../node_modules/nan/nan.h:850:62: warning: ‘v8::Local<v8::Value> node::MakeCallback(v8::Isolate*, v8::Local<v8::Object>, v8::Local<v8::String>, int, v8::Local<v8::Value>*)’ is deprecated: Use MakeCallback(..., async_context) [-Wdeprecated-declarations]
             v8::Isolate::GetCurrent(), target, symbol, argc, argv);
                                                                  ^
    In file included from ../src/epoll.cc:12:0:
    /root/.node-gyp/10.16.0/include/node/node.h:170:50: note: declared here
                     NODE_EXTERN v8::Local<v8::Value> MakeCallback(
                                                      ^
    /root/.node-gyp/10.16.0/include/node/node.h:91:42: note: in definition of macro ‘NODE_DEPRECATED’
         __attribute__((deprecated(message))) declarator
                                              ^~~~~~~~~~
    In file included from ../src/epoll.cc:15:0:
    ../node_modules/nan/nan.h: In function ‘v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, const char*, int, v8::Local<v8::Value>*)’:
    ../node_modules/nan/nan.h:865:62: warning: ‘v8::Local<v8::Value> node::MakeCallback(v8::Isolate*, v8::Local<v8::Object>, const char*, int, v8::Local<v8::Value>*)’ is deprecated: Use MakeCallback(..., async_context) [-Wdeprecated-declarations]
             v8::Isolate::GetCurrent(), target, method, argc, argv);
                                                                  ^
    In file included from ../src/epoll.cc:12:0:
    /root/.node-gyp/10.16.0/include/node/node.h:163:50: note: declared here
                     NODE_EXTERN v8::Local<v8::Value> MakeCallback(
                                                      ^
    /root/.node-gyp/10.16.0/include/node/node.h:91:42: note: in definition of macro ‘NODE_DEPRECATED’
         __attribute__((deprecated(message))) declarator
                                              ^~~~~~~~~~
    In file included from ../src/epoll.cc:15:0:
    ../node_modules/nan/nan.h: In member function ‘v8::Local<v8::Value> Nan::Callback::Call_(v8::Isolate*, v8::Local<v8::Object>, int, v8::Local<v8::Value>*) const’:
    ../node_modules/nan/nan.h:1479:5: warning: ‘v8::Local<v8::Value> node::MakeCallback(v8::Isolate*, v8::Local<v8::Object>, v8::Local<v8::Function>, int, v8::Local<v8::Value>*)’ is deprecated: Use MakeCallback(..., async_context) [-Wdeprecated-declarations]
         ));
         ^
    In file included from ../src/epoll.cc:12:0:
    /root/.node-gyp/10.16.0/include/node/node.h:177:50: note: declared here
                     NODE_EXTERN v8::Local<v8::Value> MakeCallback(
                                                      ^
    /root/.node-gyp/10.16.0/include/node/node.h:91:42: note: in definition of macro ‘NODE_DEPRECATED’
         __attribute__((deprecated(message))) declarator
                                              ^~~~~~~~~~
    ../src/epoll.cc: In static member function ‘static Nan::NAN_METHOD_RETURN_TYPE Epoll::Add(Nan::NAN_METHOD_ARGS_TYPE)’:
    ../src/epoll.cc:210:44: warning: ‘int32_t v8::Value::Int32Value() const’ is deprecated: Use maybe version [-Wdeprecated-declarations]
       int err = epoll->Add(info[0]->Int32Value(), info[1]->Int32Value());
                                                ^
    In file included from /root/.node-gyp/10.16.0/include/node/v8.h:26:0,
                     from ../src/epoll.cc:11:
    /root/.node-gyp/10.16.0/include/node/v8.h:2478:46: note: declared here
       V8_DEPRECATED("Use maybe version", int32_t Int32Value() const);
                                                  ^
    /root/.node-gyp/10.16.0/include/node/v8config.h:324:3: note: in definition of macro ‘V8_DEPRECATED’
       declarator __attribute__((deprecated(message)))
       ^~~~~~~~~~
    ../src/epoll.cc:210:67: warning: ‘int32_t v8::Value::Int32Value() const’ is deprecated: Use maybe version [-Wdeprecated-declarations]
       int err = epoll->Add(info[0]->Int32Value(), info[1]->Int32Value());
                                                                       ^
    In file included from /root/.node-gyp/10.16.0/include/node/v8.h:26:0,
                     from ../src/epoll.cc:11:
    /root/.node-gyp/10.16.0/include/node/v8.h:2478:46: note: declared here
       V8_DEPRECATED("Use maybe version", int32_t Int32Value() const);
                                                  ^
    /root/.node-gyp/10.16.0/include/node/v8config.h:324:3: note: in definition of macro ‘V8_DEPRECATED’
       declarator __attribute__((deprecated(message)))
       ^~~~~~~~~~
    ../src/epoll.cc: In static member function ‘static Nan::NAN_METHOD_RETURN_TYPE Epoll::Modify(Nan::NAN_METHOD_ARGS_TYPE)’:
    ../src/epoll.cc:230:47: warning: ‘int32_t v8::Value::Int32Value() const’ is deprecated: Use maybe version [-Wdeprecated-declarations]
       int err = epoll->Modify(info[0]->Int32Value(), info[1]->Int32Value());
                                                   ^
    In file included from /root/.node-gyp/10.16.0/include/node/v8.h:26:0,
                     from ../src/epoll.cc:11:
    /root/.node-gyp/10.16.0/include/node/v8.h:2478:46: note: declared here
       V8_DEPRECATED("Use maybe version", int32_t Int32Value() const);
                                                  ^
    /root/.node-gyp/10.16.0/include/node/v8config.h:324:3: note: in definition of macro ‘V8_DEPRECATED’
       declarator __attribute__((deprecated(message)))
       ^~~~~~~~~~
    ../src/epoll.cc:230:70: warning: ‘int32_t v8::Value::Int32Value() const’ is deprecated: Use maybe version [-Wdeprecated-declarations]
       int err = epoll->Modify(info[0]->Int32Value(), info[1]->Int32Value());
                                                                          ^
    In file included from /root/.node-gyp/10.16.0/include/node/v8.h:26:0,
                     from ../src/epoll.cc:11:
    /root/.node-gyp/10.16.0/include/node/v8.h:2478:46: note: declared here
       V8_DEPRECATED("Use maybe version", int32_t Int32Value() const);
                                                  ^
    /root/.node-gyp/10.16.0/include/node/v8config.h:324:3: note: in definition of macro ‘V8_DEPRECATED’
       declarator __attribute__((deprecated(message)))
       ^~~~~~~~~~
    ../src/epoll.cc: In static member function ‘static Nan::NAN_METHOD_RETURN_TYPE Epoll::Remove(Nan::NAN_METHOD_ARGS_TYPE)’:
    ../src/epoll.cc:247:47: warning: ‘int32_t v8::Value::Int32Value() const’ is deprecated: Use maybe version [-Wdeprecated-declarations]
       int err = epoll->Remove(info[0]->Int32Value());
                                                   ^
    In file included from /root/.node-gyp/10.16.0/include/node/v8.h:26:0,
                     from ../src/epoll.cc:11:
    /root/.node-gyp/10.16.0/include/node/v8.h:2478:46: note: declared here
       V8_DEPRECATED("Use maybe version", int32_t Int32Value() const);
                                                  ^
    /root/.node-gyp/10.16.0/include/node/v8config.h:324:3: note: in definition of macro ‘V8_DEPRECATED’
       declarator __attribute__((deprecated(message)))
       ^~~~~~~~~~
    epoll.target.mk:103: die Regel für Ziel „Release/obj.target/epoll/src/epoll.o“ scheiterte
    make: *** [Release/obj.target/epoll/src/epoll.o] Fehler 1
    make: Verzeichnis „/opt/iobroker/node_modules/epoll/build“ wird verlassen
    gyp ERR! build error
    gyp ERR! stack Error: `make` failed with exit code: 2
    gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:262:23)
    gyp ERR! stack     at ChildProcess.emit (events.js:198:13)
    gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)
    gyp ERR! System Linux 4.9.0-9-amd64
    gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
    gyp ERR! cwd /opt/iobroker/node_modules/epoll
    gyp ERR! node -v v10.16.0
    gyp ERR! node-gyp -v v3.8.0
    gyp ERR! not ok
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! epoll@0.1.22 install: `node-gyp rebuild`
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the epoll@0.1.22 install script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /root/.npm/_logs/2019-06-08T16_27_52_442Z-debug.log
    root@IoBroker:/opt/iobroker#
    
    

    was müsste ich da noch machen?


  • Forum Testing Most Active

    Eine Frage hätte ich noch.
    Mir ist folgendes aufgefallen

    Die Markierung ist der Zeitpunkt, des Update´s von Node.js 8 auf 10 , mittels (Variante D- Neuinstallation mit Restore) und Fixer Skript.
    Kann mir jemand sagen, warum sich der Netzwerk-Traffic so verändert hat bzw. woher das kommt?
    Die Grafik bezieht sich rein auf die IoBroker VM
    4fa51b02-8565-46c6-959f-cc29c288c98d-image.png



  • @crunchip sagte in [How-to] Node.js für ioBroker richtig updaten:

    was müsste ich da noch machen?

    Ich tippe mal auf einen Adapter, der die GPIOs eines RPIs abfragt und epoll nutzt als Auslöser. Installiere zum Test eine neuere Version des epoll-Moduls mit npm direkt im ioBroker-Verzeichnis. Also

    npm i epoll
    

    Und weil Du als root arbeitest, den Fixxer ggf. nicht vegessen.



  • @crunchip sagte in [How-to] Node.js für ioBroker richtig updaten:

    warum sich der Netzwerk-Traffic so verändert

    Du kannst z.B. iftop, ein Analysewerkzeug für Netzwerktraffic, verwenden. Es ähnelt dem top-Befehl.


  • Forum Testing Most Active

    @Stabilostick jep, hatte schon gegoogelt und gelesen, das es was mit den GPIO´s zu tun hat.
    Das hatte ich gemacht,

    root@IoBroker:/opt/iobroker# npm i epoll
    
    > epoll@0.1.22 install /opt/iobroker/node_modules/rpi-gpio/node_modules/epoll
    > node-gyp rebuild
    
    make: Verzeichnis „/opt/iobroker/node_modules/rpi-gpio/node_modules/epoll/build“ wird betreten
      CXX(target) Release/obj.target/epoll/src/epoll.o
    In file included from ../../nan/nan.h:192:0,
                     from ../src/epoll.cc:15:
    ../../nan/nan_maybe_43_inl.h: In function ‘Nan::Maybe<bool> Nan::ForceSet(v8::Local<v8::Object>, v8::Loca                                 l<v8::Value>, v8::Local<v8::Value>, v8::PropertyAttribute)’:
    ../../nan/nan_maybe_43_inl.h:112:15: error: ‘class v8::Object’ has no member named ‘ForceSet’
       return obj->ForceSet(isolate->GetCurrentContext(), key, value, attribs);
                   ^~~~~~~~
    In file included from ../src/epoll.cc:15:0:
    ../../nan/nan.h: In function ‘v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, v8::Local<v8:                                 :Function>, int, v8::Local<v8::Value>*)’:
    ../../nan/nan.h:835:60: warning: ‘v8::Local<v8::Value> node::MakeCallback(v8::Isolate*, v8::Local<v8::Obj                                 ect>, v8::Local<v8::Function>, int, v8::Local<v8::Value>*)’ is deprecated: Use MakeCallback(..., async_co                                 ntext) [-Wdeprecated-declarations]
             v8::Isolate::GetCurrent(), target, func, argc, argv);
                                                                ^
    In file included from ../src/epoll.cc:12:0:
    /root/.node-gyp/10.16.0/include/node/node.h:177:50: note: declared here
                     NODE_EXTERN v8::Local<v8::Value> MakeCallback(
                                                      ^
    /root/.node-gyp/10.16.0/include/node/node.h:91:42: note: in definition of macro ‘NODE_DEPRECATED’
         __attribute__((deprecated(message))) declarator
                                              ^~~~~~~~~~
    In file included from ../src/epoll.cc:15:0:
    ../../nan/nan.h: In function ‘v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, v8::Local<v8:                                 :String>, int, v8::Local<v8::Value>*)’:
    ../../nan/nan.h:850:62: warning: ‘v8::Local<v8::Value> node::MakeCallback(v8::Isolate*, v8::Local<v8::Obj                                 ect>, v8::Local<v8::String>, int, v8::Local<v8::Value>*)’ is deprecated: Use MakeCallback(..., async_cont                                 ext) [-Wdeprecated-declarations]
             v8::Isolate::GetCurrent(), target, symbol, argc, argv);
                                                                  ^
    In file included from ../src/epoll.cc:12:0:
    /root/.node-gyp/10.16.0/include/node/node.h:170:50: note: declared here
                     NODE_EXTERN v8::Local<v8::Value> MakeCallback(
                                                      ^
    /root/.node-gyp/10.16.0/include/node/node.h:91:42: note: in definition of macro ‘NODE_DEPRECATED’
         __attribute__((deprecated(message))) declarator
                                              ^~~~~~~~~~
    In file included from ../src/epoll.cc:15:0:
    ../../nan/nan.h: In function ‘v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, const char*,                                  int, v8::Local<v8::Value>*)’:
    ../../nan/nan.h:865:62: warning: ‘v8::Local<v8::Value> node::MakeCallback(v8::Isolate*, v8::Local<v8::Obj                                 ect>, const char*, int, v8::Local<v8::Value>*)’ is deprecated: Use MakeCallback(..., async_context) [-Wde                                 precated-declarations]
             v8::Isolate::GetCurrent(), target, method, argc, argv);
                                                                  ^
    In file included from ../src/epoll.cc:12:0:
    /root/.node-gyp/10.16.0/include/node/node.h:163:50: note: declared here
                     NODE_EXTERN v8::Local<v8::Value> MakeCallback(
                                                      ^
    /root/.node-gyp/10.16.0/include/node/node.h:91:42: note: in definition of macro ‘NODE_DEPRECATED’
         __attribute__((deprecated(message))) declarator
                                              ^~~~~~~~~~
    In file included from ../src/epoll.cc:15:0:
    ../../nan/nan.h: In member function ‘v8::Local<v8::Value> Nan::Callback::Call_(v8::Isolate*, v8::Local<v8                                 ::Object>, int, v8::Local<v8::Value>*) const’:
    ../../nan/nan.h:1479:5: warning: ‘v8::Local<v8::Value> node::MakeCallback(v8::Isolate*, v8::Local<v8::Obj                                 ect>, v8::Local<v8::Function>, int, v8::Local<v8::Value>*)’ is deprecated: Use MakeCallback(..., async_co                                 ntext) [-Wdeprecated-declarations]
         ));
         ^
    In file included from ../src/epoll.cc:12:0:
    /root/.node-gyp/10.16.0/include/node/node.h:177:50: note: declared here
                     NODE_EXTERN v8::Local<v8::Value> MakeCallback(
                                                      ^
    /root/.node-gyp/10.16.0/include/node/node.h:91:42: note: in definition of macro ‘NODE_DEPRECATED’
         __attribute__((deprecated(message))) declarator
                                              ^~~~~~~~~~
    ../src/epoll.cc: In static member function ‘static Nan::NAN_METHOD_RETURN_TYPE Epoll::Add(Nan::NAN_METHOD                                 _ARGS_TYPE)’:
    ../src/epoll.cc:210:44: warning: ‘int32_t v8::Value::Int32Value() const’ is deprecated: Use maybe version                                  [-Wdeprecated-declarations]
       int err = epoll->Add(info[0]->Int32Value(), info[1]->Int32Value());
                                                ^
    In file included from /root/.node-gyp/10.16.0/include/node/v8.h:26:0,
                     from ../src/epoll.cc:11:
    /root/.node-gyp/10.16.0/include/node/v8.h:2478:46: note: declared here
       V8_DEPRECATED("Use maybe version", int32_t Int32Value() const);
                                                  ^
    /root/.node-gyp/10.16.0/include/node/v8config.h:324:3: note: in definition of macro ‘V8_DEPRECATED’
       declarator __attribute__((deprecated(message)))
       ^~~~~~~~~~
    ../src/epoll.cc:210:67: warning: ‘int32_t v8::Value::Int32Value() const’ is deprecated: Use maybe version                                  [-Wdeprecated-declarations]
       int err = epoll->Add(info[0]->Int32Value(), info[1]->Int32Value());
                                                                       ^
    In file included from /root/.node-gyp/10.16.0/include/node/v8.h:26:0,
                     from ../src/epoll.cc:11:
    /root/.node-gyp/10.16.0/include/node/v8.h:2478:46: note: declared here
       V8_DEPRECATED("Use maybe version", int32_t Int32Value() const);
                                                  ^
    /root/.node-gyp/10.16.0/include/node/v8config.h:324:3: note: in definition of macro ‘V8_DEPRECATED’
       declarator __attribute__((deprecated(message)))
       ^~~~~~~~~~
    ../src/epoll.cc: In static member function ‘static Nan::NAN_METHOD_RETURN_TYPE Epoll::Modify(Nan::NAN_MET                                 HOD_ARGS_TYPE)’:
    ../src/epoll.cc:230:47: warning: ‘int32_t v8::Value::Int32Value() const’ is deprecated: Use maybe version                                  [-Wdeprecated-declarations]
       int err = epoll->Modify(info[0]->Int32Value(), info[1]->Int32Value());
                                                   ^
    In file included from /root/.node-gyp/10.16.0/include/node/v8.h:26:0,
                     from ../src/epoll.cc:11:
    /root/.node-gyp/10.16.0/include/node/v8.h:2478:46: note: declared here
       V8_DEPRECATED("Use maybe version", int32_t Int32Value() const);
                                                  ^
    /root/.node-gyp/10.16.0/include/node/v8config.h:324:3: note: in definition of macro ‘V8_DEPRECATED’
       declarator __attribute__((deprecated(message)))
       ^~~~~~~~~~
    ../src/epoll.cc:230:70: warning: ‘int32_t v8::Value::Int32Value() const’ is deprecated: Use maybe version                                  [-Wdeprecated-declarations]
       int err = epoll->Modify(info[0]->Int32Value(), info[1]->Int32Value());
                                                                          ^
    In file included from /root/.node-gyp/10.16.0/include/node/v8.h:26:0,
                     from ../src/epoll.cc:11:
    /root/.node-gyp/10.16.0/include/node/v8.h:2478:46: note: declared here
       V8_DEPRECATED("Use maybe version", int32_t Int32Value() const);
                                                  ^
    /root/.node-gyp/10.16.0/include/node/v8config.h:324:3: note: in definition of macro ‘V8_DEPRECATED’
       declarator __attribute__((deprecated(message)))
       ^~~~~~~~~~
    ../src/epoll.cc: In static member function ‘static Nan::NAN_METHOD_RETURN_TYPE Epoll::Remove(Nan::NAN_MET                                 HOD_ARGS_TYPE)’:
    ../src/epoll.cc:247:47: warning: ‘int32_t v8::Value::Int32Value() const’ is deprecated: Use maybe version                                  [-Wdeprecated-declarations]
       int err = epoll->Remove(info[0]->Int32Value());
                                                   ^
    In file included from /root/.node-gyp/10.16.0/include/node/v8.h:26:0,
                     from ../src/epoll.cc:11:
    /root/.node-gyp/10.16.0/include/node/v8.h:2478:46: note: declared here
       V8_DEPRECATED("Use maybe version", int32_t Int32Value() const);
                                                  ^
    /root/.node-gyp/10.16.0/include/node/v8config.h:324:3: note: in definition of macro ‘V8_DEPRECATED’
       declarator __attribute__((deprecated(message)))
       ^~~~~~~~~~
    epoll.target.mk:103: die Regel für Ziel „Release/obj.target/epoll/src/epoll.o“ scheiterte
    make: *** [Release/obj.target/epoll/src/epoll.o] Fehler 1
    make: Verzeichnis „/opt/iobroker/node_modules/rpi-gpio/node_modules/epoll/build“ wird verlassen
    gyp ERR! build error
    gyp ERR! stack Error: `make` failed with exit code: 2
    gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:2                                 62:23)
    gyp ERR! stack     at ChildProcess.emit (events.js:198:13)
    gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)
    gyp ERR! System Linux 4.9.0-9-amd64
    gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebui                                 ld"
    gyp ERR! cwd /opt/iobroker/node_modules/rpi-gpio/node_modules/epoll
    gyp ERR! node -v v10.16.0
    gyp ERR! node-gyp -v v3.8.0
    gyp ERR! not ok
    
    > epoll@2.0.9 install /opt/iobroker/node_modules/epoll
    > node-gyp rebuild
    
    make: Verzeichnis „/opt/iobroker/node_modules/epoll/build“ wird betreten
      CXX(target) Release/obj.target/epoll/src/epoll.o
      SOLINK_MODULE(target) Release/obj.target/epoll.node
      COPY Release/epoll.node
    make: Verzeichnis „/opt/iobroker/node_modules/epoll/build“ wird verlassen
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: epoll@0.1.22 (node_modules/rpi-gpio/node_modules/epoll):
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: epoll@0.1.22 install: `node-gyp rebuild`
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1
    
    + epoll@2.0.9
    updated 1 package and audited 48196 packages in 63.253s
    found 141 vulnerabilities (73 low, 5 moderate, 63 high)
      run `npm audit fix` to fix them, or `npm audit` for details
    root@IoBroker:/opt/iobroker#
    
    

    auch ein
    npm i unix-dgram

    root@IoBroker:/opt/iobroker# npm i unix-dgram
    
    > epoll@0.1.22 install /opt/iobroker/node_modules/rpi-gpio/node_modules/epoll
    > node-gyp rebuild
    
    make: Verzeichnis „/opt/iobroker/node_modules/rpi-gpio/node_modules/epoll/build“ wird betreten
      CXX(target) Release/obj.target/epoll/src/epoll.o
    In file included from ../../nan/nan.h:192:0,
                     from ../src/epoll.cc:15:
    ../../nan/nan_maybe_43_inl.h: In function ‘Nan::Maybe<bool> Nan::ForceSet(v8::Local<v8::Object>, v8::Loca                                 l<v8::Value>, v8::Local<v8::Value>, v8::PropertyAttribute)’:
    ../../nan/nan_maybe_43_inl.h:112:15: error: ‘class v8::Object’ has no member named ‘ForceSet’
       return obj->ForceSet(isolate->GetCurrentContext(), key, value, attribs);
                   ^~~~~~~~
    In file included from ../src/epoll.cc:15:0:
    ../../nan/nan.h: In function ‘v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, v8::Local<v8:                                 :Function>, int, v8::Local<v8::Value>*)’:
    ../../nan/nan.h:835:60: warning: ‘v8::Local<v8::Value> node::MakeCallback(v8::Isolate*, v8::Local<v8::Obj                                 ect>, v8::Local<v8::Function>, int, v8::Local<v8::Value>*)’ is deprecated: Use MakeCallback(..., async_co                                 ntext) [-Wdeprecated-declarations]
             v8::Isolate::GetCurrent(), target, func, argc, argv);
                                                                ^
    In file included from ../src/epoll.cc:12:0:
    /root/.node-gyp/10.16.0/include/node/node.h:177:50: note: declared here
                     NODE_EXTERN v8::Local<v8::Value> MakeCallback(
                                                      ^
    /root/.node-gyp/10.16.0/include/node/node.h:91:42: note: in definition of macro ‘NODE_DEPRECATED’
         __attribute__((deprecated(message))) declarator
                                              ^~~~~~~~~~
    In file included from ../src/epoll.cc:15:0:
    ../../nan/nan.h: In function ‘v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, v8::Local<v8:                                 :String>, int, v8::Local<v8::Value>*)’:
    ../../nan/nan.h:850:62: warning: ‘v8::Local<v8::Value> node::MakeCallback(v8::Isolate*, v8::Local<v8::Obj                                 ect>, v8::Local<v8::String>, int, v8::Local<v8::Value>*)’ is deprecated: Use MakeCallback(..., async_cont                                 ext) [-Wdeprecated-declarations]
             v8::Isolate::GetCurrent(), target, symbol, argc, argv);
                                                                  ^
    In file included from ../src/epoll.cc:12:0:
    /root/.node-gyp/10.16.0/include/node/node.h:170:50: note: declared here
                     NODE_EXTERN v8::Local<v8::Value> MakeCallback(
                                                      ^
    /root/.node-gyp/10.16.0/include/node/node.h:91:42: note: in definition of macro ‘NODE_DEPRECATED’
         __attribute__((deprecated(message))) declarator
                                              ^~~~~~~~~~
    In file included from ../src/epoll.cc:15:0:
    ../../nan/nan.h: In function ‘v8::Local<v8::Value> Nan::MakeCallback(v8::Local<v8::Object>, const char*,                                  int, v8::Local<v8::Value>*)’:
    ../../nan/nan.h:865:62: warning: ‘v8::Local<v8::Value> node::MakeCallback(v8::Isolate*, v8::Local<v8::Obj                                 ect>, const char*, int, v8::Local<v8::Value>*)’ is deprecated: Use MakeCallback(..., async_context) [-Wde                                 precated-declarations]
             v8::Isolate::GetCurrent(), target, method, argc, argv);
                                                                  ^
    In file included from ../src/epoll.cc:12:0:
    /root/.node-gyp/10.16.0/include/node/node.h:163:50: note: declared here
                     NODE_EXTERN v8::Local<v8::Value> MakeCallback(
                                                      ^
    /root/.node-gyp/10.16.0/include/node/node.h:91:42: note: in definition of macro ‘NODE_DEPRECATED’
         __attribute__((deprecated(message))) declarator
                                              ^~~~~~~~~~
    In file included from ../src/epoll.cc:15:0:
    ../../nan/nan.h: In member function ‘v8::Local<v8::Value> Nan::Callback::Call_(v8::Isolate*, v8::Local<v8                                 ::Object>, int, v8::Local<v8::Value>*) const’:
    ../../nan/nan.h:1479:5: warning: ‘v8::Local<v8::Value> node::MakeCallback(v8::Isolate*, v8::Local<v8::Obj                                 ect>, v8::Local<v8::Function>, int, v8::Local<v8::Value>*)’ is deprecated: Use MakeCallback(..., async_co                                 ntext) [-Wdeprecated-declarations]
         ));
         ^
    In file included from ../src/epoll.cc:12:0:
    /root/.node-gyp/10.16.0/include/node/node.h:177:50: note: declared here
                     NODE_EXTERN v8::Local<v8::Value> MakeCallback(
                                                      ^
    /root/.node-gyp/10.16.0/include/node/node.h:91:42: note: in definition of macro ‘NODE_DEPRECATED’
         __attribute__((deprecated(message))) declarator
                                              ^~~~~~~~~~
    ../src/epoll.cc: In static member function ‘static Nan::NAN_METHOD_RETURN_TYPE Epoll::Add(Nan::NAN_METHOD                                 _ARGS_TYPE)’:
    ../src/epoll.cc:210:44: warning: ‘int32_t v8::Value::Int32Value() const’ is deprecated: Use maybe version                                  [-Wdeprecated-declarations]
       int err = epoll->Add(info[0]->Int32Value(), info[1]->Int32Value());
                                                ^
    In file included from /root/.node-gyp/10.16.0/include/node/v8.h:26:0,
                     from ../src/epoll.cc:11:
    /root/.node-gyp/10.16.0/include/node/v8.h:2478:46: note: declared here
       V8_DEPRECATED("Use maybe version", int32_t Int32Value() const);
                                                  ^
    /root/.node-gyp/10.16.0/include/node/v8config.h:324:3: note: in definition of macro ‘V8_DEPRECATED’
       declarator __attribute__((deprecated(message)))
       ^~~~~~~~~~
    ../src/epoll.cc:210:67: warning: ‘int32_t v8::Value::Int32Value() const’ is deprecated: Use maybe version                                  [-Wdeprecated-declarations]
       int err = epoll->Add(info[0]->Int32Value(), info[1]->Int32Value());
                                                                       ^
    In file included from /root/.node-gyp/10.16.0/include/node/v8.h:26:0,
                     from ../src/epoll.cc:11:
    /root/.node-gyp/10.16.0/include/node/v8.h:2478:46: note: declared here
       V8_DEPRECATED("Use maybe version", int32_t Int32Value() const);
                                                  ^
    /root/.node-gyp/10.16.0/include/node/v8config.h:324:3: note: in definition of macro ‘V8_DEPRECATED’
       declarator __attribute__((deprecated(message)))
       ^~~~~~~~~~
    ../src/epoll.cc: In static member function ‘static Nan::NAN_METHOD_RETURN_TYPE Epoll::Modify(Nan::NAN_MET                                 HOD_ARGS_TYPE)’:
    ../src/epoll.cc:230:47: warning: ‘int32_t v8::Value::Int32Value() const’ is deprecated: Use maybe version                                  [-Wdeprecated-declarations]
       int err = epoll->Modify(info[0]->Int32Value(), info[1]->Int32Value());
                                                   ^
    In file included from /root/.node-gyp/10.16.0/include/node/v8.h:26:0,
                     from ../src/epoll.cc:11:
    /root/.node-gyp/10.16.0/include/node/v8.h:2478:46: note: declared here
       V8_DEPRECATED("Use maybe version", int32_t Int32Value() const);
                                                  ^
    /root/.node-gyp/10.16.0/include/node/v8config.h:324:3: note: in definition of macro ‘V8_DEPRECATED’
       declarator __attribute__((deprecated(message)))
       ^~~~~~~~~~
    ../src/epoll.cc:230:70: warning: ‘int32_t v8::Value::Int32Value() const’ is deprecated: Use maybe version                                  [-Wdeprecated-declarations]
       int err = epoll->Modify(info[0]->Int32Value(), info[1]->Int32Value());
                                                                          ^
    In file included from /root/.node-gyp/10.16.0/include/node/v8.h:26:0,
                     from ../src/epoll.cc:11:
    /root/.node-gyp/10.16.0/include/node/v8.h:2478:46: note: declared here
       V8_DEPRECATED("Use maybe version", int32_t Int32Value() const);
                                                  ^
    /root/.node-gyp/10.16.0/include/node/v8config.h:324:3: note: in definition of macro ‘V8_DEPRECATED’
       declarator __attribute__((deprecated(message)))
       ^~~~~~~~~~
    ../src/epoll.cc: In static member function ‘static Nan::NAN_METHOD_RETURN_TYPE Epoll::Remove(Nan::NAN_MET                                 HOD_ARGS_TYPE)’:
    ../src/epoll.cc:247:47: warning: ‘int32_t v8::Value::Int32Value() const’ is deprecated: Use maybe version                                  [-Wdeprecated-declarations]
       int err = epoll->Remove(info[0]->Int32Value());
                                                   ^
    In file included from /root/.node-gyp/10.16.0/include/node/v8.h:26:0,
                     from ../src/epoll.cc:11:
    /root/.node-gyp/10.16.0/include/node/v8.h:2478:46: note: declared here
       V8_DEPRECATED("Use maybe version", int32_t Int32Value() const);
                                                  ^
    /root/.node-gyp/10.16.0/include/node/v8config.h:324:3: note: in definition of macro ‘V8_DEPRECATED’
       declarator __attribute__((deprecated(message)))
       ^~~~~~~~~~
    epoll.target.mk:103: die Regel für Ziel „Release/obj.target/epoll/src/epoll.o“ scheiterte
    make: *** [Release/obj.target/epoll/src/epoll.o] Fehler 1
    make: Verzeichnis „/opt/iobroker/node_modules/rpi-gpio/node_modules/epoll/build“ wird verlassen
    gyp ERR! build error
    gyp ERR! stack Error: `make` failed with exit code: 2
    gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:2                                 62:23)
    gyp ERR! stack     at ChildProcess.emit (events.js:198:13)
    gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)
    gyp ERR! System Linux 4.9.0-9-amd64
    gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebui                                 ld"
    gyp ERR! cwd /opt/iobroker/node_modules/rpi-gpio/node_modules/epoll
    gyp ERR! node -v v10.16.0
    gyp ERR! node-gyp -v v3.8.0
    gyp ERR! not ok
    
    > unix-dgram@2.0.3 install /opt/iobroker/node_modules/unix-dgram
    > node-gyp rebuild
    
    make: Verzeichnis „/opt/iobroker/node_modules/unix-dgram/build“ wird betreten
      CXX(target) Release/obj.target/unix_dgram/src/unix_dgram.o
      SOLINK_MODULE(target) Release/obj.target/unix_dgram.node
      COPY Release/unix_dgram.node
    make: Verzeichnis „/opt/iobroker/node_modules/unix-dgram/build“ wird verlassen
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: epoll@0.1.22 (node_modules/rpi-gpio/node_modules/epoll):
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: epoll@0.1.22 install: `node-gyp rebuild`
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1
    
    + unix-dgram@2.0.3
    updated 1 package and audited 48196 packages in 67.015s
    found 141 vulnerabilities (73 low, 5 moderate, 63 high)
      run `npm audit fix` to fix them, or `npm audit` for details
    
    

  • Forum Testing Most Active

    @Stabilostick habs mal installiert, seh ne Menge Geräte und jede Menge zahlen 😀 jedoch kann ich damit auch nicht viel anfangen, hehe



  • @crunchip dann installier mal bei von GitHub. Du hast bestimmt die alte Alexa2 Version jetzt erwischt.


  • Forum Testing Most Active

    @apollon77 auf was bezogen? Alte Alexa2Version?
    Ichhatte von Git installiert, da ja nach der Neukonfiguration des Rechners, die stable 1.1.3 installiert wird.



  • @crunchip und danach auch Instanz neu gestartet? Am besten im log prüfen das auch die 2.2 gestartet wird.


  • Forum Testing Most Active

    @apollon77 ah, jetzt komm ich mit, das war deine Antwort auf mein post mit den ssml beheben.
    Erkennt man leider nicht, worauf du geantwortet hast und ich zwischenzeitlich noch mehrere Post´s /Fragen hatte.

    Deshalb

    @crunchip sagte in [How-to] Node.js für ioBroker richtig updaten:

    auf was bezogen? Alte Alexa2Version?



Suggested Topics

  • 6
  • 2
  • 9
  • 3
  • 18
  • 10
  • 316
  • 5

846
Online

32.3k
Users

38.9k
Topics

527.5k
Posts