NEWS

js-controller 3.2 jetzt im Latest!


  • @techmo Wir nutzen die aktuellste und hat in den Latest tests auch geklappt. Die Frage ist warum deine iobroker instanz nicht den DNS MX check machen kann für die Domain ... hatte bisher noch keiner. Irgendwie Firewall? Welchen DNS nimmst du? Standard ? Docker? (ich rate gerade ins blaue)


  • @apollon77 habe heute den js controller upgedatet jetzt kommt eine warnmeldung.

    web.0 2021-02-19 17:26:31.471 warn (14345) State "nothing_selected" has no existing object, this might lead to an error in future versions

    Host:
    Typ: js-controller
    Titel: JS controller
    OS: linux
    Verfügbar: 3.2.16
    Installiert: 3.2.16
    Ereignisse: ⇥17 / ↦13

    Was kann ich dagegen tun? Danke


  • @babl Wurde schon gemeldet. Kommt scheinbar aus vis (oder einem Widget?) ... muss dort gefixt werden. Bitte ggf Issue prüfen.

    Das passiert in einigen Widgets wenn man keine objectsID gewählt hat in feldern ... dann kann da nothing_selected stehen... wenn das un was geändert wird passiert das ... interessant ... Formal: prüft eure Vis Visus 🙂


  • @apollon77 puuuh, danke


  • @babl Man kann die meldung in web unterdrücken ... ist ok ... aber naja irgendein Widget scheint ja falsch konfiguriert zu sein 🙂


  • @apollon77 jepp, da hast du leider recht irgendwo wird wohl ein hund begraben liegen, grrrrrr wenn man nur wüßte wo?

    Es läuft ja alles.

    in materialdesign top app bar hier finde ich zumindestens ein objekt id nothing selected" mal testen ob es das ist.


  • @babl bin gespannt


  • Habe heute auch das update gewagt, leider.

    auf den beiden Slaves Raspi hat es funktioniert.

    Beim Master im docker auf Syno NAS nicht bzw. bekomme ich dort den iobroker nicht zu stoppen.

    root@iobroker:/opt/iobroker# iobroker stop
    iobroker controller daemon is not running
    root@iobroker:/opt/iobroker# iobroker update
    Used repository: Stable (default)
    hash unchanged, use cached sources
    update done
    Adapter    "admin"         : 4.2.1    , installed 4.2.1
    Adapter    "alarm"         : 1.9.0    
    Adapter    "alexa2"        : 3.7.1    , installed 3.7.1
    Adapter    "alpha2"        : 1.0.0    
    Adapter    "amazon-dash"   : 1.1.0    
    Adapter    "artnet"        : 1.2.2    
    Adapter    "asterisk"      : 1.0.6    
    Adapter    "asuswrt"       : 1.0.1    
    Adapter    "b-control-em"  : 0.2.1    
    Adapter    "backitup"      : 1.7.0    , installed 1.7.0
    Adapter    "beckhoff"      : 1.4.0    
    Adapter    "benq"          : 0.2.0    
    Adapter    "binance"       : 1.1.3    
    Adapter    "ble"           : 0.12.0   
    Adapter    "bmw"           : 1.3.3    
    Adapter    "bosesoundtouch": 0.9.3    
    Adapter    "botvac"        : 1.0.0    
    Adapter    "bring"         : 1.7.7    
    Adapter    "broadlink2"    : 2.0.3    
    Adapter    "bsblan"        : 0.2.0    
    Adapter    "bshb"          : 0.1.13   
    Adapter    "chromecast"    : 2.3.1    
    Adapter    "cloud"         : 4.0.4    
    Adapter    "comfoair"      : 1.1.3    
    Adapter    "contactid"     : 1.0.1    
    Adapter    "coronavirus-statistics": 0.6.3   , installed 0.6.3
    Adapter    "countdown"     : 1.1.0    
    Adapter    "cul"           : 1.3.4    
    Adapter    "daikin"        : 1.3.0    
    Adapter    "daswetter"     : 3.0.4    , installed 3.0.4
    Adapter    "deconz"        : 1.3.11   
    Adapter    "denon"         : 1.10.3   
    Adapter    "device-reminder": 1.0.6   
    Adapter    "devices"       : 0.3.15   , installed 0.3.15
    Adapter    "digitalstrom"  : 2.0.5    
    Adapter    "discovergy"    : 0.5.0    
    Adapter    "discovery"     : 2.5.0    , installed 2.5.0
    Adapter    "doorio"        : 1.1.2    
    Adapter    "ds18b20"       : 1.2.1    , installed 1.2.1
    Adapter    "dwd"           : 2.5.2    , installed 2.5.2
    Adapter    "ebus"          : 2.2.3    
    Adapter    "echarts"       : 0.4.9    
    Adapter    "ecovacs-deebot": 1.1.0    , installed 1.1.0
    Adapter    "egigeozone"    : 0.1.2    
    Adapter    "ekey"          : 1.1.0    
    Adapter    "email"         : 1.0.7    
    Adapter    "emby"          : 1.0.2    
    Adapter    "energymanager" : 1.2.3    
    Adapter    "enet"          : 1.0.1    
    Adapter    "epson_stylus_px830": 0.2.1   
    Adapter    "exchangerates" : 0.0.13   
    Adapter    "fahrplan"      : 1.0.2    
    Adapter    "fakeroku"      : 0.2.1    
    Adapter    "fb-checkpresence": 1.1.0   
    Adapter    "feiertage"     : 1.0.17   
    Adapter    "fhem"          : 1.5.3    
    Adapter    "find-my-iphone": 0.2.15   
    Adapter    "firetv"        : 1.0.0    
    Adapter    "flot"          : 1.10.6   , installed 1.10.6
    Adapter    "followthesun"  : 0.2.6    
    Adapter    "foobar2000"    : 2.0.3    
    Adapter    "fritzbox"      : 0.2.1    
    Adapter    "fritzdect"     : 0.2.4    
    Adapter    "fronius"       : 1.0.5    
    Adapter    "frontier_silicon": 0.0.10  
    Adapter    "fullcalendar"  : 1.1.0    
    Adapter    "fullybrowser"  : 2.0.1    , installed 2.0.1
    Adapter    "g-homa"        : 0.5.3    
    Adapter    "geofency"      : 0.3.2    
    Adapter    "go-e"          : 1.0.0    
    Adapter    "growatt"       : 0.0.15   
    Adapter    "gruenbeck"     : 0.0.28   
    Adapter    "habpanel"      : 0.4.3    
    Adapter    "haier"         : 1.0.2    
    Adapter    "ham"           : 3.0.2    
    Adapter    "ham-wemo"      : 1.1.0    
    Adapter    "harmony"       : 1.2.2    
    Adapter    "heatingcontrol": 1.1.2    
    Adapter    "heos"          : 1.7.5    
    Adapter    "heytech"       : 1.0.0    
    Adapter    "hid"           : 0.1.17   
    Adapter    "history"       : 1.9.12   , installed 1.9.12
    Adapter    "hm-rega"       : 3.0.16   
    Adapter    "hm-rpc"        : 1.14.35  
    Adapter    "hmip"          : 1.6.0    , installed 1.6.0
    Adapter    "homeconnect"   : 0.0.32   
    Adapter    "homee"         : 1.1.0    
    Adapter    "homepilot"     : 1.0.3    
    Adapter    "hp-ilo"        : 1.0.6    
    Adapter    "hs100"         : 2.0.1    
    Adapter    "hue"           : 3.4.0    
    Adapter    "hue-extended"  : 2.0.0    
    Adapter    "i2c"           : 1.1.1    
    Adapter    "ical"          : 1.7.4    , installed 1.7.4
    Adapter    "icons-addictive-flavour-png": 0.1.0   
    Adapter    "icons-fatcow-hosting": 0.1.0   
    Adapter    "icons-icons8"  : 0.0.1    
    Adapter    "icons-material-png": 0.1.0   
    Adapter    "icons-material-svg": 0.1.0   
    Adapter    "icons-mfd-png" : 1.0.2    
    Adapter    "icons-mfd-svg" : 1.0.2    , installed 1.0.2
    Adapter    "icons-open-icon-library-png": 0.1.2   
    Adapter    "icons-ultimate-png": 1.0.1   
    Adapter    "influxdb"      : 1.9.4    
    Adapter    "info"          : 1.7.14   , installed 1.7.14
    Adapter    "innogy-smarthome": 0.3.6   
    Adapter    "iogo"          : 0.6.5    
    Adapter    "iot"           : 1.8.9    , installed 1.8.9
    Adapter    "iqontrol"      : 1.5.0    
    Adapter    "jarvis"        : 2.0.0    
    Adapter    "javascript"    : 4.8.4    , installed 4.8.4
    Adapter    "jeelink"       : 0.1.0    
    Controller "js-controller" : 3.2.16   , installed 3.1.6 [Updateable]
    Adapter    "kecontact"     : 1.0.1    
    Adapter    "klf200"        : 1.0.1    
    Adapter    "km200"         : 1.1.6    
    Adapter    "knmi-weather"  : 1.0.0    
    Adapter    "knx"           : 1.0.39   
    Adapter    "kodi"          : 2.0.4    
    Adapter    "kostal-piko-ba": 1.1.5    
    Adapter    "kress"         : 2.5.5    
    Adapter    "lametric"      : 1.2.0    
    Adapter    "landroid"      : 1.0.3    
    Adapter    "lcn"           : 1.0.2    
    Adapter    "legrand-ecocompteur": 1.0.0   
    Adapter    "letrika_comgw" : 0.0.5    
    Adapter    "lgtv"          : 1.1.10   
    Adapter    "lgtv-rs"       : 0.1.0    
    Adapter    "lgtv11"        : 1.0.5    
    Adapter    "lifx"          : 0.1.0    
    Adapter    "lightify"      : 0.2.16   
    Adapter    "link"          : 0.5.10   
    Adapter    "linkeddevices" : 1.4.2    
    Adapter    "linktap"       : 0.1.7    
    Adapter    "linux-control" : 1.1.2    
    Adapter    "logparser"     : 1.1.0    
    Adapter    "lovelace"      : 1.0.16   
    Adapter    "loxone"        : 2.1.0    
    Adapter    "luftdaten"     : 1.0.2    
    Adapter    "lupusec"       : 1.3.2    
    Adapter    "luxtronik1"    : 0.3.0    
    Adapter    "material"      : 0.13.9   
    Adapter    "maxcube"       : 1.0.2    
    Adapter    "maxcul"        : 1.3.1    
    Adapter    "mbus"          : 2.3.1    
    Adapter    "mclighting"    : 0.1.1    
    Adapter    "megad"         : 1.2.1    
    Adapter    "megadd"        : 0.2.0    
    Adapter    "megaesp"       : 0.1.0    
    Adapter    "melcloud"      : 1.0.6    
    Adapter    "mercedesme"    : 0.0.45   
    Adapter    "mercury"       : 0.1.1    
    Adapter    "meross"        : 1.5.1    
    Adapter    "meteoalarm"    : 1.0.9    
    Adapter    "midea"         : 0.0.6    
    Adapter    "miele"         : 0.1.5    
    Adapter    "mielecloudservice": 2.0.3   
    Adapter    "mihome"        : 1.3.7    
    Adapter    "mihome-lamp"   : 1.1.0    
    Adapter    "mihome-plug"   : 0.2.1    
    Adapter    "mihome-vacuum" : 2.1.1    
    Adapter    "mikrotik"      : 1.0.11   
    Adapter    "milight"       : 0.3.6    
    Adapter    "milight-smart-light": 1.2.0   
    Adapter    "minuvis"       : 1.0.0    
    Adapter    "mobile"        : 1.0.1    
    Adapter    "modbus"        : 3.2.4    , installed 3.1.10 [Updateable]
    Adapter    "moma"          : 1.2.7    
    Adapter    "mpd"           : 1.0.5    
    Adapter    "mqtt"          : 2.3.4    , installed 2.1.14 [Updateable]
    Adapter    "mqtt-client"   : 1.3.1    
    Adapter    "musiccast"     : 0.1.5    
    Adapter    "mydlink"       : 1.1.7    
    Adapter    "mysensors"     : 2.0.1    
    Adapter    "nanoleaf-lightpanels": 1.0.6   
    Adapter    "net-tools"     : 0.1.2    
    Adapter    "netatmo"       : 1.3.3    
    Adapter    "netatmo-crawler": 0.3.9   
    Adapter    "nibeuplink"    : 0.4.0    
    Adapter    "nina"          : 0.0.24   
    Adapter    "node-red"      : 2.0.3    
    Adapter    "nuki"          : 1.4.3    
    Adapter    "nuki-extended" : 2.3.0    
    Adapter    "nut"           : 1.4.3    
    Adapter    "octoprint"     : 1.0.8    
    Adapter    "odl"           : 1.1.4    
    Adapter    "oilfox"        : 0.0.5    
    Adapter    "onkyo"         : 2.0.3    
    Adapter    "onvif"         : 0.4.4    
    Adapter    "openhab"       : 1.1.0    
    Adapter    "openligadb"    : 1.1.0    
    Adapter    "openweathermap": 0.1.0    
    Adapter    "opi"           : 0.1.1    
    Adapter    "oppoplayer"    : 0.2.1    
    Adapter    "owfs"          : 0.6.4    , installed 0.6.4
    Adapter    "owntracks"     : 1.0.0    
    Adapter    "panasonic-viera": 1.0.2   
    Adapter    "parser"        : 1.0.7    
    Adapter    "paw"           : 0.0.7    
    Adapter    "phantomjs"     : 1.1.2    
    Adapter    "pi-hole"       : 1.3.1    
    Adapter    "piface"        : 1.0.0    
    Adapter    "pimatic"       : 0.3.0    
    Adapter    "ping"          : 1.4.12   
    Adapter    "places"        : 1.0.0    
    Adapter    "plenticore"    : 2.1.6    
    Adapter    "plex"          : 0.8.11   
    Adapter    "plexconnect"   : 0.0.7    
    Adapter    "pollenflug"    : 1.0.6    
    Adapter    "proxmox"       : 1.2.0    
    Adapter    "proxy"         : 1.2.1    
    Adapter    "pushbullet"    : 0.0.11   
    Adapter    "pushover"      : 2.0.3    
    Adapter    "pushsafer"     : 1.0.3    
    Adapter    "radar2"        : 1.0.9    
    Adapter    "radiohead"     : 1.1.1    
    Adapter    "rflink"        : 2.1.6    
    Adapter    "rickshaw"      : 1.0.0    
    Adapter    "ring"          : 1.1.3    
    Adapter    "robonect"      : 0.1.3    
    Adapter    "roomba"        : 1.1.1    
    Adapter    "rpi2"          : 1.2.0    , installed 1.2.0
    Adapter    "s7"            : 1.2.2    
    Adapter    "samsung"       : 0.2.9    
    Adapter    "sayit"         : 1.12.2   
    Adapter    "sbfspot"       : 4.0.2    
    Adapter    "scenes"        : 2.3.6    
    Adapter    "schoolfree"    : 0.7.0    
    Adapter    "schwoerer-ventcube": 1.3.0   
    Adapter    "seq"           : 0.2.9    
    Adapter    "shelly"        : 4.0.6    
    Adapter    "shuttercontrol": 1.0.4    
    Adapter    "sia"           : 1.0.4    
    Adapter    "siegenia"      : 1.0.1    
    Adapter    "simple-api"    : 2.5.3    , installed 2.5.3
    Adapter    "smappee"       : 0.2.3    
    Adapter    "smartcontrol"  : 1.2.1    
    Adapter    "smartgarden"   : 1.0.3    
    Adapter    "smartmeter"    : 3.2.0    , installed 3.2.0
    Adapter    "snips"         : 1.5.1    
    Adapter    "snmp"          : 0.5.0    , installed 0.5.0
    Adapter    "socketio"      : 3.1.4    , installed 3.1.4
    Adapter    "solarlog"      : 2.0.1    
    Adapter    "solarviewdatareader": 0.2.1   
    Adapter    "solarwetter"   : 1.0.0    
    Adapter    "sonnen"        : 1.7.0    
    Adapter    "sonoff"        : 2.3.3    
    Adapter    "sonos"         : 2.1.1    
    Adapter    "sony-bravia"   : 1.0.1    
    Adapter    "spotify-premium": 1.0.0   
    Adapter    "sql"           : 1.15.5   
    Adapter    "squeezebox"    : 1.0.0    
    Adapter    "squeezeboxrpc" : 1.0.0    
    Adapter    "starline"      : 1.0.0    
    Adapter    "statistics"    : 1.0.2    
    Adapter    "stiebel-isg"   : 1.6.0    
    Adapter    "sunnyportal"   : 0.1.5    
    Adapter    "swiss-weather-api": 0.3.2   
    Adapter    "synology"      : 0.1.18   , installed 0.1.18
    Adapter    "systeminfo"    : 0.3.1    , installed 0.3.1
    Adapter    "tahoma"        : 0.3.2    
    Adapter    "tankerkoenig"  : 2.0.5    
    Adapter    "telegram"      : 1.7.0    
    Adapter    "terminal"      : 0.1.2    
    Adapter    "tesla-motors"  : 0.3.2    
    Adapter    "text2command"  : 2.0.7    , installed 2.0.7
    Adapter    "tinker"        : 1.1.0    
    Adapter    "tr-064"        : 4.2.4    , installed 4.2.2 [Updateable]
    Adapter    "tradfri"       : 2.6.5    
    Adapter    "trashschedule" : 1.1.1    , installed 1.0.3 [Updateable]
    Adapter    "tunnelbroker-endpoint-updater": 0.0.1   
    Adapter    "tuya"          : 3.5.2    
    Adapter    "tvspielfilm"   : 1.0.4    
    Adapter    "unifi"         : 0.5.8    
    Adapter    "upnp"          : 1.0.16   , installed 1.0.16
    Adapter    "vaillant"      : 0.0.11   
    Adapter    "valloxmv"      : 1.1.2    
    Adapter    "vcard"         : 0.0.9    
    Adapter    "velux"         : 0.0.7    
    Adapter    "viessmann"     : 1.3.3    , installed 1.3.3
    Adapter    "virtualpowermeter": 1.4.1   
    Adapter    "vis"           : 1.3.4    , installed 1.3.6
    Adapter    "vis-bars"      : 0.1.4    
    Adapter    "vis-canvas-gauges": 0.1.5   , installed 0.1.5
    Adapter    "vis-colorpicker": 1.2.0   , installed 1.2.0
    Adapter    "vis-fancyswitch": 1.1.0   
    Adapter    "vis-google-fonts": 0.1.0   , installed 0.1.0
    Adapter    "vis-history"   : 1.0.0    , installed 1.0.0
    Adapter    "vis-hqwidgets" : 1.1.7    , installed 1.1.7
    Adapter    "vis-icontwo"   : 0.42.0   , installed 0.42.0
    Adapter    "vis-inventwo"  : 2.7.4    
    Adapter    "vis-jqui-mfd"  : 1.0.12   , installed 1.0.12
    Adapter    "vis-justgage"  : 1.0.2    , installed 1.0.2
    Adapter    "vis-keyboard"  : 0.0.2    
    Adapter    "vis-lcars"     : 1.0.4    
    Adapter    "vis-map"       : 1.0.4    
    Adapter    "vis-material-advanced": 1.3.0   , installed 1.3.0
    Adapter    "vis-metro"     : 1.1.2    , installed 1.1.2
    Adapter    "vis-players"   : 0.1.6    
    Adapter    "vis-plumb"     : 1.0.2    , installed 1.0.2
    Adapter    "vis-rgraph"    : 0.0.2    , installed 0.0.2
    Adapter    "vis-timeandweather": 1.1.7   , installed 1.1.7
    Adapter    "vis-weather"   : 2.5.2    
    Adapter    "volvo"         : 0.0.3    
    Adapter    "vr200"         : 1.0.0    
    Adapter    "vw-connect"    : 0.0.29   
    Adapter    "weatherunderground": 3.3.0   , installed 3.2.1 [Updateable]
    Adapter    "web"           : 3.2.3    , installed 3.2.3
    Adapter    "weishaupt-wem" : 0.0.9    
    Adapter    "whatsapp-cmb"  : 0.1.6    
    Adapter    "wiffi-wz"      : 2.2.0    
    Adapter    "wifilight"     : 1.1.0    , installed 1.1.0
    Adapter    "windows-control": 0.1.5   
    Adapter    "wled"          : 0.5.6    
    Adapter    "wm-bus"        : 0.1.12   
    Adapter    "wolf"          : 1.2.1    
    Adapter    "worx"          : 1.2.3    
    Adapter    "xbox"          : 0.7.3    
    Adapter    "xs1"           : 1.0.2    
    Adapter    "yahka"         : 0.12.0   
    Adapter    "yamaha"        : 0.4.0    
    Adapter    "yeelight-2"    : 1.0.3    
    Adapter    "youtube"       : 1.0.3    
    Adapter    "yr"            : 2.0.3    
    Adapter    "zigbee"        : 1.4.4    
    Adapter    "zont"          : 0.5.3    
    Adapter    "zwave"         : 2.0.1    
    Adapter    "zwave2"        : 1.8.5    
    root@iobroker:/opt/iobroker# iobroker upgrade self
    Controller is running. Please stop ioBroker first.
    

    mit "pkill io" schließt sich die Konsole und das spiel beginnt von vorne.

    Bekomme natürlich aktuell eine Menge warnungen von den Slaves, die ja schon mit 3.2.16 laufen.

    2021-02-19 20:13:15.284  - warn: host.iobroker Objects 192.168.1.22:44616 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:15.632  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:15.632  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:15.633  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:15.633  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:15.634  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:15.635  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:16.535  - warn: host.iobroker Objects 192.168.1.22:44616 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:16.654  - warn: host.iobroker Objects 192.168.1.22:44616 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:17.809  - warn: host.iobroker Objects 192.168.1.22:44616 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:17.966  - warn: host.iobroker Objects 192.168.1.22:44616 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:19.101  - warn: host.iobroker Objects 192.168.1.22:44616 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:19.201  - warn: host.iobroker Objects 192.168.1.22:44616 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:19.460  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:19.479  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:19.479  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:19.481  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:19.494  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:19.497  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:20.419  - warn: host.iobroker Objects 192.168.1.22:44616 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:20.503  - warn: host.iobroker Objects 192.168.1.22:44616 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:21.002  - warn: host.iobroker Objects 192.168.1.22:44652 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:21.017  - warn: host.iobroker Objects 192.168.1.22:44652 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:21.713  - warn: host.iobroker Objects 192.168.1.22:44616 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:21.830  - warn: host.iobroker Objects 192.168.1.22:44616 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:23.112  - warn: host.iobroker Objects 192.168.1.22:44616 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:23.130  - warn: host.iobroker Objects 192.168.1.22:44616 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:23.318  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:23.318  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:23.318  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:23.319  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:23.319  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:23.319  - warn: host.iobroker Objects 192.168.1.12:41426 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:24.315  - warn: host.iobroker Objects 192.168.1.22:44616 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:24.419  - warn: host.iobroker Objects 192.168.1.22:44616 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:25.620  - warn: host.iobroker Objects 192.168.1.22:44616 Error from InMemDB: Error: exists NOT SUPPORTED
    2021-02-19 20:13:25.721  - warn: host.iobroker Objects 192.168.1.22:44616 Error from InMemDB: Error: exists NOT SUPPORTED
    

    Kann mir jemand helfen den Iobroker zu stoppen?

    Gruß
    Happyuser20


  • @happyuser20 sagte in js-controller 3.2 jetzt im Latest!:

    Kann mir jemand helfen den Iobroker zu stoppen?

    iobroker im Container stoppen mit pkill -u iobroker


  • @fastfoot
    Danke


  • Hallo,
    gestern habe ich den js-controller aktualisiert (v3.2.16). Seitdem spuckt der shelly-Adapter alle paar Sekunden diese Meldung aus:

    shelly.0	2021-02-24 13:15:24.759	error	(12536) Cannot find search "folder" in "system"
    

    Sonst läuft das System unauffällig.

    Hat jemand eine Idee, was da los ist?


  • @w00dy Ja, da ist der Master nicht auf controller 3.2.16 aber ein Client oder Adapter mit 3.2er code greift darauf zu. Ggf nochmal alles restarten.


  • @apollon77
    ...ich dachte ich mache dazu gleich einen Reboot und nun ist er ganz tot, anpingen lässt er sich auch nicht mehr. Da war wohl mehr defekt - OK dann eben alles neu.

  • Most Active

    @paul53 sagte in js-controller 3.2 jetzt im Latest!:

    Habe "writeFileInterval" in der iobroker.json ergänzt: So funktioniert es.

    Wenn ich fragen darf: Was genau eintragen? An eine bestimmte Stelle?

    Bin jetzt auch auf JS-Controller 3.2.16 und hatte im 3.1 dieses dort verwendet.

  • Forum Testing Most Active

    @klassisch in der Datei /opt/iobroker/iobroker-data/iobroker.json
    https://forum.iobroker.net/post/564759 bzw https://forum.iobroker.net/post/565703

  • Most Active

    @crunchip perfekt, vielen Dank!


  • Hallo,

    bei mir mag er die Updates nicht ausführen. Auch die Holzhammer-Methode bringt kein Erfolg:

    peter@proxbroker:/opt/iobroker$ iobroker upgrade self
    Update js-controller from @3.1.6 to @3.2.16
    NPM version: 6.14.11
    npm install iobroker.js-controller@3.2.16 --loglevel error --unsafe-perm --prefix "/opt/iobroker" (System call)
    npm ERR! code EBADPLATFORM
    npm ERR! notsup Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    npm ERR! notsup Valid OS:    darwin
    npm ERR! notsup Valid Arch:  any
    npm ERR! notsup Actual OS:   linux
    npm ERR! notsup Actual Arch: x64
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/iobroker/.npm/_logs/2021-02-28T06_48_31_302Z-debug.log
    Starting node restart.js
    peter@proxbroker:/opt/iobroker$ sudo -H -u iobroker npm install ioBroker/ioBroker.js-controller
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@~2.3.1 (node_modules/chokidar/node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    
    npm ERR! code EBADPLATFORM
    npm ERR! notsup Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    npm ERR! notsup Valid OS:    darwin
    npm ERR! notsup Valid Arch:  any
    npm ERR! notsup Actual OS:   linux
    npm ERR! notsup Actual Arch: x64
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/iobroker/.npm/_logs/2021-02-28T06_49_12_710Z-debug.log
    peter@proxbroker:/opt/iobroker$
    
    

  • @peterfido und du bist sicher das es nicht tat? An sich ist fsevents eine optionale dep.


  • @apollon77
    Die Meldung, dass mein JS-Controller veraltet ist, kommt weiterhin. iobroker upgrade self will immer wieder den JS-Controller aktualisieren. Von daher ja.

    iobroker update gibt folgende Zeile aus:

    Controller "js-controller" : 3.2.16   , installed 3.1.6 [Updateable]
    

    Nach einem Neustart keine Besserung:

    peter@proxbroker:/opt/iobroker$ iobroker upgrade self
    Update js-controller from @3.1.6 to @3.2.16
    NPM version: 6.14.11
    npm install iobroker.js-controller@3.2.16 --loglevel error --unsafe-perm --prefix "/opt/iobroker" (System call)
    npm ERR! code EBADPLATFORM
    npm ERR! notsup Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    npm ERR! notsup Valid OS:    darwin
    npm ERR! notsup Valid Arch:  any
    npm ERR! notsup Actual OS:   linux
    npm ERR! notsup Actual Arch: x64
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/iobroker/.npm/_logs/2021-02-28T07_52_57_477Z-debug.log
    Starting node restart.js
    peter@proxbroker:/opt/iobroker$
    
    ```[2021-02-28T07_38_18_850Z-debug.log](/assets/uploads/files/1614499780577-2021-02-28t07_38_18_850z-debug.log)
  • Forum Testing Most Active

    @peterfido sagte in js-controller 3.2 jetzt im Latest!:

    Nach einem Neustart keine Besserung:

    Du stoppst aber den iobroker bevor du ein update und upgrade self ausführst, liest sich eher so, als wenn du versuchst im laufenden Betrieb dies zu versuchen.

Suggested Topics

1.2k
Online

36.9k
Users

42.6k
Topics

591.1k
Posts