NEWS

Kein Update von Adapter möglich


  • Starter

    Hallo in die Runde!

    Ich kann bei meinem relativ neuen System keine Updates der Adapter mehr durchführen.
    Dies scheint aber nur den Adapter Admin, Discovery devices, socket.io und Web Server zu betreffen.

    Es wird eine neue Version angezeigt und auf den ersten Blick läuft das Update erfolgreich durch.
    Am Ende steht aber wieder die alte Version als aktiv.

    • Reboot vom System wurde diverse Male durchgeführt.
    • Die Node.js habe ich auf V12.16.3 hochgezogen.
    • Ein manuelles Update des Controllers (update und update self) wurde durchgeführt.

    Ich bekomme eine merkwürdige "istanbul" Fehlermeldung wenn ich in die LOGs schaue:

    $ ./iobroker upgrade discovery
    Update discovery from @2.2.2 to @2.3.5
    NPM version: 6.14.4
    npm install iobroker.discovery@2.3.5 --loglevel error --prefix "/opt/iobroker" (System call)
    npm ERR!
     Unexpected end of JSON input while parsing near '..."^3.12.1","istanbul":'
    
    npm
     
    ERR! A complete log of this run can be found in:npm ERR!     /opt/iobroker/.npm/_logs/2020-05-26T14_45_40_011Z-debug.log
    upload [6] discovery.admin /opt/iobroker/node_modules/iobroker.discovery/admin/words.js words.js application/javascript
    upload [5] discovery.admin /opt/iobroker/node_modules/iobroker.discovery/admin/translateTools.js translateTools.js application/javascript
    upload [4] discovery.admin /opt/iobroker/node_modules/iobroker.discovery/admin/settings_m.html settings_m.html text/html
    upload [3] discovery.admin /opt/iobroker/node_modules/iobroker.discovery/admin/settings.html settings.html text/html
    upload [2] discovery.admin /opt/iobroker/node_modules/iobroker.discovery/admin/index_m.html index_m.html text/html
    upload [1] discovery.admin /opt/iobroker/node_modules/iobroker.discovery/admin/index.html index.html text/html
    upload [0] discovery.admin /opt/iobroker/node_modules/iobroker.discovery/admin/discovery.png discovery.png image/png
    Adapter "discovery" updated
    process exited with code 0
    

    Mein System:

    buanet-iobroker1 (auf Synology DS218+)
    Betriebssystem linux
    Architektur x64
    CPUs 2
    Geschwindigkeit 2001 MHz
    Modell Intel(R) Celeron(R) CPU J3355 @ 2.00GHz
    RAM 9.58 GB
    Node.js v12.16.3
    NPM 6.14.4
    js-Controller: 2.2.9
    Festplatte Größe 5.24 TB
    Festplatte frei 1.38 TB
    Anzahl der Adapter 291


    Mod-Edit: Code/Log in Code Tags gepackt. Bitte benutzt die Code Tags Funktion -> </>
    Hier gehts zur Hilfe.


  • Starter

    @igloh

    wie ich sehe benutzt du noch einen alten Controller 2.2.9 es gibt schon die 3.1.4.

    mehr Infos gibt es dazu hier:

    Controller 3.1

    was passiert den wenn du im Verzeichnis /opt/iobroker folgendes machst?

    cd /opt/iobroker
    
    iobroker stop
    iobroker update
    iobroker upgrade self
    iobroker start
    

    Alternative kannst du auch mal nach schauen welche Adapter bei dir Laufen.

    cd /opt/iobroker
    iobroker list instances
    

    node & nodejs sollten gleich sein.

    node -v
    nodejs -v
    

    lg


  • Starter

    Das Update hatte ich je bereits durchgeführt.
    Hier nochmal, alles ohne Fehler:

     Adapter    "yr"            : 2.0.3                                                                                             
    Adapter    "zigbee"        : 1.0.4                                                                                             
    Adapter    "zont"          : 0.5.3                                                                                             
    Adapter    "zwave"         : 2.0.1      
    
                                                                                           
    root@buanet-iobroker1:/opt/iobroker# iobroker update self                                                                      
    Used repository: self                                                                                                          
    update done  
    

    Hier die Instanzen:

    root@buanet-iobroker1:/opt/iobroker# iobroker list instances                                                                   
    + system.adapter.admin.0                 : admin                 -  enabled, port: 8081, bind: 0.0.0.0, run as: admin          
    + system.adapter.alexa2.0                : alexa2                -  enabled                                                    
      system.adapter.daswetter.0             : daswetter             -  enabled                                                    
    + system.adapter.discovery.0             : discovery             -  enabled                                                    
      system.adapter.firetv.0                : firetv                - disabled                                                    
    + system.adapter.fritzbox.0              : fritzbox              -  enabled                                                    
    + system.adapter.fritzdect.0             : fritzdect             -  enabled                                                    
    + system.adapter.hm-rega.0               : hm-rega               -  enabled                                                    
    + system.adapter.hm-rpc.0                : hm-rpc                -  enabled, port: 0                                           
    + system.adapter.hm-rpc.1                : hm-rpc                -  enabled, port: 0                                           
    + system.adapter.hm-rpc.2                : hm-rpc                -  enabled, port: 0                                           
    + system.adapter.hue.0                   : hue                   -  enabled, port: 80                                          
      system.adapter.ical.0                  : ical                  -  enabled                                                    
      system.adapter.icons-addictive-flavour-png.0: icons-addictive-flavour-png -  enabled                                         
      system.adapter.icons-icons8.0          : icons-icons8          -  enabled                                                    
      system.adapter.icons-material-png.0    : icons-material-png    -  enabled                                                    
      system.adapter.icons-ultimate-png.0    : icons-ultimate-png    -  enabled                                                    
    + system.adapter.info.0                  : info                  -  enabled                                                    
    + system.adapter.javascript.0            : javascript            -  enabled                                                    
    + system.adapter.synology.0              : synology              -  enabled, port: 5000                                        
    + system.adapter.systeminfo.0            : systeminfo            -  enabled                                                    
    + system.adapter.terminal.0              : terminal              -  enabled, port: 8088, bind: 0.0.0.0, run as: admin          
    + system.adapter.tr-064.0                : tr-064                -  enabled                                                    
      system.adapter.vis-justgage.0          : vis-justgage          -  enabled                                                    
      system.adapter.vis-timeandweather.0    : vis-timeandweather    -  enabled                                                    
      system.adapter.vis.0                   : vis                   -  enabled                                                    
    + system.adapter.web.0                   : web                   -  enabled, port: 8082, bind: 0.0.0.0, run as: admin          
                                                                                                                                   
    + instance is alive   
    

    Bei den Versionen ist es merkwürdig das er hier bei Node.js noch die 10er Version anzeigt.
    Die Version 12. ist installiert und wird auch in der GUI angezeigt:

    root@buanet-iobroker1:/opt/iobroker# node -v                                                                                   
    v12.16.3        
    
                                                                                                                   
    root@buanet-iobroker1:/opt/iobroker# nodejs -v                                                                                 
    v10.20.1                                  
    

    Ich habe mal das "Fix" probiert. Hier meckert er aber das noch einige Module aktiv sind obwohl iobrocker gestoppt ist. Gibt es hier weitere Befehle (kill?) womit ich diese stoppen kann?

    root@buanet-iobroker1:/opt/iobroker# iobroker stop                                                                             
    Stopping iobroker controller daemon...                                                                                         
    iobroker controller daemon stopped.                                                                                            
    No "killall.sh" script found. Just stop.      
                                                                                     
    root@buanet-iobroker1:/opt/iobroker# iobroker fix                                                                              
    library: loaded                                                                                                                
    Library version=2020-04-12                                                                                                     
    ioBroker or some processes are still running:                                                                                  
     io.discovery.0                                                                                                                
     io.info.0                                                                                                                     
     io.hue.0                                                                                                                      
     io.terminal.0                                                                                                                 
     io.fritzbox.0                                                                                                                 
     io.alexa2.0                                                                                                                   
     io.javascript.0                                                                                                               
     io.fritzdect.0                                                                                                                
     io.synology.0                                                                                                                 
     io.systeminfo.0                                                                                                               
     io.admin.0                                                                                                                    
     io.web.0                                                                                                                      
    Please stop them first and try again!       
                                                                                       
    root@buanet-iobroker1:/opt/iobroker# iobroker stop                                                                             
    iobroker controller daemon is not running         
    
    

    Ich habe dann die Module alle einzeln gestoppt. Irgendwas scheint aber immer noch aktiv zu sein das er nicht fixen kann:

    root@buanet-iobroker1:/opt/iobroker# iobroker stop fritzdect.0                                                                 
    The adapter "fritzdect.0" was stopped.                                                                                         
    root@buanet-iobroker1:/opt/iobroker# iobroker fix                                                                              
    library: loaded                                                                                                                
    Library version=2020-04-12                                                                                                     
    ioBroker or some processes are still running:                                                                                  
    Please stop them first and try again!                                                                                          
    
    

    Und wenn ich versuche den Controller manuell zu installieren bekomme ich den selben Fehler wie bei den anderen 4 Adapter:

    root@buanet-iobroker1:/opt/iobroker# sudo -H -u iobroker npm install iobroker.js-controller                                    
    npm ERR! Unexpected end of JSON input while parsing near '..."^3.12.1","istanbul":'                                            
    npm ERR! A complete log of this run can be found in:                                                                           
    npm ERR!     /opt/iobroker/.npm/_logs/2020-05-27T17_56_18_831Z-debug.log       
    
    

  • Starter

    OK, das mit der falschen Node.js Version habe ich grade gefunden und gelöst.
    Das Verzeichnis von v12 ist ein anderes:

    root@buanet-iobroker1:/opt/iobroker# rm /usr/bin/node         
                                                                     
    root@buanet-iobroker1:/opt/iobroker# ln -s /usr/local/bin/node /usr/bin/node      
                                                 
    root@buanet-iobroker1:/opt/iobroker# node -v                                                                                   
    v12.16.3                                                                                                                       
                                                                                           
    root@buanet-iobroker1:/opt/iobroker# nodejs -v                                                                                 
    v12.16.3                              
    

    Das eigentliche Problem besteht aber weiterhin.



  • @igloh sagte in Kein Update von Adapter möglich:

    Ich habe dann die Module alle einzeln gestoppt. Irgendwas scheint aber immer noch aktiv zu sein

    bei Synology mit :

    pkill io
    

  • Starter

    Danke! Damit konnte ich alles stoppen und das "iobroker fix" lief durch.

    Seitdem ich vorhin aber die node.js Version angepasst habe startet die GUI gar nicht mehr 😞



  • @igloh sagte in Kein Update von Adapter möglich:

    startet die GUI gar nicht mehr

    Das heißt ... ?
    hast du ein Log davon


  • Starter

    Erst mal nur das Protokoll vom Docker und das sieht auf den ersten Bick fehlerfrei aus.

    Die Webseiten vom Admin oder Vis lassen sich halt nicht öffnet.

    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.systeminfo.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.synology.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.fritzdect.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.vis-justgage.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.firetv.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.javascript.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.alexa2.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.tr-064.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.hm-rpc.2" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.ical.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.fritzbox.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.daswetter.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.terminal.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.vis-timeandweather.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.vis.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.web.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.hm-rpc.1" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.hm-rega.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.hm-rpc.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.hue.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.info.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.discovery.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:50
    stdout
    host.buanet-iobroker1 check instance "system.adapter.admin.0" for host "buanet-iobroker1" 
    2020-05-27 18:49:49
    stdout
      
    2020-05-27 18:49:49
    stdout
    Starting ioBroker... 
    2020-05-27 18:49:49
    stdout
      
    2020-05-27 18:49:49
    stdout
    ------------------------------------------------------------ 
    2020-05-27 18:49:49
    stdout
    -----          Step 5 of 5: ioBroker startup           ----- 
    2020-05-27 18:49:49
    stdout
    ------------------------------------------------------------ 
    2020-05-27 18:49:44
    stdout
      
    2020-05-27 18:49:44
    stdout
    For more information take a look at readme.md on Github! 
    2020-05-27 18:49:44
    stdout
    Some adapters have special requirements/ settings which can be activated by the use of environment variables. 
    2020-05-27 18:49:44
    stdout
      
    2020-05-27 18:49:44
    stdout
    ------------------------------------------------------------ 
    2020-05-27 18:49:44
    stdout
    -----      Step 4 of 5: Applying special settings      ----- 
    2020-05-27 18:49:44
    stdout
    ------------------------------------------------------------ 
    2020-05-27 18:49:40
    stdout
      
    2020-05-27 18:49:40
    stdout
    Done. 
    2020-05-27 18:49:40
    stdout
    Fixing "sudo-bug" by replacing sudo in iobroker with gosu... 
    2020-05-27 18:49:40
    stdout
      
    2020-05-27 18:49:40
    stdout
    Done. 
    2020-05-27 18:49:40
    stdout
    (Re)Setting folder permissions (This might take a while! Please be patient!)... 
    2020-05-27 18:49:40
    stdout
      
    2020-05-27 18:49:40
    stdout
    ------------------------------------------------------------ 
    2020-05-27 18:49:40
    stdout
    -----   Step 3 of 5: Checking ioBroker installation    ----- 
    2020-05-27 18:49:40
    stdout
    ------------------------------------------------------------ 
    2020-05-27 18:49:40
    stdout
      
    2020-05-27 18:49:40
    stdout
    Existing installation of ioBroker detected in /opt/iobroker. 
    2020-05-27 18:49:39
    stdout
      
    2020-05-27 18:49:39
    stdout
    ------------------------------------------------------------ 
    2020-05-27 18:49:39
    stdout
    -----   Step 2 of 5: Detecting ioBroker installation   ----- 
    2020-05-27 18:49:39
    stdout
    ------------------------------------------------------------ 
    2020-05-27 18:49:39
    stdout
      
    2020-05-27 18:49:39
    stdout
    Done. 
    2020-05-27 18:49:39
    stdout
    E: Paket vi kann nicht gefunden werden. 
    2020-05-27 18:49:34
    stdout
    The following packages will be installed: vi... 
    2020-05-27 18:49:34
    stdout
    Installing additional packages is set by ENV. 
    2020-05-27 18:49:34
    stdout
      
    2020-05-27 18:49:34
    stdout
    ------------------------------------------------------------ 
    2020-05-27 18:49:34
    stdout
    -----         Step 1 of 5: Preparing container         ----- 
    2020-05-27 18:49:34
    stdout
    ------------------------------------------------------------ 
    2020-05-27 18:49:34
    stdout
      
    2020-05-27 18:49:34
    stdout
    ------------------------------------------------------------ 
    2020-05-27 18:49:34
    stdout
    -----               SETUID:    1000                    ----- 
    2020-05-27 18:49:34
    stdout
    -----               SETGID:    1000                    ----- 
    2020-05-27 18:49:34
    stdout
    -----               PACKAGES:  vi                      ----- 
    2020-05-27 18:49:34
    stdout
    -----                       ENV                        ----- 
    2020-05-27 18:49:34
    stdout
    -----                                                  ----- 
    2020-05-27 18:49:34
    stdout
    -----               npm:       6.14.4                  ----- 
    2020-05-27 18:49:33
    stdout
    -----               node:      v12.16.3                ----- 
    2020-05-27 18:49:33
    stdout
    -----               image:     v4.2.0                  ----- 
    2020-05-27 18:49:33
    stdout
    -----                     Versions                     ----- 
    2020-05-27 18:49:33
    stdout
    -----                                                  ----- 
    2020-05-27 18:49:33
    stdout
    -----               arch:      x86_64                  ----- 
    2020-05-27 18:49:33
    stdout
    -----                      System                      ----- 
    2020-05-27 18:49:33
    stdout
    -----                                                  ----- 
    2020-05-27 18:49:33
    stdout
    -----              Debugging information               ----- 
    2020-05-27 18:49:33
    stdout
    ------------------------------------------------------------ 
    2020-05-27 18:49:33
    stdout
      
    2020-05-27 18:49:33
    stdout
    ------------------------------------------------------------ 
    2020-05-27 18:49:33
    stdout
    -----                Please be patient!                ----- 
    2020-05-27 18:49:33
    stdout
    -----          Startupscript is now running.           ----- 
    2020-05-27 18:49:33
    stdout
    -----       Welcome to your ioBroker-container!        ----- 
    2020-05-27 18:49:33
    stdout
    ------------------------------------------------------------ 
    2020-05-27 18:49:33
    stdout
      
    2020-05-27 18:49:33
    stdout
    ------------------------------------------------------------ 
    2020-05-27 18:49:33
    stdout
    ---------------     2020-05-27 20:49:33      --------------- 
    2020-05-27 18:49:33
    stdout
    ------------------------------------------------------------ 
    2020-05-27 18:49:33
    stdout
      
    2020-05-27 18:43:03
    stdout
    
    2020-05-27 18:38:26
    stdout
    


  • @igloh

    Zeige mal

    iobroker status
    iobroker list instances
    

  • Most Active

    @igloh Da ist node aber nicht sauber installiert, wenn du da mit symlinks arbeiten musst.

    apt policy nodejs
    which nodejs && which node && which npm
    

  • Starter

    Danke das hat geholfen!

    Genau die Module die ich vorhin von Hand gestoppt habe, waren immer noch gestoppt.
    Auch Admin und Web.
    Dachte sie kommen zumindest bei einen Neustart wieder mit hoch, das ist aber anscheinend nicht so.

    OK.
    Nun läuft wieder alles, die Node Version stimmt, das ursprüngliche Problem besteht aber leider immer noch.

    Beim Versuch des Updates kommt wieder der genannte Fehler.

    Für heute ist aber erst mal Schluss, schon mal vielen Dank für die lehrreichen Tipps!



  • @igloh

    siehe oben von @Thomas-Braun


  • Starter

    Könnte gut sein, da steht wieder die 10er Version...

    root@buanet-iobroker1:/opt/iobroker# apt policy nodejs                                                                         
    nodejs:                                                                                                                        
      Installiert:           10.20.1-1nodesource1                                                                                  
      Installationskandidat: 10.20.1-1nodesource1                                                                                  
      Versionstabelle:                                                                                                             
     *** 10.20.1-1nodesource1 100                                                                                                  
            100 /var/lib/dpkg/status                                                                                               
    root@buanet-iobroker1:/opt/iobroker# which nodejs && which node && which npm                                                   
    /usr/bin/nodejs                                                                                                                
    /usr/local/bin/node                                                                                                            
    /usr/local/bin/npm                                                                                                             
    
    

  • Most Active

    @igloh Siehste...


  • Most Active

    @igloh

    rm /usr/local/bin/node
    rm /usr/local/bin/npm
    curl -sL https://deb.nodesource.com/setup_12.x | sudo -E bash -
    apt update
    apt dist-upgrade
    apt install nodejs --reinstall
    

    Das sollte ein node 12 richtig auf das System spülen.


  • Starter

    ich würde es erstmal so machen wie Thomas Braun schon geschrieben hat die node sauber neu zu Installieren.

    dann nochmals prüfen.

    node -v
    nodejs -v
    

    und die pfade

    which node
    /usr/bin/node
    
    which nodejs
    /usr/bin/nodejs
    

    lg


  • Starter

    Danke, habe node nun richtig installiert:

    oot@buanet-iobroker1:/opt/iobroker# node -v                                                                                   
    v12.17.0                                                                                                                       
    root@buanet-iobroker1:/opt/iobroker# nodejs -v                                                                                 
    v12.17.0                                                                                                                       
                                            
    root@buanet-iobroker1:/opt/iobroker# apt policy nodejs                                                                         
    nodejs:                                                                                                                        
      Installiert:           12.17.0-1nodesource1                                                                                  
      Installationskandidat: 12.17.0-1nodesource1                                                                                  
      Versionstabelle:                                                                                                             
     *** 12.17.0-1nodesource1 500                                                                                                  
            500 https://deb.nodesource.com/node_12.x buster/main amd64 Packages                                                    
            100 /var/lib/dpkg/status                                                                                               
         10.19.0~dfsg1-1 500                                                                                                       
            500 http://deb.debian.org/debian buster/main amd64 Packages                                                            
            500 http://security.debian.org/debian-security buster/updates/main amd64 Packages 
    

    Aber dem eigentlichen Problem hat das leider nicht geholfen.
    Ich kann weder die 4 Adatper noch den Controller (update self) upgraden.
    Es kommt weiterhin die Fehlermeldung mit dem "3.12.1","istanbu"

    code_text$ ./iobroker upgrade socketio
    Update socketio from @3.0.6 to @3.0.7
    NPM version: 6.14.4
    npm install iobroker.socketio@3.0.7 --loglevel error --prefix "/opt/iobroker" (System call)
    npm ERR! Unexpected end of JSON input while parsing near '..."^3.12.1","istanbul":'
    npm ERR! A complete log of this run can be found in:npm ERR!     /opt/iobroker/.npm/_logs/2020-05-28T06_11_16_609Z-debug.log
    upload [3] socketio.admin /opt/iobroker/node_modules/iobroker.socketio/admin/words.js words.js application/javascript
    upload [2] socketio.admin /opt/iobroker/node_modules/iobroker.socketio/admin/socketio.png socketio.png image/png
    upload [1] socketio.admin /opt/iobroker/node_modules/iobroker.socketio/admin/index_m.html index_m.html text/html
    upload [0] socketio.admin /opt/iobroker/node_modules/iobroker.socketio/admin/index.html index.html text/html
    Adapter "socketio" updated
    process exited with code 0
    

  • Starter

    Problem gelöst!

    Ein "npm cache clean --force" hat geholfen, danach konnte ich alle Adapter problemlos updaten.

    Das war ja einfach..... 😉

    Was ist noch gemerkt habe ist das zusätzlich zum "iobroker stop" das "pkill io" nicht reicht, die Module laufen trotzdem weiter. Ich habe dann letztendlich rausgefunden das man mit einen "iobroker stop all" wirklich alles stoppen kann. Man muss sie am Ende aber trotzdem wieder mit "iobroker start all" manuell starten, sonst kann man lange warten.

    Ich kam da noch drauf weil ich den Adapter auf V3 hochziehen wollte.
    Aber egal wo ist gucke oder was ich mache (z.B. iobroker upgrade self), er sagt das der aktuelle installiert ist.
    Auch nach der manuellen Installation im o.g. Link wird noch mal die 2.9.9 installiert.

    Falls mir noch einer sagen kann wie ich den V3 installieren kann wäre ich dankbar.

    Ansonsten läuft jetzt alles bei mir.
    Vielen Dank für die tolle Hilfe, ich habe zumindest auch viel dabei gelernt.


Log in to reply
 

Suggested Topics

920
Online

32.2k
Users

38.8k
Topics

526.6k
Posts