NEWS

Fehler bei der Installation "iobroker.zigbee@0.10.2" Adapter


  • Starter

    Guten Abend zusammen,

    bei der Installation des Zigbee Adapters erhalte ich den folgenden Fehler:

    $ ./iobroker add zigbee  --host raspberrypi
    NPM version: 6.13.4
    npm install iobroker.zigbee@0.10.2 --loglevel error --prefix "/opt/iobroker" (System call)
    npm
     ERR! code ENOTSUP
    npm
     ERR! notsup
     Unsupported engine for concentrate@0.2.3: wanted: {"node":"~0.10.0"} (current: {"node":"10.18.1","npm":"6.13.4"})npm ERR!
     notsup Not compatible with your version of node/npm: concentrate@0.2.3npm
     ERR! notsup Not compatible with your version of node/npm: concentrate@0.2.3
    npm ERR! 
    notsup Required: {"node":"~0.10.0"}npm ERR!
     notsup Actual:   {"npm":"6.13.4","node":"10.18.1"}
    
    npm ERR! A complete log of this run can be found in:npm ERR!     /home/iobroker/.npm/_logs/2020-02-03T20_09_39_103Z-debug.log
    ERROR: host.raspberrypi Cannot install iobroker.zigbee@0.10.2: 1
    ERROR: process exited with code 25
    

    Was kann ich tun um den Treiber zu installieren?

    Danke und viele Grüße

    Systemdata Bitte Ausfüllen
    Hardwaresystem: Pi3
    Arbeitsspeicher: 1GB
    Festplattenart: SD-Karte
    Betriebssystem: Mac
    Node-Version: 10.18.1
    Nodejs-Version: 10.18.1
    NPM-Version: 6.13.4
    Installationsart: Skriptl
    Image genutzt: Nein

  • Developer Most Active

    @iamheresy sagte in Fehler bei der Installation "iobroker.zigbee@0.10.2" Adapter:

    0.10.2

    wo hast du das den her... die aktuelle Version ist die 1.0.2


  • Starter

    Wird mir direkt im Adapter angezeigt. Verfügbare wäre 0.10.2


  • Starter

    zigbee-adapter.png


  • Developer Most Active

    @iamheresy ohh man da hab ich was verpasst... sry... kommt


  • Starter

    Hallo ich habe auch so ein Problem:

    host.raspberrypi install adapter zigbee
    Some packets could not be installed. Please install them manually
    upload [150] zigbee.admin /opt/iobroker/node_modules/iobroker.zigbee/admin/img/unknown.png img/unknown.png image/png
    upload [100] zigbee.admin /opt/iobroker/node_modules/iobroker.zigbee/admin/img/osram_g_spot.png img/osram_g_spot.png image/png
    events.js:174
          throw er; // Unhandled 'error' event
          ^
    
    Error: ENOENT: no such file or directory, open '/opt/iobroker/node_modules/iobroker.zigbee/admin/img/osram_4058075816718.png'
    Emitted 'error' event at:
        at lazyFs.open (internal/fs/streams.js:115:12)
        at FSReqWrap.args [as oncomplete] (fs.js:140:20)
    pi@raspberrypi:/opt/iobroker/node_modules $ ls
    
    

    Sorry aber bin ganz neu hab iobroker schon einige zeit laufen und nun wollte ich mal in zigbee einsteigen. Über iobroker lässt es sich auch nciht installieren.


  • Developer Most Active

    so jetzt


  • Starter

    WAs meinst du damit " so jetzt "


  • Developer

    @Stobli

    • Welche Version des Adapters versuchst du zu installieren ?
    • Welche Node Version hast du ?
    • Welche Node.JS Version hast du ?
    • Wie genau versuchst du den Adapter zu installieren ? Das gepostete Log sieht so aus als ob du den Adapter über die Konsole installieren willst. Allerdings passt aus meiner Sicht der Befehl nicht.
    • Wie sieht das vollständige Log aus ? Das was Du in den Post geschrieben hast scheint unvollständig.

    Der Kommentar von @arteck bezieht sich auf den Post von @iamheresy.

    A.



Suggested Topics

839
Online

32.3k
Users

38.9k
Topics

527.5k
Posts