NEWS

  • Forum Testing Most Active

    @langer sagte in [Linux Shell-Skript] WLAN-Wetterstation:

    Was muß ich noch machen oder was habe ich falsch gemacht??

    Hi, der Fehler steckt wie so oft im Detail:

    (UNKNOWN) [192.168.xxx.xxx] 8087 (?) open
    

    mangels "korrekter" netcat-Version kann er keine stabile Verbindung aufbauen. Deswegen geht es mal, oder halt nicht...
    Ev. habe ich dafür aber eine Lösung (die habe ich schon, nur so kann ich ev. von vorn herein eine "falsche" Version ausfiltern).
    Gib bitte mal im Terminal ls -al /etc/alternatives/nc|grep openbsd ein, da sollte bei dir jetzt nichts erscheinen.
    Gegentest: ls -al /etc/alternatives/nc|grep trad (da kommt dann so etwas wie lrwxrwxrwx 1 root root 15 Mai 9 2020 /etc/alternatives/nc -> /bin/nc.traditional) ?

    Lösung deines Problems: im Wiki --> FAQ --> "erhalte keine Daten" (netcat in passender Version nachinstallieren)

  • Forum Testing Most Active

    @protheus sagte in [Linux Shell-Skript] WLAN-Wetterstation:

    nein kalibriert habe ich nichts.
    Da fehlen mir halt die Referenzdaten um den Offset festzulegen.

    Jupp, das ist dein "Regen-Problem". Habe eben mal bei dir in den geposteten Werten nachgeschaut:

    javascript.0.Wetterstation.Druck_absolut=985.91
    

    So tief bin ich fast nie, das wäre lt. Tabelle eben "Regen" (siehst du auch auf dem Bild vom Barometer 🙂 )
    Aktuell sonnig (+auch lt. Anzeige) bei 1003 hPa
    Bei meiner Station musste ich nur die Höhe meines Montageortes über NN angeben.


  • @sborg sagte in [Linux Shell-Skript] WLAN-Wetterstation:

    @protheus sagte in [Linux Shell-Skript] WLAN-Wetterstation:

    nein kalibriert habe ich nichts.
    Da fehlen mir halt die Referenzdaten um den Offset festzulegen.

    Jupp, das ist dein "Regen-Problem". Habe eben mal bei dir in den geposteten Werten nachgeschaut:

    javascript.0.Wetterstation.Druck_absolut=985.91
    

    So tief bin ich fast nie, das wäre lt. Tabelle eben "Regen" (siehst du auch auf dem Bild vom Barometer 🙂 )
    Aktuell sonnig (+auch lt. Anzeige) bei 1003 hPa
    Bei meiner Station musste ich nur die Höhe meines Montageortes über NN angeben.

    Hi,

    naja, die Höhe konnte ich nicht angeben. (Hat halt nur die Koordinaten drin wenn ich das richtig gesehen hab)
    Aber den relativen Luftdruck ändern. Ich habe das dann mit dem nächstgelegenen Flughafen und der nächsten wunderground Wetterstation abgeglichen und den relativen Luftdruck auf 1025 hpa eingestellt.

    Das mit dem absoluten Luftdruck habe ich nicht ganz verstanden (außer das ich dafür nen extra Gerät bräuchte...). Der hat sich auf 988 umgestellt als ich Längen- und Breitengrad nochmal aktualisiert hatte.

    Grüße
    Protheus


  • @protheus
    Der absolute Luftdruck ist der Wert, den die Station misst. Der ist natürlich von der Höhe des Messpunkts abhängig (je höher, desto niedriger der Luftdruck).
    Deswegen wird der relative Luftdruck auf Meereshöhe Null umgerechnet, um die Werte vergleichen zu können. Mit diesem Wert wird dann gearbeitet.


  • @sborg ich habe InfluxDB auf meinem Raspberry installiert und ebenfalls auch den Adapter im ioBroker.

    Der Adapter im ioBroker ist grün.

    Ich habe InfluxDB bei Aussentemperatur, Wind_max und Regen_Tag aktiviert, die Werte werden auch unter Einstellungen aufgelistet.

    Leider wird mir in der Statistik nichts angezeigt. Die Aufzeichnung läuft jetzt 1,5 Tage.

    Muss ich noch irgendwas aktivieren?

    Screenshot 2021-04-06 085154.jpg
    Screenshot 2021-04-06 085102.jpg


  • @chrissi1
    Das Statistikskript läuft aber noch?

    Ich hatte es aus Reflex, wie beim Skript für Anlegen der DP, wieder deaktiviert 😉


  • @boronsbruder Ich habe gerade nachgesehen, das Statistikskript war deaktiviert.

    Ich habe es jetzt aktiviert.

    Jetzt muss ich wahrscheinlich einen Tag warten um zusehen, ob die Werte übertragen werden oder?


  • @chrissi1
    Ja, per default werden die Daten von gestern um 01:03 Uhr in die Statistik übernommen.


  • @boronsbruder

    Ok, dann warte ich jetzt bis Morgen ab und melde mich dann.

    Danke.


  • @SBorg , @Boronsbruder

    Es hat geklappt, die Statistik wird mir jetzt angezeigt. 😀

    Es lag an dem deaktivierten Wetterstation-Statistik-Skript.

    Vielen Dank für eure Hilfe. 👍

Suggested Topics

2.1k
Online

38.3k
Users

43.8k
Topics

611.7k
Posts