NEWS

Button auf Touchscreen geht wieder auf OFF


  • Moin !
    Ich habe bei mir einen Raspi inkl. 7" Touchscreen für die Visu hängen.
    Nun habe ich ein paar Buttons (hqwidgets) für Licht an / aus in der Visu.
    Im Browser mit der Maus klappt das alles super.
    Aber wenn ich am Touchscreen des Raspi was anklicke mit dem Finger dann geht das Licht für ne halbe Sekunde an und sofort wieder aus - also eher eine art delayed on.
    Ich habe aber nix weiter eingestellt und wie gesagt im normalen Browser am Rechner gehts.

    Kennt jemand das Problem? Mein WAF (Woman Accaptance Factor) sinkt gerade 😉

    Grüße Dominik

  • Developer Most Active

    moelski sagte in Button auf Touchscreen geht wieder auf OFF:

    Kennt jemand das Problem

    Ja und wundert mich das du es immer noch hast


  • arteck sagte in Button auf Touchscreen geht wieder auf OFF:

    moelski sagte in Button auf Touchscreen geht wieder auf OFF:

    Kennt jemand das Problem

    Ja und wundert mich das du es immer noch hast

    Was gibt's da zu wundern? Ich hab das Problem nämlich auch bei manchen Buttons...

  • Developer Most Active

    Thisoft das ist schon vor Monaten beoben worden..aber so wie es aussieht nicht konsequent..

    das entprellen funktioniert nicht bei allen buttons


  • arteck Sollte ich da jetzt andere Buttons verwenden? Welche funktionieren denn?
    Oder ein Github-Issue aufmachen?

  • Developer Most Active

    Thisoft mach ein issue auf GIT

  • Developer

    Welche buttons genau betrifft es? Ich habe erst kürzlich on/off in einem Projekt verwendet und bisher keine Beschwerden bekommen.

  • Developer Most Active

    Thisoft mach am besten ein beispiel export von dem knopp


  • Ich glaub eher, dass es am Touch vom Raspberry liegt. Hab das selbe Phänomen mit einem html button, welches mir nur ein Wert setzt. Ich glaub dass der Touch 2 mal reagiert bei Druck und wieder loslassen.
    Halt mal den Finger auf das Widget gedrückt, was passiert dann.

    Gruss

  • Developer

    ple da sind wir wieder beim Thema Browser und Abweichung vom Standard. Jetzt weil du es sagst fällt es mir wieder ein.
    Es gibt mindestens 3 Arten von Touch Events je nach Quelle und Browser:
    Touch Start
    Touch End
    Touch move
    Touch cancel

    Wenn jetzt nicht explizit Touch End als Trigger verwendet wird kann es vorkommen das bei Touch Start und Touch End reagiert wird. Die Interpretation der Events ist Browser Sache.


  • hast du zufällig auch eine Idee, wie man das bei raspian mit den Chrome-Browser einstellt.
    Ich glaube das betrifft irgendwie nur raspian, müsste das morgen mal testen mit meinen Dell 22 Zoll, aber da arbeitet ein TinkerBoard mit armbian.

  • Developer

    ple da kann man nix einstellen, das muss bei den Widgets berücksichtigt werden.
    Da ich bei den Widgets nicht durchsteige kann auch nicht mal schnell im Quellcode schauen ob das Berücksichtigt wurde.

  • Developer Most Active

    Jey Cee ich hah mal bissel rumgespielt.. das passiert eigentlich mit jedem Button ..
    wenn du z.w: background per javascript steuern willst. also nicht statisch sondern abhängig vom irgendeinen state


  • So, ich hab auch ein wenig rumgespielt.
    System vom Raspberry sowie Tinkerboard (armbian) komplett neu aufgesetzt. alle Adapter aus der latest mit Node 10.
    7 Zoll Raspberry Touch und einem Hannspree Touch.
    Mein HTML Button scheint nun zu funktionieren.
    Welches definitiv nicht geht ist das HQ Widget on/off.
    Das springt direkt wieder zurück auf den vorherigen Wert. Verweis auf einen Javascript Datenpunkt.

    [{"tpl":"tplHqButton","data":{"g_fixed":false,"g_visibility":false,"g_css_font_text":false,"g_css_background":false,"g_css_shadow_padding":false,"g_css_border":false,"g_gestures":false,"g_signals":false,"g_last_change":false,"visibility-cond":"==","visibility-val":1,"visibility-groups-action":"hide","oid":"javascript.0.OEE.Anlage_Stillstand","min":"false","max":"true","iconName":"img/bulb_off.png","btIconWidth":"56","offsetAuto":"true","leftOffset":"15","topOffset":"55","timeAsInterval":"true","infoLeftFontSize":"12","infoFontRightSize":"12","infoLeftPaddingLeft":"15","infoLeftPaddingRight":"50","infoRightPaddingRight":"15","signals-cond-0":"==","signals-val-0":true,"signals-icon-0":"/vis/signals/lowbattery.png","signals-icon-size-0":0,"signals-blink-0":false,"signals-horz-0":0,"signals-vert-0":0,"signals-hide-edit-0":false,"signals-cond-1":"==","signals-val-1":true,"signals-icon-1":"/vis/signals/lowbattery.png","signals-icon-size-1":0,"signals-blink-1":false,"signals-horz-1":0,"signals-vert-1":0,"signals-hide-edit-1":false,"signals-cond-2":"==","signals-val-2":true,"signals-icon-2":"/vis/signals/lowbattery.png","signals-icon-size-2":0,"signals-blink-2":false,"signals-horz-2":0,"signals-vert-2":0,"signals-hide-edit-2":false,"lc-type":"last-change","lc-is-interval":true,"lc-is-moment":false,"lc-format":"","lc-position-vert":"top","lc-position-horz":"right","lc-offset-vert":0,"lc-offset-horz":0,"lc-font-size":"12px","lc-font-family":"","lc-font-style":"","lc-bkg-color":"","lc-color":"","lc-border-width":"0","lc-border-style":"","lc-border-color":"","lc-border-radius":10,"lc-zindex":0,"descriptionLeft":"Stillstand","pushButton":false},"style":{"left":"325px","top":"26px"},"widgetSet":"hqwidgets"}]
    

  • Jey Cee Hab das mal getestet. Ja, es liegt definitiv am Browser. Mit Firefox klappt's wieder tadellos. Etwas eigenartig ist zwar schon dass Chrome lange Zeit auch keine Probleme gemacht hat und dann plötzlich war dieser "Doppelklick" da. Möglicherweise liegt's nicht nur alleine am Browser sonder auch an Windows (-Updates)?

    Egal - wie auch immer. Ich verwende jetzt einfach Firefox (oder eben noch nen anderen Browser) wo du uns jetzt aufgeklärt hast wie's zusammenhängt. Auf das GIT-Issue verzichte ich. Die Entwickler haben IMO Wichtigeres zu tun als auszuprobieren ob alles mit allen denkbaren Kombinationen von Browsern und Betriebssystemen klappt...

  • Developer

    Thisoft also ein issue wäre vielleicht trotzdem nicht verkehrt. Ich habe gerade mal nach dem Problem gesucht das es speziell mit Chrome nicht geht bzw. doppelt auslöst.
    Es scheint auch so zu sein das es einen Unterschied macht ob man ein Tablet/Smartphone hat oder einen PC (Maus und Tastatur). Hier scheint es auch Überschneidungen mit den Touch events zu geben.
    Hast du das Problem an einem Desktop?

    Edit: Es gibt sogar eine Funktion in vis die das Doppelte Auslösen verhindern sollte. Möglicherweise liegt hier eine die Lösung für einen einfachen Fix. Es wird die Zeit zwischen 2 Events ermittelt und gegen eine vorgegebene mindest warte Zeit abgeglichen. Die Zeit könnte erhöht werden, das ist aber keine gute idee, liegt eh schon bei 700ms.


  • Hmm, sorry für die späte Rückmeldung.

    Firefox kann ich natürlich noch testen. Allerdings läuft der auf dem Pi nicht so geschmeidig wie Chrome.

    Ich teste mal und berichte.


  • Lösung für Raspberry mit 7" Touch

    Ich habe noch etwas geforscht und rausgefunden das man im Chromium folgende Einstellungen machen kann:
    Touch UI Layout
    Enables touch UI layout in the browser's top chrome. – Mac, Windows, Linux, Chrome OS

    #top-chrome-touch-ui

    Touch Events API
    Force Touch Events API feature detection to always be enabled or disabled, or to be enabled when a touchscreen is detected on startup (Automatic). – Mac, Windows, Linux, Chrome OS

    #touch-events

    Die Settings erreicht man über chrome://flags/ in der Adresszeile.
    Habe beide Settings eingeschaltet ...
    Damit läuft jetzt wieder alles wie gewohnt.


  • Lösung für Firefox:

    Nachdem jetzt seit Neuem (vermutlich Firefox-Update) die gleiche Macke wie beschrieben auch im Firefox auftrat hab ich mich mal, angelehnt an den Tip von moelski, auf die Suche in der Firefox-Config begeben. Dort ist offensichtlich die folgende Einstellung dafür verantwortlich:

    dom.w3c_touch_events.legacy_apis.enabled

    die hab ich auf true gesetzt und jetzt kann man wieder normal "touchen".

    Ach ja, die Firefox-Config erreicht man mit about:config in der Adresszeile.

    Ich weiß ja nicht so wirklich die Hintergründe, aber muss man da jetzt öfters in den Settings herumschrauben? Ich meine - kann man machen - ist aber vermutlich für Otto-Einfach-Nur-ioBroker-Anwender 😉 ganz schön Hardcore - oder?


  • Thisoft Danke für den Tipp, hatte seit einiger Zeit auch das Problem mit Firefox und den HQWidgets auf einem Windows 10 Tablet.

Suggested Topics

1.4k
Online

34.6k
Users

40.7k
Topics

557.3k
Posts