NEWS

UNSOLVED [Gelöst] tr-064 Adapter startet seit admin-Upgrade auf Version 3.62 nicht mehr

  • Starter

    Hallo Gemeinde,
    Seit ich am Samstag das Upgrade des Admin-adapters gemacht habe, spinnt mein tr-064-adapter:

    [s=]host.iobroker	2019-05-13 09:42:39.617	info	Restart adapter system.adapter.tr-064.0 because enabled
    host.iobroker	2019-05-13 09:42:39.617	error	instance system.adapter.tr-064.0 terminated with code 1 ()
    Caught	2019-05-13 09:42:39.617	error	by controller[0]: at bootstrap_node.js:625:3
    Caught	2019-05-13 09:42:39.617	error	by controller[0]: at startup (bootstrap_node.js:204:16)
    Caught	2019-05-13 09:42:39.617	error	by controller[0]: at Function.Module.runMain (module.js:694:10)
    Caught	2019-05-13 09:42:39.617	error	by controller[0]: at Function.Module._load (module.js:498:3)
    Caught	2019-05-13 09:42:39.616	error	by controller[0]: at tryModuleLoad (module.js:506:12)
    Caught	2019-05-13 09:42:39.616	error	by controller[0]: at Module.load (module.js:566:32)
    Caught	2019-05-13 09:42:39.616	error	by controller[0]: at Object.Module._extensions..js (module.js:664:10)
    Caught	2019-05-13 09:42:39.616	error	by controller[0]: at Module._compile (module.js:653:30)
    Caught	2019-05-13 09:42:39.616	error	by controller[0]: at Object.<anonymous> (/opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:16:20)
    Caught	2019-05-13 09:42:39.616	error	by controller[0]: at Object.exports.Adapter (/opt/iobroker/node_modules/soef/soef.js:1383:23)
    Caught	2019-05-13 09:42:39.616	error	by controller[0]: TypeError: fns.adapter is not a function
    Caught	2019-05-13 09:42:39.616	error	by controller[0]: ^
    Caught	2019-05-13 09:42:39.615	error	by controller[0]: fns.adapter = fns.adapter(options);
    Caught	2019-05-13 09:42:39.615	error	by controller[0]: /opt/iobroker/node_modules/soef/soef.js:1383
    host.iobroker	2019-05-13 09:42:37.060	info	instance system.adapter.tr-064.0 started with pid 2035
    host.iobroker	2019-05-13 09:42:37.033	info	"system.adapter.tr-064.0" enabled[/s]
    

    node.js Version 8.16.0
    node Version 8.16.0
    npm Version 6.4.1
    js-controller 1.58
    admin 3.62
    raspberry pi 3 B+

    Neustart der Adapter und des Raspi ist erfolgt...
    Vielleicht hat jemand einen Tip.

    Gruß
    Torsten

  • Forum Testing Most Active

  • Starter

    @sigi234 Super, Danke !
    Das hat das Problem gefixt.

    Gruß
    Torsten

  • Forum Testing Most Active

    @crepp1967

    Bitte sehr,

    Bitte benutzt das Voting rechts unten im Beitrag wenn er euch geholfen hat.


  • Hallo Gemeinde,
    bei mir startet der Adapter auch nicht mehr. Den oben genannten Workaround habe ich schon getestet , ohne Erfolg.
    Aber so wie es aussieht habe ich Probleme mit dem Parser?

    host.iobroker	2019-05-16 21:48:50.097	error	instance system.adapter.tr-064.0 terminated with code 0 (OK)
    Caught	2019-05-16 21:48:50.096	error	by controller[0]: at Parser.exports.Parser.Parser.parseString (/opt/iobroker/node_modules/xml2js/lib/parser.js:322:31)
    Caught	2019-05-16 21:48:50.096	error	by controller[0]: at SAXParser.write (/opt/iobroker/node_modules/sax/lib/sax.js:1436:13)
    Caught	2019-05-16 21:48:50.096	error	by controller[0]: at closeTag (/opt/iobroker/node_modules/sax/lib/sax.js:889:7)
    Caught	2019-05-16 21:48:50.096	error	by controller[0]: at emitNode (/opt/iobroker/node_modules/sax/lib/sax.js:629:5)
    Caught	2019-05-16 21:48:50.096	error	by controller[0]: at emit (/opt/iobroker/node_modules/sax/lib/sax.js:624:35)
    Caught	2019-05-16 21:48:50.096	error	by controller[0]: at SAXParser.onclosetag (/opt/iobroker/node_modules/xml2js/lib/parser.js:261:26)
    Caught	2019-05-16 21:48:50.096	error	by controller[0]: at Parser.emit (events.js:211:7)
    Caught	2019-05-16 21:48:50.096	error	by controller[0]: at emitOne (events.js:116:13)
    Caught	2019-05-16 21:48:50.096	error	by controller[0]: at Parser.<anonymous> (/opt/iobroker/node_modules/xml2js/lib/parser.js:303:18)
    Caught	2019-05-16 21:48:50.096	error	by controller[0]: at /opt/iobroker/node_modules/iobroker.tr-064/lib/phonebook.js:144:83
    Caught	2019-05-16 21:48:50.095	error	by controller[0]: TypeError: Cannot read property 'length' of undefined
    tr-064.0	2019-05-16 21:48:50.076	info	terminating
    tr-064.0	2019-05-16 21:48:50.070	error	at Parser.exports.Parser.Parser.parseString (/opt/iobroker/node_modules/xml2js/lib/parser.js:322:31)
    tr-064.0	2019-05-16 21:48:50.070	error	at SAXParser.write (/opt/iobroker/node_modules/sax/lib/sax.js:1436:13)
    tr-064.0	2019-05-16 21:48:50.070	error	at closeTag (/opt/iobroker/node_modules/sax/lib/sax.js:889:7)
    tr-064.0	2019-05-16 21:48:50.070	error	at emitNode (/opt/iobroker/node_modules/sax/lib/sax.js:629:5)
    tr-064.0	2019-05-16 21:48:50.070	error	at emit (/opt/iobroker/node_modules/sax/lib/sax.js:624:35)
    tr-064.0	2019-05-16 21:48:50.070	error	at SAXParser.onclosetag (/opt/iobroker/node_modules/xml2js/lib/parser.js:261:26)
    tr-064.0	2019-05-16 21:48:50.070	error	at Parser.emit (events.js:211:7)
    tr-064.0	2019-05-16 21:48:50.070	error	at emitOne (events.js:116:13)
    tr-064.0	2019-05-16 21:48:50.070	error	at Parser.<anonymous> (/opt/iobroker/node_modules/xml2js/lib/parser.js:303:18)
    tr-064.0	2019-05-16 21:48:50.070	error	at /opt/iobroker/node_modules/iobroker.tr-064/lib/phonebook.js:144:83
    tr-064.0	2019-05-16 21:48:50.070	error	TypeError: Cannot read property 'length' of undefined
    tr-064.0	2019-05-16 21:48:50.068	error	uncaught exception: Cannot read property 'length' of undefined
    

Suggested Topics

2.0k
Online

35.0k
Users

41.0k
Topics

563.2k
Posts