NEWS

Webadmin nicht erreichbar


  • Starter

    Hallo zusammen,

    bin noch neu hier und will mich ganz kuz vorstellen. BIn Christian und komme aus RLP.

    Habe im Internet etwas nach Smart Home gesucht und bin dabei auf ioBroker gestossen. Da ich noch einen Raspi zuhause habe, dachte ich, ich kann das ja mal versuchen und habe ioBroker installiert. Dies verlief nun auch ohne Probleme.

    Habe anschliessend den iobroker.admin auf 3.6.0 geupdated und ein paar Adapter installiert (homee, AVM usw). Bis dahin war auch alles okay. Raspi wurde im für all dies mit einem Router im Wohnzimmer verbunden um eine gute Internetverbindung zu haben. Nun zu meinem Problem.

    Der Raspi musste nun an seinen Bestimmungsort. Dazu den Mini PC vom Strom genommen und dort plaziert wo er hin soll. Das hat alles in allem ca. 30 Minuten gedauert, bis dieser wieder am Strom war. Angeschlossen, hochgefahren und sich per URL aud den iobroker.admin verbunden. Und ab hier, geht nichts mehr. Wenn ich die URL <IP-Adress>:8081 aufrufe, bekomme ich die Fehlermeldung: Fehler, Verbindung fehlgeschlagen. Nutze ich einen noch nicht geschlossenen Tab im Browser erhalte ich folgendes (siehe Screenshot)Bildschirmfoto 2019-03-17 um 20.14.57.png
    In diesem Status befindet sich der Raspi nun seit Stunden.

    Ich habe diesen Artikel gefunden (http://www.iobroker.net/docu/?page_id=3928&lang=de) und bin mal alles durchgegenagen. Wenn ich das hier mache

    netstat -n -a -p TCP

    kann man prüfen ob die Zeile zu finden ist:
    TCP 0.0.0.0:8081 0.0.0.0:0 LISTENING

    Allerdings lauscht bei mir auf diesem Port nichts. Ich vermute mal, dass dies der Grund ist warum ich nicht mehr auf den admin zugreifen kann.

    Habt Ihr eine Idee woran das liegt? Braucht ihr mehr Infos? Vielleicht hilft das log weiter....

    2019-03-17 20:12:40.777  - error: Caught by controller[0]: TypeError: self.OnTel.GetDeflections is not a function
    2019-03-17 20:12:40.790  - error: Caught by controller[0]:     at Deflections.get (/opt/iobroker/node_modules/iobroker.tr-064/lib/deflections.js:131:16)
    2019-03-17 20:12:40.792  - error: Caught by controller[0]:     at updateDeflections (/opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:831:38)
    2019-03-17 20:12:40.792  - error: Caught by controller[0]:     at /opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:850:17
    2019-03-17 20:12:40.793  - error: Caught by controller[0]:     at safeCallback (/opt/iobroker/node_modules/soef/soef.js:188:13)
    2019-03-17 20:12:40.794  - error: Caught by controller[0]:     at Devices.update (/opt/iobroker/node_modules/soef/soef.js:762:48)
    2019-03-17 20:12:40.795  - error: Caught by controller[0]:     at Timeout.doIt [as _onTimeout] (/opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:848:21)
    2019-03-17 20:12:40.796  - error: Caught by controller[0]:     at ontimeout (timers.js:466:11)
    2019-03-17 20:12:40.797  - error: Caught by controller[0]:     at tryOnTimeout (timers.js:304:5)
    2019-03-17 20:12:40.798  - error: Caught by controller[0]:     at Timer.listOnTimeout (timers.js:267:5)
    2019-03-17 20:12:40.799  - error: host.raspberrypi instance system.adapter.tr-064.1 terminated with code 0 (OK)
    2019-03-17 20:12:40.810  - info: host.raspberrypi Restart adapter system.adapter.tr-064.1 because enabled
    2019-03-17 20:12:50.351  - info: tr-064.2 starting. Version 0.4.18 in /opt/iobroker/node_modules/iobroker.tr-064, node: v9.11.2
    2019-03-17 20:12:58.081  - warn: tr-064.2 Phonebook not supported
    2019-03-17 20:12:59.413  - error: tr-064.2 --- To use the callmonitor, enable connects to port 1012 on FritsBox by dialing #96*5* and restart this adapter
    2019-03-17 20:12:59.433  - error: tr-064.2 Cannot start callmonitor: Error: connect ECONNREFUSED 192.168.178.56:1012
    2019-03-17 20:13:01.533  - error: tr-064.2 uncaught exception: self.OnTel.GetDeflections is not a function
    2019-03-17 20:13:01.535  - error: tr-064.2 TypeError: self.OnTel.GetDeflections is not a function
        at Deflections.get (/opt/iobroker/node_modules/iobroker.tr-064/lib/deflections.js:131:16)
        at updateDeflections (/opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:831:38)
        at /opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:850:17
        at safeCallback (/opt/iobroker/node_modules/soef/soef.js:188:13)
        at Devices.update (/opt/iobroker/node_modules/soef/soef.js:762:48)
        at Timeout.doIt [as _onTimeout] (/opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:848:21)
        at ontimeout (timers.js:466:11)
        at tryOnTimeout (timers.js:304:5)
        at Timer.listOnTimeout (timers.js:267:5)
    2019-03-17 20:13:01.638  - error: Caught by controller[0]: TypeError: self.OnTel.GetDeflections is not a function
    2019-03-17 20:13:01.640  - error: Caught by controller[0]:     at Deflections.get (/opt/iobroker/node_modules/iobroker.tr-064/lib/deflections.js:131:16)
    2019-03-17 20:13:01.641  - error: Caught by controller[0]:     at updateDeflections (/opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:831:38)
    2019-03-17 20:13:01.642  - error: Caught by controller[0]:     at /opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:850:17
    2019-03-17 20:13:01.643  - error: Caught by controller[0]:     at safeCallback (/opt/iobroker/node_modules/soef/soef.js:188:13)
    2019-03-17 20:13:01.644  - error: Caught by controller[0]:     at Devices.update (/opt/iobroker/node_modules/soef/soef.js:762:48)
    2019-03-17 20:13:01.644  - error: Caught by controller[0]:     at Timeout.doIt [as _onTimeout] (/opt/iobroker/node_modules/iobroker.tr-064/tr-064.js:848:21)
    2019-03-17 20:13:01.645  - error: Caught by controller[0]:     at ontimeout (timers.js:466:11)
    2019-03-17 20:13:01.646  - error: Caught by controller[0]:     at tryOnTimeout (timers.js:304:5)
    2019-03-17 20:13:01.647  - error: Caught by controller[0]:     at Timer.listOnTimeout (timers.js:267:5)
    2019-03-17 20:13:01.648  - error: host.raspberrypi instance system.adapter.tr-064.2 terminated with code 0 (OK)
    2019-03-17 20:13:01.649  - info: host.raspberrypi Restart adapter system.adapter.tr-064.2 because enabled
    2019-03-17 20:13:10.852  - info: host.raspberrypi instance system.adapter.tr-064.1 started with pid 11160
    2019-03-17 20:13:22.136  - info: tr-064.1 starting. Version 0.4.18 in /opt/iobroker/node_modules/iobroker.tr-064, node: v9.11.2
    pi@raspberrypi:/opt/iobroker $ cat log/iobroker.2019-03-17.log |grep admin
    2019-03-17 12:42:39.505  - info: admin.0 starting. Version 3.6.0 in /opt/iobroker/node_modules/iobroker.admin, node: v9.11.2
    2019-03-17 12:42:40.146  - info: admin.0 requesting all states
    2019-03-17 12:42:40.251  - info: admin.0 requesting all objects
    2019-03-17 12:42:40.259  - info: admin.0 Request actual repository...
    2019-03-17 12:43:01.821  - info: admin.0 received all states
    2019-03-17 12:43:06.613  - warn: admin.0 Reconnection to DB.
    2019-03-17 12:43:06.734  - warn: admin.0 Reconnection to DB.
    2019-03-17 12:43:50.754  - warn: admin.0 Reconnection to DB.
    2019-03-17 12:43:51.073  - warn: admin.0 Reconnection to DB.
    2019-03-17 12:44:13.658  - error: admin.0 already running
    2019-03-17 12:44:14.572  - error: host.raspberrypi instance system.adapter.admin.0 terminated with code 7 (Adapter already running)
    2019-03-17 12:44:14.581  - info: host.raspberrypi Restart adapter system.adapter.admin.0 because enabled
    2019-03-17 12:44:44.634  - info: host.raspberrypi instance system.adapter.admin.0 started with pid 1345
    2019-03-17 12:46:07.506  - info: admin.0 starting. Version 3.6.0 in /opt/iobroker/node_modules/iobroker.admin, node: v9.11.2
    2019-03-17 12:46:08.199  - info: admin.0 requesting all states
    2019-03-17 12:46:08.292  - info: admin.0 requesting all objects
    2019-03-17 12:46:08.340  - info: admin.0 Request actual repository...
    2019-03-17 12:46:12.923  - info: admin.0 terminating http server on port 8081
    2019-03-17 12:46:14.929  - info: admin.0 terminating http server on port 8081
    2019-03-17 12:46:21.309  - info: host.raspberrypi instance system.adapter.admin.0 terminated with code 156 ()
    2019-03-17 13:47:04.209  - info: host.raspberrypi instance system.adapter.admin.0 started with pid 554
    2019-03-17 13:48:20.628  - info: admin.0 starting. Version 3.6.0 in /opt/iobroker/node_modules/iobroker.admin, node: v9.11.2
    2019-03-17 13:48:21.243  - info: admin.0 requesting all states
    2019-03-17 13:48:21.375  - info: admin.0 requesting all objects
    2019-03-17 13:48:21.383  - info: admin.0 Request actual repository...
    2019-03-17 13:48:33.618  - info: admin.0 received all states
    2019-03-17 13:48:54.493  - warn: admin.0 Reconnection to DB.
    2019-03-17 13:48:54.713  - warn: admin.0 Reconnection to DB.
    2019-03-17 13:49:21.168  - error: admin.0 already running
    2019-03-17 13:49:21.705  - error: host.raspberrypi instance system.adapter.admin.0 terminated with code 7 (Adapter already running)
    2019-03-17 13:49:21.709  - info: host.raspberrypi Restart adapter system.adapter.admin.0 because enabled
    2019-03-17 13:49:51.851  - info: host.raspberrypi instance system.adapter.admin.0 started with pid 699
    2019-03-17 13:51:00.005  - info: admin.0 starting. Version 3.6.0 in /opt/iobroker/node_modules/iobroker.admin, node: v9.11.2
    2019-03-17 13:51:00.573  - info: admin.0 requesting all states
    2019-03-17 13:51:00.665  - info: admin.0 requesting all objects
    2019-03-17 13:51:00.672  - info: admin.0 Request actual repository...
    2019-03-17 13:51:13.183  - info: admin.0 received all states
    2019-03-17 13:51:25.902  - info: admin.0 received all objects
    2019-03-17 13:51:27.310  - info: admin.0 http server listening on port 8081
    2019-03-17 13:51:27.312  - info: admin.0 Use link "http://localhost:8081" to configure.
    2019-03-17 13:51:47.889  - info: admin.0 Repository received successfully.
    2019-03-17 13:52:27.599  - error: admin.0 already running
    2019-03-17 13:52:28.180  - error: host.raspberrypi instance system.adapter.admin.0 terminated with code 7 (Adapter already running)
    2019-03-17 13:52:28.235  - info: host.raspberrypi Restart adapter system.adapter.admin.0 because enabled
    2019-03-17 13:52:58.284  - info: host.raspberrypi instance system.adapter.admin.0 started with pid 766
    2019-03-17 13:53:12.779  - info: admin.0 starting. Version 3.6.0 in /opt/iobroker/node_modules/iobroker.admin, node: v9.11.2
    2019-03-17 13:53:12.945  - info: admin.0 requesting all states
    2019-03-17 13:53:12.975  - info: admin.0 requesting all objects
    2019-03-17 13:53:12.982  - info: admin.0 Request actual repository...
    2019-03-17 13:53:15.368  - info: admin.0 received all states
    2019-03-17 13:53:20.407  - info: admin.0 received all objects
    2019-03-17 13:53:21.034  - info: admin.0 http server listening on port 8081
    2019-03-17 13:53:21.036  - info: admin.0 Use link "http://localhost:8081" to configure.
    2019-03-17 13:53:35.633  - info: admin.0 Repository received successfully.
    2019-03-17 14:01:31.637  - info: admin.0 terminating http server on port 8081
    2019-03-17 14:01:32.531  - info: admin.0 terminating http server on port 8081
    2019-03-17 14:01:33.042  - info: host.raspberrypi instance system.adapter.admin.0 terminated with code 156 ()
    2019-03-17 14:02:05.458  - info: host.raspberrypi instance system.adapter.admin.0 started with pid 485
    2019-03-17 14:07:32.286  - info: admin.0 starting. Version 3.6.0 in /opt/iobroker/node_modules/iobroker.admin, node: v9.11.2
    2019-03-17 14:07:32.916  - info: admin.0 requesting all states
    2019-03-17 14:07:33.021  - info: admin.0 requesting all objects
    2019-03-17 14:07:33.029  - info: admin.0 Request actual repository...
    2019-03-17 14:07:49.929  - info: admin.0 received all states
    2019-03-17 14:07:59.519  - warn: admin.0 Reconnection to DB.
    2019-03-17 14:07:59.679  - warn: admin.0 Reconnection to DB.
    2019-03-17 14:08:45.041  - warn: admin.0 Reconnection to DB.
    2019-03-17 14:08:45.137  - warn: admin.0 Reconnection to DB.
    

    Würde mich freuen, wenn Euer Schwarwissen hier helfen kann.

    Vielen Dank
    Christian


  • Forum Testing Most Active Global Moderator Administrators

    @korfmannc sagte in Webadmin nicht erreichbar:

    node: v9.11.2

    Diese Version wird nicht supportet.

    Ungerade Versionen sind Entwicklerbversionen.
    Node bitte auf v8.15.x downgraden, oder bei controller1.5.7 auch auf 10.x upgraden


  • Starter

    @Homoran
    vielen Dank für deine Hilfe. Darf ich fragen wie ich das downgrade? Was ist denn eigentlich der Unterschied zwischen den beiden? Und was mich am meisten interessiert ist, warum ich per Webadmin Adapter installieren konnte wenn die Version nicht stimmt?

    Gruß
    Christian


  • Forum Testing Most Active Global Moderator Administrators

    @korfmannc sagte in Webadmin nicht erreichbar:

    Was ist denn eigentlich der Unterschied zwischen den beiden?

    @Homoran sagte in Webadmin nicht erreichbar:

    Ungerade Versionen sind Entwicklerversionen.

    @korfmannc sagte in Webadmin nicht erreichbar:

    wie ich das downgrade?

    http://www.iobroker.net/docu/?page_id=8323&lang=de#Installation_Nodejs


  • Starter

    Also,

    wenn ich das hier

    sudo apt-get --purge remove node
    sudo apt-get --purge remove nodejs

    mache, bekomme ich folgende Ausgabe:

    sudo apt-get --purge remove node
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package 'node' is not installed, so not removed
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    Vielleicht ist noch zu erwähnen, dass ich eine armv61 Architektur habe (Raspi P1?).

    das curl gibt folgesndes aus
    curl -sL https://deb.nodesource.com/setup_8.x | sudo -E bash -

    Installing the NodeSource Node.js 8.x LTS Carbon repo...

    You appear to be running on ARMv6 hardware. Unfortunately this is not currently supported by the NodeSource Linux distributions. Please use the 'linux-armv6l' binary tarballs available directly from nodejs.org for Node.js 4 and later.


  • Starter

    @Homoran said in Webadmin nicht erreichbar:

    oder bei controller1.5.7 auch auf 10.x upgraden

    Wie kann ich das denn bewerkstelligen?


  • Forum Testing Most Active Global Moderator Administrators

    @korfmannc sagte in Webadmin nicht erreichbar:

    Vielleicht ist noch zu erwähnen, dass ich eine armv61 Architektur habe (Raspi P1?).

    Das wäre im Vorfeld sicher sinnvoll gewesen.
    Dann wirft das jetzt alles über den Haufen, zumal ich eine Anleitung für den neuen Installer für RasPi1 noch nicht getestet und somit nicht fertig habe.

    Der zuletzt von mir getestete Weg ging folgendermaßen:

    wget http://nodejs.org/dist/latest-v6.x/node-v6.12.2-linux-armv6l.tar.gz
    tar -xvf node-v6.12.2-linux-armv6l.tar.gz 
    cd node-v6.12.2-linux-armv6l
    sudo cp -R * /usr/local/
    sudo ln -s /usr/local/bin/node /usr/bin/nodejs
    node -v
    npm -v
    

    Hier müsstest du jetzt alles mit v6 auf v8 und der entsprechenden neuesten Unterversion austauschen.

    @korfmannc sagte in Webadmin nicht erreichbar:

    Wie kann ich das denn bewerkstelligen?

    Was?
    Node 10? (analog v8)
    oder js-controller 1.5.7)


  • Starter

    Hi,

    sorry für den Mehraufwand. Ich werde den letzten von dir getesteten Weg testen und mich gleich noch mal melden....


  • Starter

    @Homoran
    habe den alten Ordner gelöscht und deine ersten 3 Schritte gemacht. Hat alles super geklappt.

    ein

    ~/node-v8.15.1-linux-armv6l $ sudo cp -R * /usr/local/

    gibt folgendes aus:

    cp: cannot create regular file '/usr/local/bin/node': Text file busy

    im selben Ordner (~/node-v8.15.1-linux-armv6l $) macht ein sudo cp -R * /usr/local/ folgendes
    cp: cannot create regular file '/usr/local/bin/node': Text file busy

    ~/node-v8.15.1-linux-armv6l $ node -v
    v9.11.2
    ~/node-v8.15.1-linux-armv6l $ nodejs -v
    v9.11.2

    irgendwas geht hier nicht 😞


  • Forum Testing Most Active Global Moderator Administrators

    @korfmannc
    Aber bitte vorher auf bestehende node und nodejs Versionen testen und diese löschen


  • Starter

    selbes Problem:

    sudo apt-get --purge remove node
    sudo apt-get --purge remove nodejs

    mache, bekomme ich folgende Ausgabe:

    sudo apt-get --purge remove node
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package 'node' is not installed, so not removed
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


  • Forum Testing Most Active Global Moderator Administrators

    @korfmannc das ist gut wenn es nicht da ist.
    Dann musst du es nicht löschen.

    @korfmannc sagte in Webadmin nicht erreichbar:

    habe den alten Ordner gelöscht

    Welchen ordner?
    Wo stand, dass duveinen ordner löschen solltest?


  • Starter

    @Homoran

    ich habe den Ordner mit node 9.x gelöscht bevor ich per wget die neue Version installiert habe.


  • Forum Testing Most Active Global Moderator Administrators

    @korfmannc
    Dann bin ich raus.

    Der hätte über purge entfernt werden müssen.

    Ob jetzt noch irgendwelche geänderten Daten existieren weiß ich nicht


  • Starter

    @Homoran
    keine Ahnung ob das noch mal gefixed werden kann. Wenn alle Stricke reissen, werde ich morgen noch einmal neu installieren und dabei einfach die 8er Version nehmen. Sollte ja kein allzu großes Problem sein.

    Ist mit dieser Version v8 denn dann alles okay und alles läuft wie geplant? Ist, wie schon geschrieben, aktuell mal nur ein Test bevor ich mir was stärkeres als den alten Pi hole.


  • Starter

    @Homoran
    der hat sich aber nicht per purge entfernen lassen. Hatte ich ja probiert
    .


  • Forum Testing Most Active Global Moderator Administrators

    @korfmannc
    Da bin ich mir nicht sicher.
    Den zweiten befehl mit nodejs hat er ja gar nicht mehr begonnen


  • Starter

    @Homoran
    wie gesagt, Danke für die Hilfe. Und das für einen Sonntag Abend. Ich werde mich morgen einfach noch mal dran setzen und neu installieren. Ist ja weniger Aufwand als hier einen Fehler zu suchen, zumal noch nichts wirklich produktiv ist.

    Welche Konstellation würdest du mir empfehlen? Welche Bedienungsanleitung?

    Gruß
    Christian


  • Starter

    Guten Morgen @Homoran

    vielen Dank noch mal für deine Hilfe gestern. Ich habe jetzt mal neu installiert. Nun scheint alles zu passen. Ich denke ich werde das Thema mal schliessen.

    Gruß
    Christian


  • Forum Testing Most Active Global Moderator Administrators

    @korfmannc sagte in Webadmin nicht erreichbar:

    Nun scheint alles zu passen.

    Schön!
    Wenn noch was ist melde dich einfach


Log in to reply
 

Suggested Topics

  • 1
  • 2
  • 5
  • 10
  • 7
  • 7
  • 49

812
Online

32.1k
Users

38.8k
Topics

525.6k
Posts