NEWS

Kein Update von Adapter möglich



  • @igloh

    Zeige mal

    iobroker status
    iobroker list instances
    

  • Most Active

    @igloh Da ist node aber nicht sauber installiert, wenn du da mit symlinks arbeiten musst.

    apt policy nodejs
    which nodejs && which node && which npm
    

  • Starter

    Danke das hat geholfen!

    Genau die Module die ich vorhin von Hand gestoppt habe, waren immer noch gestoppt.
    Auch Admin und Web.
    Dachte sie kommen zumindest bei einen Neustart wieder mit hoch, das ist aber anscheinend nicht so.

    OK.
    Nun läuft wieder alles, die Node Version stimmt, das ursprüngliche Problem besteht aber leider immer noch.

    Beim Versuch des Updates kommt wieder der genannte Fehler.

    Für heute ist aber erst mal Schluss, schon mal vielen Dank für die lehrreichen Tipps!



  • @igloh

    siehe oben von @Thomas-Braun


  • Starter

    Könnte gut sein, da steht wieder die 10er Version...

    root@buanet-iobroker1:/opt/iobroker# apt policy nodejs                                                                         
    nodejs:                                                                                                                        
      Installiert:           10.20.1-1nodesource1                                                                                  
      Installationskandidat: 10.20.1-1nodesource1                                                                                  
      Versionstabelle:                                                                                                             
     *** 10.20.1-1nodesource1 100                                                                                                  
            100 /var/lib/dpkg/status                                                                                               
    root@buanet-iobroker1:/opt/iobroker# which nodejs && which node && which npm                                                   
    /usr/bin/nodejs                                                                                                                
    /usr/local/bin/node                                                                                                            
    /usr/local/bin/npm                                                                                                             
    
    

  • Most Active

    @igloh Siehste...


  • Most Active

    @igloh

    rm /usr/local/bin/node
    rm /usr/local/bin/npm
    curl -sL https://deb.nodesource.com/setup_12.x | sudo -E bash -
    apt update
    apt dist-upgrade
    apt install nodejs --reinstall
    

    Das sollte ein node 12 richtig auf das System spülen.


  • Starter

    ich würde es erstmal so machen wie Thomas Braun schon geschrieben hat die node sauber neu zu Installieren.

    dann nochmals prüfen.

    node -v
    nodejs -v
    

    und die pfade

    which node
    /usr/bin/node
    
    which nodejs
    /usr/bin/nodejs
    

    lg


  • Starter

    Danke, habe node nun richtig installiert:

    oot@buanet-iobroker1:/opt/iobroker# node -v                                                                                   
    v12.17.0                                                                                                                       
    root@buanet-iobroker1:/opt/iobroker# nodejs -v                                                                                 
    v12.17.0                                                                                                                       
                                            
    root@buanet-iobroker1:/opt/iobroker# apt policy nodejs                                                                         
    nodejs:                                                                                                                        
      Installiert:           12.17.0-1nodesource1                                                                                  
      Installationskandidat: 12.17.0-1nodesource1                                                                                  
      Versionstabelle:                                                                                                             
     *** 12.17.0-1nodesource1 500                                                                                                  
            500 https://deb.nodesource.com/node_12.x buster/main amd64 Packages                                                    
            100 /var/lib/dpkg/status                                                                                               
         10.19.0~dfsg1-1 500                                                                                                       
            500 http://deb.debian.org/debian buster/main amd64 Packages                                                            
            500 http://security.debian.org/debian-security buster/updates/main amd64 Packages 
    

    Aber dem eigentlichen Problem hat das leider nicht geholfen.
    Ich kann weder die 4 Adatper noch den Controller (update self) upgraden.
    Es kommt weiterhin die Fehlermeldung mit dem "3.12.1","istanbu"

    code_text$ ./iobroker upgrade socketio
    Update socketio from @3.0.6 to @3.0.7
    NPM version: 6.14.4
    npm install iobroker.socketio@3.0.7 --loglevel error --prefix "/opt/iobroker" (System call)
    npm ERR! Unexpected end of JSON input while parsing near '..."^3.12.1","istanbul":'
    npm ERR! A complete log of this run can be found in:npm ERR!     /opt/iobroker/.npm/_logs/2020-05-28T06_11_16_609Z-debug.log
    upload [3] socketio.admin /opt/iobroker/node_modules/iobroker.socketio/admin/words.js words.js application/javascript
    upload [2] socketio.admin /opt/iobroker/node_modules/iobroker.socketio/admin/socketio.png socketio.png image/png
    upload [1] socketio.admin /opt/iobroker/node_modules/iobroker.socketio/admin/index_m.html index_m.html text/html
    upload [0] socketio.admin /opt/iobroker/node_modules/iobroker.socketio/admin/index.html index.html text/html
    Adapter "socketio" updated
    process exited with code 0
    

  • Starter

    Problem gelöst!

    Ein "npm cache clean --force" hat geholfen, danach konnte ich alle Adapter problemlos updaten.

    Das war ja einfach..... 😉

    Was ist noch gemerkt habe ist das zusätzlich zum "iobroker stop" das "pkill io" nicht reicht, die Module laufen trotzdem weiter. Ich habe dann letztendlich rausgefunden das man mit einen "iobroker stop all" wirklich alles stoppen kann. Man muss sie am Ende aber trotzdem wieder mit "iobroker start all" manuell starten, sonst kann man lange warten.

    Ich kam da noch drauf weil ich den Adapter auf V3 hochziehen wollte.
    Aber egal wo ist gucke oder was ich mache (z.B. iobroker upgrade self), er sagt das der aktuelle installiert ist.
    Auch nach der manuellen Installation im o.g. Link wird noch mal die 2.9.9 installiert.

    Falls mir noch einer sagen kann wie ich den V3 installieren kann wäre ich dankbar.

    Ansonsten läuft jetzt alles bei mir.
    Vielen Dank für die tolle Hilfe, ich habe zumindest auch viel dabei gelernt.


Log in to reply
 

Suggested Topics

957
Online

32.2k
Users

38.8k
Topics

526.6k
Posts