NEWS

  • Forum Testing Most Active Global Moderator Administrators

    @dj-cd-schubser sagte in Installationsprobleme Raspberry pi:

    sudo -H npm install -g npm@6

    wieso machst du das?

  • Forum Testing Most Active Global Moderator Administrators

    @gutgut30

    Da ich von @deimos noch kein Feedback habe, bitte nur als Workaround sehen, da ich nicht weiß ob hinter dem Problem und seiner "Lösung" noch anderes steckt, was mit der Lösung evtl. nicht mehr klappt.

    Wir denken zwar nicht, aber wenn doch werde ich es hier sofort melden.

    Vorgehen für ioBroker mit piVCCU auf Raspberry Pi mit Buster

    • Das entsprechende Image bei Github herunterladen
    • Image aktualisieren mit sudo apt update && sudo apt upgrade
    • Gemäß der Doku Schritt 2 und 3 vornehmen
      • Überprüfung sollte aber nichts ergeben
    • jetzt den Befehl sudo update-ca-certificates --fresh ausführen
    • ab jetzt mit Schritt 4 der Doku fortfahren

    Viel Glück


  • @Jan1

    ~~pi@raspberrypi:~ $ sudo systemctl status iobroker
    ● iobroker.service - ioBroker Server
       Loaded: loaded (/lib/systemd/system/iobroker.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Mon 2020-05-25 14:19:42 CEST; 2h 32min ago
         Docs: http://iobroker.net
      Process: 5576 ExecStart=/bin/bash -c ${NODE} /opt/iobroker/node_modules/iobroker.js-controller/contro
     Main PID: 5576 (code=exited, status=1/FAILURE)
    
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Service RestartSec=100ms expired, scheduling 
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Scheduled restart job, restart counter is at 
    Mai 25 14:19:42 raspberrypi systemd[1]: Stopped ioBroker Server.
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Start request repeated too quickly.
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Failed with result 'exit-code'.
    Mai 25 14:19:42 raspberrypi systemd[1]: Failed to start ioBroker Server.
    ...skipping...
    ● iobroker.service - ioBroker Server
       Loaded: loaded (/lib/systemd/system/iobroker.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Mon 2020-05-25 14:19:42 CEST; 2h 32min ago
         Docs: http://iobroker.net
      Process: 5576 ExecStart=/bin/bash -c ${NODE} /opt/iobroker/node_modules/iobroker.js-controller/contro
     Main PID: 5576 (code=exited, status=1/FAILURE)
    
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Service RestartSec=100ms expired, scheduling 
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Scheduled restart job, restart counter is at 
    Mai 25 14:19:42 raspberrypi systemd[1]: Stopped ioBroker Server.
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Start request repeated too quickly.
    Mai 25 14:19:42 raspberrypi systemd[1]: iobroker.service: Failed with result 'exit-code'.
    Mai 25 14:19:42 raspberrypi systemd[1]: Failed to start ioBroker Server.
    
    ~~
    

    Mod-Edit: Code in code-tags gesetzt!

    Meinst du das hier mit abgeschnitten??

    Ich habe mich an die Anleitung gehalten. Was meinst du mit der Punkt ist deutlich beschrieben? Was habe ich übersehen?


  • @Homoran

    Zitat:
    "Als letzte Überprüfung bitte noch die Version von npm mittels npm -v überprüfen.

    Ergibt dies eine Version < 6, bitte noch mit sudo -H npm install -g npm@6 ein npm-Update durchführen"


  • @dj-cd-schubser
    Dann üben wirr mal Code auch in Code Tacks zu packen und mal die Ausgaben zu posten, wie sie in der Doku zur Node und NPM drin stehen und nicht nur zu behaupten man hats gemacht 😉


  • @Jan1
    Ich kann dir grade null folgen.


  • @dj-cd-schubser
    Ausgaben der Konsole in Code Tacks packen, dann kann man das auch lesen und nicht einfach rein kopieren.
    Dann mal bisschen was aus der Doku hier auch posten und dazu gehört eigentlich schon Standard die Ausgaben von:

    node -v
    nodejs -v
    npm -v
    

    Dann weiß man mal was Du überhaupt hast.

    Homoran hat ja gefragt warum Du das

    sudo -H npm install -g npm@6
    

    gemacht hast, denn dazu müsste man erst mal wiessen was Die ne NPM Version ist und da bei der Installation nach Doku die Node10 installiert wird, kann das nicht nötig sein , weil Node 10 NPM 6 mitbringt.

  • Forum Testing Most Active Global Moderator Administrators

    @dj-cd-schubser sagte in Installationsprobleme Raspberry pi:

    @Homoran

    Zitat:
    "Als letzte Überprüfung bitte noch die Version von npm mittels npm -v überprüfen.

    Ergibt dies eine Version < 6, bitte noch mit sudo -H npm install -g npm@6 ein npm-Update durchführen"

    ok!
    ich glaube das stammt noch aus node8 - Zeiten. Muss ich mal recherchieren

    Aber bei node 10.x sollte npm 6.x dabei sein.
    wenn das nicht geklappt hat ist etwas anderes faul


  • @Homoran
    Das schreib ich ja auch schon oben 😉

  • Forum Testing Most Active Global Moderator Administrators

    @Jan1 Dann sag dem Forum auch, dass es mit der Veröffentlichung deines Posts nicht 9 Minuten warten soll 😉


  • @Homoran
    böses Forum 😊

Suggested Topics

2.0k
Online

37.0k
Users

42.7k
Topics

593.1k
Posts