NEWS

[gelöst] NPM Module dewpoint wird nicht gefunden.


  • Hallo
    Ich habe das gleiche Problem.
    Script Engine 4.1.12
    Admin 3.6.0

    root@netfritz-FUTRO-S900:/opt/iobroker# node -v
    v8.15.1
    root@netfritz-FUTRO-S900:/opt/iobroker# nodejs -v
    v8.15.1
    root@netfritz-FUTRO-S900:/opt/iobroker# npm -v
    6.9.0
    
    const request = require('request');
    

    Cannot finde Module request
    Unter Node_Module ist der Ordner "request" schon länger vorhanden.

    java_sp.png
    Gruß NetFritz

  • Developer Most Active Administrators

    ist nur die Fehlermeldung da im javascript adapter oder kan er das Modul auch wirklich nicht finden ?
    was kommt im log wen du das script startest ?


  • Hallo
    Das ist ja das seltsame wenn ich das Script starte kommt keine Fehlermeldung, auch nicht wenn die Zeile mit request Auskommentiere.
    Hier mal das Script:

    const request = require('request');
    log("los");
    request('https://api.forecast.solar/estimate/watts/52.33/9/40/-20/4', function (error, response, body) {
      console.log('error:', error); // Print the error if one occurred 
      console.log('statusCode:', response && response.statusCode); // Print the response status code if a response was received 
      console.log('body:', body); // Print the HTML for the Google homepage. 
    });
    

    Es wird folgendes Ausgegeben:

    11:25:19.204	info	javascript.0 Stop script script.js.common.Read_Forecast_Solar
    11:25:19.241	info	javascript.0 Start javascript script.js.common.Read_Forecast_Solar
    11:25:19.241	info	javascript.0 script.js.common.Read_Forecast_Solar: los
    11:25:19.242	info	javascript.0 script.js.common.Read_Forecast_Solar: registered 0 subscriptions and 0 schedules
    11:25:20.046	info	javascript.0 script.js.common.Read_Forecast_Solar: error:
    11:25:20.047	info	javascript.0 script.js.common.Read_Forecast_Solar: statusCode:
    11:25:20.047	info	javascript.0 script.js.common.Read_Forecast_Solar: body:
    

    Gruß NetFritz


  • @pogo80 sagte:

    dewpoint rot unterstrichen angezeigt mit dem vermerk (Modul nicht gefunden).

    Vermerk ignorieren, wenn das Modul installiert ist !


  • @NetFritz sagte:

    Unter Node_Module ist der Ordner "request" schon länger vorhanden.

    Das ist nicht nötig, da der Javascript-Adapter das Modul "request" bereits mitliefert.


  • Hier der Screenshot vom Adapter
    java.PNG
    Und hier einer vom Verzeichniss
    putty.png


  • @paul53
    Versteh ich das richtig, wenn das Modul insalliert ist kann ich die Warnung ignorieren und alles sollte funktionieren.

    Habe request auch mal installiert da bekomme ich auch einen roten unterstrich.


  • @pogo80 sagte:

    wenn das Modul insalliert ist kann ich die Warnung ignorieren und alles sollte funktionieren.

    Ja.


  • @paul53
    Super vielen Dank, hab mich jetzt einfach auf meine restlichen Fehler im script Konzentriert und es funktioniert.

  • Developer Most Active Administrators

    @pogo80 sagte in [gelöst] NPM Module dewpoint wird nicht gefunden.:

    Super vielen Dank, hab mich jetzt einfach auf meine restlichen Fehler im script Konzentriert und es funktioniert.

    hat mal jemand geschaut ob es dazu ein git issue gibt den das Modul ist ja da der admin (javascript adapter) zeigt es falsch an ?

Suggested Topics

2.0k
Online

35.0k
Users

41.0k
Topics

562.3k
Posts