NEWS

WICHTIG: Updates von socketio, web, admin (Latest vorerst)


  • Hi All,

    tl;dr
    Die Adapter web, socketio und admin wurde aktualisiert und sollten bald im Latest auftauchen. Sehr alte Geräte, wie beispielsweise iPad1 und 2 und ältere Android Geräte (zB <4.4) können für Admin und Visualisierungen nicht mehr genutzt werden! Wer solche Geräte einsetzt bitte nicht updaten (und gegebenenfalls Hardware langsam mal aktualisieren :-))!

    Wer Admin aktualisiert muss ebenso ggf andere genutzte Adapter aktualisieren wenn Diese im Einsatz sind:

    • iot 1.3.0
    • Javascript 4.40 (hier kommt hinzu das bei Multihost Systemen Admin auf dem Host installiert sein muss damit die Dependency stimmt)
    • Devices 0.3.0

    Details:
    In den Adapter web, socketio (der von web auch unter der Haube genutzt wird) und Admin steckt überall socketio als eine Library drin mit der Daten zwischen dem Browser und dem ioBroker-Server ausgetauscht werden.

    Alle drei Adapter haben bisher die Version 1.7.2 dieser Library genutzt, welche inzwischen über 3 Jahre alt ist. Wir haben diese Version lange eingesetzt weil bei allen höheren Versionen einige Ältere Geräte - allen voran iPad 1 und 2 (!) - nicht mehr funktionieren.

    Da es allerdings immer mehr Probleme mit dieser alten Version gibt haben wir uns nach längerer Diskussion und Abstimmung dazu entschieden alle drei oben genannten Projekte zu aktualisieren. Damit die Wichtigkeit dieser Änderung klar wird haben wir bei allen dreien die Hauptversionsnummer angehoben auch wenn es sonst keinerlei Feature-Änderung im Vergleich zur letzten früheren Version gibt.

    Daraus ergeben sich die neuen Versionen wie folgt, die in den nächsten Stunden im Latest Repository auftauchen werden:

    • Web 3.0.0
    • Socketio 3.0.0
    • Admin 4.0.0

    Bitte beachtet dies BEVOR Ihr aktualisiert!

    Dieser Thread ist auch für Feedback und Fragen zu dieser Änderung da.

    Und noch eine Bitte: Wenn Ihr in der Vergangenheit Probleme hattet und GitHub Issues eröffnet hattet wegen Bugs in einem dieser Adapter: Bitte prüft diese Themen erneut und gebt im GitHub Issue Feedback ob die Probleme in den neuen Versionen noch existieren oder behoben sind! Jetzt mit einer aktuellen Basis ist es auch für uns einfacher Probleme klar zu untersuchen und zu beheben.

    Mini FAQ:

    • Uuups, das hab ich jetzt aber zu spät gelesen und geupdated. Was nun?
      Du kannst im Admin die Adapter auf die letzten Versionen davor downgraden. Die Reihenfolge ist wichtig: Zuerst socketio, danach web Admin ist unabhängig davon.

    Ingo

  • Forum Testing Most Active

    @apollon77

    Alles ok.

  • Forum Testing Most Active


  • Soeben alle 3 Adapter aktualisiert und soweit alles unauffällig.
    Zuvor heute schon auf nodejs 10.19.0 aktualisiert und npm rebuild, wie auch install fixer laufen lassen.

  • Most Active

    Auch hier, alles i.O. bisher.

  • Most Active

    Welche Version vom js-controller wird denn benötigt?


  • @cash daran hat sich nichts geändert. ich glaube Web und Admin brauchen einen Controller 2.x


  • Bei mir werden die Geräte nicht mehr angezeigt....

    EDIT:
    Sorry, hat wahrscheinlich nur länger gedauert, Geräte sind da...
    Brauchen aber immer sehr lange bis Sie angezeigt werden...


  • Nabend,
    ich habe die möglichen Adapter Updates auch versucht draufzuspielen. Ich weiss leider nicht mehr genau welche alle.
    Er wollte gar nicht mehr eine Stunde lang. Dann habe ich den Stecker gezogen. Seit mein rock64 wieder hochfuhr kommt immer diese Meldung:

    sudo: unable to open /var/lib/sudo/ts/rock64: Read-only file system

    Er startet iO nicht und sonst kommt auch ständig die Meldung.

    Kennt das wer? Hab ich mein Linux zerschossen? Habe den rock64 mit SD Karte.

    Gruß

  • Forum Testing Most Active

    @ebu sagte in WICHTIG: Updates von socketio, web, admin (Latest vorerst):

    Kennt das wer?

    liest man immer öfters...wenn einfach der Stecker gezogen wird😂
    wäre besser gewesen, vorher zu fragen, nicht hinterher, wenn ma´s kaputt gemacht hat😕


  • guter Hinweis. Nur alles war tot, was hätte ich Fragen sollen? 😉


  • @hene42 welche Geräte meinst du? Den Tag „Geräte“? Naja es werden da alle Objekte deines Systems geladen. Das kann je nachdem wie viele es sind etwas Dauern 😉


  • @ebu Jupp ich tippe sein filesystem hat ne Macke weg. Am besten in nem eigenen thread nach Lösungen suchen. Aber eigentlich: Backup der Adapter Karte das du hoffentlich hast nehmen und überschreiben.

    Wenn er generell noch bootet ggf das iobroker-data Verzeichnis noch wegkopieren und dann später zurück.


  • @apollon77 läuft hier auch.
    Das aufrufen von Skripte dauert länger als vorher..
    ( Chrome )


  • @apollon77 Hallo, ja den Tag Geräte. Viele sind da bei mir nicht drin, so etwa 20 Stück. Die wurden bis zum Update immer innerhalb von Sekunden angezeigt. Jetzt habe ich festgestellt das die Geräte manchmal sofort, manchmal nach Minuten und manchmal gar nicht angezeigt werden (ioBroker Symbol dreht sich ohne Ende).
    Ich muss jedes mal Chrome komplett beenden bevor ich erneut versuche die Geräte anzeigen zu lassen, ab und zu werden Sie dann angezeigt. Auch wenn ich mit anderen Computern, Handy oder Notebook drauf zugreife ist der gleiche Effekt.


  • ist es möglich, das seit dem update, der iobroker schneller im aufbau geworden ist.

    Gerät im einsatz
    Raspi 4 - 4MB


  • @ilovegym Was heißt denn bei dir "länger"?
    Ich nutze Firefox und hab gerade mal alle Skripte angehalten und neu gestartet und konnte auch mit den aktualisierten Adaptern keine wirkliche Verzögerung feststellen.


  • ACHTUNG ACHTUNG Leute - ganz böse Falle für alle Android Nutzer.

    Nach der Aktualisierung der oben genannten Adapter kommt es bei ioB reproduzierbar zu einem Totalabsturz incl. anschließendem Neustart, sobald man die ioB Android App ( bei mir unter Android 10) öffnet und einen Re-Sync durchführen will.

    Z.Zt. befinde ich mich im heimischen Netzwerk, aber ich habe in der Android App auch die Verbindungsdaten via PRO Account eingetragen.


  • @Feuersturm es betraf den Wechsel im Admin wenn man z.bsp. von Instanzen auf Skripte wechselt, aber jetzt läuft's wie gehabt.
    Lag wohl am Browser.. gab keine Fehler.


  • @apollon77

    Kurzer Bericht (für alle die es interessiert) von jemand der es bewusst installiert hat, obwohl ältere Tablets als Steuerung im Einsatz sind.

    • Alle Adapter ohne Probleme am ioBroker installiert!
    • iobroker Vis App auf älteren Tablets bekommen KEINE Verbindung mehr! (Android -Version 4.1.1)
    • IoBroker VisWeb über Chrome auf älteren Tablets macht keine Probleme. Kann alle VIEWS sehen und ansteuern.

    NACHTRAG:

    • Admin am PC funktioniert merklich schneller beim Wechsel von einem zum anderen Menüpunkt!

    Alles in allem: Vorbildlich darauf hingewiesen, dass ältere Geräte Probleme haben können. Jetzt habe ich endlich einen guten Grund, ein neues Tablet zu ordern (schon passiert) um meinen Controller auszutauschen!

Suggested Topics

  • 10
  • 18
  • 2
  • 1
  • 9
  • 4
  • 4
  • 4

1.9k
Online

36.8k
Users

42.5k
Topics

588.5k
Posts