NEWS

Hardware gewechselt, IP anpassen nicht möglich



  • Hallo.

    Ich habe vor einigen Wochen meinen NUC in Betrieb genommen, Proxmox drauf gespielt und ein VM (Debian 10 Buster) eingerichtet. Darin dann erfolgreich ioBroker installiert und in dieser Grundeinstellung plus Backitup einige Wochen unter der IP 192.168.178.62 laufen lassen.

    Da im Log keine Fehler auftraten und auch die Backups mit dem mounten der NAS funktionierten, habe ich mich letztes Wochenende entschlossen, ein aktuelles Backup meiner alten funktionerenden Rock64 Installation zu machen und in der neuen Installation zu restoren.
    Auch das funktionierte hervorragend.

    In der Fritzbox ist der DHCP-Server aktiviert, alle Geräte erhalten von der Fritzbox die IP und jedem Netzwerkgerät immer die gleiche IPv4-Adresse zuweisen.

    Darauf hin habe ich die IP vom Rock64 auf eine andere freie IP gewechselt (funktionierte auch) und wollte in der Fritzbox 7490 die Netzwerkadresse vom neuen ioBroker auf die alte Adresse 192.168.178.48 wechseln. Das ist gescheitert mit der Fehlermeldung in der Fritzbox

    Es ist ein Fehler aufgetreten.
    Fehlerbeschreibung: Die IP-Adresse wird bereits von einem anderen Gerät verwendet!
    

    Dann habe ich Sonntag den Rock komplett vom Strom genommen und heute wieder versucht, die IP-Adresse der VM zu ändern. Leider mit identischer Fehlermeldung.
    Eingestellt in der Fritze ist, das die vergebenen IP-Adressen nach Ablauf der Gültigkeit von 1 Tag wieder freigegeben werden.

    Frage: warum kann ich die alte ioBroker Adresse vom Rock64 nicht auf die neue Hardware übernehmen?

    Ich habe zwischenzeitlich auch versucht, eine statische IP in der neuen Buster Installation zu vergeben, das ist gescheitert. Ich konnte zwar auf den ioBroker zugreifen, dieser aber nicht auf das Internet.

    Gruß
    Volker



  • @Röstkartoffel
    kann es sein, dass die Fritzbox die Adresse noch eine Weile "vorhällt/reserviert"?
    Ich würde es als erstes mit einem Neustart der Fritzbox versuchen, ob diese dann die IP "losläßt"

    Ich selbst stelle die VM in Proxmox auf eine feste IP ein - das kannst Du natürlich ebenfalls machen.
    Ich stelle alle Devices - bei denen das möglich ist - auf eine feste IP ein. Nur bei denen das nicht geht erhalten eine Zuweisung vom DHCP-Server.



  • @BBTown
    Den Neustart der Fritzbox habe ich gleich am Sonntag schon gemacht. Kein Unterschied. Hatte auch gleich dabei das Fritzbox-Update durchgeführt. Laut Google soll ein Zurücksetzen auf Werkseinstellungen helfen. Das möchte ich aber vermeiden.
    Aber warum das mit dem eingestellten einen Tag nicht funktioniert, ist viellleicht ein kleiner Bug in der Fritze.

    Wie hast du die feste IP der VM eingestellt, bzw. welche Dateien muss ich wie dafür anpassen?

    Würde ich gerne versuchen. Wie ich schon schrieb, hat mein Versuch nicht funktioniert.
    Nach dem Start von ioBroker sah es zB so aus und der Kreis drehte ewig:
    Fehler Static.JPG



  • @Röstkartoffel ich bin gerade nicht am System. Du müsstest in den Einstellungen / Eigenschaften / Optionen oder so, ähnlich die Netzwerkeinstellungen sehen und verändern können.
    Doppelklick auf den Adapter öffnet den Dialog. Dort von DHCP auf feste IP umstellen.

    Je nachdem wie dein Subnet aussieht musst Du es folgendermaßen eintragen

    • wenn dein Subnet 255.255.255.0 ist, dann 192.168.178.48/24
    • wenn dein Subnet 255.255.0.0 ist, dann 192.168.178.48/16

    ich gehe mal davon aus, dass in dieser Konstellation dein Gateway wohl 192.168.178.1 lautet !?



  • @BBTown sagte in Hardware gewechselt, IP anpassen nicht möglich:

    @Röstkartoffel ich bin gerade nicht am System. Du müsstest in den Einstellungen / Eigenschaften / Optionen oder so, ähnlich die Netzwerkeinstellungen sehen und verändern können.
    Doppelklick auf den Adapter öffnet den Dialog. Dort von DHCP auf feste IP umstellen.

    Je nachdem wie dein Subnet aussieht musst Du es folgendermaßen eintragen

    • wenn dein Subnet 255.255.255.0 ist, dann 192.168.178.48/24
    • wenn dein Subnet 255.255.0.0 ist, dann 192.168.178.48/16

    ich gehe mal davon aus, dass in dieser Konstellation dein Gateway wohl 192.168.178.1 lautet !?

    Ja, Gateway ist richtig und das Subnetz ist 255.255.255.0

    Aber "Doppelklick auf Adapter öffnet den Dialog"? Das sagt mir leider garnichts.



  • @Röstkartoffel

    Du müsstest in den Einstellungen / Eigenschaften / Optionen oder so, ähnlich die Netzwerkeinstellungen sehen und verändern können.

    Was ist hieran nicht zu verstehen?
    Hast Du dir mal die Mühe gemacht und dir die Optionen und/oder Einstellungen der VM anzuschauen um zu sehen wo dort die Netzwerkeinstellungen sind?

    b4481ede-9a72-4cbe-8667-2aa5a58ffd93-image.png
    (vergiss die Zahlen, das ist ein Screenshot von einer Abbildung die die Zahlen beinhaltet)



  • @BBTown

    Doch, habe ich.

    Screenshot_2019-10-17 pve - Proxmox Virtual Environment.png

    Aber wie ich wo von DHCP auf Static umstellen kann sehe ich leider nicht.



  • @Röstkartoffel okidoki, was befindet sich alles unter "Optionen"?
    kannst Du davon auch mal einen Screenshot einstellen - wie gesagt, ich bin selbst gerade nicht am System.
    Das "Bild" welches ich suche sieht anders aus



  • @BBTown
    Danke für deine Hilfe.
    Hier der "Optionen" Screenshot:

    Screenshot_2019-10-17 pve - Proxmox Virtual Environment(1).png



  • @Röstkartoffel nein, dann muss es doch unter "Hardware - Netzwerk "gewesen sein.
    Welche Auswahl hast Du bei den Adaptern und wie ändert sich die Darstellung wenn Du einen anderen auswählst? ... ich habe nicht im Kopf welcher das sein sollte
    196ba18d-2332-4832-90c4-4b801e8e498d-image.png



  • @BBTown

    Netzwerk.JPG

    Kann ich einfach gefahrlos einen anderen Adapter wählen und ok klicken, ohne das ich den Zugriff auf die VM verliere? Sorry für die Anfängerfrage 😕



  • @Röstkartoffel

    Kann ich einfach gefahrlos einen anderen Adapter wählen

    ja klar, Du musst es ja nicht speichern 😉



  • @BBTown
    Bin ein kleiner Schisser und habe eben mal einen Clone erstellt.
    Dort alle Adapter einzeln nacheinander ausgewählt und ok gedrückt. Leider sieht es danach immer noch gleich aus (Bis auf den Adapternamen natürlich).



  • @Röstkartoffel
    dann werde ich erst helfen können, wenn ich das zu Hause nachstellen kann.



  • @BBTown
    Danke. Das ist spitze.

    Ich mache gerade HomeOffice, da geht es etwas einfacher.
    Lese mir gerade deine Super-Beschreibung im Beitrag "Proxmox-Frage: Wie regelt Ihr das Backup vom Host?" durch. 👍



  • @Röstkartoffel
    ich bin dämlich .... die Einstellung die ich die ganze Zeit gesucht habe, die ist zwar bei Containern vorhanden, aber nicht bei VM`s 🤦‍♂️

    Folgendermaßen habe ich bei mir die feste IP in der VM eingetragen

    in der Konsole folgendes eingeben:

    nano /etc/network/interfaces
    

    dort sollte eine Zeile stehen die in etwa so ausschaut:

    iface ens18 inet dhcp
    

    wobei "ens18" bei dir anders lauten kann

    als erstes kommentierst Du diese Zeile aus in dem Du ein "# " am Anfang der Zeile stellst

    unterhalb dieser Zeile kommt nun folgendes als Angabe der festen IP für deine Umgebung rein

    iface ens18 inet static
       address 192.168.178.48
       netmask 255.255.255.0
       gateway 192.168.178.1
    

    auch hier ist ggf. anstelle von "ens18" bei dir eine andere Bezeichnung für das Netzwerkinterface.

    Anschließend nano schließen und die Änderungen speichern mit:
    "[strg]+x" danach "J" danach "Eingabetaste/Return"

    und zu guter letzt

    reboot
    


  • @BBTown
    Ich werde das morgen mal so eintragen (ens18 ist auch bei meiner Installation so), bin aber der Meinung, genauso habe ich das schon mal gemacht und dann das oben gezeigte Bild mit dem drehenden Kreis gehabt.

    volker@ioBroker:~$ sudo ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host
           valid_lft forever preferred_lft forever
    2: ens18: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether ce:88:ef:ad:50:ee brd ff:ff:ff:ff:ff:ff
        inet 192.168.178.62/24 brd 192.168.178.255 scope global dynamic ens18
           valid_lft 49001sec preferred_lft 49001sec
        inet6 fe80::cc88:efff:fead:50ee/64 scope link
           valid_lft forever preferred_lft forever
    
    

    Fehlt in meiner Proxmox VM vielleicht irgendetwas, was zu der Vergabe einer statischen festen IP noch nötig ist?



  • @Röstkartoffel
    hier wird aber als IP am Ende die 62 und nicht die 48 angezeigt
    Ist das ggf. die vom DHCP vergeben IP? (scope global dynamic ens18)

    Was sagt denn bei dir nano /etc/network/interfaces ?
    (oder alternativ cat /etc/network/interfaces wenn Du den Inhalt von interfaces nur sehen, aber nicht bearbeiten willst)



  • @BBTown sagte in Hardware gewechselt, IP anpassen nicht möglich:

    der Ausdruck war aktuell, ohne Änderung an der "/etc/network/interfaces", daher die 62 und nicht die 48.

    cat /etc/network/interfaces

    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    source /etc/network/interfaces.d/*
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    allow-hotplug ens18
    iface ens18 inet dhcp
    
    

  • Forum Testing

    @Röstkartoffel @BBTown
    Ich lasse mir immer die IP adresse von der Fritte geben und wenn ich eine schon zugewiesene IP anders vergeben will mache ich das so:

    • Haken bei Diesem Netzwerkgerät immer die gleiche IPv4-Adresse zuweisen welche zu dem "alten" Gerät gehört entfernen.

    • Diese "alte" Gerät herunterfahren

    • Fritte neu starten und nach neustart unter Heimnetz - Netzwerk - Ungenutzte Verbindungen das "alte" Gerät löschen

    • Nun sollte es möglich sein dem "neuen" Gerät die IP Adresse des "alten" Gerätes zuweisen zu können

    Puuuh gar nicht so einfach zu beschreiben... Ich hoffe ihr versteht mich 😉
    In Proxmox habe ich jedenfalls noch nie eine IP geändert...



Suggested Topics

  • 5
  • 4
  • 65
  • 9
  • 3
  • 1
  • 7
  • 8

1.9k
Online

32.1k
Users

38.8k
Topics

525.9k
Posts