NEWS

[gelöst] Fehler bei Installation auf Raspberry Zero



  • Hallo Leute,

    ich versuche grade eine Minimalinstallation von ioBroker für den Garten umzusetzen, scheitere jedoch schon an der Installation von ioBroker.

    Mein Vorgehen:
    Raspbian Stretch Lite auf Raspberry Zero W installiert.

    Danach noch dieser Anleitung: klick

    sudo apt-get update && sudo apt-get upgrade
    
    node -v
    nodejs -v
    npm -v
    
    wget http://nodejs.org/dist/latest-v8.x/node-v8.16.0-linux-armv6l.tar.gz
    tar -xvf node-v8.16.0-linux-armv6l.tar.gz
    cd node-v8.16.0-linux-armv6l
    sudo cp -R * /usr/local/
    sudo ln -s /usr/local/bin/node /usr/bin/nodejs
    
    node -v
    nodejs -v
    npm -v
    
    curl -sL https://raw.githubusercontent.com/ioBroker/ioBroker/stable-installer/installer.sh | bash -
    

    Steps 1 & 2 liefen gut durch, bei 3 kam ein Abbruch mit folgender Meldung:

    
    ==========================================================================
        Installing ioBroker (3/4)
    ==========================================================================
    
    npm ERR! code EAI_AGAIN
    npm ERR! errno EAI_AGAIN
    npm ERR! request to https://registry.npmjs.org/sshpk/-/sshpk-1.16.1.tgz failed, reason: getaddrinfo EAI_AGAIN registry.npmjs.org:443
    ^C
    pi@Gardenbroker:~/node-v8.16.0-linux-armv6l $
    

    Kann mir bitte jemand weiterhelfen?
    Ich vermute ja, dass es an node 8.16.0 liegt, ich weiß aber nicht, wie ich hier weiterverfahren muss.

    Besten Dank schon mal,

    Gruß Markus



  • ich habe nun nochmal alles neu aufgesetzt, diesmal aber mit

    wget http://nodejs.org/dist/v8.15.1/node-v8.15.1-linux-armv6l.tar.gz
    tar -xvf node-v8.15.1-linux-armv6l.tar.gz
    cd node-v8.15.1-linux-armv6l
    

    hier kommt dann folgender Fehler:

    ==========================================================================
        Installing ioBroker (3/4)
    ==========================================================================
    
    npm ERR! code EAI_AGAIN
    npm ERR! errno EAI_AGAIN
    npm ERR! request to https://registry.npmjs.org/toidentifier/-/toidentifier-1.0.0.tgz failed, reason: getaddrinfo EAI_AGAIN registry.npmjs.org:443
    
    

    was läuft hier falsch?



  • Nach einiger Recherche habe ich erfahren, dass dies am DNS liegen kann - erklären kann ich es nicht, aber nachdem ich die Fritzbox neugestartet, und alle Geräte, die zur Fritzbox kommunizieren, ebenfalls neugestartet hatte, lief die Installation einfach durch.

    Also falls jemand mal die o.g. Fehlermeldung bei der Installation bekommen sollte - mein Tip: Netzwerk resetten.

    Achja, als Standard DNS habe ich in der Fritzbox 8.8.8.8 eingetragen.



Suggested Topics

1.9k
Online

32.2k
Users

38.8k
Topics

526.5k
Posts