NEWS

ASTRO function. Does not work again


  • Re: Is there problem with Blockly after last update?

    After testing for many weeks I came to a conclusion that ASTRO function does not work continuously, meaning it works ones after controller physical reboot and then never execute, see my simple Blockly script in reference post. I use all latest Linux, controller and adapters updates and 8.16.0 Node.js. Any idea what is going on?

  • Most Active

    Please show your Blockly Script here, i think there is an errror in it.
    The Astro funktion works fine in my Blocklys.

    Enrico


  • Please see my script attachedLight Script.txt Light Script.JPG

  • Most Active

    What does not work, set the control level to 99 or 0, or the telegram message, or both?
    You can use debug-blocks to control the trigger-blocks.

    Enrico


  • @RappiRN As you see, I use telegram for debugging, so schedule block works all the time (the light goes on, then off and I am getting notification from telegram), while astro works only once in a while, it works for sure once after restarting RPI by interrupting the power


  • @RappiRN May be I was not clear in my response. In ASTRO block, both telegram and setting level do not work (to be precise, work once after resetting power to Raspberry PI). In SCHEDULE block telegram and level setting work fine all the time.

  • Most Active

    Ok, in the settings from the javascript-Adapter you must set your location, or check to use the ioBroker location.

    Enrico


  • @RappiRN I am aware of this and it was done. Don't forget, in my case ASTRO work right once after fresh power up, it turns up the light in expected time.

  • Most Active

    The right once working, is it also at the right time?
    Which location settings you are using, from the adapter or from ioBroker? Sometimes it was a problem to use the ioBroker settings instead the adapter settings.
    Sorry i have not really an idea what the matter with your astro-function.

    Enrico


  • @RappiRN Yes, when I say it works right once, it means the timing is right. I tried both location settings, from the adapter as well as from system with same result.


  • Have brand new ioBroker installation on different platform (x64) with same script as show above, the Astro function still does not work. What am I doing wrong?


  • @ap2017 for debuging use debug, not telegram.
    substitute telegram whith debug to see what's going on.
    Look at the LOG.
    mine works:
    c8d8d908-8721-440c-b8e0-f1d21907f888-image.png ,
    Do you wanna Post an export of your Blockly?


  • @iomountain Thank you for your response. I changed my script as you suggested, where do I find debugging log?

    1e4c6fe1-d922-40f0-9785-51ad80cee496-image.png


  • Try Log at main screen Admin
    f48dbde0-adab-4a3e-8643-a33c864a7af0-image.png
    There you will find your "debug output" Messages


  • @iomountain I think that after long time of straggling I am getting close to resolving the issue with ASTRO function that I am experiencing. It looks like ASTRO algorithm does not like GEO coordinates in North America since it started to work fine after I set ASTRO for Berlin, Germany. Maybe negative value of Longitude confuses the algorithm?

    Could you do me a favor and try your script with GEO set to Hartford CT in USA? Thank you.


  • It works, United States Hartford 41.76 -72.68
    If you wanna see all astro times try the Script

    @ap2017
    Do you wanna Post an export of your Blockly?


  • @iomountain I will try to set ASTRO back to US, thanks


  • @ap2017 don't forget to restart iobroker. Like "iobroker stop" and "iobroker start"


  • @iomountain Day I switched to US the ASTRO stopped working (no ASTRO string in LOG file). I restarted computer after I made a change. I will try your ASTRO script

    Here is my script:


  • @iomountain Here is the log from running your script Astro Time for Today, if it helps. So, script runs but shows error code at the end of each run.

Suggested Topics

713
Online

38.4k
Users

43.9k
Topics

613.2k
Posts