NEWS

  • Global Moderator

    Nachdem ich durch was auch immer (vermute Blockly mit einem falschen Baustein) einen Fehler im JS-Adapter bekommen habe, wollte ich wiedermal den Adapter von 4.0.12 auf 4.1.12 updaten.

    Node.js ist auf 8.15.1 und NPM auf 6.4.1

    Beim Update kommt folgende Fehlermeldung:

    Dann startet sich der JS-Adapter immer wieder neu.

    Dann dachte ich, ok, starte ich mal ioBroker neu.
    Brachte auch nichts, ausser dass der JS-Adapter nun garnicht mehr da war.
    Konnte auch nicht installiert werden.

    Ok, dann hab ich das Backup von heute Nacht eingespielt und ich bin wieder auf 4.0.12

    Aber, warum kann ich nicht auf 4.1.12 updaten?

    Liest von euch wer was raus?


  • @Negalein

    Hi, hast du mal versucht den Adapter über die Konsole zu installieren:

    cd /opt/iobroker
    npm install iobroker.javascript@4.1.12
    iobroker update javascript

    Ich hatte auch mal das Problem mit einer jüngeren Version und so ging es dann bei mir.

    Liebe Grüße, Hicks

  • Global Moderator

    @Hicks sagte in Update JS-Adapter 4.0.12 auf 4.1.12:

    Hi, hast du mal versucht den Adapter über die Konsole zu installieren:

    Danke, werd ich morgen versuchen.
    Muss blad weg und da hätte ich keine Zeit für noch einen Restore.

  • Global Moderator

    @Hicks sagte in Update JS-Adapter 4.0.12 auf 4.1.12:

    Hi, hast du mal versucht den Adapter über die Konsole zu installieren:

    Sorry für die Verspätung!

    Dies hat leider auch nicht funktioniert.


  • mach mal "upload" beim JS Adapter

    c012f22d-f746-4909-96f1-1267b35960fb-grafik.png

  • Global Moderator

    @MyzerAT sagte in Update JS-Adapter 4.0.12 auf 4.1.12:

    mach mal "upload" beim JS Adapter

    ist ohne Fehler durchgelaufen.

    Meinst, ich kann jetzt ein Update auf 4.1.12 wagen?


  • leider kenn ich mich da zu wenig aus, was ich rauslese, das er als error angibt die datei "io-package.json" nicht zu finden, mach mal eine suche nach dieser datei, bei mir liegt die unter

    \\DS216II\docker\iobroker_mount\node_modules\iobroker.milight-smart-light\io-package.json
    

  • @MyzerAT sagte:

    bei mir liegt die unter

    Das ist eine andere io-package.json. Jeder Adapter hat eine Datei io-package.json. Die für den JS-Adapter ist /opt/iobroker/node_modules/iobroker.javascript/io-package.json.

  • Global Moderator

    @MyzerAT sagte in Update JS-Adapter 4.0.12 auf 4.1.12:

    leider kenn ich mich da zu wenig aus, was ich rauslese, das er als error angibt die datei "io-package.json" nicht zu finden, mach mal eine suche nach dieser datei, bei mir liegt die unter

    die io-package.json liegt bei mir in jedem Adapterverzeichnis.
    Unter anderem auch in /docker/iobroker_mount/node_modules/iobroker.javascript


  • @Negalein

    Ich würde den JS-Adapter über den Expertenmodus komplett löschen, dann neu installieren und danach uploaden.

    Ist evtl. einen Versuch wert.

    LG Hicks

  • Global Moderator

    @Hicks sagte in Update JS-Adapter 4.0.12 auf 4.1.12:

    Ich würde den JS-Adapter über den Expertenmodus komplett löschen, dann neu installieren und danach uploaden.

    Ist evtl. einen Versuch wert.

    Danke, werde ich auch versuchen.

  • Global Moderator

    Da mich bis jetzt nichts weitergebracht hat, möchte ich fragen, ob noch jemand einen Tipp hat.

Suggested Topics

2.0k
Online

35.0k
Users

41.0k
Topics

562.3k
Posts