NEWS

Meine erste Raspberry Pi ioBroker-Installation



  • … klappte direkt nach Anleitung. Bin DAU, deshalb ganz langsam hier:

    1. Raspian-Image für die SD-Karte: https://www.raspberrypi.org/downloads/raspbian/ (Raspbian Stretch Lite)

    2. Raspian-Image flashen: https://www.raspberrypi.org/documentati ... /README.md (mit Etcher)

    3. SSH aktivieren für Putty usw.: https://www.raspberrypi.org/documentati ... ccess/ssh/ (weil ohne Monitor)

    4. Anmeldung mit User 'pi' und Kennwort 'raspberry' über ssh. Gleich Bild und Ton, jippie!

    5. Raspian-Konfiguration: https://www.raspberrypi.org/documentati ... -config.md (hostname und Country ändern de.UTF8)

    6. ioBroker-Voraussetzungen installieren: http://www.iobroker.net/docu/?page_id=5106&lang=de (nodejs v8, build -ssentials; sudo nicht vergessen)

    7. npm updaten: viewtopic.php?f=17&t=15306 (sudo nicht vergessen)

    8. ioBroker fertig installieren: http://www.iobroker.net/docu/?page_id=5106&lang=de (sudo nicht vergessen)

    Erst mal Daumen hoch. 😉



  • Ich war so forsch und habe das chmod 777 auf /opt/iobroker weggelassen, bitte das Nachfolgende unter diesem Blickwinkel betrachten!



  • Problemchen Javascript-Adapter:

    Hinzufügen klappt. Admin-Dialog öffnet sich. Ich musste nichts konfiguriern. Deshalb den Dialog mit "Schließen" verlassen.

    Deshalb gab es keinen Neustart des Adapters (der steht auf Autostart nach Installation).

    Und deshalb gab es keinen eintrag <skripte>im Menü. Auch nicht als ausgeschalteteten Eintrag.

    Erst nach Adapter-Neustart erschien der Eintrag im aktiven Menü wie von Zauberhand.

    Das verwirrt Anfänger. Eintrag sollte sofort erscheinen nach Installation.

    Wo liegt der Fehler: Im js-controller, Admin-Adpter oder Javascript-Adapter? Oder vor dem Rechner?</skripte>



  • Problemchen History-Adapter:

    Habe im admin-Dialog der History-Instanz einfach keine Pfad definiert. Bin DAU und kenne mich da nicht aus. Bin mit "Schließen" aus dem Admin-Diaog raus. Instanz lief.

    Konnte dann bei irgendeinem Datenpunkt die History-Konfiguration über den Schlüssel öffnen und auf 'Aktiv' setzen. Speichern wurde blau.

    Hat aber nicht gespeichert. Dialog blieb trotz Betätigung von "Speichern" offen. "Schließen" verließ den Dialog ohne etwas zu speichern (klar). Hat natürlich nichts historisiert.

    Ordner '/opt/iobroker/iobroker-data/history' war von Installation angelegt und leer.

    Habe dann den Pfad '/opt/iobroker/iobroker-data/history' im Admin-Dialog des History-Instanz eingegeben. Instanz wurde natürlich neu gestartet. Aktivieren von History für Datenpunkt hat sofort funktioniert.

    Wo liegt der Fehler: Admin-Adapter oder History-Adapter? Oder vor dem Rechner?



  • Interessante Beobachtung (letzte zwei Posts). Checken wir

    Gesendet vom Handy …



  • Installationsquelle: latest



  • @Stabilostick:

    Problemchen Javascript-Adapter:

    Hinzufügen klappt. Admin-Dialog öffnet sich. Ich musste nichts konfiguriern. Deshalb den Dialog mit "Schließen" verlassen.

    Deshalb gab es keinen Neustart des Adapters (der steht auf Autostart nach Installation).

    Und deshalb gab es keinen eintrag <skripte>im Menü. Auch nicht als ausgeschalteteten Eintrag.

    Erst nach Adapter-Neustart erschien der Eintrag im aktiven Menü wie von Zauberhand.

    Das verwirrt Anfänger. Eintrag sollte sofort erscheinen nach Installation.

    Wo liegt der Fehler: Im js-controller, Admin-Adpter oder Javascript-Adapter? Oder vor dem Rechner?</skripte> `
    Admin. Bitte issue schreiben. 😄



  • @Stabilostick:

    Problemchen History-Adapter:

    Habe im admin-Dialog der History-Instanz einfach keine Pfad definiert. Bin DAU und kenne mich da nicht aus. Bin mit "Schließen" aus dem Admin-Diaog raus. Instanz lief.

    Konnte dann bei irgendeinem Datenpunkt die History-Konfiguration über den Schlüssel öffnen und auf 'Aktiv' setzen. Speichern wurde blau.

    Hat aber nicht gespeichert. Dialog blieb trotz Betätigung von "Speichern" offen. "Schließen" verließ den Dialog ohne etwas zu speichern (klar). Hat natürlich nichts historisiert.

    Ordner '/opt/iobroker/iobroker-data/history' war von Installation angelegt und leer.

    Habe dann den Pfad '/opt/iobroker/iobroker-data/history' im Admin-Dialog des History-Instanz eingegeben. Instanz wurde natürlich neu gestartet. Aktivieren von History für Datenpunkt hat sofort funktioniert.

    Wo liegt der Fehler: Admin-Adapter oder History-Adapter? Oder vor dem Rechner? `
    Zu diesem zeit punkt währe es interessant, was da in der Browser -Konsole drin ist.

    Da bin ich auch nicht sicher ob Admin oder History. Trotzdem Bitte bei Admin Issue anlegen.



  • @Bluefox. Ich mache nochmal eine zweite Installation und erstelle wenn es nochmal passiert die Issues.



  • So, zweite Installation. Diesmal mit CHMOD 777.

    Ist es normal, das nach der Erstinstallationssequenz folgende Warnungen kommen?

    /opt/iobroker>sudo npm install iobroker --unsafe-perm
    

    […]

    host.iobrokerpi object system.adapter.discovery.0 created

    • iobroker.js-controller@1.2.3

    added 335 packages from 568 contributors and audited 2269 packages in 120.668s

    found 97 vulnerabilities (30 low, 48 moderate, 19 high)

    run npm audit fix to fix them, or npm audit for details

    packet folder is: /opt/iobroker/node_modules/iobroker.js-controller | exists: true

    Write "./iobroker start" to start the ioBroker

    Non-critical error: ENOENT: no such file or directory, open '/opt/iobroker/node_modules/iobroker/lib/../install/linux/iobroker.sh'

    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/package.json'

    npm WARN iobroker No description

    npm WARN iobroker No repository field.

    npm WARN iobroker No README data

    npm WARN iobroker No license field.

    • iobroker@1.1.2

    added 47 packages from 23 contributors and audited 77 packages in 245.157s

    found 0 vulnerabilities

    […]

    1a. Wie kommt npm darauf, dass es unter node_modules einen iobroker-Ordner geben soll? Ok, der sollt gleich am Anfang installiert werden, aber wohin ist er entschwunden? Den habe ich unter Windows, aber nicht unter Raspian. Unter node_modukes gibt es nur die Ordner iobroker.js-controller, -.admin und -.discovery.

    -> So wird das nichts mit dem Aufruf von ./install.sh

    Irgendwie hat das, was da auf der SD-Karte landet, wenig mit https://github.com/ioBroker/ioBroker zu tun….

    1b. Die install.sh unter /opt/iobroker hat da einige lustige Pfade drin. Kann natürlich ohne den iobroker-Ordner in node_modules nicht gehen:

    sudo cp /opt/iobroker/node_modules/iobroker/install/iobroker /usr/bin/
    sudo chmod 777 /usr/bin/iobroker
    sudo cp /opt/iobroker/node_modules/iobroker/install/linux/iobroker.sh /etc/init.d/
    sudo chmod 777 /etc/init.d/iobroker.sh
    sudo bash /opt/iobroker/node_modules/iobroker/install/linux/install.sh
    

    2. Unter /opt/iobroker gibt es eine 'package.json'. Wurde die von npm erst nach der Warnung erstellt?

    —Edit: Wird von setup.js mit Bedacht so angelegt.

    Inhalt:

    {
      "name": "iobroker.inst",
      "version": "1.1.2",
      "private": true,
      "description": "Automation platform in node.js",
      "dependencies": {
        "iobroker": "^1.1.2",
        "iobroker.admin": "^3.4.6",
        "iobroker.discovery": "^1.1.0",
        "iobroker.js-controller": "^1.2.3"
      }
    }
    
    

    Ein paar Versionen:

    sudo npm view iobroker version
    1.1.2
    
    pi@iobrokerpi:/opt/iobroker/node_modules $ sudo npm ls iobroker
    iobroker.inst@1.1.2 /opt/iobroker
    └── UNMET DEPENDENCY iobroker@^1.1.2
    
    npm ERR! missing: iobroker@^1.1.2, required by iobroker.inst@1.1.2
    

    node + nodejs v8.11.3

    npm 6.2.0

    <u>Mutt dat alles so? Was ist mit dem iobroker-Ordner unter Raspian? Wo kommt iobroker.inst her?</u>



  • FYI, (fast) komplettes Installationslog

    pi@iobrokerpi:/opt/iobroker $ sudo npm install iobroker --unsafe-perm
    
    > iobroker@1.1.2 install /opt/iobroker/node_modules/iobroker
    > node lib/prepareSetup.js && node lib/setup.js
    
    NPM version: 6.2.0
    npm version >= 5: disabling package-lock
    npm install iobroker.discovery@stable --production --save
    
    > serialport@4.0.7 install /opt/iobroker/node_modules/serialport
    > node-pre-gyp install --fallback-to-build
    
    node-pre-gyp info it worked if it ends with ok
    node-pre-gyp verb cli [ '/usr/bin/node',
    node-pre-gyp verb cli   '/opt/iobroker/node_modules/serialport/node_modules/.bin/node-pre-gyp',
    node-pre-gyp verb cli   'install',
    node-pre-gyp verb cli   '--fallback-to-build' ]
    node-pre-gyp info using node-pre-gyp@0.6.32
    node-pre-gyp info using node@8.11.3 | linux | arm
    node-pre-gyp verb command install []
    [...]
    make: Verzeichnis „/opt/iobroker/node_modules/serialport/build“ wird verlassen
    node-pre-gyp info ok
    npm notice created a lockfile as package-lock.json. You should commit this file.
    + iobroker.discovery@1.1.0
    added 168 packages from 112 contributors, removed 47 packages and audited 291 packages in 82.576s
    found 18 vulnerabilities (3 low, 13 moderate, 2 high)
      run `npm audit fix` to fix them, or `npm audit` for details
    packet folder is: /opt/iobroker/node_modules/iobroker.discovery | exists: true
    npm install iobroker.admin@stable --production --save
    + iobroker.admin@3.4.6
    added 183 packages from 135 contributors and audited 638 packages in 25.396s
    found 29 vulnerabilities (11 low, 13 moderate, 5 high)
      run `npm audit fix` to fix them, or `npm audit` for details
    packet folder is: /opt/iobroker/node_modules/iobroker.admin | exists: true
    npm install iobroker.js-controller@stable --production --save
    
    > unix-dgram@0.2.3 install /opt/iobroker/node_modules/unix-dgram
    > node-gyp rebuild
    
    make: Verzeichnis „/opt/iobroker/node_modules/unix-dgram/build“ wird betreten
      CXX(target) Release/obj.target/unix_dgram/src/unix_dgram.o
      SOLINK_MODULE(target) Release/obj.target/unix_dgram.node
      COPY Release/unix_dgram.node
    make: Verzeichnis „/opt/iobroker/node_modules/unix-dgram/build“ wird verlassen
    
    > iobroker.js-controller@1.2.3 install /opt/iobroker/node_modules/iobroker.js-controller
    > node iobroker.js setup first
    
    creating conf/iobroker.json
    object system.certificates created
    object system.repositories created
    object system.config created
    object enum.rooms created
    object system.group.user created
    object system.group.administrator created
    object _design/system created
    object system.meta.uuid created
    object system.user.admin created
    host.iobrokerpi install adapter admin
    npm install --production (System call) in "/opt/iobroker/node_modules/iobroker.admin"
    npm WARN invalid config loglevel="notice"
    got /opt/iobroker/node_modules/iobroker.admin/admin
    upload [3] admin.admin /opt/iobroker/node_modules/iobroker.admin/admin/words.js words.js application/javascript
    [...]
    host.iobrokerpi object system.adapter.admin.0 created
    host.iobrokerpi install adapter discovery
    npm install --production (System call) in "/opt/iobroker/node_modules/iobroker.discovery"
    npm WARN invalid config loglevel="notice"
    [...]
    got /opt/iobroker/node_modules/iobroker.discovery/admin
    upload [5] discovery.admin /opt/iobroker/node_modules/iobroker.discovery/admin/words.js words.js application/javascript
    upload [4] discovery.admin /opt/iobroker/node_modules/iobroker.discovery/admin/settings_m.html settings_m.html text/html
    upload [3] discovery.admin /opt/iobroker/node_modules/iobroker.discovery/admin/settings.html settings.html text/html
    upload [2] discovery.admin /opt/iobroker/node_modules/iobroker.discovery/admin/index_m.html index_m.html text/html
    upload [1] discovery.admin /opt/iobroker/node_modules/iobroker.discovery/admin/index.html index.html text/html
    upload [0] discovery.admin /opt/iobroker/node_modules/iobroker.discovery/admin/discovery.png discovery.png image/png
    host.iobrokerpi object system.adapter.discovery created
    host.iobrokerpi create instance discovery
    host.iobrokerpi object discovery.0.scanRunning created
    host.iobrokerpi object discovery.0.devicesFound created
    host.iobrokerpi object discovery.0.instancesFound created
    host.iobrokerpi object discovery.0.servicesProgress created
    host.iobrokerpi object discovery.0.devicesProgress created
    host.iobrokerpi object system.adapter.discovery.0.outputCount created
    host.iobrokerpi object system.adapter.discovery.0.inputCount created
    host.iobrokerpi object system.adapter.discovery.0.uptime created
    host.iobrokerpi object system.adapter.discovery.0.memRss created
    host.iobrokerpi object system.adapter.discovery.0.memHeapTotal created
    host.iobrokerpi object system.adapter.discovery.0.memHeapUsed created
    host.iobrokerpi object system.adapter.discovery.0.connected created
    host.iobrokerpi object system.adapter.discovery.0.alive created
    host.iobrokerpi object system.adapter.discovery.0 created
    + iobroker.js-controller@1.2.3
    added 335 packages from 568 contributors and audited 2269 packages in 120.668s
    found 97 vulnerabilities (30 low, 48 moderate, 19 high)
      run `npm audit fix` to fix them, or `npm audit` for details
    packet folder is: /opt/iobroker/node_modules/iobroker.js-controller | exists: true
    Write "./iobroker start" to start the ioBroker
    Non-critical error: ENOENT: no such file or directory, open '/opt/iobroker/node_modules/iobroker/lib/../install/linux/iobroker.sh'
    npm WARN enoent ENOENT: no such file or directory, open '/opt/iobroker/package.json'
    npm WARN iobroker No description
    npm WARN iobroker No repository field.
    npm WARN iobroker No README data
    npm WARN iobroker No license field.
    
    + iobroker@1.1.2
    added 47 packages from 23 contributors and audited 77 packages in 245.157s
    found 0 vulnerabilities
    
    pi@iobrokerpi:/opt/iobroker $ 
    


  • Kurze Antwort: ja das muss so. Da steckt viel Magie drin 😉

    Lange Antwort kommt morgen wenn ich an ner echten Tastatur sitze 😉

    Gesendet vom Handy …



  • Ach Quark, mir machst Du da nichts vor. Das der Ordner einmal da ist und einmal verschwindet je nach Plattform hat bestimmt nicht mit Magie zu tun 😄

    Ich sehe ja, was er prinzipiell in der setupLinux-Funktion macht und damit ist Punkt 2 beantwortet. Habe nur noch nicht gefunden, was mit dem iobroker-Ordner passiert. Und in init.d wird auch nichts angelegt.



  • Du hast recht ich habe mich falsch erinnert.Es ist wohl doch so das npm unter bestimmten voraussetzungen das wegkickt … Mal schauen was wir tun könne. Alles etwas tricky


Log in to reply
 

Suggested Topics

1.8k
Online

32.1k
Users

38.8k
Topics

525.9k
Posts