[gelöst] Objektwert in CCU2 Systemvariable schreiben



  • Ich habe eine Pluggit Lüftungsanlage, die ich über ioBroker in die HomeMatic-Heimsteuerung einbinden möchte. Glücklicherweise gibt es den Modbus-Adapter für ioBroker. Ich habe die CCU2 schon angebunden und alle Geräte, Systemvariablen etc. werden unter Objekte angezeigt. Den Modbus-Adapter habe ich auch bereits zum Laufen gebracht und er liest erfolgreich die Daten aus der Pluggit aus und zeigt alles artig an.

    Nun habe ich im WebUI der CCU2 eine neue Systemvariable angelegt, die nennt sich "Pluggit Lüfterstufe". Diese war nach der Aktualisierung auch promt in den Objekten bei ioBroker zu finden.

    Was mir schleierhaft ist, ist wie bekomme ich bei Aktualisierung/Änderung der Lüfterstufe den Wert 0,1,2,3,4 in die Systemvariable? Muss man dafür ein Skript schreiben (JavaScript ist jetzt nicht so mein Steckenpferd) oder gibt es auch eine Klickibunti-Lösung?

    Wieso überhaupt das alles?

    Ich habe Alexa über Cloudmatic. Das funktioniert auch tadellos. Nun wäre es nett, wenn man auch die Lüfterstufe von 3 (Normalzustand) auf 4 setzen kann ohne immer zum Gerät zu laufen oder die iPhone App zu bemühen. Wir haben uns schon ziemlich an die Sprachsteuerung des gesamten Hauses gewöhnt.

    Stellenwert von ioBroker?

    Ich plane aktuell nicht ioBroker für Visualisierungen zu nutzen. Ich habe den Raspberry Pi 3 mit ioBroker nur für die Ansteuerung der Lüftungsanlage angeschafft. Wenn das funktioniert schauen wir weiter.

    Kann man mit CUxD die Pluggit als Gerät in der CCU2 anlegen? Und statt der Systemvariable einen Kanal dafür nutzen? (Vlt. rede ich auch gerade Unsinn…)

    Für Tipps und Hilfestellungen wäre ich dankbar.
    1717_bildschirmfoto_2018-02-19_um_01.10.23.png
    1717_bildschirmfoto_2018-02-19_um_01.10.38.png



  • Du solltest deine Homematic spezifischen Fragen besser im Homematic Forum stellen 😄

    Das Aktualisieren der CCU SysVar geht z.B. so :

    Blocky Javascript anlegen

    • Bei Änderung Trigger ist deine Modbus Variable, die du in der CCU haben möchtest.

    • einen STEUERE Baustein anlegen, der deinen Datenpunkt der CCU mit deinem Datenpunkt des MODBUS aktualisiert.

    Dann sollte die SysVar in der CCU auch den Modbus Datenpunktwert haben….

    Etwa so :
    3351_image2.jpg

    Grüße

    Tom



  • Hi Tom,

    danke. Blocky ist also das Mittel zum Zweck. Ja das sind ja immer so Zwitterthemen beim SmartHome.

    Gruß

    mercalli12



  • Irgendwie klappt das nicht. er aktualisiert den Wert der CCU2-Systemvariable nicht. Anbei ein paar Screenshots. Wo ist mein Denkfehler?
    1717_bildschirmfoto_2018-02-19_um_23.08.36.png
    1717_bildschirmfoto_2018-02-19_um_23.08.51.png
    1717_bildschirmfoto_2018-02-19_um_23.09.02.png



  • Hallo mercalli12

    Script NICHT in "global" abspeichern.

    Nimm "common".

    Grüße



  • Ich glaube, es liegt am aktualisiere Baustein.

    Ich denke, du solltest den steuere Baustein verwenden.

    Sonst wird der Wert nicht an die CCU übertragen.

    Bin ich auch schon drauf reingefallen 😄

    Grüße

    Tom


  • Most Active

    @TomT:

    Ich glaube, es liegt am aktualisiere Baustein.

    Ich denke, du solltest den steuere Baustein verwenden.

    Sonst wird der Wert nicht an die CCU übertragen.

    Bin ich auch schon drauf reingefallen `

    Zuerst das Script aus "Global" rausnehmen, wenns dann immer noch nicht gehen sollte, kannst du das probieren!!

    Enrico



  • Es ist genau wie ihr gesagt habt. In "Common" funktioniert es jetzt. Damit die CCU2 den Wert auch übernimmt muss man aber zwingend "steuere" verwenden. Ich habe gleich noch ein zweites Skript angelegt, dass das Ganze auch in die entgegengesetzte Richtung übermittelt. Da ich mit Alexa bei der Pluggit die Lüfterstufe auf 4 schalten will.

    Danke an euch. Es ist schon erstaunlich was alles möglich ist.



  • Prima das es klappt.

    Dann bitte noch ein [gelöst] in den Betreff Deines ersten Beitrags setzen,

    Danke!

    Grüße



  • Ich habe das gleiche Problem.

    Alles beachtet, Skript im Common und "steuere" verwendet. Ich bekomme keinen Wert geschrieben. Manuell kann ich das Objekt einem Wert unter "Objekte" geben, aber nicht über das Skript…..:(

    Verwende allerdings die CCU3


  • Most Active

    Dann zeig mal dein Script!

    Enrico


Log in to reply
 

Suggested Topics

  • 13
  • 23
  • 10
  • 5
  • 27
  • 4
  • 10
  • 6

696
Online

21.1k
Users

25.6k
Topics

310.1k
Posts