NEWS

[gelöst] Zwave - keine Funktion und viele Fehler



  • ok, ich installier grad dass von oben, mal sehen ob es dann läuft,



  • so jetzt habe ich unter geräte

    1 Z-Wave.Me RaZberry Controller ZWave+ Static PC Controller [Bereit]

    nur der button bleibt gelb? neustart habe ich auch schon gemacht,

    edit: hab nun eine zwave steckdose hinzugefügt, nun ist der button grün



  • Super



  • na dann werde ich weiter probieren,

    nochmal Vielen Dank arteck und McMoneysack für eure schnelle hilfe, 😄 😄 😄 😄

    THX 🙂



  • Beim ausführen von

    Erhalte ich folgenden Fehler:

    gyp info it worked if it ends with ok
    gyp info using node-gyp@3.6.2
    gyp info using node@8.11.2 | linux | arm
    gyp info spawn /usr/bin/python2
    gyp info spawn args [ '/usr/lib/node_modules/node-gyp/gyp/gyp_main.py',
    gyp info spawn args   'binding.gyp',
    gyp info spawn args   '-f',
    gyp info spawn args   'make',
    gyp info spawn args   '-I',
    gyp info spawn args   '/opt/iobroker/node_modules/openzwave-shared/build/config.gypi',
    gyp info spawn args   '-I',
    gyp info spawn args   '/usr/lib/node_modules/node-gyp/addon.gypi',
    gyp info spawn args   '-I',
    gyp info spawn args   '/root/.node-gyp/8.11.2/include/node/common.gypi',
    gyp info spawn args   '-Dlibrary=shared_library',
    gyp info spawn args   '-Dvisibility=default',
    gyp info spawn args   '-Dnode_root_dir=/root/.node-gyp/8.11.2',
    gyp info spawn args   '-Dnode_gyp_dir=/usr/lib/node_modules/node-gyp',
    gyp info spawn args   '-Dnode_lib_file=/root/.node-gyp/8.11.2/<(target_arch)/node.lib',
    gyp info spawn args   '-Dmodule_root_dir=/opt/iobroker/node_modules/openzwave-shared',
    gyp info spawn args   '-Dnode_engine=v8',
    gyp info spawn args   '--depth=.',
    gyp info spawn args   '--no-parallel',
    gyp info spawn args   '--generator-output',
    gyp info spawn args   'build',
    gyp info spawn args   '-Goutput_dir=.' ]
    find: ‘/usr/local/include/openzwave//’: Datei oder Verzeichnis nicht gefunden
    gyp: Call to 'find /usr/local/include/openzwave// -name ZWSecurity.h | wc -l' returned exit status 0 while in binding.gyp. while trying to load binding.gyp
    gyp ERR! configure error 
    gyp ERR! stack Error: `gyp` failed with exit code: 1
    gyp ERR! stack     at ChildProcess.onCpExit (/usr/lib/node_modules/node-gyp/lib/configure.js:336:16)
    gyp ERR! stack     at emitTwo (events.js:126:13)
    gyp ERR! stack     at ChildProcess.emit (events.js:214:7)
    gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:198:12)
    gyp ERR! System Linux 4.14.34-v7+
    gyp ERR! command "/usr/bin/node" "/usr/bin/node-gyp" "configure"
    gyp ERR! cwd /opt/iobroker/node_modules/openzwave-shared
    gyp ERR! node -v v8.11.2
    gyp ERR! node-gyp -v v3.6.2
    gyp ERR! not ok 
    

    Mir scheint Goutput_dir nicht korrekt zu sein:

    find: ‘/usr/local/include/openzwave//’

    Ideen?


  • Developer

    Bissi dürftig dein Post…

    Was hast du denn ausgeführt und warum? Der Code-Block ist leer.

    Was ist dein Problem und welche Fehler erscheinen im Log?



  • Ich wollte openzwave-shared neu installieren

    und danach````
    sudo node-gyp configure

    
    Dann erhielt ich besagten Fehler.
    
    Aber mit
    

    sudo npm install --unsafe-perm --verbose -g openzwave-shared

    
    Ist das Problem gelöst


  • Hi,

    ich bekomme meinen ZWAVE Stick auch nicht zum laufen. Beim Versuch des Erzeugens einer Instanz erhalte ich folgendes:

    ! host.iobroker install adapter zwave
    ! npm install –production (System call) in "/opt/iobroker/node_modules/iobroker.zwave"
    ! npm WARN lifecycle iobroker.zwave@1.3.1~preinstall: cannot run in wd iobroker.zwave@1.3.1 node lib/preinstall.js (wd=/opt/iobroker/node_modules/iobroker.zwave)
    ! npm WARN deprecated gulp-util@3.0.8: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5
    ! npm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
    ! npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
    ! npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
    ! npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
    ! gyp WARN EACCES user "root" does not have permission to access the dev dir "/root/.node-gyp/8.15.0"
    ! gyp WARN EACCES attempting to reinstall using temporary dev dir "/opt/iobroker/node_modules/iobroker.zwave/node_modules/openzwave-shared/.node-gyp"
    ! gyp WARN install got an error, rolling back install
    ! gyp WARN install got an error, rolling back install
    ! gyp ERR! configure error
    ! gyp ERR! stack Error: EACCES: permission denied, mkdir '/opt/iobroker/node_modules/iobroker.zwave/node_modules/openzwave-shared/.node-gyp'
    ! gyp ERR! System Linux 4.14.79-v7+
    ! gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
    ! gyp ERR! cwd /opt/iobroker/node_modules/iobroker.zwave/node_modules/openzwave-shared
    ! gyp ERR! node -v v8.15.0
    ! gyp ERR! node-gyp -v v3.8.0
    ! gyp ERR! not ok
    ! npm WARN iobroker.zwave@1.3.1 license should be a valid SPDX license expression
    ! npm ERR! code ELIFECYCLE
    ! npm ERR! errno 1
    ! npm ERR! openzwave-shared@1.4.6 install: node-gyp rebuild
    ! npm ERR! Exit status 1
    ! npm ERR!
    ! npm ERR! Failed at the openzwave-shared@1.4.6 install script.
    ! npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    ! npm ERR! A complete log of this run can be found in:
    ! npm ERR! /root/.npm/_logs/2019-01-04T10_30_20_559Z-debug.log
    ! Cannot install iobroker.zwave: 1

    Jemand eine Idee, was ich noch machen kann? Habe node-gyp und so weiter wie beschrieben nachinstalliert, configure und rebuild gemacht.

    Den iobroker habe ich ansonsten über das neue Script installiert

    Danke und Gruß

    Danyo


  • Developer

    ZWave muss bei einigen über die Konsole installiert werden. Sofern bei dir mit den Berechtigungen noch alles in Ordnung ist, sollte das so gehen.

    cd /opt/iobroker
    npm i iobroker.zwave --unsafe-perm
    
    

    Kommt dabei auch ein EACCES-Fehler, dann probiere es so:

    cd /opt/iobroker
    sudo -H npm i iobroker.zwave --unsafe-perm
    
    

    Danach muss dann manuell in ioBroker noch eine Instanz hinzugefügt werden.



  • Hallo,

    danke für die Antwort. Es hat nun geklappt, mit einem abschließendem

    sudo ldconfig

    War dann auch der letzte ZWAVE Fehler weg…. Nun läuft es.... Danke.....

    Ich habe lange Zeit openhab2 genutzt und teste seit ein paar Tagen mal wieder iobroker. Ich bin wirklich sehr

    überrascht. Könnte mir vorstellen, meine Umgebung von openhab2 auf iobroker zu wechseln.

    Nur mit der Visualisierung kommt man nicht so schnell zum Erfolg, wie bei openhab, aber auch das wird zu meistern

    sein. 🙂

    Danke für die Hilfe.... 🙂

    Gruß

    Danyo


Log in to reply
 

Suggested Topics

1.8k
Online

32.4k
Users

39.0k
Topics

528.7k
Posts