NEWS

[gelöst] Zwave - keine Funktion und viele Fehler



  • Hallo zusammen,

    meine Versuche Zwave stabil zum Laufen zu bekommen schlagen alle fehl.

    Aktuell bekomme ich folgenden Log:

    ! ````
    host.iobroker 2017-12-12 17:44:21.830 info Restart adapter system.adapter.zwave.0 because enabled
    host.iobroker 2017-12-12 17:44:21.830 error instance system.adapter.zwave.0 terminated with code 0 (OK)
    host.iobroker 2017-12-12 17:44:21.829 error Caught by controller[0]: at Object.Module._extensions..js (module.js:579:10)
    host.iobroker 2017-12-12 17:44:21.829 error Caught by controller[0]: at Module._compile (module.js:570:32)
    host.iobroker 2017-12-12 17:44:21.829 error Caught by controller[0]: at Object. (/opt/iobroker/node_modules/openzwave-shared/lib/openzwave-shared.js:26:19)
    host.iobroker 2017-12-12 17:44:21.829 error Caught by controller[0]: at require (internal/module.js:20:19)
    host.iobroker 2017-12-12 17:44:21.829 error Caught by controller[0]: at Module.require (module.js:497:17)
    host.iobroker 2017-12-12 17:44:21.828 error Caught by controller[0]: at Function.Module._load (module.js:438:3)
    host.iobroker 2017-12-12 17:44:21.828 error Caught by controller[0]: at tryModuleLoad (module.js:446:12)
    host.iobroker 2017-12-12 17:44:21.828 error Caught by controller[0]: at Module.load (module.js:487:32)
    host.iobroker 2017-12-12 17:44:21.827 error Caught by controller[0]: at Object.Module._extensions..node (module.js:597:18)
    host.iobroker 2017-12-12 17:44:21.827 error Caught by controller[0]: at Error (native)
    host.iobroker 2017-12-12 17:44:21.826 error Caught by controller[0]: Error: Module version mismatch. Expected 48, got 57.
    zwave.0 2017-12-12 17:44:21.741 error Error: Module version mismatch. Expected 48, got 57. at Error (native) at Object.Module._extensions..node (module.js:597:18) at Module.load (module.js:487:32) at tryModuleLoad (module.
    zwave.0 2017-12-12 17:44:21.738 error uncaught exception: Module version mismatch. Expected 48, got 57.
    zwave.0 2017-12-12 17:44:21.625 info starting. Version 0.9.0 in /opt/iobroker/node_modules/iobroker.zwave, node: v6.12.2
    host.iobroker 2017-12-12 17:44:20.070 info instance system.adapter.zwave.0 started with pid 15126
    host.iobroker 2017-12-12 17:43:50.061 info Restart adapter system.adapter.zwave.0 because enabled
    host.iobroker 2017-12-12 17:43:50.061 error instance system.adapter.zwave.0 terminated with code 0 (OK)
    host.iobroker 2017-12-12 17:43:50.060 error Caught by controller[0]: at Object.Module._extensions..js (module.js:579:10)
    host.iobroker 2017-12-12 17:43:50.060 error Caught by controller[0]: at Module._compile (module.js:570:32)
    host.iobroker 2017-12-12 17:43:50.059 error Caught by controller[0]: at Object. (/opt/iobroker/node_modules/openzwave-shared/lib/openzwave-shared.js:26:19)
    host.iobroker 2017-12-12 17:43:50.059 error Caught by controller[0]: at require (internal/module.js:20:19)
    host.iobroker 2017-12-12 17:43:50.059 error Caught by controller[0]: at Module.require (module.js:497:17)
    host.iobroker 2017-12-12 17:43:50.059 error Caught by controller[0]: at Function.Module._load (module.js:438:3)
    host.iobroker 2017-12-12 17:43:50.058 error Caught by controller[0]: at tryModuleLoad (module.js:446:12)
    host.iobroker 2017-12-12 17:43:50.058 error Caught by controller[0]: at Module.load (module.js:487:32)
    host.iobroker 2017-12-12 17:43:50.058 error Caught by controller[0]: at Object.Module._extensions..node (module.js:597:18)
    host.iobroker 2017-12-12 17:43:50.058 error Caught by controller[0]: at Error (native)
    host.iobroker 2017-12-12 17:43:50.056 error Caught by controller[0]: Error: Module version mismatch. Expected 48, got 57.
    zwave.0 2017-12-12 17:43:50.024 error uncaught exception: Module version mismatch. Expected 48, got 57.
    zwave.0 2017-12-12 17:43:49.808 info starting. Version 0.9.0 in /opt/iobroker/node_modules/iobroker.zwave, node: v6.12.2
    host.iobroker 2017-12-12 17:43:48.253 info instance system.adapter.zwave.0 started with pid 15098
    host.iobroker 2017-12-12 17:43:18.238 info Restart adapter system.adapter.zwave.0 because enabled
    host.iobroker 2017-12-12 17:43:18.237 error instance system.adapter.zwave.0 terminated with code 0 (OK)
    Caught 2017-12-12 17:43:18.236 error by controller[0]: at Object.Module._extensions..js (module.js:579:10)
    Caught 2017-12-12 17:43:18.236 error by controller[0]: at Module._compile (module.js:570:32)
    Caught 2017-12-12 17:43:18.235 error by controller[0]: at Object. (/opt/iobroker/node_modules/openzwave-shared/lib/openzwave-shared.js:26:19)
    Caught 2017-12-12 17:43:18.235 error by controller[0]: at require (internal/module.js:20:19)
    Caught 2017-12-12 17:43:18.235 error by controller[0]: at Module.require (module.js:497:17)
    Caught 2017-12-12 17:43:18.234 error by controller[0]: at Function.Module._load (module.js:438:3)
    Caught 2017-12-12 17:43:18.234 error by controller[0]: at tryModuleLoad (module.js:446:12)
    Caught 2017-12-12 17:43:18.234 error by controller[0]: at Module.load (module.js:487:32)
    Caught 2017-12-12 17:43:18.233 error by controller[0]: at Object.Module._extensions..node (module.js:597:18)
    Caught 2017-12-12 17:43:18.233 error by controller[0]: at Error (native)
    Caught 2017-12-12 17:43:18.232 error by controller[0]: Error: Module version mismatch. Expected 48, got 57.
    zwave.0 2017-12-12 17:43:18.171 info terminating
    zwave.0 2017-12-12 17:43:18.081 error at Object.Module._extensions..js (module.js:579:10)
    zwave.0 2017-12-12 17:43:18.081 error at Module._compile (module.js:570:32)
    zwave.0 2017-12-12 17:43:18.081 error at Object. (/opt/iobroker/node_modules/openzwave-shared/lib/openzwave-shared.js:26:19)
    zwave.0 2017-12-12 17:43:18.081 error at require (internal/module.js:20:19)
    zwave.0 2017-12-12 17:43:18.081 error at Module.require (module.js:497:17)
    zwave.0 2017-12-12 17:43:18.081 error at Function.Module._load (module.js:438:3)
    zwave.0 2017-12-12 17:43:18.081 error at tryModuleLoad (module.js:446:12)
    zwave.0 2017-12-12 17:43:18.081 error at Module.load (module.js:487:32)
    zwave.0 2017-12-12 17:43:18.081 error at Object.Module._extensions..node (module.js:597:18)
    zwave.0 2017-12-12 17:43:18.081 error at Error (native)
    zwave.0 2017-12-12 17:43:18.081 error Error: Module version mismatch. Expected 48, got 57.
    zwave.0 2017-12-12 17:43:18.078 error uncaught exception: Module version mismatch. Expected 48, got 57.
    zwave.0 2017-12-12 17:43:17.810 info starting. Version 0.9.0 in /opt/iobroker/node_modules/iobroker.zwave, node: v6.12.2
    host.iobroker 2017-12-12 17:43:16.282 info instance system.adapter.zwave.0 started with pid 15087
    host.iobroker 2017-12-12 17:43:13.857 info instance system.adapter.zwave.0 terminated with code 0 (OK)
    zwave.0 2017-12-12 17:43:13.823 info terminating
    host.iobroker 2017-12-12 17:43:13.766 info stopInstance system.adapter.zwave.0 killing pid 15048
    host.iobroker 2017-12-12 17:43:13.765 info stopInstance system.adapter.zwave.0
    host.iobroker 2017-12-12 17:43:13.762 info object change system.adapter.zwave.0
    zwave.0 2017-12-12 17:42:11.445 info List of ports: [{"comName":"/dev/ttyAMA0"},{"comName":"/dev/ttyS0"}]
    zwave.0 2017-12-12 17:42:11.274 info List of ports: [{"comName":"/dev/ttyAMA0"},{"comName":"/dev/ttyS0"}]
    zwave.0 2017-12-12 17:42:10.425 info List of ports: [{"comName":"/dev/ttyAMA0"},{"comName":"/dev/ttyS0"}]
    zwave.0 2017-12-12 17:42:10.332 info List of ports: [{"comName":"/dev/ttyAMA0"},{"comName":"/dev/ttyS0"}]
    zwave.0 2017-12-12 17:42:07.689 warn No USB selected
    zwave.0 2017-12-12 17:42:07.538 info starting. Version 0.9.0 in /opt/iobroker/node_modules/iobroker.zwave, node: v6.12.2
    iobroker 2017-12-12 17:42:05.552 info exit 0
    iobroker 2017-12-12 17:42:05.530 info host.iobroker object system.adapter.zwave.0 created
    host.iobroker 2017-12-12 17:42:05.482 info instance system.adapter.zwave.0 started with pid 15048
    host.iobroker 2017-12-12 17:42:05.454 info object change system.adapter.zwave.0
    iobroker 2017-12-12 17:42:05.389 info host.iobroker object system.adapter.zwave.0.alive created
    iobroker 2017-12-12 17:42:05.353 info host.iobroker object system.adapter.zwave.0.connected created
    iobroker 2017-12-12 17:42:05.309 info host.iobroker object system.adapter.zwave.0.memHeapUsed created
    iobroker 2017-12-12 17:42:05.263 info host.iobroker object system.adapter.zwave.0.memHeapTotal created
    iobroker 2017-12-12 17:42:05.221 info host.iobroker object system.adapter.zwave.0.memRss created
    iobroker 2017-12-12 17:42:05.182 info host.iobroker object system.adapter.zwave.0.uptime created
    iobroker 2017-12-12 17:42:05.146 info host.iobroker object system.adapter.zwave.0.inputCount created
    iobroker 2017-12-12 17:42:05.112 info host.iobroker object system.adapter.zwave.0.outputCount created
    iobroker 2017-12-12 17:42:05.069 info host.iobroker object zwave.0.info created
    iobroker 2017-12-12 17:42:05.035 info host.iobroker object zwave.0.info.connection created
    iobroker 2017-12-12 17:42:05.000 info host.iobroker object zwave.0.info.controllerMessage created
    iobroker 2017-12-12 17:42:04.965 info host.iobroker object zwave.0.info.driverReady created
    iobroker 2017-12-12 17:42:04.930 info host.iobroker object zwave.0.info.scanCompleted created
    iobroker 2017-12-12 17:42:04.895 info host.iobroker object zwave.0.info.libraryVersion created
    iobroker 2017-12-12 17:42:04.857 info host.iobroker object zwave.0.info.libraryTypeName created
    iobroker 2017-12-12 17:42:04.815 info host.iobroker object zwave.0.info.controllerNodeId created
    iobroker 2017-12-12 17:42:04.782 info host.iobroker object zwave.0.info.SUCNodeId created
    iobroker 2017-12-12 17:42:04.749 info host.iobroker object zwave.0.info.primaryController created
    iobroker 2017-12-12 17:42:04.699 info host.iobroker object zwave.0.info.staticUpdateController created
    iobroker 2017-12-12 17:42:04.659 info host.iobroker object zwave.0.info.bridgeController created
    iobroker 2017-12-12 17:42:04.605 info host.iobroker object zwave.0.info.homeId created
    iobroker 2017-12-12 17:42:04.567 info host.iobroker object zwave.0.info.OZW created
    iobroker 2017-12-12 17:42:04.516 info host.iobroker object zwave.0.inclusionOn created
    iobroker 2017-12-12 17:42:04.483 info host.iobroker object zwave.0.exclusionOn created
    iobroker 2017-12-12 17:42:04.464 info host.iobroker create instance zwave
    iobroker 2017-12-12 17:42:01.884 info add zwave

    
    Ich habe mehrfach den Zwave Adapter deinstalliert, reboot und wieder installiert.
    
    Node Version 6.12 (Downgrade von 8)
    
    NPM Version 3.10
    
    ZWave Modul im Raspberry aufgesteckt
    
    Ich habe schon folgende Anleitung befolgt:
    
    [http://forum.iobroker.net/viewtopic.php … ave#p72712](http://forum.iobroker.net/viewtopic.php?f=22&t=6988&p=72712&hilit=apt+get+zwave#p72712)
    
    Danke für Eure wirklich großartige Hilfe, bin schon Pro Mitglied, weil sowas muss unterstützt werden.
    
    Liebe Grüße
    
    Mc

  • Developer Most Active

    Error: Module version mismatch. Expected 48, got 57.

    da ist irgendwo noch was von der 8-ter Version übrig

    ls -l /usr/local/bin/node*
    ls -l /usr/bin/node*
    

    poste mal das ergebniss



  • Guten Morgen Arteck,

    danke für deine Hilfe.

    Deine Befehle erzeugen folgendes Ergebnis:

    root@iobroker:~# ls -l /usr/bin/node*
    -rwxr-xr-x 1 root root 21533460 Dez  8 19:27 /usr/bin/node
    lrwxrwxrwx 1 root root       24 Dez 11 09:20 /usr/bin/nodejs -> /etc/alternatives/nodejs
    
    

    Als Linux Anfänger kann ich damit nicht so wirklich was anfangen 🙂

    Liebe Grüße

    Mc


  • Developer Most Active

    das sind 2 Befehle… also nochmal

    erst

    ls -l /usr/local/bin/node*
    ````enter
    
    ergebniss posten


  • Sind die Ergebnisse aus beiden 😉

    Ist wahrscheinlich blöd aus Putty kopiert.

    Aber kann ich heute Abend noch mal nachreichen.

    Liebe Grüße

    Mc



  • So, jetzt aber:

    root@iobroker:~# ls -l /usr/local/bin/node*
    -rwxr-xr-x 1 root root 27179452 Dez 10 23:10 /usr/local/bin/node
    root@iobroker:~# ls -l /usr/bin/node*
    -rwxr-xr-x 1 root root 21533460 Dez  8 19:27 /usr/bin/node
    lrwxrwxrwx 1 root root       24 Dez 11 09:20 /usr/bin/nodejs -> /etc/alternatives/nodejs
    
    

    Danke Dir (Euch)!

    Liebe Grüße

    Mc


  • Developer Most Active

    da ist keine definierte version vorhanden

    mach mal nach und nach

    rm -f /usr/local/lib/libopenzwave*
    rm -f /usr/local/lib64/libopenzwave*
    rm -rf /usr/local/include/openzwave
    
    cd /opt
    curl -L -O https://github.com/OpenZWave/open-zwave/archive/master.zip
    rm -rf open-zwave-master
    unzip master.zip && rm master.zip
    cd open-zwave-master 
    make && sudo make install
    
    cd /opt/iobroker/node_modules/iobroker.zwave/node_modules/openzwave-shared
    # oder wenn der nicht existiert im Ordner
    cd /opt/iobroker/node_modules/openzwave-shared
    npm install -g node-gyp
    node-gyp configure
    node-gyp rebuild
    


  • Arteck! Du bist der Hammer 🙂

    Danke Dir vielmals. Jetzt wird sogar endlich mein Aeotec Multisensor 5 erkannt freu

    Ich hoffe sehr, dass dieses Forum den Support auch halten kann, wenn iobroker noch mehr User bekommt.

    Liebe Grüße

    Mc


  • Developer Most Active

    sehr schön



  • Hallo,

    ich habe auch probleme mit dem z-wave adapter auf meinem raspi 3, ich habe über putty die sachen von arteck installiert, leider läuft es trozdem nicht richtig, ich bekomme beim z-wave adapter nur ein gelbes symbol:

    verbunden mit host: wahr

    lebenszeichen: wahr

    verbunden mit zwave: falsch

    gehe ich in der konfiguration auf geräte hinzufügen kommt z-wave treiber is not running,


  • Developer Most Active

    ein wenig dürftig deine Aussagen..

    ist den dein zwave Stick richtig erkannt worden ??



  • wie kann ich dass überprüfen ob das z-wave modul erkannt wurde? ich habe kein dass eingebaute modul, kein usb

    gebe ich folgende befehle ein kommt dass:

    root@raspberrypi:/home/pi# ls -l /usr/local/bin/node*

    ls: Zugriff auf '/usr/local/bin/node*' nicht möglich: Datei oder Verzeichnis nicht gefunden

    root@raspberrypi:/home/pi# ls -l /usr/bin/node*

    -rwxr-xr-x 1 root root 21533036 Jan 2 20:26 /usr/bin/node

    lrwxrwxrwx 1 root root 44 Jan 3 15:01 /usr/bin/node-gyp -> ../lib/node_modules/node-gyp/bin/node-gyp.js

    lrwxrwxrwx 1 root root 24 Jan 2 22:48 /usr/bin/nodejs -> /etc/alternatives/nodejs

    im log stehen ein haufen fehlermeldungen:

    ! zwave.0 2018-01-03 16:06:23.920 error at Object.Module._extensions..js (module.js:579:10)
    ! zwave.0 2018-01-03 16:06:23.920 error at Module._compile (module.js:570:32)
    ! zwave.0 2018-01-03 16:06:23.920 error at Object. (/opt/iobroker/node_modules/iobroker.zwave/node_modules/openzwave-shared/lib/openzwave-shared.js:26:19)
    ! zwave.0 2018-01-03 16:06:23.920 error at require (internal/module.js:20:19)
    ! zwave.0 2018-01-03 16:06:23.920 error at Module.require (module.js:497:17)
    ! zwave.0 2018-01-03 16:06:23.920 error at Function.Module._load (module.js:438:3)
    ! zwave.0 2018-01-03 16:06:23.920 error at tryModuleLoad (module.js:446:12)
    ! zwave.0 2018-01-03 16:06:23.920 error at Module.load (module.js:487:32)
    ! zwave.0 2018-01-03 16:06:23.920 error at Object.Module._extensions..node (module.js:597:18)
    ! zwave.0 2018-01-03 16:06:23.920 error at Error (native)
    ! zwave.0 2018-01-03 16:06:23.920 error Error: libopenzwave.so.1.4: cannot open shared object file: No such file or directory
    ! zwave.0 2018-01-03 16:06:23.917 error uncaught exception: libopenzwave.so.1.4: cannot open shared object file: No such file or directory



  • Hi,

    hast du schon die Einstellungen für das Modul gemacht?

    Nimm diese Anleitung:

    https://wiki.fhem.de/wiki/Raspberry_Pi_ … _Bluetooth

    Danach nochmal die Artec Anleitung und reboot.

    LG

    Mc



  • @McMoneysack

    bei schritt 2 nach deiner anleitung

    sudo nano /boot/cmdline.txt

    Diese Zeile suchen:

    dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

    die ist auch da, aber der eintrag was entfernt werden soll ( console=serial0,115200 ) ist da nicht vorhanden?



  • Wenn er nicht da ist, brauchst ihn auch nicht entfernen 😉



  • ok, ich installier grad dass von oben, mal sehen ob es dann läuft,



  • so jetzt habe ich unter geräte

    1 Z-Wave.Me RaZberry Controller ZWave+ Static PC Controller [Bereit]

    nur der button bleibt gelb? neustart habe ich auch schon gemacht,

    edit: hab nun eine zwave steckdose hinzugefügt, nun ist der button grün



  • Super



  • na dann werde ich weiter probieren,

    nochmal Vielen Dank arteck und McMoneysack für eure schnelle hilfe, 😄 😄 😄 😄

    THX 🙂



  • Beim ausführen von

    Erhalte ich folgenden Fehler:

    gyp info it worked if it ends with ok
    gyp info using node-gyp@3.6.2
    gyp info using node@8.11.2 | linux | arm
    gyp info spawn /usr/bin/python2
    gyp info spawn args [ '/usr/lib/node_modules/node-gyp/gyp/gyp_main.py',
    gyp info spawn args   'binding.gyp',
    gyp info spawn args   '-f',
    gyp info spawn args   'make',
    gyp info spawn args   '-I',
    gyp info spawn args   '/opt/iobroker/node_modules/openzwave-shared/build/config.gypi',
    gyp info spawn args   '-I',
    gyp info spawn args   '/usr/lib/node_modules/node-gyp/addon.gypi',
    gyp info spawn args   '-I',
    gyp info spawn args   '/root/.node-gyp/8.11.2/include/node/common.gypi',
    gyp info spawn args   '-Dlibrary=shared_library',
    gyp info spawn args   '-Dvisibility=default',
    gyp info spawn args   '-Dnode_root_dir=/root/.node-gyp/8.11.2',
    gyp info spawn args   '-Dnode_gyp_dir=/usr/lib/node_modules/node-gyp',
    gyp info spawn args   '-Dnode_lib_file=/root/.node-gyp/8.11.2/<(target_arch)/node.lib',
    gyp info spawn args   '-Dmodule_root_dir=/opt/iobroker/node_modules/openzwave-shared',
    gyp info spawn args   '-Dnode_engine=v8',
    gyp info spawn args   '--depth=.',
    gyp info spawn args   '--no-parallel',
    gyp info spawn args   '--generator-output',
    gyp info spawn args   'build',
    gyp info spawn args   '-Goutput_dir=.' ]
    find: ‘/usr/local/include/openzwave//’: Datei oder Verzeichnis nicht gefunden
    gyp: Call to 'find /usr/local/include/openzwave// -name ZWSecurity.h | wc -l' returned exit status 0 while in binding.gyp. while trying to load binding.gyp
    gyp ERR! configure error 
    gyp ERR! stack Error: `gyp` failed with exit code: 1
    gyp ERR! stack     at ChildProcess.onCpExit (/usr/lib/node_modules/node-gyp/lib/configure.js:336:16)
    gyp ERR! stack     at emitTwo (events.js:126:13)
    gyp ERR! stack     at ChildProcess.emit (events.js:214:7)
    gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:198:12)
    gyp ERR! System Linux 4.14.34-v7+
    gyp ERR! command "/usr/bin/node" "/usr/bin/node-gyp" "configure"
    gyp ERR! cwd /opt/iobroker/node_modules/openzwave-shared
    gyp ERR! node -v v8.11.2
    gyp ERR! node-gyp -v v3.6.2
    gyp ERR! not ok 
    

    Mir scheint Goutput_dir nicht korrekt zu sein:

    find: ‘/usr/local/include/openzwave//’

    Ideen?


Log in to reply
 

Suggested Topics

2.1k
Online

32.3k
Users

39.0k
Topics

528.0k
Posts