NEWS

Bei Sonnenuntergang/Aufgang Sensor aktiv/Deaktiv geht nicht

  • Starter

    @EFE

    hier mal der Code, setze bitte sein Sensor als Trigger ein sowie Datenpunkt zum schalten

    <xml xmlns="https://developers.google.com/blockly/xml">
     <block type="on_ext" id="bf~J8y:b8w:W5sEDd}c6" x="288" y="237">
       <mutation xmlns="http://www.w3.org/1999/xhtml" items="1"></mutation>
       <field name="CONDITION">ne</field>
       <field name="ACK_CONDITION"></field>
       <value name="OID0">
         <shadow type="field_oid" id="NK1FOoTLY.tTAm|%:RE_">
           <field name="oid">default</field>
         </shadow>
       </value>
       <statement name="STATEMENT">
         <block type="controls_if" id="q!jYdn2%*Mj8f$ZQUF^0">
           <mutation elseif="1"></mutation>
           <value name="IF0">
             <block type="time_compare_ex" id="g{CVtu1g@^}ZxJ_j{wU,">
               <mutation xmlns="http://www.w3.org/1999/xhtml" end_time="true" actual_time="true"></mutation>
               <field name="USE_ACTUAL_TIME">TRUE</field>
               <field name="OPTION">between</field>
               <value name="START_TIME">
                 <shadow type="text" id="y`@AculL@]$doAQ`o`W!">
                   <field name="TEXT">12:00</field>
                 </shadow>
                 <block type="time_astro" id="bu~J@y4VENU.S1o4kCmq">
                   <field name="TYPE">sunset</field>
                   <field name="OFFSET">0</field>
                 </block>
               </value>
               <value name="END_TIME">
                 <shadow type="text" id="u(b9eluQp%wWCPby_-0Y">
                   <field name="TEXT">18:00</field>
                 </shadow>
                 <block type="time_astro" id="fi,.KCjH#7fc+,{^FF`t">
                   <field name="TYPE">sunrise</field>
                   <field name="OFFSET">0</field>
                 </block>
               </value>
             </block>
           </value>
           <statement name="DO0">
             <block type="control" id="uUrim$zi:~afE*HYJlxU">
               <mutation xmlns="http://www.w3.org/1999/xhtml" delay_input="false"></mutation>
               <field name="OID">Object ID</field>
               <field name="WITH_DELAY">FALSE</field>
               <value name="VALUE">
                 <block type="logic_boolean" id="%wb1o7V=:,8mEpO--cTK">
                   <field name="BOOL">TRUE</field>
                 </block>
               </value>
             </block>
           </statement>
           <value name="IF1">
             <block type="logic_operation" id="[iliyVUAMn9f/A.#3EN|">
               <field name="OP">AND</field>
               <value name="A">
                 <block type="on_source" id="6{zyt5m0:tmjC^h2,E;?">
                   <field name="ATTR">state.val</field>
                 </block>
               </value>
               <value name="B">
                 <block type="logic_boolean" id="Z*:bBzl:o]OpHVOHLy+m">
                   <field name="BOOL">FALSE</field>
                 </block>
               </value>
             </block>
           </value>
           <statement name="DO1">
             <block type="control" id="PfOUkV2McimqR09H5w:;">
               <mutation xmlns="http://www.w3.org/1999/xhtml" delay_input="false"></mutation>
               <field name="OID">Object ID</field>
               <field name="WITH_DELAY">FALSE</field>
               <value name="VALUE">
                 <block type="logic_boolean" id="Q-cX]=F;SS5P)R*V=CE.">
                   <field name="BOOL">TRUE</field>
                 </block>
               </value>
             </block>
           </statement>
         </block>
       </statement>
     </block>
    </xml>
    

    dc41cd4e-cbde-45d0-89f0-ed00def0d013-grafik.png


  • @canim sagte:

    hier mal der Code

    • "zwischen SU und SA" (Tag übergreifend) funktioniert nicht
    • Wert und falsch ergibt immer false
  • Starter

    @paul53 echt ?, habs nicht ausprobiert, klingt aber vom programmieren her logisch.

  • Starter

    @canim @paul53 blokly funtioniert leider nicht


  • @EFE sagte:

    blokly funtioniert leider nicht

    Welches ? Nimm das:

  • Starter

    @paul53 von @canim ich dachte das die gleich sind , bauemal kurz um auf deins .....melde mich gleich


  • @EFE sagte:

    ich dachte das die gleich sind

    Dann hätte ich mir die Bemerkungen dazu sparen können.

  • Starter

    @paul53 hab nicht aufgepasst aber funktioniert wunderbar !
    Das heißt zB. SA 8 Uhr und SU 17 Uhr keine Funktion richtig?


  • @EFE sagte:

    SA 8 Uhr und SU 17 Uhr keine Funktion richtig?

    Ja, zwischen SA und SU erfolgt keine Reaktion.

  • Starter

    @paul53 super genau das wollte ich .
    Ich danke dir für deine schnelle Unterstützung @canim danke auf für deine Mühe

  • Starter

    hi @paul53 erst mal frohe Weihnacht , ich hab noch eine frage!
    Screenshot at Dez. 27 15-35-01.png
    dieser Blockly arbeitet wunderbar aber eine Kleinigkeit ist da noch.

    Öffne ich die Türe vor SA geht die Gartenbeleuchtung an die Türe ist sagen wir mal 30min auf inzwischen ist die SA Zeit aktiviert geht die Beleuchtung nicht mehr aus wenn ich die Türe schließe oder öffne. Diese ist dauerhaft an .
    Reagiert dann erst wieder nach SU auf den Kontakt.

    Ich würde gerne noch eine Kontrolle einbauen , so das wenn SA erfolgt , Blockly guckt Fals ist AN dann Beleuchtung AUS
    bei SU ist es egal da muss ich kurz die Türe zu und Aufmachen dann geht die Beleuchtung an.


  • @EFE sagte:

    wenn SA erfolgt , Blockly guckt Fals ist AN dann Beleuchtung AUS

    Zusätzlichen Astro-Trigger bei SA: Licht aus.

    Blockly_temp.JPG

  • Starter

    @paul53 danke habs mal eingebauten melde h morgen fürs Feedback

Suggested Topics

1.7k
Online

34.9k
Users

40.9k
Topics

561.4k
Posts