NEWS

Status ioBroker und Node.js 12.x



  • Hi All,

    weil öfters mal die Frage kommt in wieweit ioBroker mit Node.js 12.x nutzbar ist habe ich mal wieder einen Check gemacht. Der Stand ist sehr gut:

    Es sind exakt 4 Adapter die noch nicht kompatibel sind
    Hier kann ich nicht zu 100% sagen das auch immer alles tut, aber die Adapter lassen sich jedenfalls sauber und erfolgreich installieren und starten. Es könnte aber im einen oder anderen Spezialfall vllt doch noch zu Problemen kommen, bisher wurde da aber nichts gemeldet.

    Der js-controller ist in jedem Fall mit Nodejs 12.x kompatibel.

    • yahka (4256 Installs): GitHub Version 0.11.0 ist ebenfalls bereits kompatibel und kommt die Tage ins Latest repository
    • amazon-dash (929 Installs): Im latest Repo gibt es bereits eine 1.1.0 die Unterstützung bietet
    • wetty (332 Installs) ist bereits nicht mit Nodejs 10 kompatibel. Da muss man in die Updates der Dependencies noch Arbeit reinstecken weil sich dort viel verändert hat
    • piface (39 Installs) braucht ebenso dependency updates

    Der Rest sollte ok sein.

    Mit dem vorauss. im April kommenden js-controller 3.0 wird die Unterstützung für Node.js 8 entfallen und ich denke das wir Node.js 12 als "Empfohlen" deklarieren werden. Bis dahin sollten mindestens die ersten zwei der vier obigen Adapter auch im Stable in kompatiblen Versionen verfügbar sein.

    Wer seine Node.js Version aktualisieren will sollte bitte weiterhin den Artikel https://forum.iobroker.net/topic/22867/how-to-node-js-für-iobroker-richtig-updaten beachten und befolgen!

    Ingo



  • Push post


Log in to reply
 

Suggested Topics

  • 1
  • 1
  • 1
  • 1
  • 1
  • 2
  • 11
  • 2

1.3k
Online

28.7k
Users

35.6k
Topics

471.2k
Posts