NEWS

Hoher CPU-Load des Raspberry


  • Ich habe jetzt nicht direkt eine Lösung für Dein Problem.

    Aber ich hatte genau das selbe Verhalten wie Du es beschreibst. Mehrere Minuten kein Zugriff auf das System. System kommt nach Neustart nicht auf die Füße. Arbeiten in VIS System hängt sich auf, etc. Ich hatte einen Rasperry PI 3 im Einsatz.

    Ich habe dann auf Multihost umgeschwenkt. Habe auf dem Master alle notwendigen Adapter (REGA, RPC, Admin, etc ist beschrieben im Beitrag siehe Link), alle anderen auf dem Slave. Vorallem der javascript Adapter hat bei mir viele Ressourcen gebraucht.

    http://forum.iobroker.net/viewtopic.php?f=8&t=9534

    1304_screenshot_235.jpg
    Die geringere Uptime vom Master ist vorhanden, da ich das System runtergefahren hatte um auf einen zweiten Master (Master Restore) den ich noch habe als Sicherung, ein Backup eingespielt habe. Die Uptime vom Slave wäre auch höher, da ist ein Stromausfall dazwischen gekommen.

    Seitdem ich die Aufteilung gemacht habe, laufen die Kisten ohne Probleme super stabil. Kein Vergleich zu vorher. Dabei ist Redis noch nicht mal aktiv, da ich mit der Sicherung der States in Redis noch auf Kriegsfuß stehe.

    Solltest Dir vielleicht Gedanken machen ob Du bereit bist in einen zweiten Raspi zu investieren. Bei mir hat es sich auf jeden Fall richtig gelohnt

    Gruß Zippolighter


  • Ja danke für den Tip, das habe ich auch schon vorbereitet. Der Slave ist schon aktiv, bin nur noch nicht dazu gekommen da das jetzige Problem dazwischenkam. Hatte ich einem Beitrag weiter oben auch erwähnt.


  • @crepp:

    @apollon77

    Habe das syslog von gestern mal durchgeforstet. Insgesamt 17 Fundstellen dieses Begriffs. Heisst das jetzt das das Problem mit dem Swapping zusammenhängt ? `

    Jain. Es heißt erstmal nur das -in dem Screenshot Fall aus Sicht des os der hm-rpc Prozess vom iobroker der Verursacher von hohem Speicherverbrauch war. Erstmal nur ein Indiz.

    Steht hm-rpc bei allen Fundstellen?


  • Nein es sind verschiedene Fehlerursachen.

    sshd

    rpi2

    radar

    hm-rpc

    kthreadd

    siehe Datei (Ich hab mal ein paar Einträge zusammengefasst)
    686_syslog.txt


  • Dann musst du auf Häufungen schauen. Das os erwischt nichts immer den hauptverursacher … falls es den in deinem Fall überhaupt gibt.


  • hm-rpc 1x

    sshd 8x

    radar 1x

    kthreadd 2x

    cron 4x

    rpi2 1x


  • Kann jemand sagen was sshd für ein Prozess ist ? Zugriff über SSH ?


  • Hab gegen 11 den javascript adapter abgeschaltet und im vis etwas gemacht. Aktuell sieht es so aus:
    686_speicher.png

    Vielleicht doch ein Speicher-Problem ?


  • nimm mal bitte normales "top". htop zeigt komische Dinge an


  • Ich habe gestern ein Image der Karte gezogen und danach war das Problem (erstmal ?) verschwunden. Ich konnte eine Stunde im vis werkeln und der Load ging nicht über 2-2,5. - sehr verwunderlich …

    Ich werde das natürlich weiter im Auge behalten.

    Danke für Eure Hilfe erstmal

  • Forum Testing Most Active Global Moderator Administrators

    @crepp:

    sehr verwunderlich `
    Nö.

    Wenn die Karte einen Schlag weg hatte und bei schreibvorgängen zu langsam war eben nicht.

    Gruß Rainer


  • Hi,

    ich habe auch täglich (zu unterschiedlichen Uhrzeiten) einen Absturz aufgrund zu hoher Temperatur.

    Bisher konnte ich nur 1x zum entsprechenden Zeitpunkt mit putty draufschauten.

    top zeigte mir den javascript und den history adapter mit sehr hoher CPU Load an.

    Ich habe die beiden mal angehalten. Seitdem scheint es zu laufen.

    Aber gibt es die Möglichkeit, die CPU Last eines einzelnen Tasks mitzuschreiben?

    Also ich hätte quasi gerne einen Mitschrieb der beiden o.g. Adapter. geht das?

  • Forum Testing Most Active Global Moderator Administrators

    Ich prüfe so ziemlich alles
    144_20180826_152248.jpg
    Top (Tabelle rechts unten, rot umrahmt) gibt die cpu und speicherauslastung für jeden Prozess an.

    Die System Load enthält aber auch noch die I/O Vorgänge.

    So kann bei niedriger CPU Auslastung die Load trotzdem sehr hoch srin, wenn z.b. die sd karte sehr langsam ist.

    Gruß Rainer


  • Danke dir.

    Das ist ja quasi meine top abfrage die ich geamcht habe.

    Aber ich kann ja nicht ständig den Screen beobachten.

    Daher möchte ich gerne eine Verlaufsaufzeichnung der CPU Last für die beiden Prozesse.

    Wenn dann der Pi abstürzt, kann ich im Verlauf oder dem GRaphen nachsehen welcher Prozess zum Zeitpunkt des Absturzes am aktivsten war.

  • Forum Testing Most Active Global Moderator Administrators

    Die drei werte in den blau umrandeten gauges logge ich auch.

    Das json, das in der Tabelle dargestellt wird kann prinzipiell auch geloggt werden (alst text) oder die Werte müssten extrahiert werden.

    Aber wie ich dir vorsichtig klarmachen wollte spiegelt ein hoher Wert der Load nicht unbedingt eine hohe cpu Auslastung wider.

    Gruß Rainer


  • Hmm ok.

    Ich habe jetzt auf jeden Fall herausgefunden dass der History Adapter für meine Hohe Auslastung verantwortlich ist.

    Warum der node da so oft aufgeführt wird… Keine Ahnung !? 😐

    Die CPU-Last ist wirklich nicht unbedingt das Problem, eher die Load an sich.

    7541_2018-08-29_09_00_12-pi_iobroker-raspi___.png

    Die SD karte sollte aber durch meine Einstellungen doch nicht zu stark belastet werden.

    Zumal ich gerade mal 10 Datenpunkte mit dem History Adapter logge.

    In den geloggten Datenpunkten habe ich folgende Einstellungen:
    7541_2018-08-29_09_01_31-objects_-_iobroker.png

  • Forum Testing Most Active Global Moderator Administrators

    @aleks-83:

    Warum der node da so oft aufgeführt wird… `
    Das ist nicht gut. Auch die hohen PID deuten auf dauernde Neustarts hin.

    Einfach nur node steht da, wenn ein Adapter noch nicht vollkommen geladen ist.

    Außerdem swapped dein Raspi. Das erhöht auch die Load

    Gruß

    Rainer


  • Was kann ich dagegen tun?

  • Forum Testing Most Active Global Moderator Administrators

    Ich würde erst einmal rebooten und dann top eine zeitlang beobachten.


  • Es kann sein dass ein reboot wirklich nötig war. Ich hatte gerade ein paar Adapter reaktiviert.

    Nach einem reboot und gut 1h Laufen lassen sieht der top so aus:
    7541_2018-08-29_10_22_26-pi_iobroker-raspi___.png

    Load ist deutlich runter gegangen.

    Aber node wird zwischendurch immer wieder aufgerufen.

    Die PID ist nun in 1h halb so hoch wie vorher in 30 min.

    Ist das immer noch zu viel?

Suggested Topics

1.9k
Online

36.9k
Users

42.6k
Topics

591.5k
Posts