NEWS

Nodejs v8.x unter Buster


  • Forum Testing Most Active Global Moderator Administrators

    Aufmerksam gemacht durch die ersten User mit einem RaspberryPi 4, bei denen es Probleme mit der Installation von Node 8 gab haben wir uns damit näher beschäftigt.

    Ich habe heute meinen RasPi4 gekauft und konnte es nachvollziehen:

    • Auch wenn man nach der Anleitung node.js 8.x installieren will bekommt man node 10
    • Bei dieser Installation ist kein npm dabei
    • installiert man es nach erhält man npm 5.8.0

    Die offizielle Lesart ist daher:

    Unter Debian Buster geht nur noch node 10

    Warum?
    Im Buster-Repository liegt bereits node 10 vor, jedoch eine ältere Version und dazu noch ohne npm. Der Aufruf mit curl ... 8.x... fügt ein weiteres Repo hinzu, genommen wird aber immer die neuste Version.

    Kein npm
    Wenn zuvor mit curl...10.x.. das nodesource Repository hinzufügt klappt alles.
    Jetzt wird mit dem Befehl apt install nodejs node v10.16.0 (Stand jetzt) und npm v6.9.0 installiert

    Viel Spaß mit Buster



Suggested Topics

948
Online

27.8k
Users

34.6k
Topics

456.3k
Posts