NEWS

Не устанавливается Iobroker под Windows


  • Всем привет, помогите плиз

    Iobroker под Windows 10, раньше работал нормально, потом почему-то перестал

    Удаляю стандартно через Control Panel

    Пробую ставить заново отсюда http://www.iobroker.net/docu/?ddownload=2614

    В процессе установки черный экран с логами установки быстро закрывается, я не успеваю посмотреть какую ошибку дает.

    В результате создается только пустой каталог etc и файлы uninstall

    8264_iobroker.png

    Где можно найти логи, что ему не нравится при установке?

    Спасибо большое


  • Нашла логи

    тут лежат C:\Users%user%\AppData\Roaming\npm-cache_logs

    Но ничего не поняла, ошибка

    1283 verbose node v8.11.3
    1284 verbose npm  v6.4.1
    1285 error code ELIFECYCLE
    1286 error errno 4
    1287 error iobroker@1.1.2 install: `node lib/prepareSetup.js && node lib/setup.js`
    1287 error Exit status 4
    1288 error Failed at the iobroker@1.1.2 install script.
    1288 error This is probably not a problem with npm. There is likely additional logging output above.
    1289 verbose exit [ 4, true ]
    

    Помогите плжст!

    ! 0 info it worked if it ends with ok
    ! 1 verbose cli [ 'C:\Program Files\nodejs\node.exe',
    ! 1 verbose cli 'C:\Users\TATIANA\AppData\Roaming\npm\node_modules\npm\bin\npm-cli.js',
    ! 1 verbose cli 'install',
    ! 1 verbose cli 'iobroker',
    ! 1 verbose cli '–prefix',
    ! 1 verbose cli 'd:\ioBroker' ]
    ! 2 info using npm@6.4.1
    ! 3 info using node@v8.11.3
    ! 4 verbose npm-session 2f3d304f384caf34
    ! 5 silly install loadCurrentTree
    ! 6 silly install readGlobalPackageData
    ! 7 http fetch GET 304 https://registry.npmjs.org/iobroker 384ms (from cache)
    ! 8 silly pacote tag manifest for iobroker@latest fetched in 401ms
    ! 9 timing stage:loadCurrentTree Completed in 608ms
    ! 10 silly install loadIdealTree
    ! 11 silly install cloneCurrentTreeToIdealTree
    ! 12 timing stage:loadIdealTree:cloneCurrentTree Completed in 0ms
    ! 13 silly install loadShrinkwrap
    ! 14 timing stage:loadIdealTree:loadShrinkwrap Completed in 0ms
    ! 15 silly install loadAllDepsIntoIdealTree
    ! 16 silly resolveWithNewModule iobroker@1.1.2 checking installable status
    ! 17 http fetch GET 304 https://registry.npmjs.org/semver 62ms (from cache)
    ! 18 silly pacote range manifest for semver@^5.5.0 fetched in 62ms
    ! 19 silly resolveWithNewModule semver@5.6.0 checking installable status
    ! 20 http fetch GET 304 https://registry.npmjs.org/yargs 131ms (from cache)
    ! 21 silly pacote range manifest for yargs@^7.0.2 fetched in 131ms
    ! 22 silly resolveWithNewModule yargs@7.1.0 checking installable status
    ! 23 http fetch GET 304 https://registry.npmjs.org/camelcase 89ms (from cache)
    ! 24 silly pacote range manifest for camelcase@^3.0.0 fetched in 89ms
    ! 25 silly resolveWithNewModule camelcase@3.0.0 checking installable status
    ! 26 http fetch GET 304 https://registry.npmjs.org/decamelize 89ms (from cache)
    ! 27 silly pacote range manifest for decamelize@^1.1.1 fetched in 89ms
    ! 28 silly resolveWithNewModule decamelize@1.2.0 checking installable status
    ! 29 http fetch GET 304 https://registry.npmjs.org/get-caller-file 169ms (from cache)
    ! 30 http fetch GET 304 https://registry.npmjs.org/which-module 80ms (from cache)
    ! 31 http fetch GET 304 https://registry.npmjs.org/y18n 80ms (from cache)
    ! 32 silly pacote range manifest for get-caller-file@^1.0.1 fetched in 185ms
    ! 33 silly resolveWithNewModule get-caller-file@1.0.3 checking installable status
    ! 34 silly pacote range manifest for which-module@^1.0.0 fetched in 96ms
    ! 35 silly resolveWithNewModule which-module@1.0.0 checking installable status
    ! 36 silly pacote range manifest for y18n@^3.2.1 fetched in 96ms
    ! 37 silly resolveWithNewModule y18n@3.2.1 checking installable status
    ! 38 http fetch GET 304 https://registry.npmjs.org/read-pkg-up 200ms (from cache)
    ! 39 http fetch GET 304 https://registry.npmjs.org/cliui 200ms (from cache)
    ! 40 http fetch GET 304 https://registry.npmjs.org/require-directory 200ms (from cache)
    ! 41 silly pacote range manifest for read-pkg-up@^1.0.1 fetched in 200ms
    ! 42 silly resolveWithNewModule read-pkg-up@1.0.1 checking installable status
    ! 43 silly pacote range manifest for cliui@^3.2.0 fetched in 200ms
    ! 44 silly resolveWithNewModule cliui@3.2.0 checking installable status
    ! 45 silly pacote range manifest for require-directory@^2.1.1 fetched in 200ms
    ! 46 silly resolveWithNewModule require-directory@2.1.1 checking installable status
    ! 47 http fetch GET 304 https://registry.npmjs.org/os-locale 200ms (from cache)
    ! 48 http fetch GET 304 https://registry.npmjs.org/set-blocking 200ms (from cache)
    ! 49 silly pacote range manifest for os-locale@^1.4.0 fetched in 216ms
    ! 50 silly resolveWithNewModule os-locale@1.4.0 checking installable status
    ! 51 silly pacote range manifest for set-blocking@^2.0.0 fetched in 216ms
    ! 52 silly resolveWithNewModule set-blocking@2.0.0 checking installable status
    ! 53 http fetch GET 304 https://registry.npmjs.org/string-width 216ms (from cache)
    ! 54 silly pacote range manifest for string-width@^1.0.2 fetched in 216ms
    ! 55 silly resolveWithNewModule string-width@1.0.2 checking installable status
    ! 56 http fetch GET 304 https://registry.npmjs.org/yargs-parser 53ms (from cache)
    ! 57 silly pacote range manifest for yargs-parser@^5.0.0 fetched in 53ms
    ! 58 silly resolveWithNewModule yargs-parser@5.0.0 checking installable status
    ! 59 http fetch GET 304 https://registry.npmjs.org/require-main-filename 254ms (from cache)
    ! 60 silly pacote range manifest for require-main-filename@^1.0.1 fetched in 254ms
    ! 61 silly resolveWithNewModule require-main-filename@1.0.1 checking installable status
    ! 62 http fetch GET 304 https://registry.npmjs.org/wrap-ansi 62ms (from cache)
    ! 63 silly pacote range manifest for wrap-ansi@^2.0.0 fetched in 62ms
    ! 64 silly resolveWithNewModule wrap-ansi@2.1.0 checking installable status
    ! 65 http fetch GET 304 https://registry.npmjs.org/strip-ansi 62ms (from cache)
    ! 66 silly pacote range manifest for strip-ansi@^3.0.1 fetched in 62ms
    ! 67 silly resolveWithNewModule strip-ansi@3.0.1 checking installable status
    ! 68 http fetch GET 304 https://registry.npmjs.org/code-point-at 64ms (from cache)
    ! 69 silly pacote range manifest for code-point-at@^1.0.0 fetched in 66ms
    ! 70 silly resolveWithNewModule code-point-at@1.1.0 checking installable status
    ! 71 http fetch GET 304 https://registry.npmjs.org/is-fullwidth-code-point 67ms (from cache)
    ! 72 silly pacote range manifest for is-fullwidth-code-point@^1.0.0 fetched in 69ms
    ! 73 silly resolveWithNewModule is-fullwidth-code-point@1.0.0 checking installable status
    ! 74 http fetch GET 304 https://registry.npmjs.org/number-is-nan 52ms (from cache)
    ! 75 silly pacote range manifest for number-is-nan@^1.0.0 fetched in 52ms
    ! 76 silly resolveWithNewModule number-is-nan@1.0.1 checking installable status
    ! 77 http fetch GET 304 https://registry.npmjs.org/ansi-regex 62ms (from cache)
    ! 78 silly pacote range manifest for ansi-regex@^2.0.0 fetched in 62ms
    ! 79 silly resolveWithNewModule ansi-regex@2.1.1 checking installable status
    ! 80 http fetch GET 304 https://registry.npmjs.org/lcid 54ms (from cache)
    ! 81 silly pacote range manifest for lcid@^1.0.0 fetched in 54ms
    ! 82 silly resolveWithNewModule lcid@1.0.0 checking installable status
    ! 83 http fetch GET 304 https://registry.npmjs.org/invert-kv 69ms (from cache)
    ! 84 silly pacote range manifest for invert-kv@^1.0.0 fetched in 69ms
    ! 85 silly resolveWithNewModule invert-kv@1.0.0 checking installable status
    ! 86 http fetch GET 304 https://registry.npmjs.org/read-pkg 47ms (from cache)
    ! 87 silly pacote range manifest for read-pkg@^1.0.0 fetched in 62ms
    ! 88 silly resolveWithNewModule read-pkg@1.1.0 checking installable status
    ! 89 http fetch GET 304 https://registry.npmjs.org/find-up 78ms (from cache)
    ! 90 silly pacote range manifest for find-up@^1.0.0 fetched in 78ms
    ! 91 silly resolveWithNewModule find-up@1.1.2 checking installable status
    ! 92 http fetch GET 304 https://registry.npmjs.org/path-exists 38ms (from cache)
    ! 93 silly pacote range manifest for path-exists@^2.0.0 fetched in 38ms
    ! 94 silly resolveWithNewModule path-exists@2.1.0 checking installable status
    ! 95 http fetch GET 304 https://registry.npmjs.org/pinkie-promise 54ms (from cache)
    ! 96 silly pacote range manifest for pinkie-promise@^2.0.0 fetched in 54ms
    ! 97 silly resolveWithNewModule pinkie-promise@2.0.1 checking installable status
    ! 98 http fetch GET 304 https://registry.npmjs.org/pinkie 53ms (from cache)
    ! 99 silly pacote range manifest for pinkie@^2.0.0 fetched in 53ms
    ! 100 silly resolveWithNewModule pinkie@2.0.4 checking installable status
    ! 101 http fetch GET 304 https://registry.npmjs.org/normalize-package-data 63ms (from cache)
    ! 102 silly pacote range manifest for normalize-package-data@^2.3.2 fetched in 63ms
    ! 103 silly resolveWithNewModule normalize-package-data@2.4.0 checking installable status
    ! 104 http fetch GET 304 https://registry.npmjs.org/load-json-file 94ms (from cache)
    ! 105 silly pacote range manifest for load-json-file@^1.0.0 fetched in 94ms
    ! 106 silly resolveWithNewModule load-json-file@1.1.0 checking installable status
    ! 107 http fetch GET 304 https://registry.npmjs.org/path-type 100ms (from cache)
    ! 108 silly pacote range manifest for path-type@^1.0.0 fetched in 100ms
    ! 109 silly resolveWithNewModule path-type@1.1.0 checking installable status
    ! 110 http fetch GET 200 https://registry.npmjs.org/graceful-fs 16ms (from cache)
    ! 111 silly pacote range manifest for graceful-fs@^4.1.2 fetched in 16ms
    ! 112 silly resolveWithNewModule graceful-fs@4.1.11 checking installable status
    ! 113 http fetch GET 304 https://registry.npmjs.org/pify 63ms (from cache)
    ! 114 silly pacote range manifest for pify@^2.0.0 fetched in 63ms
    ! 115 silly resolveWithNewModule pify@2.3.0 checking installable status
    ! 116 http fetch GET 304 https://registry.npmjs.org/strip-bom 79ms (from cache)
    ! 117 http fetch GET 304 https://registry.npmjs.org/parse-json 79ms (from cache)
    ! 118 silly pacote range manifest for strip-bom@^2.0.0 fetched in 79ms
    ! 119 silly resolveWithNewModule strip-bom@2.0.0 checking installable status
    ! 120 silly pacote range manifest for parse-json@^2.2.0 fetched in 79ms
    ! 121 silly resolveWithNewModule parse-json@2.2.0 checking installable status
    ! 122 http fetch GET 304 https://registry.npmjs.org/error-ex 47ms (from cache)
    ! 123 silly pacote range manifest for error-ex@^1.2.0 fetched in 63ms
    ! 124 silly resolveWithNewModule error-ex@1.3.2 checking installable status
    ! 125 http fetch GET 304 https://registry.npmjs.org/is-arrayish 47ms (from cache)
    ! 126 silly pacote range manifest for is-arrayish@^0.2.1 fetched in 47ms
    ! 127 silly resolveWithNewModule is-arrayish@0.2.1 checking installable status
    ! 128 http fetch GET 304 https://registry.npmjs.org/is-utf8 59ms (from cache)
    ! 129 silly pacote range manifest for is-utf8@^0.2.0 fetched in 59ms
    ! 130 silly resolveWithNewModule is-utf8@0.2.1 checking installable status
    ! 131 http fetch GET 304 https://registry.npmjs.org/is-builtin-module 69ms (from cache)
    ! 132 silly pacote range manifest for is-builtin-module@^1.0.0 fetched in 69ms
    ! 133 silly resolveWithNewModule is-builtin-module@1.0.0 checking installable status
    ! 134 http fetch GET 304 https://registry.npmjs.org/hosted-git-info 69ms (from cache)
    ! 135 silly pacote range manifest for hosted-git-info@^2.1.4 fetched in 69ms
    ! 136 silly resolveWithNewModule hosted-git-info@2.7.1 checking installable status
    ! 137 http fetch GET 304 https://registry.npmjs.org/validate-npm-package-license 84ms (from cache)
    ! 138 silly pacote range manifest for validate-npm-package-license@^3.0.1 fetched in 84ms
    ! 139 silly resolveWithNewModule validate-npm-package-license@3.0.4 checking installable status
    ! 140 http fetch GET 304 https://registry.npmjs.org/builtin-modules 69ms (from cache)
    ! 141 silly pacote range manifest for builtin-modules@^1.0.0 fetched in 69ms
    ! 142 silly resolveWithNewModule builtin-modules@1.1.1 checking installable status
    ! 143 http fetch GET 304 https://registry.npmjs.org/spdx-correct 64ms (from cache)
    ! 144 http fetch GET 304 https://registry.npmjs.org/spdx-expression-parse 65ms (from cache)
    ! 145 silly pacote range manifest for spdx-correct@^3.0.0 fetched in 67ms
    ! 146 silly resolveWithNewModule spdx-correct@3.0.2 checking installable status
    ! 147 silly pacote range manifest for spdx-expression-parse@^3.0.0 fetched in 69ms
    ! 148 silly resolveWithNewModule spdx-expression-parse@3.0.0 checking installable status
    ! 149 http fetch GET 304 https://registry.npmjs.org/spdx-license-ids 47ms (from cache)
    ! 150 silly pacote range manifest for spdx-license-ids@^3.0.0 fetched in 47ms
    ! 151 silly resolveWithNewModule spdx-license-ids@3.0.1 checking installable status
    ! 152 http fetch GET 304 https://registry.npmjs.org/spdx-exceptions 62ms (from cache)
    ! 153 silly pacote range manifest for spdx-exceptions@^2.1.0 fetched in 62ms
    ! 154 silly resolveWithNewModule spdx-exceptions@2.2.0 checking installable status
    ! 155 timing stage:loadIdealTree:loadAllDepsIntoIdealTree Completed in 1688ms
    ! 156 timing stage:loadIdealTree Completed in 1719ms
    ! 157 silly currentTree ioBroker
    ! 158 silly idealTree ioBroker
    ! 158 silly idealTree -- iobroker@1.1.2 ! 158 silly idealTree +-- ansi-regex@2.1.1 ! 158 silly idealTree +-- builtin-modules@1.1.1 ! 158 silly idealTree +-- camelcase@3.0.0 ! 158 silly idealTree +-- cliui@3.2.0 ! 158 silly idealTree +-- code-point-at@1.1.0 ! 158 silly idealTree +-- decamelize@1.2.0 ! 158 silly idealTree +-- error-ex@1.3.2 ! 158 silly idealTree +-- find-up@1.1.2 ! 158 silly idealTree +-- get-caller-file@1.0.3 ! 158 silly idealTree +-- graceful-fs@4.1.11 ! 158 silly idealTree +-- hosted-git-info@2.7.1 ! 158 silly idealTree +-- invert-kv@1.0.0 ! 158 silly idealTree +-- is-arrayish@0.2.1 ! 158 silly idealTree +-- is-builtin-module@1.0.0 ! 158 silly idealTree +-- is-fullwidth-code-point@1.0.0 ! 158 silly idealTree +-- is-utf8@0.2.1 ! 158 silly idealTree +-- lcid@1.0.0 ! 158 silly idealTree +-- load-json-file@1.1.0 ! 158 silly idealTree +-- normalize-package-data@2.4.0 ! 158 silly idealTree +-- number-is-nan@1.0.1 ! 158 silly idealTree +-- os-locale@1.4.0 ! 158 silly idealTree +-- parse-json@2.2.0 ! 158 silly idealTree +-- path-exists@2.1.0 ! 158 silly idealTree +-- path-type@1.1.0 ! 158 silly idealTree +-- pify@2.3.0 ! 158 silly idealTree +-- pinkie-promise@2.0.1 ! 158 silly idealTree +-- pinkie@2.0.4 ! 158 silly idealTree +-- read-pkg-up@1.0.1 ! 158 silly idealTree +-- read-pkg@1.1.0 ! 158 silly idealTree +-- require-directory@2.1.1 ! 158 silly idealTree +-- require-main-filename@1.0.1 ! 158 silly idealTree +-- semver@5.6.0 ! 158 silly idealTree +-- set-blocking@2.0.0 ! 158 silly idealTree +-- spdx-correct@3.0.2 ! 158 silly idealTree +-- spdx-exceptions@2.2.0 ! 158 silly idealTree +-- spdx-expression-parse@3.0.0 ! 158 silly idealTree +-- spdx-license-ids@3.0.1 ! 158 silly idealTree +-- string-width@1.0.2 ! 158 silly idealTree +-- strip-ansi@3.0.1 ! 158 silly idealTree +-- strip-bom@2.0.0 ! 158 silly idealTree +-- validate-npm-package-license@3.0.4 ! 158 silly idealTree +-- which-module@1.0.0 ! 158 silly idealTree +-- wrap-ansi@2.1.0 ! 158 silly idealTree +-- y18n@3.2.1 ! 158 silly idealTree +-- yargs-parser@5.0.0 ! 158 silly idealTree -- yargs@7.1.0
    ! 159 silly install generateActionsToTake
    ! 160 timing stage:generateActionsToTake Completed in 16ms
    ! 161 silly diffTrees action count 47
    ! 162 silly diffTrees add ansi-regex@2.1.1
    ! 163 silly diffTrees add builtin-modules@1.1.1
    ! 164 silly diffTrees add camelcase@3.0.0
    ! 165 silly diffTrees add code-point-at@1.1.0
    ! 166 silly diffTrees add decamelize@1.2.0
    ! 167 silly diffTrees add get-caller-file@1.0.3
    ! 168 silly diffTrees add graceful-fs@4.1.11
    ! 169 silly diffTrees add hosted-git-info@2.7.1
    ! 170 silly diffTrees add invert-kv@1.0.0
    ! 171 silly diffTrees add is-arrayish@0.2.1
    ! 172 silly diffTrees add error-ex@1.3.2
    ! 173 silly diffTrees add is-builtin-module@1.0.0
    ! 174 silly diffTrees add is-utf8@0.2.1
    ! 175 silly diffTrees add lcid@1.0.0
    ! 176 silly diffTrees add number-is-nan@1.0.1
    ! 177 silly diffTrees add is-fullwidth-code-point@1.0.0
    ! 178 silly diffTrees add os-locale@1.4.0
    ! 179 silly diffTrees add parse-json@2.2.0
    ! 180 silly diffTrees add pify@2.3.0
    ! 181 silly diffTrees add pinkie@2.0.4
    ! 182 silly diffTrees add pinkie-promise@2.0.1
    ! 183 silly diffTrees add path-exists@2.1.0
    ! 184 silly diffTrees add find-up@1.1.2
    ! 185 silly diffTrees add path-type@1.1.0
    ! 186 silly diffTrees add require-directory@2.1.1
    ! 187 silly diffTrees add require-main-filename@1.0.1
    ! 188 silly diffTrees add semver@5.6.0
    ! 189 silly diffTrees add set-blocking@2.0.0
    ! 190 silly diffTrees add spdx-exceptions@2.2.0
    ! 191 silly diffTrees add spdx-license-ids@3.0.1
    ! 192 silly diffTrees add spdx-expression-parse@3.0.0
    ! 193 silly diffTrees add spdx-correct@3.0.2
    ! 194 silly diffTrees add strip-ansi@3.0.1
    ! 195 silly diffTrees add string-width@1.0.2
    ! 196 silly diffTrees add strip-bom@2.0.0
    ! 197 silly diffTrees add load-json-file@1.1.0
    ! 198 silly diffTrees add validate-npm-package-license@3.0.4
    ! 199 silly diffTrees add normalize-package-data@2.4.0
    ! 200 silly diffTrees add read-pkg@1.1.0
    ! 201 silly diffTrees add read-pkg-up@1.0.1
    ! 202 silly diffTrees add which-module@1.0.0
    ! 203 silly diffTrees add wrap-ansi@2.1.0
    ! 204 silly diffTrees add cliui@3.2.0
    ! 205 silly diffTrees add y18n@3.2.1
    ! 206 silly diffTrees add yargs-parser@5.0.0
    ! 207 silly diffTrees add yargs@7.1.0
    ! 208 silly diffTrees add iobroker@1.1.2
    ! 209 silly decomposeActions action count 376
    ! 210 silly decomposeActions fetch ansi-regex@2.1.1
    ! 211 silly decomposeActions extract ansi-regex@2.1.1
    ! 212 silly decomposeActions preinstall ansi-regex@2.1.1
    ! 213 silly decomposeActions build ansi-regex@2.1.1
    ! 214 silly decomposeActions install ansi-regex@2.1.1
    ! 215 silly decomposeActions postinstall ansi-regex@2.1.1
    ! 216 silly decomposeActions finalize ansi-regex@2.1.1
    ! 217 silly decomposeActions refresh-package-json ansi-regex@2.1.1
    ! 218 silly decomposeActions fetch builtin-modules@1.1.1
    ! 219 silly decomposeActions extract builtin-modules@1.1.1
    ! 220 silly decomposeActions preinstall builtin-modules@1.1.1
    ! 221 silly decomposeActions build builtin-modules@1.1.1
    ! 222 silly decomposeActions install builtin-modules@1.1.1
    ! 223 silly decomposeActions postinstall builtin-modules@1.1.1
    ! 224 silly decomposeActions finalize builtin-modules@1.1.1
    ! 225 silly decomposeActions refresh-package-json builtin-modules@1.1.1
    ! 226 silly decomposeActions fetch camelcase@3.0.0
    ! 227 silly decomposeActions extract camelcase@3.0.0
    ! 228 silly decomposeActions preinstall camelcase@3.0.0
    ! 229 silly decomposeActions build camelcase@3.0.0
    ! 230 silly decomposeActions install camelcase@3.0.0
    ! 231 silly decomposeActions postinstall camelcase@3.0.0
    ! 232 silly decomposeActions finalize camelcase@3.0.0
    ! 233 silly decomposeActions refresh-package-json camelcase@3.0.0
    ! 234 silly decomposeActions fetch code-point-at@1.1.0
    ! 235 silly decomposeActions extract code-point-at@1.1.0
    ! 236 silly decomposeActions preinstall code-point-at@1.1.0
    ! 237 silly decomposeActions build code-point-at@1.1.0
    ! 238 silly decomposeActions install code-point-at@1.1.0
    ! 239 silly decomposeActions postinstall code-point-at@1.1.0
    ! 240 silly decomposeActions finalize code-point-at@1.1.0
    ! 241 silly decomposeActions refresh-package-json code-point-at@1.1.0
    ! 242 silly decomposeActions fetch decamelize@1.2.0
    ! 243 silly decomposeActions extract decamelize@1.2.0
    ! 244 silly decomposeActions preinstall decamelize@1.2.0
    ! 245 silly decomposeActions build decamelize@1.2.0
    ! 246 silly decomposeActions install decamelize@1.2.0
    ! 247 silly decomposeActions postinstall decamelize@1.2.0
    ! 248 silly decomposeActions finalize decamelize@1.2.0
    ! 249 silly decomposeActions refresh-package-json decamelize@1.2.0
    ! 250 silly decomposeActions fetch get-caller-file@1.0.3
    ! 251 silly decomposeActions extract get-caller-file@1.0.3
    ! 252 silly decomposeActions preinstall get-caller-file@1.0.3
    ! 253 silly decomposeActions build get-caller-file@1.0.3
    ! 254 silly decomposeActions install get-caller-file@1.0.3
    ! 255 silly decomposeActions postinstall get-caller-file@1.0.3
    ! 256 silly decomposeActions finalize get-caller-file@1.0.3
    ! 257 silly decomposeActions refresh-package-json get-caller-file@1.0.3
    ! 258 silly decomposeActions fetch graceful-fs@4.1.11
    ! 259 silly decomposeActions extract graceful-fs@4.1.11
    ! 260 silly decomposeActions preinstall graceful-fs@4.1.11
    ! 261 silly decomposeActions build graceful-fs@4.1.11
    ! 262 silly decomposeActions install graceful-fs@4.1.11
    ! 263 silly decomposeActions postinstall graceful-fs@4.1.11
    ! 264 silly decomposeActions finalize graceful-fs@4.1.11
    ! 265 silly decomposeActions refresh-package-json graceful-fs@4.1.11
    ! 266 silly decomposeActions fetch hosted-git-info@2.7.1
    ! 267 silly decomposeActions extract hosted-git-info@2.7.1
    ! 268 silly decomposeActions preinstall hosted-git-info@2.7.1
    ! 269 silly decomposeActions build hosted-git-info@2.7.1
    ! 270 silly decomposeActions install hosted-git-info@2.7.1
    ! 271 silly decomposeActions postinstall hosted-git-info@2.7.1
    ! 272 silly decomposeActions finalize hosted-git-info@2.7.1
    ! 273 silly decomposeActions refresh-package-json hosted-git-info@2.7.1
    ! 274 silly decomposeActions fetch invert-kv@1.0.0
    ! 275 silly decomposeActions extract invert-kv@1.0.0
    ! 276 silly decomposeActions preinstall invert-kv@1.0.0
    ! 277 silly decomposeActions build invert-kv@1.0.0
    ! 278 silly decomposeActions install invert-kv@1.0.0
    ! 279 silly decomposeActions postinstall invert-kv@1.0.0
    ! 280 silly decomposeActions finalize invert-kv@1.0.0
    ! 281 silly decomposeActions refresh-package-json invert-kv@1.0.0
    ! 282 silly decomposeActions fetch is-arrayish@0.2.1
    ! 283 silly decomposeActions extract is-arrayish@0.2.1
    ! 284 silly decomposeActions preinstall is-arrayish@0.2.1
    ! 285 silly decomposeActions build is-arrayish@0.2.1
    ! 286 silly decomposeActions install is-arrayish@0.2.1
    ! 287 silly decomposeActions postinstall is-arrayish@0.2.1
    ! 288 silly decomposeActions finalize is-arrayish@0.2.1
    ! 289 silly decomposeActions refresh-package-json is-arrayish@0.2.1
    ! 290 silly decomposeActions fetch error-ex@1.3.2
    ! 291 silly decomposeActions extract error-ex@1.3.2
    ! 292 silly decomposeActions preinstall error-ex@1.3.2
    ! 293 silly decomposeActions build error-ex@1.3.2
    ! 294 silly decomposeActions install error-ex@1.3.2
    ! 295 silly decomposeActions postinstall error-ex@1.3.2
    ! 296 silly decomposeActions finalize error-ex@1.3.2
    ! 297 silly decomposeActions refresh-package-json error-ex@1.3.2
    ! 298 silly decomposeActions fetch is-builtin-module@1.0.0
    ! 299 silly decomposeActions extract is-builtin-module@1.0.0
    ! 300 silly decomposeActions preinstall is-builtin-module@1.0.0
    ! 301 silly decomposeActions build is-builtin-module@1.0.0
    ! 302 silly decomposeActions install is-builtin-module@1.0.0
    ! 303 silly decomposeActions postinstall is-builtin-module@1.0.0
    ! 304 silly decomposeActions finalize is-builtin-module@1.0.0
    ! 305 silly decomposeActions refresh-package-json is-builtin-module@1.0.0
    ! 306 silly decomposeActions fetch is-utf8@0.2.1
    ! 307 silly decomposeActions extract is-utf8@0.2.1
    ! 308 silly decomposeActions preinstall is-utf8@0.2.1
    ! 309 silly decomposeActions build is-utf8@0.2.1
    ! 310 silly decomposeActions install is-utf8@0.2.1
    ! 311 silly decomposeActions postinstall is-utf8@0.2.1
    ! 312 silly decomposeActions finalize is-utf8@0.2.1
    ! 313 silly decomposeActions refresh-package-json is-utf8@0.2.1
    ! 314 silly decomposeActions fetch lcid@1.0.0
    ! 315 silly decomposeActions extract lcid@1.0.0
    ! 316 silly decomposeActions preinstall lcid@1.0.0
    ! 317 silly decomposeActions build lcid@1.0.0
    ! 318 silly decomposeActions install lcid@1.0.0
    ! 319 silly decomposeActions postinstall lcid@1.0.0
    ! 320 silly decomposeActions finalize lcid@1.0.0
    ! 321 silly decomposeActions refresh-package-json lcid@1.0.0
    ! 322 silly decomposeActions fetch number-is-nan@1.0.1
    ! 323 silly decomposeActions extract number-is-nan@1.0.1
    ! 324 silly decomposeActions preinstall number-is-nan@1.0.1
    ! 325 silly decomposeActions build number-is-nan@1.0.1
    ! 326 silly decomposeActions install number-is-nan@1.0.1
    ! 327 silly decomposeActions postinstall number-is-nan@1.0.1
    ! 328 silly decomposeActions finalize number-is-nan@1.0.1
    ! 329 silly decomposeActions refresh-package-json number-is-nan@1.0.1
    ! 330 silly decomposeActions fetch is-fullwidth-code-point@1.0.0
    ! 331 silly decomposeActions extract is-fullwidth-code-point@1.0.0
    ! 332 silly decomposeActions preinstall is-fullwidth-code-point@1.0.0
    ! 333 silly decomposeActions build is-fullwidth-code-point@1.0.0
    ! 334 silly decomposeActions install is-fullwidth-code-point@1.0.0
    ! 335 silly decomposeActions postinstall is-fullwidth-code-point@1.0.0
    ! 336 silly decomposeActions finalize is-fullwidth-code-point@1.0.0
    ! 337 silly decomposeActions refresh-package-json is-fullwidth-code-point@1.0.0
    ! 338 silly decomposeActions fetch os-locale@1.4.0
    ! 339 silly decomposeActions extract os-locale@1.4.0
    ! 340 silly decomposeActions preinstall os-locale@1.4.0
    ! 341 silly decomposeActions build os-locale@1.4.0
    ! 342 silly decomposeActions install os-locale@1.4.0
    ! 343 silly decomposeActions postinstall os-locale@1.4.0
    ! 344 silly decomposeActions finalize os-locale@1.4.0
    ! 345 silly decomposeActions refresh-package-json os-locale@1.4.0
    ! 346 silly decomposeActions fetch parse-json@2.2.0
    ! 347 silly decomposeActions extract parse-json@2.2.0
    ! 348 silly decomposeActions preinstall parse-json@2.2.0
    ! 349 silly decomposeActions build parse-json@2.2.0
    ! 350 silly decomposeActions install parse-json@2.2.0
    ! 351 silly decomposeActions postinstall parse-json@2.2.0
    ! 352 silly decomposeActions finalize parse-json@2.2.0
    ! 353 silly decomposeActions refresh-package-json parse-json@2.2.0
    ! 354 silly decomposeActions fetch pify@2.3.0
    ! 355 silly decomposeActions extract pify@2.3.0
    ! 356 silly decomposeActions preinstall pify@2.3.0
    ! 357 silly decomposeActions build pify@2.3.0
    ! 358 silly decomposeActions install pify@2.3.0
    ! 359 silly decomposeActions postinstall pify@2.3.0
    ! 360 silly decomposeActions finalize pify@2.3.0
    ! 361 silly decomposeActions refresh-package-json pify@2.3.0
    ! 362 silly decomposeActions fetch pinkie@2.0.4
    ! 363 silly decomposeActions extract pinkie@2.0.4
    ! 364 silly decomposeActions preinstall pinkie@2.0.4
    ! 365 silly decomposeActions build pinkie@2.0.4
    ! 366 silly decomposeActions install pinkie@2.0.4
    ! 367 silly decomposeActions postinstall pinkie@2.0.4
    ! 368 silly decomposeActions finalize pinkie@2.0.4
    ! 369 silly decomposeActions refresh-package-json pinkie@2.0.4
    ! 370 silly decomposeActions fetch pinkie-promise@2.0.1
    ! 371 silly decomposeActions extract pinkie-promise@2.0.1
    ! 372 silly decomposeActions preinstall pinkie-promise@2.0.1
    ! 373 silly decomposeActions build pinkie-promise@2.0.1
    ! 374 silly decomposeActions install pinkie-promise@2.0.1
    ! 375 silly decomposeActions postinstall pinkie-promise@2.0.1
    ! 376 silly decomposeActions finalize pinkie-promise@2.0.1
    ! 377 silly decomposeActions refresh-package-json pinkie-promise@2.0.1
    ! 378 silly decomposeActions fetch path-exists@2.1.0
    ! 379 silly decomposeActions extract path-exists@2.1.0
    ! 380 silly decomposeActions preinstall path-exists@2.1.0
    ! 381 silly decomposeActions build path-exists@2.1.0
    ! 382 silly decomposeActions install path-exists@2.1.0
    ! 383 silly decomposeActions postinstall path-exists@2.1.0
    ! 384 silly decomposeActions finalize path-exists@2.1.0
    ! 385 silly decomposeActions refresh-package-json path-exists@2.1.0
    ! 386 silly decomposeActions fetch find-up@1.1.2
    ! 387 silly decomposeActions extract find-up@1.1.2
    ! 388 silly decomposeActions preinstall find-up@1.1.2
    ! 389 silly decomposeActions build find-up@1.1.2
    ! 390 silly decomposeActions install find-up@1.1.2
    ! 391 silly decomposeActions postinstall find-up@1.1.2
    ! 392 silly decomposeActions finalize find-up@1.1.2
    ! 393 silly decomposeActions refresh-package-json find-up@1.1.2
    ! 394 silly decomposeActions fetch path-type@1.1.0
    ! 395 silly decomposeActions extract path-type@1.1.0
    ! 396 silly decomposeActions preinstall path-type@1.1.0
    ! 397 silly decomposeActions build path-type@1.1.0
    ! 398 silly decomposeActions install path-type@1.1.0
    ! 399 silly decomposeActions postinstall path-type@1.1.0
    ! 400 silly decomposeActions finalize path-type@1.1.0
    ! 401 silly decomposeActions refresh-package-json path-type@1.1.0
    ! 402 silly decomposeActions fetch require-directory@2.1.1
    ! 403 silly decomposeActions extract require-directory@2.1.1
    ! 404 silly decomposeActions preinstall require-directory@2.1.1
    ! 405 silly decomposeActions build require-directory@2.1.1
    ! 406 silly decomposeActions install require-directory@2.1.1
    ! 407 silly decomposeActions postinstall require-directory@2.1.1
    ! 408 silly decomposeActions finalize require-directory@2.1.1
    ! 409 silly decomposeActions refresh-package-json require-directory@2.1.1
    ! 410 silly decomposeActions fetch require-main-filename@1.0.1
    ! 411 silly decomposeActions extract require-main-filename@1.0.1
    ! 412 silly decomposeActions preinstall require-main-filename@1.0.1
    ! 413 silly decomposeActions build require-main-filename@1.0.1
    ! 414 silly decomposeActions install require-main-filename@1.0.1
    ! 415 silly decomposeActions postinstall require-main-filename@1.0.1
    ! 416 silly decomposeActions finalize require-main-filename@1.0.1
    ! 417 silly decomposeActions refresh-package-json require-main-filename@1.0.1
    ! 418 silly decomposeActions fetch semver@5.6.0
    ! 419 silly decomposeActions extract semver@5.6.0
    ! 420 silly decomposeActions preinstall semver@5.6.0
    ! 421 silly decomposeActions build semver@5.6.0
    ! 422 silly decomposeActions install semver@5.6.0
    ! 423 silly decomposeActions postinstall semver@5.6.0
    ! 424 silly decomposeActions finalize semver@5.6.0
    ! 425 silly decomposeActions refresh-package-json semver@5.6.0
    ! 426 silly decomposeActions fetch set-blocking@2.0.0
    ! 427 silly decomposeActions extract set-blocking@2.0.0
    ! 428 silly decomposeActions preinstall set-blocking@2.0.0
    ! 429 silly decomposeActions build set-blocking@2.0.0
    ! 430 silly decomposeActions install set-blocking@2.0.0
    ! 431 silly decomposeActions postinstall set-blocking@2.0.0
    ! 432 silly decomposeActions finalize set-blocking@2.0.0
    ! 433 silly decomposeActions refresh-package-json set-blocking@2.0.0
    ! 434 silly decomposeActions fetch spdx-exceptions@2.2.0
    ! 435 silly decomposeActions extract spdx-exceptions@2.2.0
    ! 436 silly decomposeActions preinstall spdx-exceptions@2.2.0
    ! 437 silly decomposeActions build spdx-exceptions@2.2.0
    ! 438 silly decomposeActions install spdx-exceptions@2.2.0
    ! 439 silly decomposeActions postinstall spdx-exceptions@2.2.0
    ! 440 silly decomposeActions finalize spdx-exceptions@2.2.0
    ! 441 silly decomposeActions refresh-package-json spdx-exceptions@2.2.0
    ! 442 silly decomposeActions fetch spdx-license-ids@3.0.1
    ! 443 silly decomposeActions extract spdx-license-ids@3.0.1
    ! 444 silly decomposeActions preinstall spdx-license-ids@3.0.1
    ! 445 silly decomposeActions build spdx-license-ids@3.0.1
    ! 446 silly decomposeActions install spdx-license-ids@3.0.1
    ! 447 silly decomposeActions postinstall spdx-license-ids@3.0.1
    ! 448 silly decomposeActions finalize spdx-license-ids@3.0.1
    ! 449 silly decomposeActions refresh-package-json spdx-license-ids@3.0.1
    ! 450 silly decomposeActions fetch spdx-expression-parse@3.0.0
    ! 451 silly decomposeActions extract spdx-expression-parse@3.0.0
    ! 452 silly decomposeActions preinstall spdx-expression-parse@3.0.0
    ! 453 silly decomposeActions build spdx-expression-parse@3.0.0
    ! 454 silly decomposeActions install spdx-expression-parse@3.0.0
    ! 455 silly decomposeActions postinstall spdx-expression-parse@3.0.0
    ! 456 silly decomposeActions finalize spdx-expression-parse@3.0.0
    ! 457 silly decomposeActions refresh-package-json spdx-expression-parse@3.0.0
    ! 458 silly decomposeActions fetch spdx-correct@3.0.2
    ! 459 silly decomposeActions extract spdx-correct@3.0.2
    ! 460 silly decomposeActions preinstall spdx-correct@3.0.2
    ! 461 silly decomposeActions build spdx-correct@3.0.2
    ! 462 silly decomposeActions install spdx-correct@3.0.2
    ! 463 silly decomposeActions postinstall spdx-correct@3.0.2
    ! 464 silly decomposeActions finalize spdx-correct@3.0.2
    ! 465 silly decomposeActions refresh-package-json spdx-correct@3.0.2
    ! 466 silly decomposeActions fetch strip-ansi@3.0.1
    ! 467 silly decomposeActions extract strip-ansi@3.0.1
    ! 468 silly decomposeActions preinstall strip-ansi@3.0.1
    ! 469 silly decomposeActions build strip-ansi@3.0.1
    ! 470 silly decomposeActions install strip-ansi@3.0.1
    ! 471 silly decomposeActions postinstall strip-ansi@3.0.1
    ! 472 silly decomposeActions finalize strip-ansi@3.0.1
    ! 473 silly decomposeActions refresh-package-json strip-ansi@3.0.1
    ! 474 silly decomposeActions fetch string-width@1.0.2
    ! 475 silly decomposeActions extract string-width@1.0.2
    ! 476 silly decomposeActions preinstall string-width@1.0.2
    ! 477 silly decomposeActions build string-width@1.0.2
    ! 478 silly decomposeActions install string-width@1.0.2
    ! 479 silly decomposeActions postinstall string-width@1.0.2
    ! 480 silly decomposeActions finalize string-width@1.0.2
    ! 481 silly decomposeActions refresh-package-json string-width@1.0.2
    ! 482 silly decomposeActions fetch strip-bom@2.0.0
    ! 483 silly decomposeActions extract strip-bom@2.0.0
    ! 484 silly decomposeActions preinstall strip-bom@2.0.0
    ! 485 silly decomposeActions build strip-bom@2.0.0
    ! 486 silly decomposeActions install strip-bom@2.0.0
    ! 487 silly decomposeActions postinstall strip-bom@2.0.0
    ! 488 silly decomposeActions finalize strip-bom@2.0.0
    ! 489 silly decomposeActions refresh-package-json strip-bom@2.0.0
    ! 490 silly decomposeActions fetch load-json-file@1.1.0
    ! 491 silly decomposeActions extract load-json-file@1.1.0
    ! 492 silly decomposeActions preinstall load-json-file@1.1.0
    ! 493 silly decomposeActions build load-json-file@1.1.0
    ! 494 silly decomposeActions install load-json-file@1.1.0
    ! 495 silly decomposeActions postinstall load-json-file@1.1.0
    ! 496 silly decomposeActions finalize load-json-file@1.1.0
    ! 497 silly decomposeActions refresh-package-json load-json-file@1.1.0
    ! 498 silly decomposeActions fetch validate-npm-package-license@3.0.4
    ! 499 silly decomposeActions extract validate-npm-package-license@3.0.4
    ! 500 silly decomposeActions preinstall validate-npm-package-license@3.0.4
    ! 501 silly decomposeActions build validate-npm-package-license@3.0.4
    ! 502 silly decomposeActions install validate-npm-package-license@3.0.4
    ! 503 silly decomposeActions postinstall validate-npm-package-license@3.0.4
    ! 504 silly decomposeActions finalize validate-npm-package-license@3.0.4
    ! 505 silly decomposeActions refresh-package-json validate-npm-package-license@3.0.4
    ! 506 silly decomposeActions fetch normalize-package-data@2.4.0
    ! 507 silly decomposeActions extract normalize-package-data@2.4.0
    ! 508 silly decomposeActions preinstall normalize-package-data@2.4.0
    ! 509 silly decomposeActions build normalize-package-data@2.4.0
    ! 510 silly decomposeActions install normalize-package-data@2.4.0
    ! 511 silly decomposeActions postinstall normalize-package-data@2.4.0
    ! 512 silly decomposeActions finalize normalize-package-data@2.4.0
    ! 513 silly decomposeActions refresh-package-json normalize-package-data@2.4.0
    ! 514 silly decomposeActions fetch read-pkg@1.1.0
    ! 515 silly decomposeActions extract read-pkg@1.1.0
    ! 516 silly decomposeActions preinstall read-pkg@1.1.0
    ! 517 silly decomposeActions build read-pkg@1.1.0
    ! 518 silly decomposeActions install read-pkg@1.1.0
    ! 519 silly decomposeActions postinstall read-pkg@1.1.0
    ! 520 silly decomposeActions finalize read-pkg@1.1.0
    ! 521 silly decomposeActions refresh-package-json read-pkg@1.1.0
    ! 522 silly decomposeActions fetch read-pkg-up@1.0.1
    ! 523 silly decomposeActions extract read-pkg-up@1.0.1
    ! 524 silly decomposeActions preinstall read-pkg-up@1.0.1
    ! 525 silly decomposeActions build read-pkg-up@1.0.1
    ! 526 silly decomposeActions install read-pkg-up@1.0.1
    ! 527 silly decomposeActions postinstall read-pkg-up@1.0.1
    ! 528 silly decomposeActions finalize read-pkg-up@1.0.1
    ! 529 silly decomposeActions refresh-package-json read-pkg-up@1.0.1
    ! 530 silly decomposeActions fetch which-module@1.0.0
    ! 531 silly decomposeActions extract which-module@1.0.0
    ! 532 silly decomposeActions preinstall which-module@1.0.0
    ! 533 silly decomposeActions build which-module@1.0.0
    ! 534 silly decomposeActions install which-module@1.0.0
    ! 535 silly decomposeActions postinstall which-module@1.0.0
    ! 536 silly decomposeActions finalize which-module@1.0.0
    ! 537 silly decomposeActions refresh-package-json which-module@1.0.0
    ! 538 silly decomposeActions fetch wrap-ansi@2.1.0
    ! 539 silly decomposeActions extract wrap-ansi@2.1.0
    ! 540 silly decomposeActions preinstall wrap-ansi@2.1.0
    ! 541 silly decomposeActions build wrap-ansi@2.1.0
    ! 542 silly decomposeActions install wrap-ansi@2.1.0
    ! 543 silly decomposeActions postinstall wrap-ansi@2.1.0
    ! 544 silly decomposeActions finalize wrap-ansi@2.1.0
    ! 545 silly decomposeActions refresh-package-json wrap-ansi@2.1.0
    ! 546 silly decomposeActions fetch cliui@3.2.0
    ! 547 silly decomposeActions extract cliui@3.2.0
    ! 548 silly decomposeActions preinstall cliui@3.2.0
    ! 549 silly decomposeActions build cliui@3.2.0
    ! 550 silly decomposeActions install cliui@3.2.0
    ! 551 silly decomposeActions postinstall cliui@3.2.0
    ! 552 silly decomposeActions finalize cliui@3.2.0
    ! 553 silly decomposeActions refresh-package-json cliui@3.2.0
    ! 554 silly decomposeActions fetch y18n@3.2.1
    ! 555 silly decomposeActions extract y18n@3.2.1
    ! 556 silly decomposeActions preinstall y18n@3.2.1
    ! 557 silly decomposeActions build y18n@3.2.1
    ! 558 silly decomposeActions install y18n@3.2.1
    ! 559 silly decomposeActions postinstall y18n@3.2.1
    ! 560 silly decomposeActions finalize y18n@3.2.1
    ! 561 silly decomposeActions refresh-package-json y18n@3.2.1
    ! 562 silly decomposeActions fetch yargs-parser@5.0.0
    ! 563 silly decomposeActions extract yargs-parser@5.0.0
    ! 564 silly decomposeActions preinstall yargs-parser@5.0.0
    ! 565 silly decomposeActions build yargs-parser@5.0.0
    ! 566 silly decomposeActions install yargs-parser@5.0.0
    ! 567 silly decomposeActions postinstall yargs-parser@5.0.0
    ! 568 silly decomposeActions finalize yargs-parser@5.0.0
    ! 569 silly decomposeActions refresh-package-json yargs-parser@5.0.0
    ! 570 silly decomposeActions fetch yargs@7.1.0
    ! 571 silly decomposeActions extract yargs@7.1.0
    ! 572 silly decomposeActions preinstall yargs@7.1.0
    ! 573 silly decomposeActions build yargs@7.1.0
    ! 574 silly decomposeActions install yargs@7.1.0
    ! 575 silly decomposeActions postinstall yargs@7.1.0
    ! 576 silly decomposeActions finalize yargs@7.1.0
    ! 577 silly decomposeActions refresh-package-json yargs@7.1.0
    ! 578 silly decomposeActions fetch iobroker@1.1.2
    ! 579 silly decomposeActions extract iobroker@1.1.2
    ! 580 silly decomposeActions preinstall iobroker@1.1.2
    ! 581 silly decomposeActions build iobroker@1.1.2
    ! 582 silly decomposeActions install iobroker@1.1.2
    ! 583 silly decomposeActions postinstall iobroker@1.1.2
    ! 584 silly decomposeActions finalize iobroker@1.1.2
    ! 585 silly decomposeActions refresh-package-json iobroker@1.1.2
    ! 586 silly install executeActions
    ! 587 silly doSerial global-install 376
    ! 588 verbose correctMkdir C:\Users\TATIANA\AppData\Roaming\npm-cache_locks correctMkdir not in flight; initializing
    ! 589 verbose lock using C:\Users\TATIANA\AppData\Roaming\npm-cache_locks\staging-07aec478ec01a593.lock for d:\ioBroker\node_modules.staging
    ! 590 silly doParallel extract 47
    ! 591 silly extract ansi-regex@2.1.1
    ! 592 silly extract builtin-modules@1.1.1
    ! 593 silly extract camelcase@3.0.0
    ! 594 silly extract code-point-at@1.1.0
    ! 595 silly extract decamelize@1.2.0
    ! 596 silly extract get-caller-file@1.0.3
    ! 597 silly extract graceful-fs@4.1.11
    ! 598 silly extract hosted-git-info@2.7.1
    ! 599 silly extract invert-kv@1.0.0
    ! 600 silly extract is-arrayish@0.2.1
    ! 601 silly extract error-ex@1.3.2
    ! 602 silly extract is-builtin-module@1.0.0
    ! 603 silly extract is-utf8@0.2.1
    ! 604 silly extract lcid@1.0.0
    ! 605 silly extract number-is-nan@1.0.1
    ! 606 silly extract is-fullwidth-code-point@1.0.0
    ! 607 silly extract os-locale@1.4.0
    ! 608 silly extract parse-json@2.2.0
    ! 609 silly extract pify@2.3.0
    ! 610 silly extract pinkie@2.0.4
    ! 611 silly extract pinkie-promise@2.0.1
    ! 612 silly extract path-exists@2.1.0
    ! 613 silly extract find-up@1.1.2
    ! 614 silly extract path-type@1.1.0
    ! 615 silly extract require-directory@2.1.1
    ! 616 silly extract require-main-filename@1.0.1
    ! 617 silly extract semver@5.6.0
    ! 618 silly extract set-blocking@2.0.0
    ! 619 silly extract spdx-exceptions@2.2.0
    ! 620 silly extract spdx-license-ids@3.0.1
    ! 621 silly extract spdx-expression-parse@3.0.0
    ! 622 silly extract spdx-correct@3.0.2
    ! 623 silly extract strip-ansi@3.0.1
    ! 624 silly extract string-width@1.0.2
    ! 625 silly extract strip-bom@2.0.0
    ! 626 silly extract load-json-file@1.1.0
    ! 627 silly extract validate-npm-package-license@3.0.4
    ! 628 silly extract normalize-package-data@2.4.0
    ! 629 silly extract read-pkg@1.1.0
    ! 630 silly extract read-pkg-up@1.0.1
    ! 631 silly extract which-module@1.0.0
    ! 632 silly extract wrap-ansi@2.1.0
    ! 633 silly extract cliui@3.2.0
    ! 634 silly extract y18n@3.2.1
    ! 635 silly extract yargs-parser@5.0.0
    ! 636 silly extract yargs@7.1.0
    ! 637 silly extract iobroker@1.1.2
    ! 638 silly tarball trying ansi-regex@^2.0.0 by hash: sha1-w7M6te42DYbg5ijwRorn7yfWVN8=
    ! 639 silly tarball trying builtin-modules@^1.0.0 by hash: sha1-Jw8HbFpywC9bZaR9+Uxf46J4iS8=
    ! 640 silly tarball trying camelcase@^3.0.0 by hash: sha1-MvxLn82vhF/N9+c7uXysImHwqwo=
    ! 641 silly tarball trying code-point-at@^1.0.0 by hash: sha1-DQcLTQQ6W+ozovGkDi7bPZpMz3c=
    ! 642 silly tarball trying decamelize@^1.1.1 by hash: sha1-9lNNFRSCabIDUue+4m9QH5oZEpA=
    ! 643 silly tarball trying get-caller-file@^1.0.1 by hash: sha512-3t6rVToeoZfYSGd8YoLFR2DJkiQrIiUrGcjvFX2mDw3bn6k2OtwHN0TNCLbBO+w8qTvimhDkv+LSscbJY1vE6w==
    ! 644 silly tarball trying graceful-fs@^4.1.2 by hash: sha1-Dovf5NHduIVNZOBOp8AOKgJuVlg=
    ! 645 silly tarball trying hosted-git-info@^2.1.4 by hash: sha512-7T/BxH19zbcCTa8XkMlbK5lTo1WtgkFi3GvdWEyNuc4Vex7/9Dqbnpsf4JMydcfj9HCg4zUWFTL3Za6lapg5/w==
    ! 646 silly tarball trying invert-kv@^1.0.0 by hash: sha1-EEqOSqym09jNFXqO+L+rLXo//bY=
    ! 647 silly tarball trying is-arrayish@^0.2.1 by hash: sha1-d8mYQFJ6qOyxqLppe4BkWnqSap0=
    ! 648 silly tarball trying error-ex@^1.2.0 by hash: sha512-7dFHNmqeFSEt2ZBsCriorKnn3Z2pj+fd9kmI6QoWw4//DL+icEBfc0U7qJCisqrTsKTjw4fNFy2pW9OqStD84g==
    ! 649 silly tarball trying is-builtin-module@^1.0.0 by hash: sha1-VAVy0096wxGfj3bDDLwbHgN6/74=
    ! 650 silly tarball trying is-utf8@^0.2.0 by hash: sha1-Sw2hRCEE0bM2NA6AeX6GXPOffXI=
    ! 651 silly tarball trying lcid@^1.0.0 by hash: sha1-MIrMr6C8SDo4Z7S28rlQYlHRuDU=
    ! 652 silly tarball trying number-is-nan@^1.0.0 by hash: sha1-CXtgK1NCKlIsGvuHkDGDNpQaAR0=
    ! 653 silly tarball trying is-fullwidth-code-point@^1.0.0 by hash: sha1-754xOG8DGn8NZDr4L95QxFfvAMs=
    ! 654 silly tarball trying os-locale@^1.4.0 by hash: sha1-IPnxeuKe00XoveWDsT0gCYA8FNk=
    ! 655 silly tarball trying parse-json@^2.2.0 by hash: sha1-9ID0BDTvgHQfhGkJn43qGPVaTck=
    ! 656 silly tarball trying pify@^2.0.0 by hash: sha1-7RQaasBDqEnqWISY59yosVMw6Qw=
    ! 657 silly tarball trying pinkie@^2.0.0 by hash: sha1-clVrgM+g1IqXToDnckjoDtT3+HA=
    ! 658 silly tarball trying pinkie-promise@^2.0.0 by hash: sha1-ITXW36ejWMBprJsXh3YogihFD/o=
    ! 659 silly tarball trying path-exists@^2.0.0 by hash: sha1-D+tsZPD8UY2adU3V77YscCJ2H0s=
    ! 660 silly tarball trying find-up@^1.0.0 by hash: sha1-ay6YIrGizgpgq2TWEOzK1TyyTQ8=
    ! 661 silly tarball trying path-type@^1.0.0 by hash: sha1-WcRPfuSR2nBNpBXaWkBwuk+P5EE=
    ! 662 silly tarball trying require-directory@^2.1.1 by hash: sha1-jGStX9MNqxyXbiNE/+f3kqam30I=
    ! 663 silly tarball trying require-main-filename@^1.0.1 by hash: sha1-l/cXtp1IeE9fUmpsWqj/3aBVpNE=
    ! 664 silly tarball trying semver@^5.5.0 by hash: sha512-RS9R6R35NYgQn++fkDWaOmqGoj4Ek9gGs+DPxNUZKuwE183xjJroKvyo1IzVFeXvUrvmALy6FWD5xrdJT25gMg==
    ! 665 silly tarball trying set-blocking@^2.0.0 by hash: sha1-BF+XgtARrppoA93TgrJDkrPYkPc=
    ! 666 silly tarball trying spdx-exceptions@^2.1.0 by hash: sha512-2XQACfElKi9SlVb1CYadKDXvoajPgBVPn/gOQLrTvHdElaVhr7ZEbqJaRnJLVNeaI4cMEAgVCeBMKF6MWRDCRA==
    ! 667 silly tarball trying spdx-license-ids@^3.0.0 by hash: sha512-TfOfPcYGBB5sDuPn3deByxPhmfegAhpDYKSOXZQN81Oyrrif8ZCodOLzK3AesELnCx03kikhyDwh0pfvvQvF8w==
    ! 668 silly tarball trying spdx-expression-parse@^3.0.0 by hash: sha512-Yg6D3XpRD4kkOmTpdgbUiEJFKghJH03fiC1OPll5h/0sO6neh2jqRDVHOQ4o/LMea0tgCkbMgea5ip/e+MkWyg==
    ! 669 silly tarball trying spdx-correct@^3.0.0 by hash: sha512-q9hedtzyXHr5S0A1vEPoK/7l8NpfkFYTq6iCY+Pno2ZbdZR6WexZFtqeVGkGxW3TEJMN914Z55EnAGMmenlIQQ==
    ! 670 silly tarball trying strip-ansi@^3.0.1 by hash: sha1-ajhfuIU9lS1f8F0Oiq+UJ43GPc8=
    ! 671 silly tarball trying string-width@^1.0.2 by hash: sha1-EYvfW4zcUaKn5w0hHgfisLmxB9M=
    ! 672 silly tarball trying strip-bom@^2.0.0 by hash: sha1-YhmoVhZSBJHzV4i9vxRHqZx+aw4=
    ! 673 silly tarball trying load-json-file@^1.0.0 by hash: sha1-lWkFcI1YtLq0wiYbBPWfMcmTdMA=
    ! 674 silly tarball trying validate-npm-package-license@^3.0.1 by hash: sha512-DpKm2Ui/xN7/HQKCtpZxoRWBhZ9Z0kqtygG8XCgNQ8ZlDnxuQmWhj566j8fN4Cu3/JmbhsDo7fcAJq4s9h27Ew==
    ! 675 silly tarball trying normalize-package-data@^2.3.2 by hash: sha512-9jjUFbTPfEy3R/ad/2oNbKtW9Hgovl5O1FvFWKkKblNXoN/Oou6+9+KKohPK13Yc3/TyunyWhJp6gvRNR/PPAw==
    ! 676 silly tarball trying read-pkg@^1.0.0 by hash: sha1-9f+qXs0pyzHAR0vKfXVra7KePyg=
    ! 677 silly tarball trying read-pkg-up@^1.0.1 by hash: sha1-nWPBMnbAZZGNV/ACpX9AobZD+wI=
    ! 678 silly tarball trying which-module@^1.0.0 by hash: sha1-u6Y8qGGUiZT/MHc2CJ47lgJsKk8=
    ! 679 silly tarball trying wrap-ansi@^2.0.0 by hash: sha1-2Pw9KE3QV5T+hJc8rs3Rz4JP3YU=
    ! 680 silly tarball trying cliui@^3.2.0 by hash: sha1-EgYBU3qRbSmUD5NNo7SNWFo5IT0=
    ! 681 silly tarball trying y18n@^3.2.1 by hash: sha1-bRX7qITAhnnA136I53WegR4H+kE=
    ! 682 silly tarball trying yargs-parser@^5.0.0 by hash: sha1-J17PDX/+Bcd+ZOfIbkzZS/DhIoo=
    ! 683 silly tarball trying yargs@^7.0.2 by hash: sha1-a6MY6xaWFyf10oT46gA+jWFU0Mg=
    ! 684 silly tarball trying iobroker@latest by hash: sha1-kHUXTlqOD0WDgutLvudNs94Z9fw=
    ! 685 silly tarball no local data for error-ex@^1.2.0. Extracting by manifest.
    ! 686 silly extract camelcase@^3.0.0 extracted to d:\ioBroker\node_modules.staging\camelcase-3ad74404 (154ms)
    ! 687 silly extract invert-kv@^1.0.0 extracted to d:\ioBroker\node_modules.staging\invert-kv-ee442c7c (170ms)
    ! 688 silly extract decamelize@^1.1.1 extracted to d:\ioBroker\node_modules.staging\decamelize-0ba114bd (170ms)
    ! 689 silly extract get-caller-file@^1.0.1 extracted to d:\ioBroker\node_modules.staging\get-caller-file-502c7d2c (170ms)
    ! 690 silly extract ansi-regex@^2.0.0 extracted to d:\ioBroker\node_modules.staging\ansi-regex-8eb58da5 (185ms)
    ! 691 silly extract is-builtin-module@^1.0.0 extracted to d:\ioBroker\node_modules.staging\is-builtin-module-60f0c1ff (170ms)
    ! 692 silly extract code-point-at@^1.0.0 extracted to d:\ioBroker\node_modules.staging\code-point-at-6ca5b365 (170ms)
    ! 693 silly extract number-is-nan@^1.0.0 extracted to d:\ioBroker\node_modules.staging\number-is-nan-60016a13 (170ms)
    ! 694 silly extract os-locale@^1.4.0 extracted to d:\ioBroker\node_modules.staging\os-locale-a09d6b6d (170ms)
    ! 695 silly extract is-fullwidth-code-point@^1.0.0 extracted to d:\ioBroker\node_modules.staging\is-fullwidth-code-point-d67b089b (170ms)
    ! 696 silly extract pinkie@^2.0.0 extracted to d:\ioBroker\node_modules.staging\pinkie-b6f9e91f (170ms)
    ! 697 silly extract path-exists@^2.0.0 extracted to d:\ioBroker\node_modules.staging\path-exists-02be61e4 (170ms)
    ! 698 silly extract pify@^2.0.0 extracted to d:\ioBroker\node_modules.staging\pify-dd514420 (170ms)
    ! 699 silly extract is-utf8@^0.2.0 extracted to d:\ioBroker\node_modules.staging\is-utf8-22b619c7 (170ms)
    ! 700 silly extract pinkie-promise@^2.0.0 extracted to d:\ioBroker\node_modules.staging\pinkie-promise-24df3ee0 (170ms)
    ! 701 silly extract find-up@^1.0.0 extracted to d:\ioBroker\node_modules.staging\find-up-568070f3 (170ms)
    ! 702 silly extract path-type@^1.0.0 extracted to d:\ioBroker\node_modules.staging\path-type-e6597794 (170ms)
    ! 703 silly extract spdx-license-ids@^3.0.0 extracted to d:\ioBroker\node_modules.staging\spdx-license-ids-2bca2237 (170ms)
    ! 704 silly extract spdx-exceptions@^2.1.0 extracted to d:\ioBroker\node_modules.staging\spdx-exceptions-81820bc4 (170ms)
    ! 705 silly extract string-width@^1.0.2 extracted to d:\ioBroker\node_modules.staging\string-width-21f46256 (170ms)
    ! 706 silly extract load-json-file@^1.0.0 extracted to d:\ioBroker\node_modules.staging\load-json-file-6e4f8fb5 (170ms)
    ! 707 silly extract strip-ansi@^3.0.1 extracted to d:\ioBroker\node_modules.staging\strip-ansi-f4c89f18 (170ms)
    ! 708 silly extract strip-bom@^2.0.0 extracted to d:\ioBroker\node_modules.staging\strip-bom-da6c8f79 (170ms)
    ! 709 silly extract validate-npm-package-license@^3.0.1 extracted to d:\ioBroker\node_modules.staging\validate-npm-package-license-49bde32d (170ms)
    ! 710 silly extract read-pkg-up@^1.0.1 extracted to d:\ioBroker\node_modules.staging\read-pkg-up-e457186d (170ms)
    ! 711 silly extract read-pkg@^1.0.0 extracted to d:\ioBroker\node_modules.staging\read-pkg-516b6c6c (170ms)
    ! 712 silly extract wrap-ansi@^2.0.0 extracted to d:\ioBroker\node_modules.staging\wrap-ansi-7d9d670f (170ms)
    ! 713 silly extract y18n@^3.2.1 extracted to d:\ioBroker\node_modules.staging\y18n-9c7ef7fd (185ms)
    ! 714 silly extract lcid@^1.0.0 extracted to d:\ioBroker\node_modules.staging\lcid-c433cc1b (185ms)
    ! 715 silly extract set-blocking@^2.0.0 extracted to d:\ioBroker\node_modules.staging\set-blocking-8df7dd5e (185ms)
    ! 716 silly extract cliui@^3.2.0 extracted to d:\ioBroker\node_modules.staging\cliui-366da990 (185ms)
    ! 717 silly extract which-module@^1.0.0 extracted to d:\ioBroker\node_modules.staging\which-module-d3f45931 (185ms)
    ! 718 silly extract builtin-modules@^1.0.0 extracted to d:\ioBroker\node_modules.staging\builtin-modules-4a61e175 (185ms)
    ! 719 silly extract spdx-correct@^3.0.0 extracted to d:\ioBroker\node_modules.staging\spdx-correct-7bf010cb (185ms)
    ! 720 silly extract require-main-filename@^1.0.1 extracted to d:\ioBroker\node_modules.staging\require-main-filename-1c8bac9a (185ms)
    ! 721 silly extract is-arrayish@^0.2.1 extracted to d:\ioBroker\node_modules.staging\is-arrayish-4349962f (185ms)
    ! 722 silly extract require-directory@^2.1.1 extracted to d:\ioBroker\node_modules.staging\require-directory-35320d58 (185ms)
    ! 723 silly extract spdx-expression-parse@^3.0.0 extracted to d:\ioBroker\node_modules.staging\spdx-expression-parse-1ba786e0 (185ms)
    ! 724 silly extract graceful-fs@^4.1.2 extracted to d:\ioBroker\node_modules.staging\graceful-fs-86ef2ecc (185ms)
    ! 725 silly extract hosted-git-info@^2.1.4 extracted to d:\ioBroker\node_modules.staging\hosted-git-info-5c2a0448 (185ms)
    ! 726 silly extract yargs-parser@^5.0.0 extracted to d:\ioBroker\node_modules.staging\yargs-parser-bf61d403 (185ms)
    ! 727 silly extract parse-json@^2.2.0 extracted to d:\ioBroker\node_modules.staging\parse-json-097b2a27 (185ms)
    ! 728 silly extract semver@^5.5.0 extracted to d:\ioBroker\node_modules.staging\semver-717d6f17 (185ms)
    ! 729 silly extract normalize-package-data@^2.3.2 extracted to d:\ioBroker\node_modules.staging\normalize-package-data-40bad782 (201ms)
    ! 730 http fetch GET 200 https://registry.npmjs.org/error-ex/-/e ... -1.3.2.tgz 116ms
    ! 731 silly extract error-ex@^1.2.0 extracted to d:\ioBroker\node_modules.staging\error-ex-0a8e1cae (217ms)
    ! 732 silly extract yargs@^7.0.2 extracted to d:\ioBroker\node_modules.staging\yargs-97a72c8f (217ms)
    ! 733 silly extract iobroker@latest extracted to d:\ioBroker\node_modules.staging\iobroker-a9faf2cc (254ms)
    ! 734 timing action:extract Completed in 269ms
    ! 735 silly doReverseSerial unbuild 376
    ! 736 silly doSerial remove 376
    ! 737 silly doSerial move 376
    ! 738 silly doSerial finalize 376
    ! 739 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\ansi-regex
    ! 740 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\builtin-modules
    ! 741 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\camelcase
    ! 742 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\code-point-at
    ! 743 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\decamelize
    ! 744 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\get-caller-file
    ! 745 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\graceful-fs
    ! 746 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\hosted-git-info
    ! 747 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\invert-kv
    ! 748 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\is-arrayish
    ! 749 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\error-ex
    ! 750 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\is-builtin-module
    ! 751 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\is-utf8
    ! 752 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\lcid
    ! 753 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\number-is-nan
    ! 754 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\is-fullwidth-code-point
    ! 755 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\os-locale
    ! 756 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\parse-json
    ! 757 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\pify
    ! 758 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\pinkie
    ! 759 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\pinkie-promise
    ! 760 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\path-exists
    ! 761 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\find-up
    ! 762 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\path-type
    ! 763 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\require-directory
    ! 764 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\require-main-filename
    ! 765 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\semver
    ! 766 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\set-blocking
    ! 767 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\spdx-exceptions
    ! 768 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\spdx-license-ids
    ! 769 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\spdx-expression-parse
    ! 770 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\spdx-correct
    ! 771 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\strip-ansi
    ! 772 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\string-width
    ! 773 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\strip-bom
    ! 774 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\load-json-file
    ! 775 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\validate-npm-package-license
    ! 776 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\normalize-package-data
    ! 777 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\read-pkg
    ! 778 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\read-pkg-up
    ! 779 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\which-module
    ! 780 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\wrap-ansi
    ! 781 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\cliui
    ! 782 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\y18n
    ! 783 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\yargs-parser
    ! 784 silly finalize d:\ioBroker\node_modules\iobroker\node_modules\yargs
    ! 785 silly finalize d:\ioBroker\node_modules\iobroker
    ! 786 timing action:finalize Completed in 116ms
    ! 787 silly doParallel refresh-package-json 47
    ! 788 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\ansi-regex
    ! 789 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\builtin-modules
    ! 790 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\camelcase
    ! 791 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\code-point-at
    ! 792 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\decamelize
    ! 793 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\get-caller-file
    ! 794 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\graceful-fs
    ! 795 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\hosted-git-info
    ! 796 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\invert-kv
    ! 797 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\is-arrayish
    ! 798 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\error-ex
    ! 799 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\is-builtin-module
    ! 800 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\is-utf8
    ! 801 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\lcid
    ! 802 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\number-is-nan
    ! 803 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\is-fullwidth-code-point
    ! 804 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\os-locale
    ! 805 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\parse-json
    ! 806 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\pify
    ! 807 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\pinkie
    ! 808 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\pinkie-promise
    ! 809 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\path-exists
    ! 810 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\find-up
    ! 811 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\path-type
    ! 812 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\require-directory
    ! 813 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\require-main-filename
    ! 814 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\semver
    ! 815 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\set-blocking
    ! 816 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\spdx-exceptions
    ! 817 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\spdx-license-ids
    ! 818 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\spdx-expression-parse
    ! 819 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\spdx-correct
    ! 820 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\strip-ansi
    ! 821 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\string-width
    ! 822 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\strip-bom
    ! 823 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\load-json-file
    ! 824 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\validate-npm-package-license
    ! 825 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\normalize-package-data
    ! 826 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\read-pkg
    ! 827 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\read-pkg-up
    ! 828 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\which-module
    ! 829 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\wrap-ansi
    ! 830 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\cliui
    ! 831 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\y18n
    ! 832 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\yargs-parser
    ! 833 silly refresh-package-json d:\ioBroker\node_modules\iobroker\node_modules\yargs
    ! 834 silly refresh-package-json d:\ioBroker\node_modules\iobroker
    ! 835 timing action:refresh-package-json Completed in 1352ms
    ! 836 silly doParallel preinstall 47
    ! 837 silly preinstall ansi-regex@2.1.1
    ! 838 info lifecycle ansi-regex@2.1.1~preinstall: ansi-regex@2.1.1
    ! 839 silly preinstall builtin-modules@1.1.1
    ! 840 info lifecycle builtin-modules@1.1.1~preinstall: builtin-modules@1.1.1
    ! 841 silly preinstall camelcase@3.0.0
    ! 842 info lifecycle camelcase@3.0.0~preinstall: camelcase@3.0.0
    ! 843 silly preinstall code-point-at@1.1.0
    ! 844 info lifecycle code-point-at@1.1.0~preinstall: code-point-at@1.1.0
    ! 845 silly preinstall decamelize@1.2.0
    ! 846 info lifecycle decamelize@1.2.0~preinstall: decamelize@1.2.0
    ! 847 silly preinstall get-caller-file@1.0.3
    ! 848 info lifecycle get-caller-file@1.0.3~preinstall: get-caller-file@1.0.3
    ! 849 silly preinstall graceful-fs@4.1.11
    ! 850 info lifecycle graceful-fs@4.1.11~preinstall: graceful-fs@4.1.11
    ! 851 silly preinstall hosted-git-info@2.7.1
    ! 852 info lifecycle hosted-git-info@2.7.1~preinstall: hosted-git-info@2.7.1
    ! 853 silly preinstall invert-kv@1.0.0
    ! 854 info lifecycle invert-kv@1.0.0~preinstall: invert-kv@1.0.0
    ! 855 silly preinstall is-arrayish@0.2.1
    ! 856 info lifecycle is-arrayish@0.2.1~preinstall: is-arrayish@0.2.1
    ! 857 silly preinstall error-ex@1.3.2
    ! 858 info lifecycle error-ex@1.3.2~preinstall: error-ex@1.3.2
    ! 859 silly preinstall is-builtin-module@1.0.0
    ! 860 info lifecycle is-builtin-module@1.0.0~preinstall: is-builtin-module@1.0.0
    ! 861 silly preinstall is-utf8@0.2.1
    ! 862 info lifecycle is-utf8@0.2.1~preinstall: is-utf8@0.2.1
    ! 863 silly preinstall lcid@1.0.0
    ! 864 info lifecycle lcid@1.0.0~preinstall: lcid@1.0.0
    ! 865 silly preinstall number-is-nan@1.0.1
    ! 866 info lifecycle number-is-nan@1.0.1~preinstall: number-is-nan@1.0.1
    ! 867 silly preinstall is-fullwidth-code-point@1.0.0
    ! 868 info lifecycle is-fullwidth-code-point@1.0.0~preinstall: is-fullwidth-code-point@1.0.0
    ! 869 silly preinstall os-locale@1.4.0
    ! 870 info lifecycle os-locale@1.4.0~preinstall: os-locale@1.4.0
    ! 871 silly preinstall parse-json@2.2.0
    ! 872 info lifecycle parse-json@2.2.0~preinstall: parse-json@2.2.0
    ! 873 silly preinstall pify@2.3.0
    ! 874 info lifecycle pify@2.3.0~preinstall: pify@2.3.0
    ! 875 silly preinstall pinkie@2.0.4
    ! 876 info lifecycle pinkie@2.0.4~preinstall: pinkie@2.0.4
    ! 877 silly preinstall pinkie-promise@2.0.1
    ! 878 info lifecycle pinkie-promise@2.0.1~preinstall: pinkie-promise@2.0.1
    ! 879 silly preinstall path-exists@2.1.0
    ! 880 info lifecycle path-exists@2.1.0~preinstall: path-exists@2.1.0
    ! 881 silly preinstall find-up@1.1.2
    ! 882 info lifecycle find-up@1.1.2~preinstall: find-up@1.1.2
    ! 883 silly preinstall path-type@1.1.0
    ! 884 info lifecycle path-type@1.1.0~preinstall: path-type@1.1.0
    ! 885 silly preinstall require-directory@2.1.1
    ! 886 info lifecycle require-directory@2.1.1~preinstall: require-directory@2.1.1
    ! 887 silly preinstall require-main-filename@1.0.1
    ! 888 info lifecycle require-main-filename@1.0.1~preinstall: require-main-filename@1.0.1
    ! 889 silly preinstall semver@5.6.0
    ! 890 info lifecycle semver@5.6.0~preinstall: semver@5.6.0
    ! 891 silly preinstall set-blocking@2.0.0
    ! 892 info lifecycle set-blocking@2.0.0~preinstall: set-blocking@2.0.0
    ! 893 silly preinstall spdx-exceptions@2.2.0
    ! 894 info lifecycle spdx-exceptions@2.2.0~preinstall: spdx-exceptions@2.2.0
    ! 895 silly preinstall spdx-license-ids@3.0.1
    ! 896 info lifecycle spdx-license-ids@3.0.1~preinstall: spdx-license-ids@3.0.1
    ! 897 silly preinstall spdx-expression-parse@3.0.0
    ! 898 info lifecycle spdx-expression-parse@3.0.0~preinstall: spdx-expression-parse@3.0.0
    ! 899 silly preinstall spdx-correct@3.0.2
    ! 900 info lifecycle spdx-correct@3.0.2~preinstall: spdx-correct@3.0.2
    ! 901 silly preinstall strip-ansi@3.0.1
    ! 902 info lifecycle strip-ansi@3.0.1~preinstall: strip-ansi@3.0.1
    ! 903 silly preinstall string-width@1.0.2
    ! 904 info lifecycle string-width@1.0.2~preinstall: string-width@1.0.2
    ! 905 silly preinstall strip-bom@2.0.0
    ! 906 info lifecycle strip-bom@2.0.0~preinstall: strip-bom@2.0.0
    ! 907 silly preinstall load-json-file@1.1.0
    ! 908 info lifecycle load-json-file@1.1.0~preinstall: load-json-file@1.1.0
    ! 909 silly preinstall validate-npm-package-license@3.0.4
    ! 910 info lifecycle validate-npm-package-license@3.0.4~preinstall: validate-npm-package-license@3.0.4
    ! 911 silly preinstall normalize-package-data@2.4.0
    ! 912 info lifecycle normalize-package-data@2.4.0~preinstall: normalize-package-data@2.4.0
    ! 913 silly preinstall read-pkg@1.1.0
    ! 914 info lifecycle read-pkg@1.1.0~preinstall: read-pkg@1.1.0
    ! 915 silly preinstall read-pkg-up@1.0.1
    ! 916 info lifecycle read-pkg-up@1.0.1~preinstall: read-pkg-up@1.0.1
    ! 917 silly preinstall which-module@1.0.0
    ! 918 info lifecycle which-module@1.0.0~preinstall: which-module@1.0.0
    ! 919 silly preinstall wrap-ansi@2.1.0
    ! 920 info lifecycle wrap-ansi@2.1.0~preinstall: wrap-ansi@2.1.0
    ! 921 silly preinstall cliui@3.2.0
    ! 922 info lifecycle cliui@3.2.0~preinstall: cliui@3.2.0
    ! 923 silly preinstall y18n@3.2.1
    ! 924 info lifecycle y18n@3.2.1~preinstall: y18n@3.2.1
    ! 925 silly preinstall yargs-parser@5.0.0
    ! 926 info lifecycle yargs-parser@5.0.0~preinstall: yargs-parser@5.0.0
    ! 927 silly preinstall yargs@7.1.0
    ! 928 info lifecycle yargs@7.1.0~preinstall: yargs@7.1.0
    ! 929 silly preinstall iobroker@1.1.2
    ! 930 info lifecycle iobroker@1.1.2~preinstall: iobroker@1.1.2
    ! 931 timing action:preinstall Completed in 16ms
    ! 932 silly doSerial build 376
    ! 933 silly build ansi-regex@2.1.1
    ! 934 info linkStuff ansi-regex@2.1.1
    ! 935 silly linkStuff ansi-regex@2.1.1 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 936 silly linkStuff ansi-regex@2.1.1 is part of a global install
    ! 937 silly linkStuff ansi-regex@2.1.1 is installed into a global node_modules
    ! 938 silly build builtin-modules@1.1.1
    ! 939 info linkStuff builtin-modules@1.1.1
    ! 940 silly linkStuff builtin-modules@1.1.1 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 941 silly linkStuff builtin-modules@1.1.1 is part of a global install
    ! 942 silly linkStuff builtin-modules@1.1.1 is installed into a global node_modules
    ! 943 silly build camelcase@3.0.0
    ! 944 info linkStuff camelcase@3.0.0
    ! 945 silly linkStuff camelcase@3.0.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 946 silly linkStuff camelcase@3.0.0 is part of a global install
    ! 947 silly linkStuff camelcase@3.0.0 is installed into a global node_modules
    ! 948 silly build code-point-at@1.1.0
    ! 949 info linkStuff code-point-at@1.1.0
    ! 950 silly linkStuff code-point-at@1.1.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 951 silly linkStuff code-point-at@1.1.0 is part of a global install
    ! 952 silly linkStuff code-point-at@1.1.0 is installed into a global node_modules
    ! 953 silly build decamelize@1.2.0
    ! 954 info linkStuff decamelize@1.2.0
    ! 955 silly linkStuff decamelize@1.2.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 956 silly linkStuff decamelize@1.2.0 is part of a global install
    ! 957 silly linkStuff decamelize@1.2.0 is installed into a global node_modules
    ! 958 silly build get-caller-file@1.0.3
    ! 959 info linkStuff get-caller-file@1.0.3
    ! 960 silly linkStuff get-caller-file@1.0.3 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 961 silly linkStuff get-caller-file@1.0.3 is part of a global install
    ! 962 silly linkStuff get-caller-file@1.0.3 is installed into a global node_modules
    ! 963 silly build graceful-fs@4.1.11
    ! 964 info linkStuff graceful-fs@4.1.11
    ! 965 silly linkStuff graceful-fs@4.1.11 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 966 silly linkStuff graceful-fs@4.1.11 is part of a global install
    ! 967 silly linkStuff graceful-fs@4.1.11 is installed into a global node_modules
    ! 968 silly build hosted-git-info@2.7.1
    ! 969 info linkStuff hosted-git-info@2.7.1
    ! 970 silly linkStuff hosted-git-info@2.7.1 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 971 silly linkStuff hosted-git-info@2.7.1 is part of a global install
    ! 972 silly linkStuff hosted-git-info@2.7.1 is installed into a global node_modules
    ! 973 silly build invert-kv@1.0.0
    ! 974 info linkStuff invert-kv@1.0.0
    ! 975 silly linkStuff invert-kv@1.0.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 976 silly linkStuff invert-kv@1.0.0 is part of a global install
    ! 977 silly linkStuff invert-kv@1.0.0 is installed into a global node_modules
    ! 978 silly build is-arrayish@0.2.1
    ! 979 info linkStuff is-arrayish@0.2.1
    ! 980 silly linkStuff is-arrayish@0.2.1 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 981 silly linkStuff is-arrayish@0.2.1 is part of a global install
    ! 982 silly linkStuff is-arrayish@0.2.1 is installed into a global node_modules
    ! 983 silly build error-ex@1.3.2
    ! 984 info linkStuff error-ex@1.3.2
    ! 985 silly linkStuff error-ex@1.3.2 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 986 silly linkStuff error-ex@1.3.2 is part of a global install
    ! 987 silly linkStuff error-ex@1.3.2 is installed into a global node_modules
    ! 988 silly build is-builtin-module@1.0.0
    ! 989 info linkStuff is-builtin-module@1.0.0
    ! 990 silly linkStuff is-builtin-module@1.0.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 991 silly linkStuff is-builtin-module@1.0.0 is part of a global install
    ! 992 silly linkStuff is-builtin-module@1.0.0 is installed into a global node_modules
    ! 993 silly build is-utf8@0.2.1
    ! 994 info linkStuff is-utf8@0.2.1
    ! 995 silly linkStuff is-utf8@0.2.1 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 996 silly linkStuff is-utf8@0.2.1 is part of a global install
    ! 997 silly linkStuff is-utf8@0.2.1 is installed into a global node_modules
    ! 998 silly build lcid@1.0.0
    ! 999 info linkStuff lcid@1.0.0
    ! 1000 silly linkStuff lcid@1.0.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1001 silly linkStuff lcid@1.0.0 is part of a global install
    ! 1002 silly linkStuff lcid@1.0.0 is installed into a global node_modules
    ! 1003 silly build number-is-nan@1.0.1
    ! 1004 info linkStuff number-is-nan@1.0.1
    ! 1005 silly linkStuff number-is-nan@1.0.1 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1006 silly linkStuff number-is-nan@1.0.1 is part of a global install
    ! 1007 silly linkStuff number-is-nan@1.0.1 is installed into a global node_modules
    ! 1008 silly build is-fullwidth-code-point@1.0.0
    ! 1009 info linkStuff is-fullwidth-code-point@1.0.0
    ! 1010 silly linkStuff is-fullwidth-code-point@1.0.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1011 silly linkStuff is-fullwidth-code-point@1.0.0 is part of a global install
    ! 1012 silly linkStuff is-fullwidth-code-point@1.0.0 is installed into a global node_modules
    ! 1013 silly build os-locale@1.4.0
    ! 1014 info linkStuff os-locale@1.4.0
    ! 1015 silly linkStuff os-locale@1.4.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1016 silly linkStuff os-locale@1.4.0 is part of a global install
    ! 1017 silly linkStuff os-locale@1.4.0 is installed into a global node_modules
    ! 1018 silly build parse-json@2.2.0
    ! 1019 info linkStuff parse-json@2.2.0
    ! 1020 silly linkStuff parse-json@2.2.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1021 silly linkStuff parse-json@2.2.0 is part of a global install
    ! 1022 silly linkStuff parse-json@2.2.0 is installed into a global node_modules
    ! 1023 silly build pify@2.3.0
    ! 1024 info linkStuff pify@2.3.0
    ! 1025 silly linkStuff pify@2.3.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1026 silly linkStuff pify@2.3.0 is part of a global install
    ! 1027 silly linkStuff pify@2.3.0 is installed into a global node_modules
    ! 1028 silly build pinkie@2.0.4
    ! 1029 info linkStuff pinkie@2.0.4
    ! 1030 silly linkStuff pinkie@2.0.4 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1031 silly linkStuff pinkie@2.0.4 is part of a global install
    ! 1032 silly linkStuff pinkie@2.0.4 is installed into a global node_modules
    ! 1033 silly build pinkie-promise@2.0.1
    ! 1034 info linkStuff pinkie-promise@2.0.1
    ! 1035 silly linkStuff pinkie-promise@2.0.1 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1036 silly linkStuff pinkie-promise@2.0.1 is part of a global install
    ! 1037 silly linkStuff pinkie-promise@2.0.1 is installed into a global node_modules
    ! 1038 silly build path-exists@2.1.0
    ! 1039 info linkStuff path-exists@2.1.0
    ! 1040 silly linkStuff path-exists@2.1.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1041 silly linkStuff path-exists@2.1.0 is part of a global install
    ! 1042 silly linkStuff path-exists@2.1.0 is installed into a global node_modules
    ! 1043 silly build find-up@1.1.2
    ! 1044 info linkStuff find-up@1.1.2
    ! 1045 silly linkStuff find-up@1.1.2 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1046 silly linkStuff find-up@1.1.2 is part of a global install
    ! 1047 silly linkStuff find-up@1.1.2 is installed into a global node_modules
    ! 1048 silly build path-type@1.1.0
    ! 1049 info linkStuff path-type@1.1.0
    ! 1050 silly linkStuff path-type@1.1.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1051 silly linkStuff path-type@1.1.0 is part of a global install
    ! 1052 silly linkStuff path-type@1.1.0 is installed into a global node_modules
    ! 1053 silly build require-directory@2.1.1
    ! 1054 info linkStuff require-directory@2.1.1
    ! 1055 silly linkStuff require-directory@2.1.1 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1056 silly linkStuff require-directory@2.1.1 is part of a global install
    ! 1057 silly linkStuff require-directory@2.1.1 is installed into a global node_modules
    ! 1058 silly build require-main-filename@1.0.1
    ! 1059 info linkStuff require-main-filename@1.0.1
    ! 1060 silly linkStuff require-main-filename@1.0.1 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1061 silly linkStuff require-main-filename@1.0.1 is part of a global install
    ! 1062 silly linkStuff require-main-filename@1.0.1 is installed into a global node_modules
    ! 1063 silly build semver@5.6.0
    ! 1064 info linkStuff semver@5.6.0
    ! 1065 silly linkStuff semver@5.6.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1066 silly linkStuff semver@5.6.0 is part of a global install
    ! 1067 silly linkStuff semver@5.6.0 is installed into a global node_modules
    ! 1068 verbose linkBins [ { semver: './bin/semver' },
    ! 1068 verbose linkBins 'd:\ioBroker\node_modules\iobroker\node_modules\.bin',
    ! 1068 verbose linkBins false ]
    ! 1069 silly build set-blocking@2.0.0
    ! 1070 info linkStuff set-blocking@2.0.0
    ! 1071 silly linkStuff set-blocking@2.0.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1072 silly linkStuff set-blocking@2.0.0 is part of a global install
    ! 1073 silly linkStuff set-blocking@2.0.0 is installed into a global node_modules
    ! 1074 silly build spdx-exceptions@2.2.0
    ! 1075 info linkStuff spdx-exceptions@2.2.0
    ! 1076 silly linkStuff spdx-exceptions@2.2.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1077 silly linkStuff spdx-exceptions@2.2.0 is part of a global install
    ! 1078 silly linkStuff spdx-exceptions@2.2.0 is installed into a global node_modules
    ! 1079 silly build spdx-license-ids@3.0.1
    ! 1080 info linkStuff spdx-license-ids@3.0.1
    ! 1081 silly linkStuff spdx-license-ids@3.0.1 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1082 silly linkStuff spdx-license-ids@3.0.1 is part of a global install
    ! 1083 silly linkStuff spdx-license-ids@3.0.1 is installed into a global node_modules
    ! 1084 silly build spdx-expression-parse@3.0.0
    ! 1085 info linkStuff spdx-expression-parse@3.0.0
    ! 1086 silly linkStuff spdx-expression-parse@3.0.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1087 silly linkStuff spdx-expression-parse@3.0.0 is part of a global install
    ! 1088 silly linkStuff spdx-expression-parse@3.0.0 is installed into a global node_modules
    ! 1089 silly build spdx-correct@3.0.2
    ! 1090 info linkStuff spdx-correct@3.0.2
    ! 1091 silly linkStuff spdx-correct@3.0.2 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1092 silly linkStuff spdx-correct@3.0.2 is part of a global install
    ! 1093 silly linkStuff spdx-correct@3.0.2 is installed into a global node_modules
    ! 1094 silly build strip-ansi@3.0.1
    ! 1095 info linkStuff strip-ansi@3.0.1
    ! 1096 silly linkStuff strip-ansi@3.0.1 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1097 silly linkStuff strip-ansi@3.0.1 is part of a global install
    ! 1098 silly linkStuff strip-ansi@3.0.1 is installed into a global node_modules
    ! 1099 silly build string-width@1.0.2
    ! 1100 info linkStuff string-width@1.0.2
    ! 1101 silly linkStuff string-width@1.0.2 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1102 silly linkStuff string-width@1.0.2 is part of a global install
    ! 1103 silly linkStuff string-width@1.0.2 is installed into a global node_modules
    ! 1104 silly build strip-bom@2.0.0
    ! 1105 info linkStuff strip-bom@2.0.0
    ! 1106 silly linkStuff strip-bom@2.0.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1107 silly linkStuff strip-bom@2.0.0 is part of a global install
    ! 1108 silly linkStuff strip-bom@2.0.0 is installed into a global node_modules
    ! 1109 silly build load-json-file@1.1.0
    ! 1110 info linkStuff load-json-file@1.1.0
    ! 1111 silly linkStuff load-json-file@1.1.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1112 silly linkStuff load-json-file@1.1.0 is part of a global install
    ! 1113 silly linkStuff load-json-file@1.1.0 is installed into a global node_modules
    ! 1114 silly build validate-npm-package-license@3.0.4
    ! 1115 info linkStuff validate-npm-package-license@3.0.4
    ! 1116 silly linkStuff validate-npm-package-license@3.0.4 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1117 silly linkStuff validate-npm-package-license@3.0.4 is part of a global install
    ! 1118 silly linkStuff validate-npm-package-license@3.0.4 is installed into a global node_modules
    ! 1119 silly build normalize-package-data@2.4.0
    ! 1120 info linkStuff normalize-package-data@2.4.0
    ! 1121 silly linkStuff normalize-package-data@2.4.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1122 silly linkStuff normalize-package-data@2.4.0 is part of a global install
    ! 1123 silly linkStuff normalize-package-data@2.4.0 is installed into a global node_modules
    ! 1124 silly build read-pkg@1.1.0
    ! 1125 info linkStuff read-pkg@1.1.0
    ! 1126 silly linkStuff read-pkg@1.1.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1127 silly linkStuff read-pkg@1.1.0 is part of a global install
    ! 1128 silly linkStuff read-pkg@1.1.0 is installed into a global node_modules
    ! 1129 silly build read-pkg-up@1.0.1
    ! 1130 info linkStuff read-pkg-up@1.0.1
    ! 1131 silly linkStuff read-pkg-up@1.0.1 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1132 silly linkStuff read-pkg-up@1.0.1 is part of a global install
    ! 1133 silly linkStuff read-pkg-up@1.0.1 is installed into a global node_modules
    ! 1134 silly build which-module@1.0.0
    ! 1135 info linkStuff which-module@1.0.0
    ! 1136 silly linkStuff which-module@1.0.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1137 silly linkStuff which-module@1.0.0 is part of a global install
    ! 1138 silly linkStuff which-module@1.0.0 is installed into a global node_modules
    ! 1139 silly build wrap-ansi@2.1.0
    ! 1140 info linkStuff wrap-ansi@2.1.0
    ! 1141 silly linkStuff wrap-ansi@2.1.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1142 silly linkStuff wrap-ansi@2.1.0 is part of a global install
    ! 1143 silly linkStuff wrap-ansi@2.1.0 is installed into a global node_modules
    ! 1144 silly build cliui@3.2.0
    ! 1145 info linkStuff cliui@3.2.0
    ! 1146 silly linkStuff cliui@3.2.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1147 silly linkStuff cliui@3.2.0 is part of a global install
    ! 1148 silly linkStuff cliui@3.2.0 is installed into a global node_modules
    ! 1149 silly build y18n@3.2.1
    ! 1150 info linkStuff y18n@3.2.1
    ! 1151 silly linkStuff y18n@3.2.1 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1152 silly linkStuff y18n@3.2.1 is part of a global install
    ! 1153 silly linkStuff y18n@3.2.1 is installed into a global node_modules
    ! 1154 silly build yargs-parser@5.0.0
    ! 1155 info linkStuff yargs-parser@5.0.0
    ! 1156 silly linkStuff yargs-parser@5.0.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1157 silly linkStuff yargs-parser@5.0.0 is part of a global install
    ! 1158 silly linkStuff yargs-parser@5.0.0 is installed into a global node_modules
    ! 1159 silly build yargs@7.1.0
    ! 1160 info linkStuff yargs@7.1.0
    ! 1161 silly linkStuff yargs@7.1.0 has d:\ioBroker\node_modules\iobroker\node_modules as its parent node_modules
    ! 1162 silly linkStuff yargs@7.1.0 is part of a global install
    ! 1163 silly linkStuff yargs@7.1.0 is installed into a global node_modules
    ! 1164 silly build iobroker@1.1.2
    ! 1165 info linkStuff iobroker@1.1.2
    ! 1166 silly linkStuff iobroker@1.1.2 has d:\ioBroker\node_modules as its parent node_modules
    ! 1167 silly linkStuff iobroker@1.1.2 is part of a global install
    ! 1168 silly linkStuff iobroker@1.1.2 is installed into a global node_modules
    ! 1169 silly linkStuff iobroker@1.1.2 is installed into the top-level global node_modules
    ! 1170 timing action:build Completed in 22ms
    ! 1171 silly doSerial global-link 376
    ! 1172 silly doParallel update-linked 0
    ! 1173 silly doSerial install 376
    ! 1174 silly install ansi-regex@2.1.1
    ! 1175 info lifecycle ansi-regex@2.1.1~install: ansi-regex@2.1.1
    ! 1176 silly install builtin-modules@1.1.1
    ! 1177 info lifecycle builtin-modules@1.1.1~install: builtin-modules@1.1.1
    ! 1178 silly install camelcase@3.0.0
    ! 1179 info lifecycle camelcase@3.0.0~install: camelcase@3.0.0
    ! 1180 silly install code-point-at@1.1.0
    ! 1181 info lifecycle code-point-at@1.1.0~install: code-point-at@1.1.0
    ! 1182 silly install decamelize@1.2.0
    ! 1183 info lifecycle decamelize@1.2.0~install: decamelize@1.2.0
    ! 1184 silly install get-caller-file@1.0.3
    ! 1185 info lifecycle get-caller-file@1.0.3~install: get-caller-file@1.0.3
    ! 1186 silly install graceful-fs@4.1.11
    ! 1187 info lifecycle graceful-fs@4.1.11~install: graceful-fs@4.1.11
    ! 1188 silly install hosted-git-info@2.7.1
    ! 1189 info lifecycle hosted-git-info@2.7.1~install: hosted-git-info@2.7.1
    ! 1190 silly install invert-kv@1.0.0
    ! 1191 info lifecycle invert-kv@1.0.0~install: invert-kv@1.0.0
    ! 1192 silly install is-arrayish@0.2.1
    ! 1193 info lifecycle is-arrayish@0.2.1~install: is-arrayish@0.2.1
    ! 1194 silly install error-ex@1.3.2
    ! 1195 info lifecycle error-ex@1.3.2~install: error-ex@1.3.2
    ! 1196 silly install is-builtin-module@1.0.0
    ! 1197 info lifecycle is-builtin-module@1.0.0~install: is-builtin-module@1.0.0
    ! 1198 silly install is-utf8@0.2.1
    ! 1199 info lifecycle is-utf8@0.2.1~install: is-utf8@0.2.1
    ! 1200 silly install lcid@1.0.0
    ! 1201 info lifecycle lcid@1.0.0~install: lcid@1.0.0
    ! 1202 silly install number-is-nan@1.0.1
    ! 1203 info lifecycle number-is-nan@1.0.1~install: number-is-nan@1.0.1
    ! 1204 silly install is-fullwidth-code-point@1.0.0
    ! 1205 info lifecycle is-fullwidth-code-point@1.0.0~install: is-fullwidth-code-point@1.0.0
    ! 1206 silly install os-locale@1.4.0
    ! 1207 info lifecycle os-locale@1.4.0~install: os-locale@1.4.0
    ! 1208 silly install parse-json@2.2.0
    ! 1209 info lifecycle parse-json@2.2.0~install: parse-json@2.2.0
    ! 1210 silly install pify@2.3.0
    ! 1211 info lifecycle pify@2.3.0~install: pify@2.3.0
    ! 1212 silly install pinkie@2.0.4
    ! 1213 info lifecycle pinkie@2.0.4~install: pinkie@2.0.4
    ! 1214 silly install pinkie-promise@2.0.1
    ! 1215 info lifecycle pinkie-promise@2.0.1~install: pinkie-promise@2.0.1
    ! 1216 silly install path-exists@2.1.0
    ! 1217 info lifecycle path-exists@2.1.0~install: path-exists@2.1.0
    ! 1218 silly install find-up@1.1.2
    ! 1219 info lifecycle find-up@1.1.2~install: find-up@1.1.2
    ! 1220 silly install path-type@1.1.0
    ! 1221 info lifecycle path-type@1.1.0~install: path-type@1.1.0
    ! 1222 silly install require-directory@2.1.1
    ! 1223 info lifecycle require-directory@2.1.1~install: require-directory@2.1.1
    ! 1224 silly install require-main-filename@1.0.1
    ! 1225 info lifecycle require-main-filename@1.0.1~install: require-main-filename@1.0.1
    ! 1226 silly install semver@5.6.0
    ! 1227 info lifecycle semver@5.6.0~install: semver@5.6.0
    ! 1228 silly install set-blocking@2.0.0
    ! 1229 info lifecycle set-blocking@2.0.0~install: set-blocking@2.0.0
    ! 1230 silly install spdx-exceptions@2.2.0
    ! 1231 info lifecycle spdx-exceptions@2.2.0~install: spdx-exceptions@2.2.0
    ! 1232 silly install spdx-license-ids@3.0.1
    ! 1233 info lifecycle spdx-license-ids@3.0.1~install: spdx-license-ids@3.0.1
    ! 1234 silly install spdx-expression-parse@3.0.0
    ! 1235 info lifecycle spdx-expression-parse@3.0.0~install: spdx-expression-parse@3.0.0
    ! 1236 silly install spdx-correct@3.0.2
    ! 1237 info lifecycle spdx-correct@3.0.2~install: spdx-correct@3.0.2
    ! 1238 silly install strip-ansi@3.0.1
    ! 1239 info lifecycle strip-ansi@3.0.1~install: strip-ansi@3.0.1
    ! 1240 silly install string-width@1.0.2
    ! 1241 info lifecycle string-width@1.0.2~install: string-width@1.0.2
    ! 1242 silly install strip-bom@2.0.0
    ! 1243 info lifecycle strip-bom@2.0.0~install: strip-bom@2.0.0
    ! 1244 silly install load-json-file@1.1.0
    ! 1245 info lifecycle load-json-file@1.1.0~install: load-json-file@1.1.0
    ! 1246 silly install validate-npm-package-license@3.0.4
    ! 1247 info lifecycle validate-npm-package-license@3.0.4~install: validate-npm-package-license@3.0.4
    ! 1248 silly install normalize-package-data@2.4.0
    ! 1249 info lifecycle normalize-package-data@2.4.0~install: normalize-package-data@2.4.0
    ! 1250 silly install read-pkg@1.1.0
    ! 1251 info lifecycle read-pkg@1.1.0~install: read-pkg@1.1.0
    ! 1252 silly install read-pkg-up@1.0.1
    ! 1253 info lifecycle read-pkg-up@1.0.1~install: read-pkg-up@1.0.1
    ! 1254 silly install which-module@1.0.0
    ! 1255 info lifecycle which-module@1.0.0~install: which-module@1.0.0
    ! 1256 silly install wrap-ansi@2.1.0
    ! 1257 info lifecycle wrap-ansi@2.1.0~install: wrap-ansi@2.1.0
    ! 1258 silly install cliui@3.2.0
    ! 1259 info lifecycle cliui@3.2.0~install: cliui@3.2.0
    ! 1260 silly install y18n@3.2.1
    ! 1261 info lifecycle y18n@3.2.1~install: y18n@3.2.1
    ! 1262 silly install yargs-parser@5.0.0
    ! 1263 info lifecycle yargs-parser@5.0.0~install: yargs-parser@5.0.0
    ! 1264 silly install yargs@7.1.0
    ! 1265 info lifecycle yargs@7.1.0~install: yargs@7.1.0
    ! 1266 silly install iobroker@1.1.2
    ! 1267 info lifecycle iobroker@1.1.2~install: iobroker@1.1.2
    ! 1268 verbose lifecycle iobroker@1.1.2~install: unsafe-perm in lifecycle true
    ! 1269 verbose lifecycle iobroker@1.1.2~install: PATH: C:\Users\TATIANA\AppData\Roaming\npm\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin;d:\ioBroker\node_modules\iobroker\node_modules.bin;d:\ioBroker\node_modules.bin;C:\Program Files (x86)\Intel\iCLS Client;C:\Program Files\Intel\iCLS Client;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\Skype\Phone;C:\WINDOWS\System32\OpenSSH;C:\Program Files\nodejs;D:\Program Files (x86)\PuTTY;D:\Python\Python37\Scripts;D:\Python\Python37;C:\Users\TATIANA\AppData\Local\Microsoft\WindowsApps;C:\Users\TATIANA\AppData\Roaming\npm
    ! 1270 verbose lifecycle iobroker@1.1.2~install: CWD: d:\ioBroker\node_modules\iobroker
    ! 1271 silly lifecycle iobroker@1.1.2~install: Args: [ '/d /s /c', 'node lib/prepareSetup.js && node lib/setup.js' ]
    ! 1272 silly lifecycle iobroker@1.1.2~install: Returned: code: 4 signal: null
    ! 1273 info lifecycle iobroker@1.1.2~install: Failed to exec install script
    ! 1274 timing action:install Completed in 2168ms
    ! 1275 verbose unlock done using C:\Users\TATIANA\AppData\Roaming\npm-cache_locks\staging-07aec478ec01a593.lock for d:\ioBroker\node_modules.staging
    ! 1276 timing stage:rollbackFailedOptional Completed in 100ms
    ! 1277 timing stage:runTopLevelLifecycles Completed in 6386ms
    ! 1278 verbose stack Error: iobroker@1.1.2 install: node lib/prepareSetup.js && node lib/setup.js
    ! 1278 verbose stack Exit status 4
    ! 1278 verbose stack at EventEmitter. <anonymous>(C:\Users\TATIANA\AppData\Roaming\npm\node_modules\npm\node_modules\npm-lifecycle\index.js:301:16)
    ! 1278 verbose stack at emitTwo (events.js:126:13)
    ! 1278 verbose stack at EventEmitter.emit (events.js:214:7)
    ! 1278 verbose stack at ChildProcess. <anonymous>(C:\Users\TATIANA\AppData\Roaming\npm\node_modules\npm\node_modules\npm-lifecycle\lib\spawn.js:55:14)
    ! 1278 verbose stack at emitTwo (events.js:126:13)
    ! 1278 verbose stack at ChildProcess.emit (events.js:214:7)
    ! 1278 verbose stack at maybeClose (internal/child_process.js:925:16)
    ! 1278 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:209:5)
    ! 1279 verbose pkgid iobroker@1.1.2
    ! 1280 verbose cwd C:\Program Files\nodejs
    ! 1281 verbose Windows_NT 10.0.17134
    ! 1282 verbose argv "C:\Program Files\nodejs\node.exe" "C:\Users\TATIANA\AppData\Roaming\npm\node_modules\npm\bin\npm-cli.js" "install" "iobroker" "–prefix" "d:\ioBroker"
    ! 1283 verbose node v8.11.3
    ! 1284 verbose npm v6.4.1
    ! 1285 error code ELIFECYCLE
    ! 1286 error errno 4
    ! 1287 error iobroker@1.1.2 install: node lib/prepareSetup.js && node lib/setup.js
    ! 1287 error Exit status 4
    ! 1288 error Failed at the iobroker@1.1.2 install script.
    ! 1288 error This is probably not a problem with npm. There is likely additional logging output above.
    ! 1289 verbose exit [ 4, true ]</anonymous></anonymous>


  • У меня тоже не ставится на семерку, перепробовал все версии node от 4.8 до 10.13, не ставится инсталятором, подскажите как быть?

    Спасибо.


  • Буду третьим. Та же история. Вин 10 на 64 бит. Откликнитесь знатоки. Уже неделю стучу в бубен и всё без толку.


  • Я сделал.

    Записывайте.

    __1. Ставим Node.js, я грузанул node-v10.13.0-x64

    2. Открываем консоль под админом.

    3. Последовательно вводим

    npm install –global windows-build-tools

    md C:\iobroker

    cd /d C:\iobroker

    npm install iobroker

    npm install –production

    если не ставится то вводим

    npm install –production –-unsafe-perm

    Все__


  • Ура, помогло!

    Огромное спасибо!


  • а мне не помогло 😞

    Изначально iobroker был установлен в d:\iobroker

    Выполнила все шаги оттуда, стартанула iobroker, но http://localhost:8081 не отвечает (ERR_CONNECTION_REFUSED)

    Создала каталог на диске C, все повторила, результат тот же…

    А как все корректно удалить? и все с нуля поставить?

    ! C:\iobroker>npm i –production --unsafe-perm
    ! npm WARN deprecated dgram@1.0.1: npm is holding this package for security reasons. As it's a core Node module, we will not transfer it over to other users. You may safely remove the package from your dependencies.
    ! > iobroker.js-controller@1.4.2 preinstall C:\iobroker\node_modules\iobroker.js-controller
    ! > node lib/preinstall_check.js
    ! NPM version: 6.5.0
    ! npm version >= 5: disabling package-lock
    ! > unix-dgram@0.2.3 install C:\iobroker\node_modules\unix-dgram
    ! > node-gyp rebuild
    ! C:\iobroker\node_modules\unix-dgram>if not defined npm_config_node_gyp (node "C:\Users\TATIANA\AppData\Roaming\npm\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\....\node_modules\node-gyp\bin\node-gyp.js" rebuild ) else (node "C:\Users\TATIANA\AppData\Roaming\npm\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js" rebuild )
    ! Выполняется последовательная сборка проектов в этом решении. Чтобы включить параллельную сборку, добавьте параметр "/m".
    ! unix_dgram.cc
    ! win_delay_load_hook.cc
    ! c:\iobroker\node_modules\unix-dgram\node_modules\nan\nan_maybe_43_inl.h(88): error C2039: ForceSet: не является членом
    ! "v8::Object" (компилируется исходный файл ..\src\unix_dgram.cc) [C:\iobroker\node_modules\unix-dgram\build\unix_dgram.v
    ! cxproj]
    ! c:\users\tatiana.node-gyp\10.15.0\include\node\v8.h(3243): note: см. объявление "v8::Object" (компилируется исходны
    ! й файл ..\src\unix_dgram.cc)
    ! c:\iobroker\node_modules\unix-dgram\node_modules\nan\nan.h(816): warning C4996: 'node::MakeCallback': объявлен deprecat
    ! e (компилируется исходный файл ..\src\unix_dgram.cc) [C:\iobroker\node_modules\unix-dgram\build\unix_dgram.vcxproj]
    ! c:\users\tatiana.node-gyp\10.15.0\include\node\node.h(176): note: см. объявление "node::MakeCallback" (компилируетс
    ! я исходный файл ..\src\unix_dgram.cc)
    ! c:\iobroker\node_modules\unix-dgram\node_modules\nan\nan.h(830): warning C4996: 'node::MakeCallback': объявлен deprecat
    ! e (компилируется исходный файл ..\src\unix_dgram.cc) [C:\iobroker\node_modules\unix-dgram\build\unix_dgram.vcxproj]
    ! c:\users\tatiana.node-gyp\10.15.0\include\node\node.h(169): note: см. объявление "node::MakeCallback" (компилируетс
    ! я исходный файл ..\src\unix_dgram.cc)
    ! c:\iobroker\node_modules\unix-dgram\node_modules\nan\nan.h(844): warning C4996: 'node::MakeCallback': объявлен deprecat
    ! e (компилируется исходный файл ..\src\unix_dgram.cc) [C:\iobroker\node_modules\unix-dgram\build\unix_dgram.vcxproj]
    ! c:\users\tatiana.node-gyp\10.15.0\include\node\node.h(162): note: см. объявление "node::MakeCallback" (компилируетс
    ! я исходный файл ..\src\unix_dgram.cc)
    ! c:\iobroker\node_modules\unix-dgram\node_modules\nan\nan.h(1457): warning C4996: 'node::MakeCallback': объявлен depreca
    ! te (компилируется исходный файл ..\src\unix_dgram.cc) [C:\iobroker\node_modules\unix-dgram\build\unix_dgram.vcxproj]
    ! c:\users\tatiana.node-gyp\10.15.0\include\node\node.h(176): note: см. объявление "node::MakeCallback" (компилируетс
    ! я исходный файл ..\src\unix_dgram.cc)
    ! c:\iobroker\node_modules\unix-dgram\src\unix_dgram.cc(9): fatal error C1083: Не удается открыть файл включение: unistd.
    ! h: No such file or directory, [C:\iobroker\node_modules\unix-dgram\build\unix_dgram.vcxproj]
    ! gyp ERR! build error
    ! gyp ERR! stack Error: C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\MSBuild\15.0\Bin\MSBuild.exe failed with exit code: 1
    ! gyp ERR! stack at ChildProcess.onExit (C:\Users\TATIANA\AppData\Roaming\npm\node_modules\npm\node_modules\node-gyp\lib\build.js:262:23)
    ! gyp ERR! stack at ChildProcess.emit (events.js:182:13)
    ! gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:240:12)
    ! gyp ERR! System Windows_NT 10.0.17134
    ! gyp ERR! command "D:\Program Files\nodejs\node.exe" "C:\Users\TATIANA\AppData\Roaming\npm\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js" "rebuild"
    ! gyp ERR! cwd C:\iobroker\node_modules\unix-dgram
    ! gyp ERR! node -v v10.15.0
    ! gyp ERR! node-gyp -v v3.8.0
    ! gyp ERR! not ok
    ! > ursa-optional@0.9.10 install C:\iobroker\node_modules\ursa-optional
    ! > node rebuild.js
    ! > serialport@6.2.2 install C:\iobroker\node_modules\serialport
    ! > prebuild-install || node-gyp rebuild
    ! > iobroker.js-controller@1.4.2 install C:\iobroker\node_modules\iobroker.js-controller
    ! > node iobroker.js setup first
    ! creating conf/iobroker.json
    ! object system.certificates created
    ! object system.repositories created
    ! object system.config created
    ! object enum.functions created
    ! object enum.rooms created
    ! object system.group.user created
    ! object system.group.administrator created
    ! object _design/system created
    ! object system.meta.uuid created: 5cfbcb56-d0af-d69f-c9b3-492a8f0362db
    ! object system.user.admin created
    ! host.DESKTOP-2JHKI4U install adapter admin
    ! npm install –production (System call) in "C:/iobroker/node_modules/iobroker.admin"
    ! npm WARN deprecated gulp-util@3.0.8: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5
    ! npm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
    ! npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
    ! npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
    ! npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
    ! npm notice created a lockfile as package-lock.json. You should commit this file.
    ! got C:/iobroker/node_modules/iobroker.admin/admin
    ! upload [3] admin.admin C:/iobroker/node_modules/iobroker.admin/admin/words.js words.js application/javascript
    ! upload [2] admin.admin C:/iobroker/node_modules/iobroker.admin/admin/index_m.html index_m.html text/html
    ! upload [1] admin.admin C:/iobroker/node_modules/iobroker.admin/admin/index.html index.html text/html
    ! upload [0] admin.admin C:/iobroker/node_modules/iobroker.admin/admin/admin.png admin.png image/png
    ! host.DESKTOP-2JHKI4U object system.adapter.admin created
    ! host.DESKTOP-2JHKI4U create instance admin
    ! host.DESKTOP-2JHKI4U object admin.0 created
    ! host.DESKTOP-2JHKI4U object admin.0.info created
    ! host.DESKTOP-2JHKI4U object system.adapter.admin.upload created
    ! host.DESKTOP-2JHKI4U object system.adapter.admin.0.outputCount created
    ! host.DESKTOP-2JHKI4U object system.adapter.admin.0.inputCount created
    ! host.DESKTOP-2JHKI4U object system.adapter.admin.0.uptime created
    ! host.DESKTOP-2JHKI4U object system.adapter.admin.0.memRss created
    ! host.DESKTOP-2JHKI4U object system.adapter.admin.0.memHeapTotal created
    ! host.DESKTOP-2JHKI4U object system.adapter.admin.0.memHeapUsed created
    ! host.DESKTOP-2JHKI4U object system.adapter.admin.0.connected created
    ! host.DESKTOP-2JHKI4U object system.adapter.admin.0.alive created
    ! host.DESKTOP-2JHKI4U object system.adapter.admin.0 created
    ! host.DESKTOP-2JHKI4U install adapter discovery
    ! npm install –production (System call) in "C:/iobroker/node_modules/iobroker.discovery"
    ! npm WARN deprecated dgram@1.0.1: npm is holding this package for security reasons. As it's a core Node module, we will not transfer it over to other users. You may safely remove the package from your dependencies.
    ! npm WARN deprecated gulp-util@3.0.8: gulp-util is deprecated - replace it, following the guidelines at https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5
    ! npm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
    ! npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
    ! npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
    ! npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
    ! npm notice created a lockfile as package-lock.json. You should commit this file.
    ! got C:/iobroker/node_modules/iobroker.discovery/admin
    ! upload [5] discovery.admin C:/iobroker/node_modules/iobroker.discovery/admin/words.js words.js application/javascript
    ! upload [4] discovery.admin C:/iobroker/node_modules/iobroker.discovery/admin/settings_m.html settings_m.html text/html
    ! upload [3] discovery.admin C:/iobroker/node_modules/iobroker.discovery/admin/settings.html settings.html text/html
    ! upload [2] discovery.admin C:/iobroker/node_modules/iobroker.discovery/admin/index_m.html index_m.html text/html
    ! upload [1] discovery.admin C:/iobroker/node_modules/iobroker.discovery/admin/index.html index.html text/html
    ! upload [0] discovery.admin C:/iobroker/node_modules/iobroker.discovery/admin/discovery.png discovery.png image/png
    ! host.DESKTOP-2JHKI4U object system.adapter.discovery created
    ! host.DESKTOP-2JHKI4U create instance discovery
    ! host.DESKTOP-2JHKI4U object discovery.0.scanRunning created
    ! host.DESKTOP-2JHKI4U object discovery.0.devicesFound created
    ! host.DESKTOP-2JHKI4U object discovery.0.instancesFound created
    ! host.DESKTOP-2JHKI4U object discovery.0.servicesProgress created
    ! host.DESKTOP-2JHKI4U object discovery.0.devicesProgress created
    ! host.DESKTOP-2JHKI4U object system.adapter.discovery.0.outputCount created
    ! host.DESKTOP-2JHKI4U object system.adapter.discovery.0.inputCount created
    ! host.DESKTOP-2JHKI4U object system.adapter.discovery.0.uptime created
    ! host.DESKTOP-2JHKI4U object system.adapter.discovery.0.memRss created
    ! host.DESKTOP-2JHKI4U object system.adapter.discovery.0.memHeapTotal created
    ! host.DESKTOP-2JHKI4U object system.adapter.discovery.0.memHeapUsed created
    ! host.DESKTOP-2JHKI4U object system.adapter.discovery.0.connected created
    ! host.DESKTOP-2JHKI4U object system.adapter.discovery.0.alive created
    ! host.DESKTOP-2JHKI4U object system.adapter.discovery.0 created
    ! > rsa-compat@1.9.2 postinstall C:\iobroker\node_modules\rsa-compat
    ! > node lib/telemetry.js event:install
    ! > iobroker.inst@1.3.1 install C:\iobroker
    ! > node lib/checkVersions.js
    ! NPM version: 6.5.0
    ! > iobroker.inst@1.3.1 postinstall C:\iobroker
    ! > node lib/install.js
    ! Write "iobroker start" to start the ioBroker
    ! npm install node-windows@0.1.14 –production --save --prefix "C:/iobroker"
    ! ioBroker service installed. Write "serviceIoBroker start" to start the service and go to http://localhost:8081 to open the admin UI.
    ! To see the outputs do not start the service, but write "node node_modules/iobroker.js-controller/controller"
    ! npm WARN optional SKIPPING OPTIONAL DEPENDENCY: unix-dgram@0.2.3 (node_modules\unix-dgram):
    ! npm WARN optional SKIPPING OPTIONAL DEPENDENCY: unix-dgram@0.2.3 install: node-gyp rebuild
    ! npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1
    ! added 509 packages from 290 contributors and audited 1811 packages in 109.755s
    ! found 23 vulnerabilities (17 low, 6 high)
    ! run npm audit fix to fix them, or npm audit for details
    ! C:\iobroker>iobroker start
    ! C:\iobroker>node node_modules/iobroker.js-controller/iobroker.js start
    ! Starting iobroker controller daemon...
    ! C:\iobroker>


  • Установите поверх установленного, но теперь уже инсталятором, потом удалите например брокера, например Ccleaner - ом, ну или установка и удаление программ, удалите Node.js также все не удаленные папки, очистите реестр и заново поставьте.


  • Windows 10, 64. После установки не открывается начальная страница, пробовал дважды.

    Ставил с этого сайта - http://www.iobroker.net/docu/?page_id=2630&lang=ru.

    Вот по этой ссылке: "Очень просто можно установить с помощью инсталлятора:

    http://download.iobroker.org/ioBrokerIn … latest.exe".

    И вот так все "УМНЫЕ ДОМА" - везде кривизна.


  • Я не думаю что на 10ку как то отличается.

    https://www.youtube.com/watch?v=mjdKRbKw8wc


  • У меня стационарный комп. Windows-10, 64 бит. Не устанавливается IoBroker. Кто-нибудь может подсказать, как установить?


  • Так у меня тоже стационар, только семерка, я ж Вам ссылку дал как ставить, там в описании ссылка на команды указаны, Вы пробовали?


  • "Orange ZERO - установка IoBroker. Превращаем одноплатник в точку доступа" - вот, что открывается по ссылке


  • Пробуйте

    1. Ставим Node.js, я грузанул node-v10.13.0-x64

    2. Открываем консоль под админом.

    3. Последовательно вводим

    npm install –global windows-build-tools

    md C:\iobroker

    cd /d C:\iobroker

    npm install iobroker

    npm install –production

    если не ставится то вводим

    npm install –production –-unsafe-perm


  • Вроде все поставилось. Питон 2.7, JS. Большое Вам спасибо, открылся, теперь буду постепенно осваивать.


  • Рано радовался. В логах сплошные ошибки. Черт знает, что делать?

    Переставил. Установил NodeRed 1.7.1.


  • https://www.youtube.com/watch?v=KxU_ZK8IGVE я устанавливал на Windows, нет никаких ошибок.


  • В общем все удалила, почистила CCleaner, удалила сервис ioBroker с помощью (https://processhacker.sourceforge.io/downloads.php

    Потом все заново поставила, как описал Golan и все заработало, но!

    При новой установке выдавались абсолютно те же ошибки, что и раньше, но почему-то поверх предыдущей версии не запускалось, а с нуля заработало.

    Все чудесатее и чудесатее…


  • @Tatiana:

    абсолютно те же ошибки, что и раньше `
    О каких ошибках Вы говорите?


  • found 23 vulnerabilities (17 low, 6 high)
    run `npm audit fix` to fix them, or `npm audit` for details
    

    Какие точно были ошибки уже не скажу, но их было 6 high и при установке поверх и при установке в чистый каталог

Suggested Topics

  • 9
  • 3
  • 5
  • 2
  • 256
  • 5
  • 100
  • 2

2.0k
Online

34.9k
Users

40.9k
Topics

561.9k
Posts