NEWS

Alexa2 Routinen sind leer - Amazon Änderung!


  • Hi All,

    seit gestern Abend häufen sich Meldungen das Routinen im Adapter "leer" sind. Ersten checks zufolge hat Amazon scheinbar Dinge geändert. Das prüfe ich jetzt und dann gibt es einen Fix.

    EDIT: Die version 3.6.0 fixt das Problem!

    Wer es verhindern kann, startet Euren ioBroker und vor allem Alexa2 Adapter NICHT neu ... so lange sollten die Routinen noch da sein ... ob Sie noch tun falls über ioBroker ausgelöst ist unbekannt.
    Bei einem Neustart des Adapters werden Sie vorauss. aus den Objekten verschwinden.

    Ingo


  • Version 3.6.0 bzw Github version bitte testen und zurückmelden


  • @apollon77 installation lief ohne Probleme durch. Hab nur eine Fehlermeldung bei Adapter-Start erhalten (hatte vorher den Adapter nicht neu gestartet wegen bekanntem Problem):

    alexa2.0	2021-01-28 11:17:16.168	info	(4789) Deleting the following states: ["Echo-Devices.90F007186533044H.Routines.preconfigured:good_night_custom_utt_trigger","Echo-Devices.90F007186533044H.Routines.preconfigured:start_my_day_custom_ut
    alexa2.0	2021-01-28 11:17:16.167	info	(4789) Subscribing to states...
    alexa2.0	2021-01-28 11:16:51.904	info	(4789) Alexa-Push-Connection established. Disable Polling
    alexa2.0	2021-01-28 11:16:46.809	info	(4789) starting. Version 3.6.0 in /opt/iobroker/node_modules/iobroker.alexa2, node: v12.20.1, js-controller: 3.2.10
    host.ioBroker2	2021-01-28 11:16:44.172	info	instance system.adapter.alexa2.0 started with pid 4789
    host.ioBroker2	2021-01-28 11:16:43.143	info	Restart adapter system.adapter.alexa2.0 because enabled
    host.ioBroker2	2021-01-28 11:16:43.143	info	instance system.adapter.alexa2.0 terminated with code 156 (START_IMMEDIATELY_AFTER_STOP)
    alexa2.0	2021-01-28 11:16:42.492	info	(4626) Terminated (START_IMMEDIATELY_AFTER_STOP): Without reason
    alexa2.0	2021-01-28 11:16:42.489	error	(4626) Error: Error while checking Authentication: Error: no JSON
    

    NACHTRAG: Routinen sind bei mir weiterhin vorhanden


  • @apollon77
    Ist etwas seltsam, da manche Routinen nun wieder über den Adapter laufen und andere nicht.


  • Routinen sind wieder da mit 1.6.0 und keine Fehler im Log.
    Bisher habe ich aber keine Skripte mit Trigger auf diesen Objekten. Daher kann ich nur sagen dass sie existieren.


  • @kueppert Der Fehler schient beim beenden gewesen zu sein ... beobachten 🙂


  • @jan1 wie meinen?


  • @apollon77
    Wie geschrieben, wenn ich manche Routinen über den Adapter starte laufen diese und andere nicht.
    Da ich aber über den Adapter eh keine Routinen starte, ist mir das nicht so wichtig und ich habe jetzt einfach mal getestet, ob es funktioniert. Bevor ich die Git Version drauf hatte, liefen die Routinen aber auch (hatte ich vor dem Update getestet).


  • @jan1 Und per Alexa App kannst du die betroffenen routinen starten und laufen?? Dann müsste man sich das im Debug ansachauen... bzw kannst du sagen was die routinen vllt "spezielles" tun?


  • @apollon77
    meine Routinen sind eigentlich sehr simpel und schalten nur ein Gerät oder DP an und aus, damit ich mir eben keinen abbrechen muss bei der Sprachsteuerung. Da die bis jetzt alle noch liefen hatte ich auch gar nicht bemerkt, dass hier über den Adapter gesteuerte Routinen wohl bei einigen nicht mehr laufen.
    Das hatte ich dann simuliert, in dem ich im Alexa Adapter eben die Routine manuelle auf true gesetzt hatte und das hat bei einigen funktioniert, aber eben nicht bei allen, komisch.

    Ich bin nicht zu Hause und kann deshalb jetzt nicht testen, kannst aber gerne schon schreiben was ich wie simulieren soll, damit es Dir weiter hilft.


  • @jan1 AM Ende ist die Frage ob Du an irgendwas festmachen kannst "aah wenn das drin ist tut bzw tut nicht" oder so ... das gleiche wenn die routione manuell per alexa app erfolgreich getriggert werden kann


  • @apollon77
    ich schau mal morgen, aber wie geschrieben, meine Routinen schalten fast alle nur ein Gerät direkt im Amazon Konto, oder eben ein DP den ich über IoT, oder Nodred an Alexa weiter reiche.


  • DIe 3.6.0 ist dann jetzt auch ins stable gegangen


  • @apollon77
    version alexa 3.6.0
    IoT 1.8.11

    Ich habe im iot Adapter mehrere Alexa Geräte eingerichtet.
    Mir ist bei einem Gerät aufgefallen, dass dieses mit Alexa nicht mehr ein/ausgeschaltet werden kann.

    Ich habe dann lt. diesem Beitrag alexa 3.6.0 installiert, das betroffene Gerät im iot Adapter gelöscht und
    neu eingerichtet.
    Leider findet der Alexa Skill dieses Gerät nicht mehr.

    Ich habe einmal INFO bei alexa2 eingeschaltet

    2021-01-28 18:04:04.919 - info: host.raspi4 instance system.adapter.alexa2.0 started with pid 24951
    2021-01-28 18:04:07.181 - info: alexa2.0 (24951) starting. Version 3.6.0 in /opt/iobroker/node_modules/iobroker.alexa2, node: v10.19.0, js-controller: 3.1.6
    2021-01-28 18:04:10.437 - info: alexa2.0 (24951) Unknown Device, but enabling commands, Try it and report back if commands work.
    2021-01-28 18:04:10.438 - info: alexa2.0 (24951) Report to developer as GitHub issue with details for device. Please grab full next line pot. from logfile on disk if cutted
    2021-01-28 18:04:10.439 - info: alexa2.0 (24951) Device-type:A265XOI9586NML (DIALOG_INTERFACE_VERSION,MULTI_WAKEWORDS_SUPPORTED,TIMERS_AND_ALARMS,ACTIVE_AFTER_FRO,ARTHUR_TARGET,SUPPORTS_LOCALE,CHANGE_NAME,PERSISTENT_CONNECTION,EARCONS,SUPPORTS_SOFTWARE_VERSION,SOUND_SETTINGS,ASCENDING_ALARM_VOLUME,PAIR_BT_SINK,SUPPORTS_CONNECTED_HOME_CLOUD_ONLY,SUPPORTS_LOCALE_SWITCH,SPEECH_RECOGNIZER_USS,CUSTOM_ALARM_TONE,REMINDERS,FLASH_BRIEFING,VOLUME_SETTING,MICROPHONE)
    2021-01-28 18:04:10.515 - info: alexa2.0 (24951) Alexa-Push-Connection established. Disable Polling
    
    2021-01-28 18:08:00.243 - warn: alexa2.0 (24951) Smart Home device request blocked for SKILL_eyJza2lsbElkIjoiYW16bjEuYXNrLnNraWxsLjk4ZDZkZjBiLWEyZTAtNGZkNi1iYzQwLWJhOTNlZDBkNjMyZSIsInN0YWdlIjoibGl2ZSJ9_6284413
    2021-01-28 18:08:00.246 - warn: alexa2.0 (24951) Smart Home device request blocked for SKILL_eyJza2lsbElkIjoiYW16bjEuYXNrLnNraWxsLjk4ZDZkZjBiLWEyZTAtNGZkNi1iYzQwLWJhOTNlZDBkNjMyZSIsInN0YWdlIjoibGl2ZSJ9_6284411
    2021-01-28 18:08:00.248 - warn: alexa2.0 (24951) Smart Home device request blocked for SKILL_eyJza2lsbElkIjoiYW16bjEuYXNrLnNraWxsLjk4ZDZkZjBiLWEyZTAtNGZkNi1iYzQwLWJhOTNlZDBkNjMyZSIsInN0YWdlIjoibGl2ZSJ9_6284412
    2021-01-28 18:08:00.250 - warn: alexa2.0 (24951) Smart Home device request blocked for SKILL_eyJza2lsbElkIjoiYW16bjEuYXNrLnNraWxsLjk4ZDZkZjBiLWEyZTAtNGZkNi1iYzQwLWJhOTNlZDBkNjMyZSIsInN0YWdlIjoibGl2ZSJ9_6284418
    2021-01-28 18:08:00.251 - warn: alexa2.0 (24951) Smart Home device request blocked for SKILL_eyJza2lsbElkIjoiYW16bjEuYXNrLnNraWxsLjk4ZDZkZjBiLWEyZTAtNGZkNi1iYzQwLWJhOTNlZDBkNjMyZSIsInN0YWdlIjoibGl2ZSJ9_6284417
    2021-01-28 18:08:00.253 - warn: alexa2.0 (24951) Smart Home device request blocked for SKILL_eyJza2lsbElkIjoiYW16bjEuYXNrLnNraWxsLjk4ZDZkZjBiLWEyZTAtNGZkNi1iYzQwLWJhOTNlZDBkNjMyZSIsInN0YWdlIjoibGl2ZSJ9_6284415
    2021-01-28 18:08:00.255 - warn: alexa2.0 (24951) Smart Home device request blocked for SKILL_eyJza2lsbElkIjoiYW16bjEuYXNrLnNraWxsLjk4ZDZkZjBiLWEyZTAtNGZkNi1iYzQwLWJhOTNlZDBkNjMyZSIsInN0YWdlIjoibGl2ZSJ9_6284416
    2021-01-28 18:08:00.257 - warn: alexa2.0 (24951) Smart Home device request blocked for SKILL_eyJza2lsbElkIjoiYW16bjEuYXNrLnNraWxsLjk4ZDZkZjBiLWEyZTAtNGZkNi1iYzQwLWJhOTNlZDBkNjMyZSIsInN0YWdlIjoibGl2ZSJ9_6284414
    
    
    
    

  • @hanss Ok Alexa Skill und Alexa2 Adapter sind zwei paar Schuhe ... und das Du ioBroker geräte nicht schalten kannst bzw andere Smart Devices nicht schnell nacheinander schalten kannst ist Absicht. Ich sehe hier nichts was auf Probleme mit Alexa2 hinweist 🙂


  • @apollon77
    An wen muß ich mich denn wenden, wenn Alexa Geräte im IoT Adapter nicht mehr
    bei der Alexa als SmartHome Gerät zu finden sind?


  • @hanss Am besten schau die Cloud/IOT FAQ durch (lnk hier rechts in der Roten Box) und dann gibt es dort Threads bei Fragen


  • @apollon77
    So, heute laufen wieder alle Routinen. Der Unterschied warm gestern einige gezickt hatten, war wohl die Anbindung. IoT war ok und NodeRed lief nicht, zumindest ist das der größte Unterschied bei meinen Routinen.


  • @jan1 Vielen Dank fürs Feedback!


  • @apollon77
    leider läuft node-red nicht mehr mit Alexa2.IoT ist ok.
    Hoffentlich es wird eine Lösung geben, da ich sehr viel mit node-red über Alexa steuere.

Suggested Topics

1.9k
Online

36.6k
Users

42.4k
Topics

586.4k
Posts