NEWS

zwei gleiche skripte, nur eines funktioniert....


  • Hallo

    Ich habe folgendes Skript, das eine Variable auf Homematic beschreibt.
    Dieses funktioniert wunderbar.

    //Schreibe Werte von Smart-me Zähler Pool-UV in CCU Variablen
    
    // Leistung aller 3 Phasen in Variable auf CCU schreiben
    var idvar3 = "modbus.2.holdingRegisters.48196_power_total";/*power total von modbus.2*/
    var idstrom_pool_uv_verbrauch_aktuell= "hm-rega.0.14026";/*Schreibe in HM Variable strom_pool_uv_verbrauch_aktuell*/
    on(idvar3, idstrom_pool_uv_verbrauch_aktuell); // Synchronisierung
    

    Nun habe wollte ich dieses kopieren, um eine andere Homematic Variable zu beschreiben.
    Dieses funktioniert aber aus mir unerklärlichen Gründen nicht.

    //Schreibe Werte von Smart-me Zähler Pool-UV in CCU Variablen
    
    // Leistung Zähler Pool-UV gesamt in Variable auf CCU schreiben
    var idvar2 = "modbus.2.holdingRegisters.48268_energy_import_total";/*power total von modbus.2*/
    var idstrom_gesamt_uv_pool= "hm-rega.0.12270";/* hm-rega Zahl muss gesucht werden im hm-rpc Adapter! Schreibe in HM Variable strom_zuleitung_haus_verbrauch_aktuell*/
    on(idvar2, idstrom_gesamt_uv_pool); // Synchronisierung
    

    Auch nach stundenlanger suche, kann ich nicht sagen, was da nicht stimmen sollte. Kann mir jemand sagen, was da falsch dran ist?
    Gruss
    Ritschi


  • @Ritschi ich habe es raus gefunden.
    Ich hatte bei "modbus.2.holdingRegisters.48196_power_total"
    nach dem total einen leerschlag drin...... 😞

Suggested Topics

  • 36
  • 9
  • 469
  • 39
  • 4
  • 3
  • 2
  • 1

1.8k
Online

38.3k
Users

43.7k
Topics

611.0k
Posts