NEWS

iobroker: Could not connect database (invalid protocol)



  • @Thomas-Braun said in iobroker: Could not connect database (invalid protocol):

    iobroker list instances

    iobroker list instances
    
    Could not connect database at 0.0.0.0:9000 (invalid protocol). Please make sure the configured IP and port points to a host running JS-Controller >= 2.0.
    Could not connect database at 0.0.0.0:9000 (invalid protocol). Please make sure the configured IP and port points to a host running JS-Controller >= 2.0.
      system.adapter.backitup.0              : backitup              - disabled
      system.adapter.bring.0                 : bring                 -  enabled
      system.adapter.cloud.0                 : cloud                 - disabled
      system.adapter.coronavirus-statistics.0: coronavirus-statistics -  enabled
      system.adapter.cul.0                   : cul                   -  enabled, port: 23
      system.adapter.daswetter.0             : daswetter             - disabled
      system.adapter.discovery.0             : discovery             -  enabled
      system.adapter.fb-checkpresence.0      : fb-checkpresence      -  enabled
      system.adapter.flot.0                  : flot                  -  enabled
      system.adapter.fritzbox.0              : fritzbox              -  enabled
      system.adapter.history.0               : history               -  enabled
      system.adapter.hm-rega.0               : hm-rega               -  enabled
      system.adapter.hm-rpc.1                : hm-rpc                -  enabled, port: 18701
      system.adapter.hm-rpc.2                : hm-rpc                -  enabled, port: 12001
      system.adapter.hm-rpc.3                : hm-rpc                -  enabled, port: 12010
      system.adapter.info.0                  : info                  -  enabled
      system.adapter.iqontrol.0              : iqontrol              -  enabled
      system.adapter.javascript.0            : javascript            -  enabled
      system.adapter.material.0              : material              -  enabled
      system.adapter.mihome.0                : mihome                - disabled, port: 9898, bind: 0.0.0.0
      system.adapter.mqtt.1                  : mqtt                  -  enabled, port: 1885, bind: 0.0.0.0
      system.adapter.openweathermap.0        : openweathermap        - disabled
      system.adapter.ping.0                  : ping                  -  enabled
      system.adapter.rickshaw.0              : rickshaw              -  enabled
      system.adapter.shelly.0                : shelly                -  enabled, port: 1882, bind: 10.168.1.26
      system.adapter.shuttercontrol.0        : shuttercontrol        - disabled
      system.adapter.simple-api.0            : simple-api            -  enabled, port: 8087, bind: 0.0.0.0, run as: admin
      system.adapter.telegram.0              : telegram              -  enabled, port: 8443, bind: 0.0.0.0
      system.adapter.telegram.1              : telegram              - disabled, port: 8443, bind: 0.0.0.0
      system.adapter.terminal.0              : terminal              - disabled, port: 8088, bind: 0.0.0.0, run as: admin
      system.adapter.text2command.0          : text2command          -  enabled
      system.adapter.tr-064.0                : tr-064                -  enabled
      system.adapter.web.0                   : web                   -  enabled, port: 8082, bind: 0.0.0.0, run as: admin
      system.adapter.wetty.0                 : wetty                 - disabled, port: 8089, bind: 0.0.0.0
      system.adapter.yahka.0                 : yahka                 - disabled
      system.adapter.yamaha.0                : yamaha                -  enabled
      system.adapter.zigbee.0                : zigbee                -  enabled, port: /dev/ttyACM0
    
    + instance is alive
    


  • @_Matze_

    🙄 Sieht so aus, als hätte ich mir durch die Installation von webhooks den Port 9000 versperrt


  • Most Active

    @_Matze_
    Genau, auf 9000 läuft ein webhook

    0 :::9000                 :::*                    LISTEN      0          24180      703/webhook
    

    Kannst die Ports vom iobroker mit einer custom installation aber auf andere Ports biegen.



  • @Thomas-Braun
    Den Webhook habe ich wieder deinstalliert - trotzdem kann ich noch nicht per Browser darauf zugreifen. Ich vermute durch meine Reparaturversuche habe ich noch etwas anderes zerlegt.

    iobroker status
    iobroker is running on this host.
    
    At least one iobroker host is running.
    
    Objects type: file
    States  type: file
    

    Hast Du noch einen Tip?


  • Most Active

    @_Matze_ Zeig nochmal die Instanzen:

    iobroker list instances
    


  • @Thomas-Braun said in iobroker: Could not connect database (invalid protocol):

    iobroker list instances

    iobroker list instances
      system.adapter.backitup.0              : backitup              - disabled
    + system.adapter.bring.0                 : bring                 -  enabled
      system.adapter.cloud.0                 : cloud                 - disabled
      system.adapter.coronavirus-statistics.0: coronavirus-statistics -  enabled
    + system.adapter.cul.0                   : cul                   -  enabled, port: 23
      system.adapter.daswetter.0             : daswetter             - disabled
    + system.adapter.discovery.0             : discovery             -  enabled
      system.adapter.fb-checkpresence.0      : fb-checkpresence      -  enabled
      system.adapter.flot.0                  : flot                  -  enabled
    + system.adapter.fritzbox.0              : fritzbox              -  enabled
      system.adapter.history.0               : history               -  enabled
    + system.adapter.hm-rega.0               : hm-rega               -  enabled
    + system.adapter.hm-rpc.1                : hm-rpc                -  enabled, port: 18701
    + system.adapter.hm-rpc.2                : hm-rpc                -  enabled, port: 12001
    + system.adapter.hm-rpc.3                : hm-rpc                -  enabled, port: 12010
      system.adapter.info.0                  : info                  -  enabled
      system.adapter.iqontrol.0              : iqontrol              -  enabled
      system.adapter.javascript.0            : javascript            -  enabled
      system.adapter.material.0              : material              -  enabled
      system.adapter.mihome.0                : mihome                - disabled, port: 9898, bind: 0.0.0.0
    + system.adapter.mqtt.1                  : mqtt                  -  enabled, port: 1885, bind: 0.0.0.0
      system.adapter.openweathermap.0        : openweathermap        - disabled
    + system.adapter.ping.0                  : ping                  -  enabled
      system.adapter.rickshaw.0              : rickshaw              -  enabled
    + system.adapter.shelly.0                : shelly                -  enabled, port: 1882, bind: 10.168.1.26
      system.adapter.shuttercontrol.0        : shuttercontrol        - disabled
    + system.adapter.simple-api.0            : simple-api            -  enabled, port: 8087, bind: 0.0.0.0, run as: admin
    + system.adapter.telegram.0              : telegram              -  enabled, port: 8443, bind: 0.0.0.0
      system.adapter.telegram.1              : telegram              - disabled, port: 8443, bind: 0.0.0.0
      system.adapter.terminal.0              : terminal              - disabled, port: 8088, bind: 0.0.0.0, run as: admin
    + system.adapter.text2command.0          : text2command          -  enabled
    + system.adapter.tr-064.0                : tr-064                -  enabled
    + system.adapter.web.0                   : web                   -  enabled, port: 8082, bind: 0.0.0.0, run as: admin
      system.adapter.wetty.0                 : wetty                 - disabled, port: 8089, bind: 0.0.0.0
      system.adapter.yahka.0                 : yahka                 - disabled
    + system.adapter.yamaha.0                : yamaha                -  enabled
    + system.adapter.zigbee.0                : zigbee                -  enabled, port: /dev/ttyACM0
    
    + instance is alive
    

  • Most Active

    @_Matze_
    iobroker add admin



  • @Thomas-Braun said in iobroker: Could not connect database (invalid protocol):

    iobroker add admin

    Das war es! Herzlichen Dank für Deine Hilfe!!! Es läuft wieder alles 👍 👏 👏


  • Most Active

    @_Matze_ Freut mich. Magst du noch verraten wo der webhook herkam?



  • @Thomas-Braun Den hatte ich am Vorabend installiert. Da hatte ich versucht eine Telegram direkt an einen User abzusetzen, um an die fertige Spülmaschine zu erinnern. Automatische Kommunikation mit Teens 🙂
    https://nordicapis.com/how-to-build-your-first-telegram-bot-using-php-in-under-30-minutes/
    Tja, und dann blieb der Webhook einfach zurück, ohne dass ich ihn wieder sauber deinstalliert hätte. Beim nächsten Reboot hat sich das dann bemerkbar gemacht.


Log in to reply
 

Suggested Topics

1.6k
Online

29.9k
Users

37.0k
Topics

495.3k
Posts