NEWS

Tuya Adapter lässt sich in ioBroker nicht installieren



  • Ich bin neu hier, kann leider keine Lösung finden und würde mich sehr über eure Hilfe freuen!

    Das Problem:
    Ich möchte den Tuya Adapter installieren - dies ist aber nicht möglich.
    Fehlermeldung:

    $ ./iobroker add tuya  --host piserviant
    NPM version: 6.14.4
    npm install iobroker.tuya@3.2.2 --loglevel error --prefix "/opt/iobroker" (System call)
    npm ERR! Unexpected end of JSON input while parsing near '...de":">= 0.10"}},"0.7.'
    npm ERR! A complete log of this run can be found in:npm ERR!     /home/iobroker/.npm/_logs/2020-04-10T21_00_46_563Z-debug.log
    ERROR: host.piserviant Cannot install iobroker.tuya@3.2.2: 1
    ERROR: process exited with code 25
    

    Lösungsversuche die ich bereits gestartet habe - direkt über Github zu installieren wie in einem YouTube Video gezeigt. Dabei gehe ich auf das GitHub Kätzchen unter Adapter und gehe dann auf beliebig, dort "https://github.com/Apollon77/ioBroker.tuya" eingegeben - Fehler wie folgt:

    $ ./iobroker url "https://github.com/Apollon77/ioBroker.tuya" --debug
    install https://github.com/Apollon77/ioBroker.tuya/tarball/70f57fdb607fd6c5aba253647bcdb38b8370d254
    NPM version: 6.14.4
    npm install https://github.com/Apollon77/ioBroker.tuya/tarball/70f57fdb607fd6c5aba253647bcdb38b8370d254 --loglevel error --prefix "/opt/iobroker" (System call)
    npm
     ERR! Unexpected end of JSON input while parsing near '...de":">= 0.10"}},"0.7.'
    
    npm ERR! A complete log of this run can be found in:npm ERR!     /home/iobroker/.npm/_logs/2020-04-10T21_03_29_054Z-debug.log
    ERROR: host.piserviant Cannot install https://github.com/Apollon77/ioBroker.tuya/tarball/70f57fdb607fd6c5aba253647bcdb38b8370d254: 1
    ERROR: process exited with code 25
    

    Daraufhin habe ich nach dem parsing Error gesucht, Lösungsvorschläge waren:
    iobroker stop
    npm cache clean --force
    sudo npm install -g @angular/cli
    reboot

    Ergab keine Fehler, hat aber leider auch keine Abhilfe geschaffen..

    Alle anderen von mir benötigten Adapter lassen sich ohne weiteres installieren, da ich aber 99% Tuya Geräte besitze bringt mir das nüscht. Da ich genau diesen Adapter bräuchte.

    Habt ihr irgendwelche Ideen oder Vorschläge?
    Oder gibt es auch eine Möglichkeit das Manuell zu installieren?

    Vielen Dank schonmal & schöne Ostern!

    Systemdata Bitte Ausfüllen
    Hardwaresystem: Raspberry Pi 4
    Arbeitsspeicher: 2GB
    Festplattenart: SD-Karte 32GB
    Betriebssystem: Raspbian
    Node-Version: 10.20.0
    Nodejs-Version: 10.20.0
    NPM-Version: 6.14.4
    Installationsart: Skript
    Image genutzt: Ja (offizielles Raspberry Image)
    Ort/Name der Imagedatei: -

  • Most Active

    @DominikW

    Hast du nur über Konsole oder Git versucht zu installieren?
    Wie ist es über die Admin Adapter Seite?
    Du hast schon die neue Nodejs 10er Version. Kann sein das da das Problem hängt.
    Ansonsten wenn du weisst was du tust kannst du über die Konsole auch eingeben :
    cd /opt/iobroker
    NPM install iobroker.tuya@3.2.3

    Ohne zu wissen welche js Controller oder admin Version Du hast.



  • Vielen Dank,
    ich habe es jetzt über Umwege geschafft.
    Nachdem ich manuell im 3. Anlauf 3.2.3 installieren konnte, ging es dann auch über das Admin Panel.
    Danke!



Suggested Topics

1.9k
Online

32.2k
Users

38.8k
Topics

526.5k
Posts