NEWS

Installation on openSuse failed



  • Hello to all
    I'm new to the forum and my name is Luigi.
    I have linux openSuse 64bit installed on vmware, and I'm trying to install ioBroken.
    I installed nodejs, but when I install iobroken I get these errors, even if it finally tells me that it has been installed successfully, but in the browser at http: // myIp: 8081 there is nothing.
    And also in the / opt / iobroker folder I have only one file (illegible): iob
    Here is the result of konsole:

    
        Welcome to the ioBroker installer!
        Installer version: 2019-07-21
        
        You might need to enter your password a couple of times.
    
    ==========================================================================
    
    
    ==========================================================================
        Installing prerequisites (1/4)
    ==========================================================================
    
    Il flag q è sconosciuto.
    Installed acl
    Il flag q è sconosciuto.
    Installed sudo
    Il flag q è sconosciuto.
    Installed libcap2-bin
    Il flag q è sconosciuto.
    Installed build-essential
    Il flag q è sconosciuto.
    Installed libavahi-compat-libdnssd-dev
    Il flag q è sconosciuto.
    Installed libudev-dev
    Il flag q è sconosciuto.
    Installed libpam0g-dev
    Il flag q è sconosciuto.
    Installed pkg-config
    Il flag q è sconosciuto.
    Installed git
    Il flag q è sconosciuto.
    Installed curl
    Il flag q è sconosciuto.
    Installed unzip
    sudo: setcap: comando non trovato
    
    ==========================================================================
        Creating ioBroker user and directory (2/4)
    ==========================================================================
    
    usermod: group 'iobroker' does not exist
    Created /etc/sudoers.d/iobroker
    chown: gruppo non valido: "luigi:luigi"
    Directory /opt/iobroker created
    touch: impossibile fare touch di '/opt/iobroker/INSTALLER_INFO.txt': Permesso negato
    chmod: impossibile accedere a '/opt/iobroker/INSTALLER_INFO.txt': File o directory non esistente
    bash: riga 458: /opt/iobroker/INSTALLER_INFO.txt: Permesso negato
    bash: riga 459: /opt/iobroker/INSTALLER_INFO.txt: Permesso negato
    bash: riga 460: /opt/iobroker/INSTALLER_INFO.txt: Permesso negato
    
    ==========================================================================
        Installing ioBroker (3/4)
    ==========================================================================
    
    bash: riga 472: /opt/iobroker/INSTALLER_INFO.txt: Permesso negato
    /usr/bin/node10: error while loading shared libraries: libicui18n.so.suse64.2: cannot open shared object file: No such file or directory
    /usr/bin/node10: error while loading shared libraries: libicui18n.so.suse64.2: cannot open shared object file: No such file or directory
    
    ==========================================================================
        Finalizing installation (4/4)
    ==========================================================================
    
    bash: riga 498: /opt/iobroker/INSTALLER_INFO.txt: Permesso negato
    bash: riga 569: /opt/iobroker/iobroker: Permesso negato
    chmod: impossibile accedere a '/opt/iobroker/iobroker': File o directory non esistente
    Enabling autostart...
    chown: impossibile accedere a '/lib/systemd/system/iobroker.service': File o directory non esistente
    chmod: impossibile accedere a '/lib/systemd/system/iobroker.service': File o directory non esistente
    Failed to enable unit: Unit file iobroker.service does not exist.
    Failed to start iobroker.service: Unit iobroker.service not found.
    Autostart enabled!
    bash: riga 717: /opt/iobroker/INSTALLER_INFO.txt: Permesso negato
    Fixing directory permissions...
    chown: gruppo non valido: "iobroker:iobroker"
    usermod: group 'iobroker' does not exist
    This system does not support setting default permissions.
    Do not use npm to manually install adapters unless you know what you are doing!
    main: riga 601: /opt/iobroker/INSTALLER_INFO.txt: Permesso negato
    
    ==========================================================================
    
        ioBroker was installed successfully
        Open http://192.168.116.133:8081 in a browser and start configuring!
    
    ==========================================================================
    
    
    You need to re-login before doing anything else on the console!
    
    luigi@localhost:~> iobroker stop
    If 'iobroker' is not a typo you can use command-not-found to lookup the package that contains it, like this:
        cnf iobroker
    luigi@localhost:~> sudo mkdir /home/iobroker
    [sudo] password di root: 
    mkdir: impossibile creare la directory "/home/iobroker": File già esistente
    luigi@localhost:~> sudo chown iobroker /home/iobroker
    luigi@localhost:~> iobroken start
    If 'iobroken' is not a typo you can use command-not-found to lookup the package that contains it, like this:
        cnf iobroken
    luigi@localhost:~> 
    
    

    tanks



  • @chiabgigi said in Installation on openSuse failed:

    Hello to all
    I'm new to the forum and my name is Luigi.
    I have linux openSuse 64bit installed on vmware, and I'm trying to install ioBroken.
    I installed nodejs, but when https aka ms remoteconnect I install iobroken I get these errors, even if it finally tells me that it has been installed successfully, but in the browser at http: // myIp: 8081 there is nothing.
    And also in the / opt / iobroker folder I have only one file (illegible): iob
    Here is the result of konsole:

    
        Welcome to the ioBroker installer!
        Installer version: 2019-07-21
        
        You might need to enter your password a couple of times.
    
    ==========================================================================
    
    
    ==========================================================================
        Installing prerequisites (1/4)
    ==========================================================================
    
    Il flag q è sconosciuto.
    Installed acl
    Il flag q è sconosciuto.
    Installed sudo
    Il flag q è sconosciuto.
    Installed libcap2-bin
    Il flag q è sconosciuto.
    Installed build-essential
    Il flag q è sconosciuto.
    Installed libavahi-compat-libdnssd-dev
    Il flag q è sconosciuto.
    Installed libudev-dev
    Il flag q è sconosciuto.
    Installed libpam0g-dev
    Il flag q è sconosciuto.
    Installed pkg-config
    Il flag q è sconosciuto.
    Installed git
    Il flag q è sconosciuto.
    Installed curl
    Il flag q è sconosciuto.
    Installed unzip
    sudo: setcap: comando non trovato
    
    ==========================================================================
        Creating ioBroker user and directory (2/4)
    ==========================================================================
    
    usermod: group 'iobroker' does not exist
    Created /etc/sudoers.d/iobroker
    chown: gruppo non valido: "luigi:luigi"
    Directory /opt/iobroker created
    touch: impossibile fare touch di '/opt/iobroker/INSTALLER_INFO.txt': Permesso negato
    chmod: impossibile accedere a '/opt/iobroker/INSTALLER_INFO.txt': File o directory non esistente
    bash: riga 458: /opt/iobroker/INSTALLER_INFO.txt: Permesso negato
    bash: riga 459: /opt/iobroker/INSTALLER_INFO.txt: Permesso negato
    bash: riga 460: /opt/iobroker/INSTALLER_INFO.txt: Permesso negato
    
    ==========================================================================
        Installing ioBroker (3/4)
    ==========================================================================
    
    bash: riga 472: /opt/iobroker/INSTALLER_INFO.txt: Permesso negato
    /usr/bin/node10: error while loading shared libraries: libicui18n.so.suse64.2: cannot open shared object file: No such file or directory
    /usr/bin/node10: error while loading shared libraries: libicui18n.so.suse64.2: cannot open shared object file: No such file or directory
    
    ==========================================================================
        Finalizing installation (4/4)
    ==========================================================================
    
    bash: riga 498: /opt/iobroker/INSTALLER_INFO.txt: Permesso negato
    bash: riga 569: /opt/iobroker/iobroker: Permesso negato
    chmod: impossibile accedere a '/opt/iobroker/iobroker': File o directory non esistente
    Enabling autostart...
    chown: impossibile accedere a '/lib/systemd/system/iobroker.service': File o directory non esistente
    chmod: impossibile accedere a '/lib/systemd/system/iobroker.service': File o directory non esistente
    Failed to enable unit: Unit file iobroker.service does not exist.
    Failed to start iobroker.service: Unit iobroker.service not found.
    Autostart enabled!
    bash: riga 717: /opt/iobroker/INSTALLER_INFO.txt: Permesso negato
    Fixing directory permissions...
    chown: gruppo non valido: "iobroker:iobroker"
    usermod: group 'iobroker' does not exist
    This system does not support setting default permissions.
    Do not use npm to manually install adapters unless you know what you are doing!
    main: riga 601: /opt/iobroker/INSTALLER_INFO.txt: Permesso negato
    
    ==========================================================================
    
        ioBroker was installed successfully
        Open http://192.168.116.133:8081 in a browser and start configuring!
    
    ==========================================================================
    
    
    You need to re-login before doing anything else on the console!
    
    luigi@localhost:~> iobroker stop
    If 'iobroker' is not a typo you can use command-not-found to lookup the package that contains it, like this:
        cnf iobroker
    luigi@localhost:~> sudo mkdir /home/iobroker
    [sudo] password di root: 
    mkdir: impossibile [https aka ms remoteconnect](https://one2step.net/aka-ms-remoteconnect-minecraft/) creare la directory "/home/iobroker": File già esistente
    luigi@localhost:~> sudo chown iobroker /home/iobroker
    luigi@localhost:~> iobroken start
    If 'iobroken' is not a typo you can use command-not-found to lookup the package that contains it, like this:
        cnf iobroken
    luigi@localhost:~> 
    
    

    tanks

    Any update on this OP? I'm having the same issue here.
    Thanks in advane


  • Most Active

    @jrjong11
    Try installing in a debian based distribution.


  • Developer

    @jrjong11
    If I look at the generated errors (and assuming I translate them correctly) the Skript fails at 3 points:

    • setcap: either the command does not exist or it cannot be used with sudo
    Sudo: setcap: comando non trovato
    
    • creating the user iobroker and group iobroker seems to fail
    • creating the folder /opt/iobroker seems to fail due to lack of permissions.

    @Thomas-Braun mentioned the easy way out - use a Debian based Linux as basis.
    If you want to keep opensuse, you can try the following steps:

    • create a user and group iobroker (without password, the user does not need to log on
    • create a folder /opt/iobroker and „chown“ it to iobroker
    • ensure that the user iobroker is allowed to use sudo
    • Run the script again.

    A.


Log in to reply
 

Suggested Topics

1.9k
Online

32.2k
Users

38.8k
Topics

526.5k
Posts