NEWS


  • Пытался установить раз 10, ничего не выходит, разными способами. В конце установки что-то падает. Система по адресу в итоге не открывается. Проц Arm6. Из готовых образов есть на другие Малины. Может кто встречал ссылку установленного брокера на сабж? Хочу с него начать знакомства, а не с других систем.
    Или последнее время проект заброшен?


  • @Comrade_ekb
    Устанавливал на rpi zero w, перед установкой иоб необходимо nodejs установить. У вас установлено?
    Более информативно в телеграмм-канале @ioBroker smarthome.
    Лучше на 3 малинку установите, будет проще.


  • Аналогичная проблема, но при ручной установке на чистый OrangePi Zero.
    На RPi ставится без проблем, но нужно именно на OrangePi Zero (Armbian Linux 4.19.59-sunxi).
    Готовые образы не стартуют.

    NodeJS 10.15.2
    NPM 5.8.0

    При попытке запуск или получения статуса ioBroker:

    internal/modules/cjs/loader.js:583
        throw err;
        ^
    
    Error: Cannot find module '/opt/iobroker/node_modules/iobroker.js-controller/iobroker.js'
        at Function.Module._resolveFilename (internal/modules/cjs/loader.js:581:15)
        at Function.Module._load (internal/modules/cjs/loader.js:507:25)
        at Function.Module.runMain (internal/modules/cjs/loader.js:742:12)
        at startup (internal/bootstrap/node.js:283:19)
        at bootstrapNodeJSCore (internal/bootstrap/node.js:743:3)
    

    Пробовал переустанавливать и NodeJS и NPM и сам ioBroker.

    Прошу помощи 🙄


  • Папка "/opt/iobroker/node_modules" пуста.
    Может быть это проблемы с правами?!

    Пробовал всё переустанавливать из под SUDO - нет эффекта.


  • В итоге решил проблему переустановкой NPM.

    Перечитал медленно и вдумчиво https://www.iobroker.net/#ru/documentation/install/linux.md
    и заметил:

    В качестве последней проверки, пожалуйста, проверьте версию npm с помощью npm -v.
    Если это приводит к версии <6, пожалуйста, сделайте обновление npm с sudo -H npm install -g npm@6
    

    От оно чё, а у меня 5.8.0.
    Не знаю почему, но по умолчанию ставится именно нечетная версия.

    В итоге после переустановки NPM и самого ioBroker всё заработало.

    👍

Suggested Topics

2.2k
Online

35.0k
Users

40.9k
Topics

562.1k
Posts