NEWS

  • Starter

    Добрый день.

    Подскажите как установить Iobroker на Raspberry B первого поколения?
    Пытался делать все по инструкции с сайта Raspberry (JESSIE) – быстрый старт, но по инструкции устанавливается древняя нода. В итоге установщик ругается на древние драйвера и не устанавливается, параллельно прибивая ноду.
    Попытки обновить ноду на версию 8 окончились безуспешно. " You appear to be running on ARMv6 hardware. Unfortunately this is not current ly supported by the NodeSource Linux distributions. Please use the 'linux-armv6l ' binary tarballs available directly from nodejs.org for Node.js 4 and later."

    Помогите разобраться что делать.
    Желательно попроще, так как с линуксом вообще не знаком.

  • Starter

    Сам спросил, сам отвечу.
    Частично помогла с вопросом инструкция от немцев, она тоже не рабочая, но в ней больше информации, чем в нашей.
    На момент написания данного сообщения, установщик iobroker выдает кучу ошибок и не устанавливается. Написал админам, надеюсь поправят инструкцию в ближайшее время.

    Пишу для нубов, типа меня, которые линукс первый раз увидели и с компьютером на Вы.
    Если верить всей ругани, которую пришлось читать от установщика iobroker, то node он хочет не ниже 8.12 версии, а npm не меньше 6.4.1.
    Версии узнаются, путем набора в командной строке putty или малины
    node -v
    npm -v

    Приступаем к установке.
    Следуем инструкции по установке, а как доходим до пункта 5. Установить Node.js заново для Raspbery 1 используем следующее:

    Чтобы установить последнюю версию node для малины, переходим сюда и сохраняем ссылку для своей малины. Для первой малины требуется ссылка, которая возникает при наведении на ARMv6.
    Дальше в командах для установки указываем данные этой ссылки.
    Чтобы установить node используем следующие команды:

    wget http://адрес актуальной версии node
    tar -xvf название архива
    cd название файла из ссылки
    sudo cp -R * /usr/local/
    sudo ln -s /usr/local/bin/node /usr/bin/nodejs
    reboot
    

    Пример:
    На данный момент актуальная версия 10.15.3 с включенной npm 6.4.1.
    Ссылка на скачивание для ARMv6: https://nodejs.org/dist/v10.15.3/node-v10.15.3-linux-armv6l.tar.xz
    Название архива: node-v10.15.3-linux-armv6l.tar.xz
    Название файла: node-v10.15.3-linux-armv6l
    Команды на установку будут следующие:

    wget https://nodejs.org/dist/v10.15.3/node-v10.15.3-linux-armv6l.tar.xz
    tar -xvf node-v10.15.3-linux-armv6l.tar.xz
    cd node-v10.15.3-linux-armv6l
    sudo cp -R * /usr/local/
    sudo ln -s /usr/local/bin/node /usr/bin/nodejs
    reboot
    

    После установки node, приступаем к установке iobroker.
    Он устанавливается одной строчкой (не забываем работать из root)

    curl -sL https://iobroker.net/install.sh | bash -
    

    После установки iobroker, малинку желательно перезапустить.

    reboot
    

    Когда малина загрузится, надо запустить сервер iobroker:

    sudo iobroker start
    

    После этого можно заходить в вэбинтерфейс и конфигурировать сервер iobroker.

    Так же на сайте не верно указан способ запуска web версии.
    http://raspiPI:8081 Он верен, только если в настройках малины ваш hostname назван как raspiPI У меня по умолчанию он был raspberrypi поэтому вебка не открывалась.
    Правильно будет :
    http://IP-Adresse:8081
    или
    http://HostName:8081
    Ip адрес можно узнать кучей способов, я смотрю в роутере.
    HostName можно задать любой в конфиге малины, в который можно попасть, набрав команду sudo raspi-config

    Свежую информацию по процедуре установки можно читать на https://github.com/ioBroker/ioBroker/wiki/Installation

  • Starter

  • Starter

    Оказалось, что и процедура установки на нашем сайте не верная. При попытке установить iobroker методикой с русскоязычного сайта, установщик вылетает с ошибкой и отсылает на https://github.com/ioBroker/ioBroker/wiki/Installation

    Теперь инсталлировать iobroker можно всего одной строчкой

    curl -sL https://iobroker.net/install.sh | bash -
    

    Конечно, предварительно следует установить node версии равной или выше 8.12 и npm равной или выше 6.4.1. Как это сделать, описал выше.


  • @Sel Огромное спасибо за свежую инструкцию 2019 года ибо все остальные инструкции даже 2018 года не приводили к рабочему результату. Ваша тоже не привела, на последнем этапе посыпались какие-то ошибки и остановка не дошла до конца.

    Это была последняя попытка....

    Хотел упорно установить эту систему, так как многие ее расхваливали в других форумах. Но с горечью обнаружил, что походу ее забросили, ибо куча битых ссылок, куцие комментарии в темах. Что случилось с брокером? Есть смысл на него тратить вообще время или если уж изучать, то Home Assistant, который яро противопостовляют Брокеру... Все криво и косо еще на этапе установки... тьфу нахер, пол дня убил.

Suggested Topics

2.1k
Online

35.0k
Users

40.9k
Topics

562.0k
Posts