NEWS

Objekte für SKripte anlegen…wo?


  • Hallo zusammen,

    ich bin gerade dabei auf ioBroker umzusteigen und meine alten Sktrite aus Scriptgui selber mit Javascript zu schreiben.

    Dafür brauche ich eine Menge neuer Objekte, welche ich auch im Reiter Objekte angelegt bekomme.

    Die Skripte funktionieren dann auch. Aber wenn ich die Objekte nicht im ORder javascript.0 liegen, sondern in einem anderen Ordner bekomme ich im LOG immer die Fehlermeldung javascript.0 2016-12-26 12:59:12.426 error change ID is empty: {"common":{"name":"null","enabled":false},"type":"channel","_id":null}

    Das Objekt wird aber korrekt beschrieben und hat auch nen korrekten Zustand (true/false).

    Mich stört halt der error im Log. Gibt es da eine Lösung oder mache ich etwas falsch?


  • @Idefix2008:

    ,"type":"channel","_id":null `
    Wenn mit setState auf Datenpunkt-Objekte (type: state) anderer Adapter zugegriffen wird, muss die komplette ID angegeben werden.

    setState('Adaptername.N.mein_Datenpunkt', Wert);
    

  • @Idefix2008:

    {"common":{"name":"null","enabled":false},"type":"channel","_id":null} `
    Anscheinend hast Du bei den ersten Versuchen, Objekte im Admin-Reiter "Objekte" zu erstellen, ein Kanal-Objekt erzeugt, das den Namen "null" und die ID null hat. Das Objekt solltest Du suchen (Filter verwenden) und löschen !


  • Danke hab es jetzt hinbekommen 🙂

Suggested Topics

  • 1
  • 3
  • 11
  • 4
  • 7
  • 1
  • 1
  • 17

1.1k
Online

38.4k
Users

43.8k
Topics

612.8k
Posts