NEWS

Jalousie nur schalten wenn Tür zu ,,,


  • Nabend zusammen , ich kämpfe mich durch als Ex HM User ( Da war das alles sehr einfach aufgebaut)

    Nun versuche ich um 22 Uhr die Jalousie auf 0% zu fahren wenn diese auf 100 % steht und die Tür zu ist.

    Mein Ansatz war dieser ... klappt aber nicht .. was mache ich falsch ?!

    Unbenannt.JPG

    Danke Schonmal 🙂

    <xml xmlns="https://developers.google.com/blockly/xml">
      <block type="schedule" id="a709k=KmDoX?]1w#kMez" x="-612" y="-137">
        <field name="SCHEDULE">0 22 * * *</field>
        <statement name="STATEMENT">
          <block type="debug" id="p0/v6P/Tl@|hS;Ce|CrM">
            <field name="Severity">log</field>
            <value name="TEXT">
              <shadow type="text" id="U[aMzAV$^q?YBVo%,?yC">
                <field name="TEXT">22uhr alles zu </field>
              </shadow>
            </value>
            <next>
              <block type="controls_if" id="85%YO($(69o|loISC0w9">
                <value name="IF0">
                  <block type="logic_operation" id="#9bcL||-(4Nqo+S8}9~4">
                    <field name="OP">AND</field>
                    <value name="A">
                      <block type="logic_compare" id="tcRz`39`1w2[nILcrd+s">
                        <field name="OP">EQ</field>
                        <value name="A">
                          <block type="get_value" id="I%0h0_$y;=A}p$sviPt/">
                            <field name="ATTR">val</field>
                            <field name="OID">hm-rpc.0.LEQ1469482.1.STATE</field>
                          </block>
                        </value>
                        <value name="B">
                          <block type="logic_boolean" id="_vzt7QHU/:)QQF(e)fi6">
                            <field name="BOOL">TRUE</field>
                          </block>
                        </value>
                      </block>
                    </value>
                    <value name="B">
                      <block type="logic_compare" id="aDBk:p|8L^vKz_uEElt$">
                        <field name="OP">EQ</field>
                        <value name="A">
                          <block type="field_oid" id="VH8Q(1mxp2:rJKgz!V7i">
                            <field name="oid">hm-rpc.0.HEQ0111471.1.LEVEL</field>
                          </block>
                        </value>
                        <value name="B">
                          <block type="text" id="f^o@nayOcIr/Ya93Jxc.">
                            <field name="TEXT">100</field>
                          </block>
                        </value>
                      </block>
                    </value>
                  </block>
                </value>
                <next>
                  <block type="control" id="49$uP8YGU7`Ltn,XljI/">
                    <mutation xmlns="http://www.w3.org/1999/xhtml" delay_input="false"></mutation>
                    <field name="OID">hm-rpc.0.HEQ0111471.1.LEVEL</field>
                    <field name="WITH_DELAY">FALSE</field>
                    <value name="VALUE">
                      <block type="text" id="NBWJ?X=ei7UM_$3~38%S">
                        <field name="TEXT">0</field>
                      </block>
                    </value>
                  </block>
                </next>
              </block>
            </next>
          </block>
        </statement>
      </block>
    </xml>
    

  • @ftpgonzo sagte: was mache ich falsch ?!

    "steuere" muss in das mache-Maul.
    LEVEL enthält Zahlen (aus "Mathematik"), keine Strings.
    Die Tür ist zu bei STATE = true ?


  • @paul53 Nabend paul 🙂

    wenn ich eine Matheblock einsetzte springt der immer wieder raus 😞 (bei dem oberen Block)


  • @paul53 sagte in Jalousie nur schalten wenn Tür zu ,,,:

    @ftpgonzo sagte: was mache ich falsch ?!

    "steuere" muss in das mache-Maul.
    LEVEL enthält Zahlen (aus "Mathematik"), keine Strings.
    Die Tür ist zu bei STATE = true ?

    Das Problem habe ich bei mir aber auch, und ich muss es als String angeben. Mit Zahl läuft es nicht. Warum auch immer, und ja es ist eigentlich als Zahl angelegt. Funktioniert aber nur als String.

    @ftpgonzo gucke dir mal den Adapter Shuttercontrol an. Da kannst du sowas alles eintragen. Funktioniert wunderbar 😉


  • @fenriswolf Danke ich schau mal 🙂


  • @ftpgonzo sagte: wenn ich eine Matheblock einsetzte springt der immer wieder raus

    Das ist kein Wunder, da die ID immer ein String ist. Es muss der Block "Wert vom Objekt" verwendet werden.


  • @paul53 Danke jetzt geht es 🙂 ich glaube das wird noch ein Paar Tage & Foren dauern bis ich da mal durchblicke 🙂

Suggested Topics

  • 4
  • 16
  • 3
  • 10
  • 3
  • 7
  • 12
  • 4

1.4k
Online

38.3k
Users

43.8k
Topics

611.8k
Posts