NEWS


  • albi_63 Dann solltest du mit dem Sonoff Adapter besser zu recht kommen.
    Hast du es schon ausprobiert?

    So sieht die Datenstruktur aus.
    Screenshot_2020-06-12-16-11-47~2.png

  • Starter

    Hallo Jan
    Wenn ich die Sonoff Instanz starte bleibt die Rot. Wenn ich den Port von 1883 auf 1884 ändere und in den MQTT Einstellungungen des NodeMCU die Einstellungen vom Port und Passwort ändere geht der Adapter auf grün, allerdings sehe ich unter Objekte nur:

    Sonos.jpg

    und keine weiteren Datenpunkte.
    Temperatur, Distanz , Humidity ect nicht vorhanden.

    Das kommt vom Nodemcu:

    nodemcu.png

    Was mache ich falsch?
    Brauche ich die MQTT Instanz nicht mehr?

  • Starter

    paul53
    Hallo Paul
    Wie definiere ich dein Script wenn ich zwei Temperatursensoren am laufen habe?
    Ich habe da was versucht allerdings geht das in die Hose....

    const idSensor = 'mqtt.0.Smarthome.Wassertank.tele.SENSOR';
    
    // const idDSTemp1 = '0_userdata.0.Objekte.Wassertank.Temp_DS18B20-1';
    
    // const idDSTemp2 = '0_userdata.0.Objekte.Wassertank.Temp_DS18B20-2';
    
    const idDHTemp = '0_userdata.0.Objekte.Wassertank.idDHTemp';
    
    const idDHHum  = '0_userdata.0.Objekte.Wassertank.idDSTemp';
    
    const idDist = '0_userdata.0.Objekte.Wassertank.SR04_Distance';
    
     
    
    on(idSensor, function(dp) { // triggert bei Wertänderung
    
       let obj = JSON.parse(dp.state.val);
    
      // setState(idDSTemp1, obj.DS18B20-1.Temperature, true);
    
       // setState(idDSTemp2, obj.DS18B20-2.Temperature, true);
    
       setState(idDHTemp, obj.DHT11.Temperature, true);
    
       setState(idDHHum, obj.DHT11.Humidity, true);
    
       setState(idDist, obj.SR04.Distance, true);
    

    Der String kommt folgendermassen an:

    {"Time":"2020-06-12T18:56:00","DS18B20-1":{"Id":"01192A390A6C","Temperature":24.8},"DS18B20-2":{"Id":"0301A279895F","Temperature":22.4},"DHT11":{"Temperature":27.2,"Humidity":44.0},"SR04":{"Distance":30.000},"TempUnit":"C"}
    

    Danke für dein Feedback


  • albi_63 sagte:

    zwei Temperatursensoren am laufen habe?

    DS18B20-1 und DS18B20-2 enthalten unzulässige Zeichen (-) für die Punkt-Notation. Der Zugriff muss dann anders erfolgen:

       setState(idDSTemp1, obj['DS18B20-1'].Temperature, true);
       setState(idDSTemp2, obj['DS18B20-2'].Temperature, true);
    
  • Starter

    paul53
    Hallo Paul,
    Ich danke dir vielmals. Es klappt wunderbar.😊


  • albi_63
    Screenshot_2020-06-12-20-36-16~2.png

    Alle drei Sachen angehakt?

    Du kannst nur den Sonoff oder den MQTT Adapter laufen lassen.
    Sonst kommen sie sich ins Gehege.
    Oder wie du es gemacht hast, die Ports zu ändern.

  • Starter

    Jan.S100
    Hy Jan
    Hatte alles schon so angeklickt wie du mir gesendet hast. Bekomme keine Daten.
    Kann es an der alten Firmware "Sonoff-Tasmota 6.7.1" liegen? Wenn ich die aktuellste mit "8.x.x" aufspiele, bekomme ich meinen SR04 Sensor nicht mehr zur Auswahl. Allerdings habe ich mit der neusten Firmware jetzt noch nicht getestet, ob mir die Daten übermittelt werden.


  • albi_63 Tja, da müssen wohl die Spezialisten ran. 🤔 So tief stecke ich dann doch nicht in der Materie.


  • albi_63 also 8.3.1.3 ist derzeit die aktuelleste (abseits von stable) .... und von 6.x auf 8.x ist ein großer sprung. andererseits werden da auch viele fehler behoben 😉

  • Starter

    harrym
    Hy harrim
    Danke für dein Feedback.
    Ich hatte die 8.3.1 zu Anfang aufgespielt, bekam allerdings nicht mehr meinen Sensor SR04, danach ging ich Version um Version zurück bis mein Sensor wieder auftauchte und das bei der 6.7.1.
    Wenn ich jetzt die aktuellste wieder aufspiele funktioniert es vielleicht mit dem Sonos. Allerdings bringt mir das nichts, da ja die Werte vom SR04 nicht abesetzt werden können. Somit arbeite ich mit MQTT und dem Script von Paul. Das funktioniert soweit.
    Danke euch allen für die Unterstützung.

Suggested Topics

1.5k
Online

34.6k
Users

40.7k
Topics

557.5k
Posts