NEWS

Cron Trigger Uhrzeit stimmt nicht


  • Starter

    Servus. Ich hab diverse Trigger als Blockly mit Cron erstellt. Z.B. jeden Montag um 0:00 oder jeden Sonntag um 23:59 die jeweils immer eine Stunde später ausgeführt werden. Die Uhrzeit im ioBroker passt und im raspberry ist auch die richtige Zeitzone angegeben. Kann mir das einer erklären?

    Gruß Jaschkopf


  • Starter

    Vor diesem Problem stehe ich auch gerade... Weder Astro noch Cron triggern zur eingestellten Zeit.


  • Starter

    @KLVN sagte in Cron Trigger Uhrzeit stimmt nicht:

    Vor diesem Problem stehe ich auch gerade... Weder Astro noch Cron triggern zur eingestellten Zeit.

    Ok, habe weiter gewühlt und zwei selten dumme Fehler meinerseits gefunden:

    1. Mein Pi war noch auf die falsche Zeitzone eingestellt (war mich sicher, dass ich es umgestellt habe)
      "sudo raspi-config" -> "Localization options" -> "Change Timezone"
      (danach habe ich vorsorglich noch "iobroker stop" und "iobroker start" ausgeführt)
    2. In Blockly hatte ich den Debug-Modus aktiviert und als ich ins Log gesehen habe, kam mir dann diese Meldung entgegen: "(21617) script.js.Sonnenuntergang: setForeignState(id=shelly.xxx, state={"val":true,"ack":false}) - wurde nicht ausgeführt, während der Debug-Modus aktiv ist"

    Jetzt funktionieren nachweislich die Cron-Jobs, die Astro-Funktion werde ich noch testen.


Log in to reply
 

Suggested Topics

1.7k
Online

32.4k
Users

39.0k
Topics

528.7k
Posts