NEWS

Hoher CPU-Load des Raspberry


  • Hab gegen 11 den javascript adapter abgeschaltet und im vis etwas gemacht. Aktuell sieht es so aus:
    686_speicher.png

    Vielleicht doch ein Speicher-Problem ?


  • nimm mal bitte normales "top". htop zeigt komische Dinge an


  • Ich habe gestern ein Image der Karte gezogen und danach war das Problem (erstmal ?) verschwunden. Ich konnte eine Stunde im vis werkeln und der Load ging nicht über 2-2,5. - sehr verwunderlich …

    Ich werde das natürlich weiter im Auge behalten.

    Danke für Eure Hilfe erstmal

  • Forum Testing Most Active Global Moderator Administrators

    @crepp:

    sehr verwunderlich `
    Nö.

    Wenn die Karte einen Schlag weg hatte und bei schreibvorgängen zu langsam war eben nicht.

    Gruß Rainer


  • Hi,

    ich habe auch täglich (zu unterschiedlichen Uhrzeiten) einen Absturz aufgrund zu hoher Temperatur.

    Bisher konnte ich nur 1x zum entsprechenden Zeitpunkt mit putty draufschauten.

    top zeigte mir den javascript und den history adapter mit sehr hoher CPU Load an.

    Ich habe die beiden mal angehalten. Seitdem scheint es zu laufen.

    Aber gibt es die Möglichkeit, die CPU Last eines einzelnen Tasks mitzuschreiben?

    Also ich hätte quasi gerne einen Mitschrieb der beiden o.g. Adapter. geht das?

  • Forum Testing Most Active Global Moderator Administrators

    Ich prüfe so ziemlich alles
    144_20180826_152248.jpg
    Top (Tabelle rechts unten, rot umrahmt) gibt die cpu und speicherauslastung für jeden Prozess an.

    Die System Load enthält aber auch noch die I/O Vorgänge.

    So kann bei niedriger CPU Auslastung die Load trotzdem sehr hoch srin, wenn z.b. die sd karte sehr langsam ist.

    Gruß Rainer


  • Danke dir.

    Das ist ja quasi meine top abfrage die ich geamcht habe.

    Aber ich kann ja nicht ständig den Screen beobachten.

    Daher möchte ich gerne eine Verlaufsaufzeichnung der CPU Last für die beiden Prozesse.

    Wenn dann der Pi abstürzt, kann ich im Verlauf oder dem GRaphen nachsehen welcher Prozess zum Zeitpunkt des Absturzes am aktivsten war.

  • Forum Testing Most Active Global Moderator Administrators

    Die drei werte in den blau umrandeten gauges logge ich auch.

    Das json, das in der Tabelle dargestellt wird kann prinzipiell auch geloggt werden (alst text) oder die Werte müssten extrahiert werden.

    Aber wie ich dir vorsichtig klarmachen wollte spiegelt ein hoher Wert der Load nicht unbedingt eine hohe cpu Auslastung wider.

    Gruß Rainer


  • Hmm ok.

    Ich habe jetzt auf jeden Fall herausgefunden dass der History Adapter für meine Hohe Auslastung verantwortlich ist.

    Warum der node da so oft aufgeführt wird… Keine Ahnung !? 😐

    Die CPU-Last ist wirklich nicht unbedingt das Problem, eher die Load an sich.

    7541_2018-08-29_09_00_12-pi_iobroker-raspi___.png

    Die SD karte sollte aber durch meine Einstellungen doch nicht zu stark belastet werden.

    Zumal ich gerade mal 10 Datenpunkte mit dem History Adapter logge.

    In den geloggten Datenpunkten habe ich folgende Einstellungen:
    7541_2018-08-29_09_01_31-objects_-_iobroker.png

  • Forum Testing Most Active Global Moderator Administrators

    @aleks-83:

    Warum der node da so oft aufgeführt wird… `
    Das ist nicht gut. Auch die hohen PID deuten auf dauernde Neustarts hin.

    Einfach nur node steht da, wenn ein Adapter noch nicht vollkommen geladen ist.

    Außerdem swapped dein Raspi. Das erhöht auch die Load

    Gruß

    Rainer


  • Was kann ich dagegen tun?

  • Forum Testing Most Active Global Moderator Administrators

    Ich würde erst einmal rebooten und dann top eine zeitlang beobachten.


  • Es kann sein dass ein reboot wirklich nötig war. Ich hatte gerade ein paar Adapter reaktiviert.

    Nach einem reboot und gut 1h Laufen lassen sieht der top so aus:
    7541_2018-08-29_10_22_26-pi_iobroker-raspi___.png

    Load ist deutlich runter gegangen.

    Aber node wird zwischendurch immer wieder aufgerufen.

    Die PID ist nun in 1h halb so hoch wie vorher in 30 min.

    Ist das immer noch zu viel?

  • Forum Testing Most Active Global Moderator Administrators

    @aleks-83:

    Aber node wird zwischendurch immer wieder aufgerufen. `
    Das kann normal sein wenn du scheduled Adapter hast.

    Es kann aber auch der zigte Versuch eines (oder zweier) Adapter sein zu starten.

    Sind denn alle Adapter aufgeführt oder fehlen welche?

    Wenn ja, welche?

    Gruß

    Rainer

Suggested Topics

1.1k
Online

34.9k
Users

40.9k
Topics

560.7k
Posts