NEWS

[Gelöst] Owntracks, keine Datenpunkte places.0


  • Guten Abend,
    ich versuche die Anwesentheit eines Android-Handys via owntracks App und den Places Adapter umzusetzen.
    In der App habe ich den Ort Zuhause angelegt und unter Verbindung den Modus http und den Host https://service.iobroker.in/v1/iotService?service=custom_Britta&key=xxx&user=yyy gewählt.
    In iobroker benutze den iot-Adapter. Dort ist der Custom "Britta" in der Whitelist eingetragen.
    In der Adapterkonfiguration von places ist unter Allgemein der Radius auf 50 Meter und der Name des Ortes auf "Zuhause" gestellt. Unter Orte ist der Name "Zuhause" mit Breitengrad und Längengrad und Radius eingetragen. Unter Benutzer ist "Britta" und unter Integration die IOT-Instanz "iot.0" und der IOT-Service "Britta".
    Unter iot.0.services.custom_Britta steht {"_type":"location","acc":15,"alt":315,"batt":33,"conn":"w","inregions":["Zuhause"],"lat":aaa,"lon":bbb,"tid":"0x","tst":1577481588,"vac":2,"vel":0}
    Bem: aaa und bbb erstetzt.
    Da ich den Bewegungsmodus zum Testen in der App an habe, wird der Datenpunkt ca alle 30 Sekunden beschrieben.
    Mein Skript zum Weiterleiten wäre


    Und ab da passiert nichts mehr.
    d7b5f67d-63c8-436c-a2de-dea66aeccd8f-grafik.png

    Mein js-controller ist 2.1.1. Liegt hier vielleicht das Problem?

    Viele Grüße Martin

    Nachtrag:
    @apollon77 Ich habe gesehen, dass du im GitHub stehst, hättest du ggf. eine Idee?


  • @PeterPan Naja das was da drin steht in ein JSON, das nur mit "," zu splitten tut nicht so wirklich.

    var data = JSON.parse(obj.state.val) und dann data.lat und so geht vllt besser oder ?!


  • @apollon77 Vielen Dank für die schnelle Antwort, ich hatte (da wenig Kenntnisse vorhanden) das Skript ohne Sinn aus einem anderen Forumsbeitrag 🙄 .
    Deine Anmerkung habe ich umgesetzt, mit log() bekomme ich nun die richtigen Daten heraus.


    Allerdings bleibt es dabei, dass unter places.0 keine Einträge kommen.
    Skript sieht jetzt so aus:

    Die Instanz Places läuft auf einem anderen Host, könnte das noch eine Rolle spielen?


  • @PeterPan @apollon77 Es lag daran, dass ich den Breiten- und Längengrad nicht in den System-Haupteinstellungen eingetragen hatte. Trotzdem vielen Dank!!!

Suggested Topics

  • 8
  • 27
  • 3
  • 4
  • 3
  • 4
  • 4
  • 5

1.9k
Online

38.4k
Users

43.8k
Topics

612.3k
Posts