NEWS

  • Starter

    Добрый день!

    Установил драйвер IoT Assistants, привязал его к облаку iobroker.pro, связал аккаунт iobroker.pro с аккаунтом Яндекса.
    Снимок экрана от 2019-10-06 13-26-50.png

    При добавлении устройств в "Устройства Алиса" возникает ошибка (скриншот), пробовал добавить устройство в "Устройства Google Home" устройства добовляються.
    Снимок экрана от 2019-10-06 13-18-55.png

    В changelog нашел вот такую запись
    Снимок экрана от 2019-10-06 13-30-44.png

    У кого-нибудь получилось привязать устройства к Алисе?

    P.S. Не хотелось бы юзать навыки алисы и каждый раз проговаривать лишнее - название навыка

    P.P.S. Я правильно понимаю, что можно создать виртуальное устройство, привязать к нему скрипт со сценой и алиса его будет запускать по команде "Алиса включи %имя виртуального устройства%"


  • @Bonus said in Драйвер IoT Assistants и Алиса:

    Добрый день!

    Установил драйвер IoT Assistants, привязал его к облаку iobroker.pro, связал аккаунт iobroker.pro с аккаунтом Яндекса.
    Снимок экрана от 2019-10-06 13-26-50.png

    При добавлении устройств в "Устройства Алиса" возникает ошибка (скриншот), пробовал добавить устройство в "Устройства Google Home" устройства добовляються.
    Снимок экрана от 2019-10-06 13-18-55.png

    В changelog нашел вот такую запись
    Снимок экрана от 2019-10-06 13-30-44.png

    У кого-нибудь получилось привязать устройства к Алисе?

    P.S. Не хотелось бы юзать навыки алисы и каждый раз проговаривать лишнее - название навыка

    P.P.S. Я правильно понимаю, что можно создать виртуальное устройство, привязать к нему скрипт со сценой и алиса его будет запускать по команде "Алиса включи %имя виртуального устройства%"

    У меня получилось
    Порядок моего подключения такой.
    Зарегистрирован на iobroker.pro, открыл для яндекса https , т.к. http принимать не хочет.
    Установил драйвер iot. Далее через телефон запросил подключение к устройству
    Получил пароль на почту для временного доступа.
    Ну а дальше все понятно.
    Недостаток по моему - не видит домашних датчиков , не регулирует плавно яркость света и т.д., только вкл. и выкл. Хотя в демо м предлагается настроить термостат , но я этого не пробовал.
    Если, что пишите. Постараюсь ответить

  • Starter

    @andrey1509 Большое спасибо за ответ!

    @andrey1509 said in Драйвер IoT Assistants и Алиса:

    открыл для яндекса https

    А где открыли https?

    @andrey1509 said in Драйвер IoT Assistants и Алиса:

    Ну а дальше все понятно.

    Подскажите у Вас драйвер cloud установлен? К какому облаку он подключен pro или net? Если pro оплачена ли у Вас подписка?

    Мне кажется что мои проблемы с добавлением устройств в драйвер iot как то связанны с драйвером cloud


  • @Bonus said in Драйвер IoT Assistants и Алиса:

    @andrey1509 Большое спасибо за ответ!

    @andrey1509 said in Драйвер IoT Assistants и Алиса:

    открыл для яндекса https

    А где открыли https?

    @andrey1509 said in Драйвер IoT Assistants и Алиса:

    Ну а дальше все понятно.

    Подскажите у Вас драйвер cloud установлен? К какому облаку он подключен pro или net? Если pro оплачена ли у Вас подписка?

    Мне кажется что мои проблемы с добавлением устройств в драйвер iot как то связанны с драйвером cloud

    Драйвер cloud удалил. В драйвере admin включил https

  • Starter

    Как просмотреть логи драйвера?

    В логах только такая информация

    Снимок экрана от 2019-10-12 15-20-35.png


  • @Bonus said in Драйвер IoT Assistants и Алиса:

    Как просмотреть логи драйвера?

    В логах только такая информация

    Снимок экрана от 2019-10-12 15-20-35.png

    Так на телефоне в Яндекс , устройства, умный дом- соединились с iobroker. Если соединились, то все в порядке. У меня в логах тоже тишина, хотя голосовые команды исполняются.

  • Starter

    @andrey1509 Спасибо за помощь, но я попрежнему не могу добавить устройства в раздел "Устройства Алисы"

    Для проверки я поставил iobroker на чисты debian и попрежнему получаю сообщение "Устройство %name% не было добавлено"

    Я в тупике. Я попробовал в расширенных настройках драйвера выставить опцию "Вывод отладочной информации" но в логах попрежнему скудная информация о драйвере iot.

    Так на телефоне в Яндекс , устройства, умный дом- соединились с iobroker.

    Да соеденились, но список устройств на телефоне пуст т.к. я не могу добавить устройства в драйвере iot.broker


  • @Bonus said in Драйвер IoT Assistants и Алиса:

    @andrey1509 Спасибо за помощь, но я попрежнему не могу добавить устройства в раздел "Устройства Алисы"

    Для проверки я поставил iobroker на чисты debian и попрежнему получаю сообщение "Устройство %name% не было добавлено"

    Я в тупике. Я попробовал в расширенных настройках драйвера выставить опцию "Вывод отладочной информации" но в логах попрежнему скудная информация о драйвере iot.

    Так на телефоне в Яндекс , устройства, умный дом- соединились с iobroker.

    Да соеденились, но список устройств на телефоне пуст т.к. я не могу добавить устройства в драйвере iot.broker

    Извиняюсь , что сразу не ответил.
    Если не разобрались, то давайте по порядку.
    Категории у вас заполнены? Нет , то заполняем. После этого , "Объекты" заполняем поля "Комнаты" и "Функции".
    capture_20191017082903.png
    В драйвере IOT во вкладке " умные перечисления" должны появиться список "комнаты" и "функции" , включаем то , чем будем управлять.
    capture_20191017083233.png
    Далее "Устройства алисы" видим список , вот он и должен быть на телефоне.
    Если чего не понято , то стучите в "телеграмм", удачи.

  • Starter

    @andrey1509, Здравствуйте. Такая же беда, да плюс еще одна.
    Вроде бы все верно сделал, зарегистрировался на iobroker.pro, установил драйвер IOT, ввёл в IOT регистрационные данные, вроде как соединение с сервером появилось, о чем свидетельствует зеленый индикатор рядом с iot.0 в разделе настроек iobroker.
    настроил категории, не все правда:
    004.JPG
    В настройках драйвера iot.0 "Умные перечисления" появилось следующее.
    002.JPG
    Но в "устройствах Алисы" ничего нет, попытки добавить через + возвращают тот же результат, что и у товарища с ником Bonus.
    Ну, думаю, буду включать HTTPS в драйвере admin, сертификаты выбрал по умолчанию.
    После сохранения пропал доступ через браузер, пытался входить через HTTPS://IP:8081 , тоже безрезультатно.
    Помогла переустановка драйвера admin через SSH

    cd /opt/iobroker
    iobroker del admin
    iobroker add admin
    

    Видел вот в этом посте решение похожей проблемы, но я не смог связать со своей. Вот часть, которая выдаётся за решение проблемы. Простите за такой машинный перевод, не знаю почему так, возможно, у автора необычный диалект:

    "Это было потому , что давайте шифрования , который использует порт 80 - й Поскольку Web.0 уже «Использовать этот экземпляр для автоматического обновления» функция включена, это укусил с «Использовать этот экземпляр для автоматического обновления» в Admin.0, так как только один экземпляр может использовать 80 - й порт Ли активирован в Admin.0 и теперь все работает"

    Как я понял, когда включаем HTTPS, то требуется 80 порт, который якобы занят драйвером Web.0 (в целях обновления, вроде бы) Но у меня admin.0 висит на 8081 порту, Web.0 висит на 8082. В активных настройках этих драйверов порт 80 нигде не фигурирует. В общем так и не понял как и что безопасно подправить, чтобы не уложить систему.

    Подскажите, пожалуйста, дальнейшие действия. Почему устройства не попадают в "Устройства Алисы", влияет ли на это Https шифрование? Как правильно включить Https шифрование для работы с Алисой, может какие-то особенные сертификаты нужны? Как правильно включить Https шифрование, чтобы доступ к веб интерфейсу не отваливался, или он не отваливается, а просто я в него неправильно вхожу? Буду очень признателен за помощь. Спасибо.

  • Starter

    Удалось включить шифрование. Сначала надо подправить файл openssl.cnf
    Заменить в нем последнюю строку
    CipherString = DEFAULT@SECLEVEL=2
    на
    CipherString = DEFAULT@SECLEVEL=1

    cd /etc/ssl/
    sudo nano openssl.cnf
    

    Надеюсь это не вредный совет...

    Потом включаем шифрование в драйвере web.0 , но, наверное это было не обязательно.

    001.JPG
    002.JPG
    После этого проверяем доступ к web.0, который в моём случае висит на порту 8082.
    Только теперь с HTTPS , например https://192.168.0.221:8082/
    Браузер ругается на устаревший сертификат, но зайти можно.

    То же самое делаем с драйвером admin.0, у меня он на порту 8081
    003.JPG
    004.JPG

    Как я понял, сертификаты должны обновиться, но этого не происходит.

    Но, это не помогло, основная проблема осталась, не добавляются устройства Алисы, хотя в Amazon Alexa и Google Home добавляются.


  • @Анатолий-П Алиса умеет переключать что-либо . Остальные функции не доступны. Попробуйте создать другой навык.
    Пойдите в телеграмм https://t.me/iobroker быстрее ответят.

  • Starter

    @Анатолий-П Здравствуйте!
    Мне удалось найти проблему и ее решение.
    Проблема оказалась в одной галочке)
    Мне удалось добиться работы Алисы (уже во второй раз)

    1. JS-controller версии 2.0 и выше
    2. В категориях нужно создать необходимые для управления устройства и в функциях и в комнатах.
      Снимок экрана от 2019-12-16 20-27-24.png Снимок экрана от 2019-12-16 20-27-15.png
    3. Устройства в Алисе у меня появляются после вот таких настроек драйвера iot
      Снимок экрана от 2019-12-16 20-25-05.png
      причем галочка "Личные настройки (только pro)" оказалась решающей, хотя у меня нет оплаченного Pro аккаунта.
      Снимок экрана от 2019-12-16 20-24-43.png

Suggested Topics

  • 14
  • 3

1.9k
Online

34.9k
Users

40.9k
Topics

560.7k
Posts