NEWS

[gelöst] snapshot vom flot/browser


  • hallo

    ich hab leider nichts gefunden, daher meine frage.

    gibts ein gutes (einfaches) tool für die command-line, mit dem ich meinen flot als .jpg .gif oder sonst was speichern kann,

    damit ichs dann eventuell per mail/telegram usw verschicken kann?

    danke

    lg


  • Probiers doch mit dem Adapter hier: Screenshot mit PhantomJS

    Gruß

    dna909


  • super, danke

    werd ich heute probieren.


  • Verdammt - installation geht ned.

    Zuerst upgrade auf npm 6.5.0

    Und dann erst kein Erfolg


  • jemand eine idee??

    RPI 3B+

    Node.js v8.14.0

    NPM 6.4.1

    $ ./iobroker add phantomjs  --host RPI_Slave1
    NPM version: 6.4.1
    npm install iobroker.phantomjs --production --save --prefix "/opt/iobroker" (System call)
    Unexpected platform or architecture: linux/armIt seems there is no binary available for your platform/architecture
    Try to install PhantomJS globally
    
    npm WARN svg-inline-react@1.0.3 requires a peer of react@^0.14.0 || ^15.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"arm"})
    
    npm ERR! code ELIFECYCLEnpm ERR! errno 1
    npm ERR! phantomjs-prebuilt@2.1.16 install: `node install.js`
    npm ERR! Exit status 1
    npm ERR! 
    npm ERR! Failed at the phantomjs-prebuilt@2.1.16 install script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/iobroker/.npm/_logs/2019-01-10T16_32_48_343Z-debug.log
    
    host.RPI_Master install adapter phantomjs
    NPM version: 6.4.1npm install iobroker.phantomjs --production --save --prefix "/opt/iobroker" (System call)
    
    Unexpected platform or architecture: linux/armIt seems there is no binary available for your platform/architecture
    Try to install PhantomJS globally
    
    npm
     WARN svg-inline-react@1.0.3 requires a peer of react@^0.14.0 || ^15.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"arm"})
    
    npm
     ERR! code ELIFECYCLEnpm ERR! errno 1
    
    npm ERR! phantomjs-prebuilt@2.1.16 install: `node install.js`npm ERR! Exit status 1
    
    npm ERR! npm ERR! Failed at the phantomjs-prebuilt@2.1.16 install script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/iobroker/.npm/_logs/2019-01-10T16_33_39_525Z-debug.log
    
    host.RPI_Master install adapter phantomjs
    NPM version: 6.4.1
    npm install iobroker.phantomjs --production --save --prefix "/opt/iobroker" (System call)
    Unexpected platform or architecture: linux/armIt seems there is no binary available for your platform/architecture
    Try to install PhantomJS globally
    
    npm
     WARN svg-inline-react@1.0.3 requires a peer of react@^0.14.0 || ^15.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"arm"})
    
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1npm
     ERR! phantomjs-prebuilt@2.1.16 install: `node install.js`npm ERR! Exit status 1
    npm ERR! 
    npm ERR!
     Failed at the phantomjs-prebuilt@2.1.16 install script.npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    
    npm ERR! A complete log of this run can be found in:npm ERR!     /home/iobroker/.npm/_logs/2019-01-10T16_34_29_877Z-debug.log
    
    host.RPI_Master install adapter phantomjs
    ERROR: host.RPI_Master Cannot install phantomjs
    ERROR: process exited with code 13
    
    

  • hat niemand eine idee bezüglich meines phantomjs problems oder mit welchem anderen tool ich sowas hinbekommen könnte?

  • Kategorie Mod

    Mal die readme gelesen ???

    ` > Prerequire

    It is used prebuild package of phantomjs. If for your system the prebuild does not exist, you cannot use this adapter. On some linux systems the additional library "libfontconfig" is required. It can be installed as follow:

    sudo apt-get install libfontconfig `


  • danke

    eigentlich schon, aber heißt das nun, dass es mit phantomjs gar nicht geht am rpi oder nur wenn ich das davor installiere?

    @Segway:

    Mal die readme gelesen ???

    ` > Prerequire

    It is used prebuild package of phantomjs. If for your system the prebuild does not exist, you cannot use this adapter. On some linux systems the additional library "libfontconfig" is required. It can be installed as follow:

    sudo apt-get install libfontconfig

Suggested Topics

  • 26
  • 1
  • 10
  • 5
  • 1
  • 4
  • 9
  • 9

1.8k
Online

38.3k
Users

43.7k
Topics

611.0k
Posts